Brauche Hilfe bei gtk-sharp 3 und gstreamer kompilieren

Vom einfachen Programm zum fertigen Debian-Paket, Fragen rund um Programmiersprachen, Scripting und Lizenzierung.
Antworten
CrazyMetal
Beiträge: 1
Registriert: 07.07.2017 10:42:12

Brauche Hilfe bei gtk-sharp 3 und gstreamer kompilieren

Beitrag von CrazyMetal » 21.11.2017 15:53:37

Hallo zusammen,
ich möchte .NET-Bindings für gstreamer machen und habe mich an diesem Post orientiert.

Ich habe mir gtk-sharp 3 von git geladen und kompiliert.

Nun zu dem Problem:
Nach dem Ausführen von

Code: Alles auswählen

./autogen.sh -prefix=`pkg-config --variable=prefix mono`
bekomme ich immer die Fehlermeldung, dass die Version von gtk-sharp < 3 ist.

configure: error: Package requirements (glib-sharp-3.0 >= 3.22.6) were not met:
Requested 'glib-sharp-3.0 >= 3.22.6' but version of GLib is 2.99.4

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_SHARP_CFLAGS
and GLIB_SHARP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Auch in den Paketquellen (Debian Jessie) sehe ich für gtk-sharp 3 lediglich eine Versionsnummer von 2.99.4

Hier stehe ich grade etwas auf dem Schlauch, vielleicht kann ja jemand etwas Licht ins Dunkel bringen.

Danke und Gruß
Crazy

Antworten