Postfix: Relayhost wird nicht gefunden

Debian macht sich hervorragend als Web- und Mailserver. Schau auch in den " Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
jph
Beiträge: 377
Registriert: 06.12.2015 15:06:07
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Greven/Westf.

Postfix: Relayhost wird nicht gefunden

Beitrag von jph » 11.02.2018 18:01:32

Hallo zusammen,

ich habe einen LXC-Container aufgesetzt und will dort Postfix als Satellitensystem einrichten. Mein Fileserver soll als Relayhost verwendet werden.

Folgende Konfiguration (anonymisiert):

Code: Alles auswählen

/etc/hosts:
192.168.178.8   relayhost.in.meinedomain.tld relayhost

Code: Alles auswählen

/etc/postfix/main.cf:
…
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination
myhostname = satellit.in.meinedomain.tld
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = satellit.in.meinedomain.tld, localhost
relayhost = [relayhost.in.meinedomain.tld]
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = + 
inet_interfaces = loopback-only
inet_protocols = all

masquerade_domains = meinedomain.tld
Problem: das funktioniert nicht, weil relayhost.in.meinedomain.tld nicht aufgelöst wird. Im Log steht

Code: Alles auswählen

deliver_request_final: send: "Host or domain name not found. Name service error for name=relayhost.in.meinedomain.tld
Wenn ich in main.cf die IP des Relayhosts eintrage, funktioniert es. Wo liegt der Fehler?

Der Satellit ist ein LXC-Container mit Debian 9.

Danke & Gruß

Jan

Benutzeravatar
bluestar
Beiträge: 622
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: Postfix: Relayhost wird nicht gefunden

Beitrag von bluestar » 13.02.2018 00:29:17

Versuch mal den Eintrag
viewtopic.php?f=8&t=167784#p1156140

Benutzeravatar
jph
Beiträge: 377
Registriert: 06.12.2015 15:06:07
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Greven/Westf.

[gelöst] Postfix: Relayhost wird nicht gefunden

Beitrag von jph » 13.02.2018 17:14:33

bluestar hat geschrieben: ↑ zum Beitrag ↑
13.02.2018 00:29:17
Versuch mal den Eintrag
viewtopic.php?f=8&t=167784#p1156140
Jau! smtp_host_lookup hat geholfen. Vielen Dank! :D

Antworten