Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Debian macht sich hervorragend als Web- und Mailserver. Schau auch in den " Tipps und Tricks"-Bereich.
Benutzeravatar
oln
Beiträge: 45
Registriert: 05.01.2021 09:41:24

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von oln » 18.06.2021 08:19:47

Noch ne Frage. Was gibt ein

Code: Alles auswählen

netstat -plntu | grep dovecot
aus?
Weil ich in deiner dovecot.conf keinen inet_listener für imaps finde.
Gruß Ole

knaffi
Beiträge: 19
Registriert: 08.03.2021 23:44:01

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von knaffi » 18.06.2021 13:40:45

Moin,

habe das Passwort des entsprechenden Accounts nun geändert. Jetzt sind keine Sonderzeichen mehr vorhanden, mit Ausnahme von _ und -. wenn ich jetzt den Schritt mit 'a login ...' erneut durchführe, kommt die Fehlermeldung:

Code: Alles auswählen

-bash: a: Kommando nicht gefunden.
Sollte das nun so sein?

netstat -plntu | grep dovecot: https://nopaste.debianforum.de/41405 (Täusche ich mich, oder müsste dort nicht auch der smtp-Port 587 zu finden sein?)
oln hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 07:35:05
In deinem Mailclient benutzt du für IMAP den Port 143. Versuch es mal bitte mit 993 wie auf der Konsole und bei Secure mal TLS/SSL(wenn es das dort gibt).
Oder TLS und akzeptiere mal alle Zertifikate.
Habe ich nun getestet. Zur Auswahl stehen nur TLS oder SSL. Beides mit imap 993 getestet, bei beiden keine Verbindung möglich.


Viele Grüße

Benutzeravatar
oln
Beiträge: 45
Registriert: 05.01.2021 09:41:24

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von oln » 18.06.2021 15:31:13

knaffi hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 13:40:45
habe das Passwort des entsprechenden Accounts nun geändert. Jetzt sind keine Sonderzeichen mehr vorhanden, mit Ausnahme von _ und -. wenn ich jetzt den Schritt mit 'a login ...' erneut durchführe, kommt die Fehlermeldung:

Code: Alles auswählen

-bash: a: Kommando nicht gefunden.
Sollte das nun so sein?
Nein. Eigentlich solltest du nach

Code: Alles auswählen

root@deinhostname~]# openssl s_client -connect <deineIP>:993
hier stehen bleiben:

Code: Alles auswählen

    Start Time: 1624022875
    Timeout   : 7200 (sec)
    Verify return code: 21 (unable to verify the first certificate)
    Extended master secret: yes
---
* OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE LITERAL+ AUTH=PLAIN] Dovecot (Debian) ready.
Und dort gibt du dann die Befehe ein.
Das sieht dann so aus:

Code: Alles auswählen

a login user@example.com deinpasswort
a OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE SORT SORT=DISPLAY THREAD=REFERENCES THREAD=REFS THREAD=ORDEREDSUBJECT MULTIAPPEND URL-PARTIAL CATENATE UNSELECT CHILDREN NAMESPACE UIDPLUS LIST-EXTENDED I18NLEVEL=1 CONDSTORE QRESYNC ESEARCH ESORT SEARCHRES WITHIN CONTEXT=SEARCH LIST-STATUS BINARY MOVE SNIPPET=FUZZY LITERAL+ NOTIFY SPECIAL-USE QUOTA] Logged in
a select inbox
* FLAGS (\Answered \Flagged \Deleted \Seen \Draft NonJunk)
* OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft NonJunk \*)] Flags permitted.
* 0 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 1615286494] UIDs valid
* OK [UIDNEXT 1567] Predicted next UID
* OK [HIGHESTMODSEQ 3008] Highest
a OK [READ-WRITE] Select completed (0.002 + 0.000 + 0.001 secs).
Zuletzt geändert von oln am 18.06.2021 15:42:02, insgesamt 1-mal geändert.
Gruß Ole

Benutzeravatar
oln
Beiträge: 45
Registriert: 05.01.2021 09:41:24

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von oln » 18.06.2021 15:37:26

knaffi hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 13:40:45
netstat -plntu | grep dovecot: https://nopaste.debianforum.de/41405 (Täusche ich mich, oder müsste dort nicht auch der smtp-Port 587 zu finden sein?)
Nein SMTP macht der Postfix. Da du nach dovecot grepst, siehst du nur eben das.
Gruß Ole


Benutzeravatar
oln
Beiträge: 45
Registriert: 05.01.2021 09:41:24

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von oln » 18.06.2021 15:53:45

Na dann geht doch der Login. Dann liegt der Fehler wo anders. Firewall?
Gruß Ole

Benutzeravatar
bluestar
Beiträge: 1733
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von bluestar » 18.06.2021 16:02:23

Deine Ursache habe sehe ich gerade:
knaffi hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 13:40:45

Code: Alles auswählen

root@deinhostname~]# openssl s_client -connect <deineIP>:993
hier stehen bleiben:

Code: Alles auswählen

    Start Time: 1624022875
    Timeout   : 7200 (sec)
    Verify return code: 21 (unable to verify the first certificate)
    Extended master secret: yes
---
* OK [CAPABILITY IMAP4rev1 SASL-IR LOGIN-REFERRALS ID ENABLE IDLE LITERAL+ AUTH=PLAIN] Dovecot (Debian) ready.
Der Fehler liegt hier Verify return code: 21 (unable to verify the first certificate), du musst sicherstellen, dass openssl als auch der Webmailer das Zertifikat auch validieren können.

knaffi
Beiträge: 19
Registriert: 08.03.2021 23:44:01

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von knaffi » 18.06.2021 20:37:29

Woran könnte das genau liegen? SSL Zertifikate der Sicherheit halber neu generieren?


Viele Grüße

Benutzeravatar
bluestar
Beiträge: 1733
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von bluestar » 18.06.2021 20:47:03

knaffi hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 20:37:29
Woran könnte das genau liegen?
Fehlende Root-Ca, Zwischenzertifikate nicht eingebunden, in der Konfiguration des Webmail-Clienten fehlt die Konfiguration der vertrauten Zertifikate.

Da du noch Stretch verwendest ist es vermutlich die fehlende neue R3 Root-CA von LetsEncrypt.
knaffi hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 20:37:29
SSL Zertifikate der Sicherheit halber neu generieren?
Das ändert an fehlender Konfiguration nichts.

knaffi
Beiträge: 19
Registriert: 08.03.2021 23:44:01

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von knaffi » 18.06.2021 20:49:35

Das Problem ist, dass an der Konfiguration nichts geändert wurde. Es wurden lediglich die abgelaufenen Zertifikate neu erstellt.
Wo soll ich da suchen?
Vor dem erneuern hat alles problemlos funktioniert.


Viele Grüße

Benutzeravatar
bluestar
Beiträge: 1733
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von bluestar » 18.06.2021 20:57:47

knaffi hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 20:49:35
Das Problem ist, dass an der Konfiguration nichts geändert wurde. Es wurden lediglich die abgelaufenen Zertifikate neu erstellt.
Ist die Zertifikatskette (Zwischenzertifikat, Root-CA) von alten und neuen Zertifikaten gleich?
knaffi hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 20:49:35
Wo soll ich da suchen?
Siehe meinen vorheriger Post.

knaffi
Beiträge: 19
Registriert: 08.03.2021 23:44:01

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von knaffi » 20.06.2021 00:44:17

Kurze Frage, was sind Zwischenzertifikate? Das höre ich ehrlicherweise zum ersten Mal.

Die Config für den Webmail-Client habe ich mir angesehen, dort gibt es keine Option für SSL-Zertifikate o.ä.

Wenn ich die SMTP Verbindung über mein Forum teste, wird mir dort auch angezeigt, dass eine SMTP-Verbindung nicjt möglich ist. Die Zertifinate sind in der dovecot.conf korrekt angegeben, das habe ich auch nochmals geprüft.


Viele Grüße

Benutzeravatar
bluestar
Beiträge: 1733
Registriert: 26.10.2004 11:16:34
Wohnort: Rhein-Main-Gebiet

Re: Mailserver (Postfix & Dovecot) funktionieren nicht. Ggf Probleme mit Dovecot

Beitrag von bluestar » 20.06.2021 13:16:54

knaffi hat geschrieben: ↑ zum Beitrag ↑
20.06.2021 00:44:17
Kurze Frage, was sind Zwischenzertifikate?
Frag doch mal eine Suchmaschine.

knaffi hat geschrieben: ↑ zum Beitrag ↑
20.06.2021 00:44:17
Die Config für den Webmail-Client habe ich mir angesehen, dort gibt es keine Option für SSL-Zertifikate o.ä.
Ist der Webmailer PHP basiert?
knaffi hat geschrieben: ↑ zum Beitrag ↑
20.06.2021 00:44:17
Wenn ich die SMTP Verbindung über mein Forum teste, wird mir dort auch angezeigt, dass eine SMTP-Verbindung nicjt möglich ist.
Ist deine Forensoftware PHP basiert?

Es ist nunmal ein Vertrauensproblem und kein Dovecot/Postfix/Zertifikats-Problem.
bluestar hat geschrieben: ↑ zum Beitrag ↑
18.06.2021 20:47:03
Fehlende Root-Ca ….
Da du noch Stretch verwendest ist es vermutlich die fehlende neue R3 Root-CA von LetsEncrypt.
Hast du das geprüft ggfs. korrigiert?

Antworten