E-Mails werden nicht "weitergeleitet"

Debian macht sich hervorragend als Web- und Mailserver. Schau auch in den " Tipps und Tricks"-Bereich.
Antworten
Benni1000
Beiträge: 15
Registriert: 24.11.2011 23:41:13

E-Mails werden nicht "weitergeleitet"

Beitrag von Benni1000 » 23.02.2012 21:27:40

Hallo,
Ich habe einen Postfix Server eingerichtet das versenden von mails funktioniert prima.
Das empfangen von Mails eigentlich auch die mail kommt im Server an:

Code: Alles auswählen

Feb 23 20:17:59 vmanager*** postfix/smtpd[1526]: E32E06A240: client=mail-qy0-f176.google.com[****************]
Feb 23 20:18:00 vmanager435 postfix/cleanup[1530]: E32E06A240: message-id=<*******************************************@mail.gmail.com>
Feb 23 20:18:00 vmanager435 postfix/qmgr[1514]: E32E06A240: from=<************@gmail.com>, size=2137, nrcpt=1 (queue active)
Feb 23 20:18:00 vmanager435 postfix/trivial-rewrite[1529]: warning: do not list domain *********.eu in BOTH mydestination and virtual_alias_domains
Feb 23 20:18:00 vmanager435 postfix/local[1531]: E32E06A240: to=<admin@*******.eu>, relay=local, delay=0.32, delays=0.31/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)
Feb 23 20:18:00 vmanager435 postfix/qmgr[1514]: E32E06A240: removed
Die Mails werden dann in /home/admin/Maildir/new verschoben.
Das problem ist das squirrelmail und Thunderbird etc die Mails nicht abrufen können.
Könnt ihr mir sagen was ich da einrichten muss?
Mfg Benni1000

Benni1000
Beiträge: 15
Registriert: 24.11.2011 23:41:13

Re: E-Mails werden nicht "weitergeleitet"

Beitrag von Benni1000 » 23.02.2012 22:49:34

Ich habs gelöst / Kann geschlossen werden.
mail_location in dovecot war falsch eingetragen .

Benutzeravatar
pangu
Beiträge: 1348
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: E-Mails werden nicht "weitergeleitet"

Beitrag von pangu » 24.02.2012 00:05:53

vielleicht kannst du ja anderen Usern, die ebenfalls ähnliche Probleme haben, mit deiner Lösung versorgen. Sei doch so fair, und schreib wenigstens rein, was genau die Ursache war und wie du es behoben hast. Das ist doch ein großer Teil vom Sinn eines Threads ;) Sofern ich mich nämlich wage erinnern kann, wurde die mail_location Direktive von dovecot 1.1 auf 1.2 geändert. Während in der 1.1er Version der übliche default-Eintrag noch anerkannt wurde, wird er bei der 1.2 quasi als 'deprecated' angemahnt (oder gar verweigert?).
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

Benni1000
Beiträge: 15
Registriert: 24.11.2011 23:41:13

Re: E-Mails werden nicht "weitergeleitet"

Beitrag von Benni1000 » 24.02.2012 00:24:41

Das Problem war das das ich einfach den Pfad falsch eingetragen hatte :)
Aber zu früh gefreut dafür geht jetzt postfix nicht mehr.
Weis einer eine Lösung :( ?

Code: Alles auswählen

Feb 23 23:17:12 vmanager435 postfix/smtpd[3910]: connect from chello213047008119.west2.11.vie.surfer.at[************]
Feb 23 23:17:12 vmanager435 postfix/smtpd[3910]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Feb 23 23:17:12 vmanager435 postfix/smtpd[3910]: warning: SASL authentication problem: unable to open Berkeley db /etc/sasldb2: No such file or directory
Feb 23 23:17:12 vmanager435 postfix/smtpd[3910]: warning: SASL authentication failure: no secret in database

Benni1000
Beiträge: 15
Registriert: 24.11.2011 23:41:13

Re: E-Mails werden nicht "weitergeleitet"

Beitrag von Benni1000 » 24.02.2012 22:20:10

Hallo :(
Den obrigen Fehler hab ich durch das verschieben von dateien fixen können.
Jetzt taucht ein neuer auf wenn man sich von aussen auf den Server verbinden will (mit Tunderbird) um eine Mail zu senden:

Code: Alles auswählen

Feb 24 21:17:55 vmanager435 dovecot: IMAP(admin): Disconnected: Logged out bytes=91/791
Feb 24 21:18:51 vmanager435 postfix/smtpd[17734]: connect from chello213047008119.west2.11.vie.surfer.at[213.47.8.119]
Feb 24 21:18:51 vmanager435 postfix/smtpd[17734]: warning: SASL authentication failure: Password verification failed
Feb 24 21:18:51 vmanager435 postfix/smtpd[17734]: warning: chello213047008119.west2.11.vie.surfer.at[213.47.8.119]: SASL PLAIN authentication failed: authentication failure
Feb 24 21:18:51 vmanager435 postfix/smtpd[17734]: warning: chello213047008119.west2.11.vie.surfer.at[213.47.8.119]: SASL LOGIN authentication failed: authentication failure
Feb 24 21:18:58 vmanager435 postfix/smtpd[17734]: warning: SASL authentication failure: Password verification failed
Feb 24 21:18:58 vmanager435 postfix/smtpd[17734]: warning: chello213047008119.west2.11.vie.surfer.at[213.47.8.119]: SASL PLAIN authentication failed: authentication failure
Feb 24 21:18:58 vmanager435 postfix/smtpd[17734]: warning: chello213047008119.west2.11.vie.surfer.at[213.47.8.119]: SASL LOGIN authentication failed: authentication failure
Feb 24 21:19:00 vmanager435 dovecot: imap-login: Login: user=<admin>, method=PLAIN, rip=84.200.8.189, lip=84.200.8.189, secured
Feb 24 21:19:00 vmanager435 dovecot: IMAP(admin): Disconnected: Logged out bytes=91/791
Das ist meine /etc/default/saslauthd

Code: Alles auswählen

#
# Settings for saslauthd daemon
# Please read /usr/share/doc/sasl2-bin/README.Debian for details.
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Description of this saslauthd instance. Recommended.
# (suggestion: SASL Authentication Daemon)
DESC="SASL Authentication Daemon"

# Short name of this saslauthd instance. Strongly recommended.
# (suggestion: saslauthd)
NAME="saslauthd"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent  -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam       -- use PAM
# rimap     -- use a remote IMAP server
# shadow    -- use the local shadow password file
# sasldb    -- use the local sasldb database file
# ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="shadow"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

# Other options (default: -c -m /var/run/saslauthd)
# Note: You MUST specify the -m option or saslauthd won't run!
#
# See /usr/share/doc/sasl2-bin/README.Debian for Debian-specific information.
# See the saslauthd man page for general information about these options.
#
# Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
#OPTIONS="-c -m /var/run/saslauthd -r"
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
Meine /etc/postfix/main.cf

Code: Alles auswählen

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no
append_dot_mydomain = no
delay_warning_time = 4h
myhostname = benni1000.eu
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = benni1000.eu,localhost.localdomain, localhost
mynetworks = 127.0.0.0/8
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_maps = hash:/etc/postfix/virtual_alias
virtual_alias_domains = /etc/postfix/virtual_domains
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, reject_unknown_recipient_domain,  permit_sasl_authenticated, reject_unauth_destination
smtpd_helo_restrictions = permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_hostname, reject_unknown_hostname
smtpd_sender_restrictions = reject_unknown_sender_domain
smtpd_helo_required = yes
strict_rfc821_envelopes = yes
home_mailbox = Maildir/
Meine /etc/postfix/sasl/smtpd.conf

Code: Alles auswählen

pwcheck_method: saslauthd
mech_list: login plain
autotransition:true
saslauthd_path: /var/run/saslauthd/mux
pwcheck_method: saslauthd
Wäre sehr erfreut über jede art von Hilfe.

Antworten