[ERLEDIGT] Mails über Webinterface nicht versendbar

Debian macht sich hervorragend als Web- und Mailserver. Schau auch in den " Tipps und Tricks"-Bereich.
Antworten
netlord
Beiträge: 18
Registriert: 23.12.2011 11:33:05

[ERLEDIGT] Mails über Webinterface nicht versendbar

Beitrag von netlord » 26.07.2018 11:45:46

Hallo

ich habe einen Mailserver installiert (Dovecot, Postfix und Rspamd) und als Frontend Roundcube.
Wenn ich von zu Hause aus Mails verschicke (Thunderbird) geht alles problemlos.

Wenn ich aber versuche es über Roundcube zu machen bekomme ich die Meldung Request timed out SMTP Error (-1): Connection to server failed.

Das ist die Ausgabe von postconf -n

Code: Alles auswählen

append_dot_mydomain = no
biff = no
bounce_queue_lifetime = 1h
compatibility_level = 2
inet_interfaces = all
inet_protocols = ipv4
local_recipient_maps = $virtual_mailbox_maps
mailbox_size_limit = 0
maximal_backoff_time = 15m
maximal_queue_lifetime = 1h
message_size_limit = 52428800
milter_default_action = accept
milter_mail_macros = i {mail_addr} {client_addr} {client_name} {auth_authen}
milter_protocol = 6
minimal_backoff_time = 5m
mua_client_restrictions = permit_mynetworks,permit_sasl_authenticated,reject
mua_relay_restrictions = reject_non_fqdn_recipient,reject_unknown_recipient_domain,permit_mynetworks,permit_sasl_authenticated,reject
mua_sender_restrictions = permit_mynetworks,reject_non_fqdn_sender,reject_sender_login_mismatch,permit_sasl_authenticated,reject
myhostname = mail.xxxxx.com
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 localhost xxxxx.com
non_smtpd_milters = inet:localhost:11332
postscreen_access_list = permit_mynetworks cidr:/etc/postfix/postscreen_access
postscreen_blacklist_action = drop
postscreen_dnsbl_action = drop
postscreen_dnsbl_sites = ix.dnsbl.manitu.net*2 zen.spamhaus.org*2
postscreen_dnsbl_threshold = 2
postscreen_greet_action = drop
queue_run_delay = 5m
recipient_delimiter = +
smtp_dns_support_level = dnssec
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
smtp_tls_ciphers = high
smtp_tls_policy_maps = mysql:/etc/postfix/sql/tls-policy.cf
smtp_tls_protocols = !SSLv2, !SSLv3
smtp_tls_security_level = dane
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_client_restrictions = permit_mynetworks permit_sasl_authenticated check_client_access hash:/etc/postfix/without_ptr reject_unknown_client_hostname
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks reject_invalid_helo_hostname reject_non_fqdn_helo_hostname reject_unknown_helo_hostname
smtpd_milters = inet:localhost:11332
smtpd_recipient_restrictions = permit_mynetworks check_recipient_access mysql:/etc/postfix/sql/recipient-access.cf
smtpd_relay_restrictions = permit_mynetworks reject_non_fqdn_recipient reject_unknown_recipient_domain reject_unauth_destination
smtpd_tls_cert_file = /etc/letsencrypt/live/xxxx.com/fullchain.pem
smtpd_tls_ciphers = high
smtpd_tls_key_file = /etc/letsencrypt/live/xxxx.com/privkey.pem
smtpd_tls_protocols = !SSLv2, !SSLv3
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
tls_high_cipherlist = EDH+CAMELLIA:EDH+aRSA:EECDH+aRSA+AESGCM:EECDH+aRSA+SHA256:EECDH:+CAMELLIA128:+AES128:+SSLv3:!aNULL:!eNULL:!LOW:!3DES:!MD5:!EXP:!PSK:!DSS:!RC4:!SEED:!IDEA:!ECDSA:kEDH:CAMELLIA128-SHA:AES128-SHA
tls_preempt_cipherlist = yes
tls_ssl_options = NO_COMPRESSION
virtual_alias_maps = mysql:/etc/postfix/sql/aliases.cf
virtual_gid_maps = static:117
virtual_mailbox_domains = mysql:/etc/postfix/sql/domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/sql/accounts.cf
virtual_transport = lmtp:unix:private/dovecot-lmtp
virtual_uid_maps = static:112
ich dacht mit permit_mynetworks soll keine authentifizierung stattfinden und es sollte so gehen.

Sieht jemand was hab ich falsch gemacht habe?
Danke!

*edith*

ich habe gerade gesehen dass

myhostname = mail.xxxxx.com
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 localhost xxxxx.com

muss bei mynetworks auch mail.xxxxx.com rein?
Mal testen.
Zuletzt geändert von netlord am 31.07.2018 13:20:01, insgesamt 1-mal geändert.
danke und gruß

netlord

Benutzeravatar
weshalb
Beiträge: 898
Registriert: 16.05.2012 14:19:49

Re: Mails über Webinterface nicht versendbar

Beitrag von weshalb » 26.07.2018 12:24:47

Schau mal in die Konfig von Roundcube. auf Server/Clientseite.

netlord
Beiträge: 18
Registriert: 23.12.2011 11:33:05

Re: Mails über Webinterface nicht versendbar

Beitrag von netlord » 30.07.2018 16:59:53

weshalb hat geschrieben: ↑ zum Beitrag ↑
26.07.2018 12:24:47
Schau mal in die Konfig von Roundcube. auf Server/Clientseite.
Meinst Preferences / Server settings?
Die ist recht leer.

Brauch ich da noch ein Plugin dazu?

In der config.inc.php siehts so aus:
// The mail host chosen to perform the log-in.
// Leave blank to show a textbox at login, give a list of hosts
// to display a pulldown menu or set one host as string.
// To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://
// Supported replacement variables:
// %n - hostname ($_SERVER['SERVER_NAME'])
// %t - hostname without the first part
// %d - domain (http hostname $_SERVER['HTTP_HOST'] without the first part)
// %s - domain name after the '@' from e-mail address provided at login screen
// For example %n = mail.domain.tld, %t = domain.tld
$config['default_host'] = '%s';

// SMTP server host (for sending mails).
// To use SSL/TLS connection, enter hostname with prefix ssl:// or tls://
// If left blank, the PHP mail() function is used
// Supported replacement variables:
// %h - user's IMAP hostname
// %n - hostname ($_SERVER['SERVER_NAME'])
// %t - hostname without the first part
// %d - domain (http hostname $_SERVER['HTTP_HOST'] without the first part)
// %z - IMAP domain (IMAP hostname without the first part)
// For example %n = mail.domain.tld, %t = domain.tld
$config['smtp_server'] = '%n';

// SMTP port (default is 25; use 587 for STARTTLS or 465 for the
// deprecated SSL over SMTP (aka SMTPS))
$config['smtp_port'] = 993;

// SMTP username (if required) if you use %u as the username Roundcube
// will use the current username for login
$config['smtp_user'] = '%u';

// SMTP password (if required) if you use %p as the password Roundcube
// will use the current user's password for login
$config['smtp_pass'] = '%p';

// provide an URL where a user can get support for this Roundcube installation
// PLEASE DO NOT LINK TO THE ROUNDCUBE.NET WEBSITE HERE!
$config['support_url'] = '';

// Name your service. This is displayed on the login screen and in the window title
ist da was falsch?
danke und gruß

netlord

Benutzeravatar
weshalb
Beiträge: 898
Registriert: 16.05.2012 14:19:49

Re: Mails über Webinterface nicht versendbar

Beitrag von weshalb » 30.07.2018 20:29:13

Ja genau, die solltest du anpassen.

Bei mir hatte ich beim alten Roundcube immer:
$rcmail_config['default_host'] = 'tls://localhost';

$rcmail_config['smtp_server'] = 'tls://localhost';

// SMTP port (default is 25; 465 for SSL)
$rcmail_config['smtp_port'] = 465;

// SMTP username (if required) if you use %u as the username Roundcube
// will use the current username for login
$rcmail_config['smtp_user'] = '%u';

// SMTP password (if required) if you use %p as the password Roundcube
// will use the current user's password for login
$rcmail_config['smtp_pass'] = '%p';

netlord
Beiträge: 18
Registriert: 23.12.2011 11:33:05

Re: Mails über Webinterface nicht versendbar

Beitrag von netlord » 31.07.2018 13:19:38

weshalb hat geschrieben: ↑ zum Beitrag ↑
30.07.2018 20:29:13
Ja genau, die solltest du anpassen.

Bei mir hatte ich beim alten Roundcube immer:
$rcmail_config['smtp_server'] = 'tls://localhost';

// SMTP port (default is 25; 465 for SSL)
$rcmail_config['smtp_port'] = 465;
Danke für den Schubs in die richtige Richtung!

Mit 'tls://localhost' hats nicht geklappt, aber mit 'tls://mail.server.tld' funktionierts nun.

Und - da ich STARTTLS Verwende port 587

Ist erledigt. Danke
danke und gruß

netlord

Benutzeravatar
weshalb
Beiträge: 898
Registriert: 16.05.2012 14:19:49

Re: [ERLEDIGT] Mails über Webinterface nicht versendbar

Beitrag von weshalb » 31.07.2018 14:10:52

Vergiß auch nicht, in Roundcube selbst bei der Identität des jeweiligen Nutzers die richtige Mailadresse einzutragen.

Meistens steht da "username@localhost"

Desweitern ist es wichtig, in Postfix folgendes einzustellen:
smtpd_sender_login_maps = hash:/etc/postfix/smtpdsender
smtpd_sender_restrictions =
reject_authenticated_sender_login_mismatch,
permit_sasl_authenticated
smtpd_relay_restrictions =
reject_authenticated_sender_login_mismatch,
permit_mynetworks,
permit_sasl_authenticated,
permit_auth_destination,
reject
In der "smtpdsenderdatei" wird für den User die Emailadresse nochmals gesondert aufgelistet, ähnlich wie in der virtual_alias_maps. Wahrscheinlich kannst du die auch dazu benutzen.

Grund ist der, dass man beispielsweise in Roundcube unter Identität keine beliebige Emailadresse eigeben kann.

Antworten