[GELÖST] SoGO.service kann nicht auf MySQL-DB zugreifen

Debian macht sich hervorragend als Web- und Mailserver. Schau auch in den " Tipps und Tricks"-Bereich.
Antworten
BrotherJ
Beiträge: 184
Registriert: 15.11.2018 07:56:18

[GELÖST] SoGO.service kann nicht auf MySQL-DB zugreifen

Beitrag von BrotherJ » 10.01.2021 18:50:56

Ich habe wie hier (viewtopic.php?f=8&t=179944&p=1261161#p1261161) beschreiben, SoGO vorbereitet für die Abfrage einer MySQL-DB mit Mailbenutzer-Konten und sogo.service neugestartet.

Code: Alles auswählen

systemctl restart sogo
Die Error-Logdatei von Mysql zeigt mir aber

Code: Alles auswählen

2021-01-10 18:44:00 1703 [Warning] Aborted connection 1703 to db: 'postfix' user: 'postfix' host: 'localhost' (Got an error reading communication packets)
2021-01-10 18:44:47 1704 [Warning] Access denied for user 'postfix'@'localhost' (using password: YES)
2021-01-10 18:44:47 1705 [Warning] Access denied for user 'postfix'@'localhost' (using password: YES)
2021-01-10 18:44:47 1706 [Warning] Access denied for user 'postfix'@'localhost' (using password: YES)
Wenn ich mich mit demselben Passwort aus

Code: Alles auswählen

defaults write sogod SOGoUserSources '\''({type = sql;id = directory;viewURL = mysql://postfix:password@localhost:3306/postfix/postfix_view;canAuthenticate = YES;isAddressBook = YES;displayName = "Global Address Book";MailFieldNames = (aliases, ad_aliases, senderacl);userPasswordAlgorithm = ssha256;})'\'
über die Mysql-CLI anmelde, dann bekomme ich den gewünscht Zugriff.

Was könnte da schief laufen, bei dem Zugriff durch den sogo.service beim Starten?

Beste Grüße

BrotherJ
Zuletzt geändert von BrotherJ am 17.01.2021 18:42:29, insgesamt 1-mal geändert.
Happiness is NOT a description IT'S A way of life!

Benutzeravatar
novalix
Beiträge: 1818
Registriert: 05.10.2005 12:32:57
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: elberfeld

Re: SoGO.service kann nicht auf MySQL-DB zugreifen

Beitrag von novalix » 11.01.2021 18:18:38

Sieht erstmal OK aus. Gibt es die view denn? Wenn Du Dich per cli client verbindest, machst Du das mit dem gleichen Pfad?
Das Wem, Wieviel, Wann, Wozu und Wie zu bestimmen ist aber nicht jedermannns Sache und ist nicht leicht.
Darum ist das Richtige selten, lobenswert und schön.

BrotherJ
Beiträge: 184
Registriert: 15.11.2018 07:56:18

Re: SoGO.service kann nicht auf MySQL-DB zugreifen

Beitrag von BrotherJ » 13.01.2021 15:11:34

Ja die View existiert. Das Problem liegt m. E. woanders. Ich mache mal mit einem anderen User sogo und der DB sogo weiter - das ist auf einer Testmaschine.
Hier ist genau dasselbe Problem

Code: Alles auswählen

# mysql -u sogo -ppasswort -D sogo -h localhost
ERROR 1045 (28000): Access denied for user 'sogo'@'localhost' (using password: YES)
aber mit

Code: Alles auswählen

# mysql -u sogo -p -D sogo -h localhost          
Enter password: 
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 17
Server version: 10.1.47-MariaDB-0+deb9u1 Debian 9.13

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [sogo]>
klappt es. Es klappt nur, wenn ich das Passwort interaktiv eingebe. Das ist natürlich bei einem Script ganz schlecht.
Happiness is NOT a description IT'S A way of life!

BrotherJ
Beiträge: 184
Registriert: 15.11.2018 07:56:18

Re: SoGO.service kann nicht auf MySQL-DB zugreifen

Beitrag von BrotherJ » 13.01.2021 15:15:27

BrotherJ hat geschrieben: ↑ zum Beitrag ↑
13.01.2021 15:11:34
Ja die View existiert. Das Problem liegt m. E. woanders. Ich mache das mal mit einem anderen User sogo und der DB sogo weiter - das ist auf einer Testmaschine.
Hier ist genau dasselbe Problem

Code: Alles auswählen

# mysql -u sogo -ppasswort -D sogo -h localhost
ERROR 1045 (28000): Access denied for user 'sogo'@'localhost' (using password: YES)
aber mit

Code: Alles auswählen

# mysql -u sogo -p -D sogo -h localhost          
Enter password: 
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MariaDB monitor.  Commands end with ; or \g.
Your MariaDB connection id is 17
Server version: 10.1.47-MariaDB-0+deb9u1 Debian 9.13

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

MariaDB [sogo]>
klappt es. Es klappt nur, wenn ich das Passwort interaktiv eingebe. Das ist natürlich bei einem Script ganz schlecht.
Happiness is NOT a description IT'S A way of life!

BrotherJ
Beiträge: 184
Registriert: 15.11.2018 07:56:18

Re: [GELÖST] SoGO.service kann nicht auf MySQL-DB zugreifen

Beitrag von BrotherJ » 17.01.2021 18:45:58

Problem lag im Passwort selber:

Der User postfix hatte ein Passwort wie "suub$e&uTho7" generiert mit pwgen. Das Anmelden via Script "mysql -u postfix -psuub$e&uTho7" scheiterte am &-Literal. Ändern des Passwortes in Eines ohne Sonderzeichen löste das Problem.
Happiness is NOT a description IT'S A way of life!

Antworten