[gelöst]Boot-Vorgang bricht ab wg. fstab-Eintrag für WebDav-Anbindung

Probleme mit Samba, NFS, FTP und Co.
Antworten
frankieboy
Beiträge: 322
Registriert: 19.08.2003 15:25:48
Wohnort: Bremen

[gelöst]Boot-Vorgang bricht ab wg. fstab-Eintrag für WebDav-Anbindung

Beitrag von frankieboy » 12.09.2018 00:29:22

Hallo Forum,

ich möchte eine Nextcloud-Anbindung mit WebDav erreichen. Zu diesem Zweck habe ich folgenden fstab-Eintrag vorgenommen:

Code: Alles auswählen

https://nxff.xxxx.de/remote.php/webdav/	/home/frankie/nxff	davfs	user,rw,auto	0	0
.

Leider bricht der Bootvorgang beim Neustarten deswegen immer ab. Ich kann mich dann nur noch im abgesicherten Modus einloggen. Die Log-Datei "journalctl -xb" zeigt dazu folgenden Fehlerhinweis:
-- Unit home-frankie-nxff.mount has begun starting up.
Sep 11 23:55:55 algier mount.davfs[258]: davfs2 1.5.4
Sep 11 23:55:55 algier systemd[1]: home-frankie-nxff.mount: Mount process exited, code=exited status=255
Sep 11 23:55:55 algier systemd[1]: Failed to mount /home/frankie/nxff.
-- Subject: Unit home-frankie-nxff.mount has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit home-frankie-nxff.mount has failed.
--
-- The result is failed.
Sep 11 23:55:55 algier systemd[1]: Dependency failed for Local File Systems.
-- Subject: Unit local-fs.target has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit local-fs.target has failed.
--
-- The result is dependency.
Sep 11 23:55:55 algier systemd[1]: local-fs.target: Job local-fs.target/start failed with result 'dependency'.
Sep 11 23:55:55 algier systemd[1]: local-fs.target: Triggering OnFailure= dependencies.
Sep 11 23:55:55 algier systemd[1]: home-frankie-nxff.mount: Unit entered failed state.
Sep 11 23:55:55 algier systemd[1]: Starting Preprocess NFS configuration...
Wenn ich allerdings als normaler User eingloggt bin, komme ich mit

Code: Alles auswählen

mount -a
sehr wohl zum gewünschten Ziel. Ich soll noch die Zugangskennung eingeben und dann sind die NextCloud-Ordner auch schon sichtbar, so wie es sein soll.

Wie gehe ich hier jetzt am besten vor?
Zuletzt geändert von frankieboy am 29.09.2018 21:53:38, insgesamt 1-mal geändert.
Debian Stretch mit xfce-Desktop

Benutzeravatar
jph
Beiträge: 406
Registriert: 06.12.2015 15:06:07
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Greven/Westf.

Re: Boot-Vorgang bricht ab wg. fstab-Eintrag für WebDav-Anbindung

Beitrag von jph » 12.09.2018 18:12:35

Wahrscheinlich wird versucht zu mounten, bevor das Netzwerk da ist. Nichts ungewöhnliches im Bootvorgang. Schau dir Wiki-Artikel zum Thema Netzlaufwerke einbinden an.

Benutzeravatar
Tintom
Beiträge: 1464
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Boot-Vorgang bricht ab wg. fstab-Eintrag für WebDav-Anbindung

Beitrag von Tintom » 13.09.2018 08:48:59

Alternativ gibt es für netzwerkbasierte Dateisysteme auch die Mountoption _netdev.
EDIT: Ich sehe gerade erst das 'auto' als Mountoption, damit ist mein Hinweis hinfällig. Wenn hingegen erst gemountet werden soll, sobald ein Zugriff darauf stattfindet, ist noauto sinnvoller.

frankieboy
Beiträge: 322
Registriert: 19.08.2003 15:25:48
Wohnort: Bremen

Re: Boot-Vorgang bricht ab wg. fstab-Eintrag für WebDav-Anbindung

Beitrag von frankieboy » 29.09.2018 21:51:35

Hallo Forum,

ich bitte um Entschuldigung, dass ich mich erst jetzt wieder melde. Leider ist es so, dass auch ich dem Wahnsinn des Alltags manchmal Vorrang einräumen muss und mich nicht mit den Dingen kann, die mich wirklich interessieren ... :roll: Na ja, so 'nen bisschen habe ich doch gebastelt, dieses und jenes gelesen und eine, wie ich meine, gute Lösung gefunden. Auch eure Beiträge waren hilfreich.
Tintom hat geschrieben: ↑ zum Beitrag ↑
13.09.2018 08:48:59
EDIT: Ich sehe gerade erst das 'auto' als Mountoption, damit ist mein Hinweis hinfällig. Wenn hingegen erst gemountet werden soll, sobald ein Zugriff darauf stattfindet, ist noauto sinnvoller.
Ja. besonders bei einer wackligen Datenverbindung (WLan) ist die 'auto'-Option nicht sinnvoll. Ich habe es auf 'noauto' umgestellt. Die /etc/fstab sieht jetzt so aus:

Code: Alles auswählen

https://nxff.xxxx.de/remote.php/webdav/	/home/frankie/nxff	davfs	rw,noauto,user,uid=1000,gid=1000	0	0
Als Ideal hat sch für mich auch dieses Tutorial erwiesen:
https://blog.tausys.de/2011/04/26/onlin ... einbinden/ Ich habe mich daran beinahe 1:1 gehalten. Den "mount"-Befehl brauche ich jedoch nicht in der Konsole ausführen. XFCE/Thunar stellt mit vorgenannter Konfiguration ein Datei-Symbol "nxff" zur Verfügung, das nach Anklicken die Cloud problemlos einbindet.

Problem gelöst :D
Debian Stretch mit xfce-Desktop

Antworten