isc-dhcp-server - DHCPOFFER - sehr irritierend

Probleme mit Samba, NFS, FTP und Co.
Antworten
gosseberry
Beiträge: 15
Registriert: 02.10.2017 08:54:54

isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von gosseberry » 02.10.2017 15:47:26

Hallo DebianUserInnen,

ich bin neu im Forum; aber kein LINUX Neuling, wohl aber ein debian Neuling.
Auf meinem RaspberryRechner (owncloud) läuft Debian Jessie. Dieser stellt mir gewisse Service zur Verfügung u.a auch den dhcp-Service.
Stelle ich in der /etc/dhcp/dhcp.conf eine IP-Ranges zur Verfügung

Code: Alles auswählen

subnet 10.10.10.0 netmask 255.255.255.0 {
range 10.10.10.100 10.10.10.103;
option domain-name-servers 10.10.10.253;
option routers 10.10.10.253;
so vergibt der DHCP-Server dem RaspberryRechner eine IP-Adresse aus den Range:

Code: Alles auswählen

DHCPDISCOVER from b8:27:eb:8f:2e:f0 via wlan0
Oct 02 15:06:11 klara100Cloud dhcpd[6103]: DHCPOFFER on 10.10.10.101 to b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Oct 02 15:06:12 klara100Cloud dhcpd[6103]: DHCPREQUEST for 10.10.10.101 (10.10.10.6) from b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Oct 02 15:06:12 klara100Cloud dhcpd[6103]: DHCPACK on 10.10.10.101 to b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Das versteht ich nicht!
Das hat zur Folge, dass mein owncloud sync nicht funktioniert, da der Rechner immer mit der 10.10.10.6 angesprochen werden muss. Ich komme hier nicht weiter und es wäre schön, wenn mir jemand einen Tipp geben könnte. Was mache ich falsch (Syntax; Konfiguration)?

Gruß


Nun meine config-Daten:
more /etc/network/interfaces

Code: Alles auswählen

source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

#iface eth0 inet manual

allow-hotplug wlan0
#iface wlan0 inet manual
iface wlan0 inet static
    address 10.10.10.6 
    netmask 255.255.255.0
    gateway 10.10.10.253
    dns-nameservers 10.10.10.6
    dns-domain klara100.lan
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
more /etc/dhcp/dhcpd.conf

Code: Alles auswählen

ddns-update-style none;

# option definitions common to all supported networks...
option domain-name "Klara100.lan";
option domain-name-servers 10.10.10.6;

default-lease-time 600;
max-lease-time 7200;
authoritative;

log-facility local7;

subnet 10.10.10.0 netmask 255.255.255.0 {
 range 10.10.10.100 10.10.10.103;
  option domain-name-servers 10.10.10.6;
  option routers 10.10.10.253;
}

host uk.tablet {
        hardware ethernet 60:21:C0:AA:4A:15;
        fixed-address 10.10.10.7;
        }
ifconfig

Code: Alles auswählen

wlan0     Link encap:Ethernet  HWaddr   b8:27:eb:8f:2e:f0
          inet addr:10.10.10.6  Bcast:10.10.10.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1


MSfree
Beiträge: 3234
Registriert: 25.09.2007 19:59:30

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von MSfree » 02.10.2017 15:55:21

gosseberry hat geschrieben: ↑ zum Beitrag ↑
02.10.2017 15:47:26
...
Auf meinem RaspberryRechner (owncloud) läuft Debian Jessie. Dieser stellt mir gewisse Service zur Verfügung u.a auch den dhcp-Service.
...
so vergibt der DHCP-Server dem RaspberryRechner eine IP-Adresse...
Verstehe ich das richtig?
Du willst, dem RaspberryRechner mittels seinem eigenen, dort laufenden DHCP-Server sich selbst eine IP-Adresse geben lassen?

So kann DHCP gar nicht funktionieren.

gosseberry
Beiträge: 15
Registriert: 02.10.2017 08:54:54

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von gosseberry » 02.10.2017 16:17:48

MSfree hat geschrieben: ↑ zum Beitrag ↑
02.10.2017 15:55:21
gosseberry hat geschrieben: ↑ zum Beitrag ↑
02.10.2017 15:47:26
...
Auf meinem RaspberryRechner (owncloud) läuft Debian Jessie. Dieser stellt mir gewisse Service zur Verfügung u.a auch den dhcp-Service.
...
so vergibt der DHCP-Server dem RaspberryRechner eine IP-Adresse...
Verstehe ich das richtig?
Du willst, dem RaspberryRechner mittels seinem eigenen, dort laufenden DHCP-Server sich selbst eine IP-Adresse geben lassen?

So kann DHCP gar nicht funktionieren.
Falsch verstanden: Der Raspberry hat eine Interface config siehe code: /etc/network/interfaces.
Der DHCP Server beantwortet ein Request und liefert eine ip-adresse aus dem Range.!!! Irrsinn!



Was DHCP machen soll ist klar.

Jana66
Beiträge: 3546
Registriert: 03.02.2016 12:41:11

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von Jana66 » 02.10.2017 17:00:44

Debian benutzt als Standard Debiandnsmasq. Agiert als DNS-Forwarder und DHCP-Server. Konfigurationsdatei: /etc/dnsmasq.conf
Inhalte: https://wiki.ubuntuusers.de/Dnsmasq/
Wozu also Debianisc-dhcp-server? Kommt sich nur in die Quere. Deinstallieren.

Code: Alles auswählen

range 10.10.10.100 10.10.10.103;
Nicht bisschen eng und DHCP witzlos?
DHCP-Server per WLAN angebunden ... ungut. Oder willst du einen Router mit DHCP und evtl. DNS basteln? Dann wäre einiges unüblich, wenn nicht gar falsch. Im Übrigen verstehe ich den Log-Auszug wie @MSFree, trotzdem WLAN0 (MAC b8:27:eb:8f:2e:f0) angeblich die fixe .6 hat, offenbar kein DHCP-Client sein soll. (Und nicht sein darf.)

Poste mal einen kleinen ASCII-Netzwerkplan mit Diensten (DHCP, DNS, Router, ...) und Adressen pro Büchse und gewünschten Subnetzen zwischen Netzwerkkomponenten! Damit der
Irrsinn!
ein Ende hat.

Edit: Owncloud überlesen. Würde dann den Raspi per LAN an (WLAN-) Router anbinden, Raspi-WLAN nicht nutzen. Ist sowieso langsam und im überlasten 2,4-GHz-Band. Auf dem wahrscheinlich schnelleren WLAN-Router laufen bereits alle benötigten Netzwerkdienste (DHCP, DNS) zentral. 2 DHCP-Server wollen gekonnt sein und dürfen nicht ein Subnetz gleichzeitig bedienen. Ist vielleicht der Fehler oben.

Eventuell lohnt ein DNS-Forwarder oder rekursiver Resolver Debianunbound auf einem staendig laufenden Owncloud-Raspi. Evtl. auch PiHole als Anti-Tracking-Massnahme für alle Hosts im Netz, einschließlich Smartwanzen. Der Raspi würde in der Konstellation nur eine fixe IP erhalten. Alles andere macht der Router. Zumal wenn mehrere Subnetze existieren, würde der Raspi-DHCP nur direct connected Netzwerke erreichen. Also ohne Tricks.
Zuletzt geändert von Jana66 am 02.10.2017 18:35:51, insgesamt 2-mal geändert.
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

gosseberry
Beiträge: 15
Registriert: 02.10.2017 08:54:54

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von gosseberry » 02.10.2017 18:01:07

Jana66 hat geschrieben: ↑ zum Beitrag ↑
02.10.2017 17:00:44
Debian benutzt als Standard Debiandnsmasq. Agiert als DNS-Forwarder und DHCP-Server. Konfigurationsdatei: /etc/dnsmasq.conf
Inhalte: https://wiki.ubuntuusers.de/Dnsmasq/
Wozu also Debianisc-dhcp-server? Kommt sich nur in die Quere. Deinstallieren.
Okay - schau ich mir mal an.

Code: Alles auswählen

range 10.10.10.100 10.10.10.103;
Nicht bisschen eng und DHCP witzlos?

Nein - Der Range ist extra klein gehalten; für Gäste; Es gibt noch mehrere FIX-Adressen, die aber nicht abgegeben waren.

DHCP-Server per WLAN angebunden ... ungut.
Wieso?
Oder willst du einen Router mit DHCP und evtl. DNS basteln? Dann wäre einiges unüblich, wenn nicht gar falsch. Im Übrigen verstehe ich den Log-Auszug wie @MSFree, trotzdem WLAN0 (MAC b8:27:eb:8f:2e:f0) angeblich die fixe .6 hat, offenbar kein DHCP-Client sein soll. (Und nicht sein darf.) Richtig
Nicht angeblich sondern real: wenn die /etc/network/interface richtig eingelesen wird
Raspberry soll dhcp-Server und lokaler dns-Server werden; kein router wenn ip-router damit gemeint ist.
Warum ist das unüblich und falsch? Verstehe ich nicht. Ich kann doch einen DHCP-Server aufsetzen, der mir die Client bedient und den Clients mitteilt, wer der der lokale DNS ist - oder sehe ich das falsch? Vielleicht geht das bei debian eben mit dsnmasq


Poste mal einen kleinen ASCII-Netzwerkplan mit Diensten (DHCP, DNS, Router, ...) und Adressen pro Büchse und gewünschten Subnetzen zwischen Netzwerkkomponenten! Damit der
Irrsinn!
ein Ende hat.
Danke für jeden weiteren Tipp und Kommentar.

Gruß
RB

gosseberry
Beiträge: 15
Registriert: 02.10.2017 08:54:54

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von gosseberry » 02.10.2017 19:50:08

Jana66 hat geschrieben: ↑ zum Beitrag ↑
02.10.2017 17:00:44
Debian benutzt als Standard Debiandnsmasq. Agiert als DNS-Forwarder und DHCP-Server. Konfigurationsdatei: /etc/dnsmasq.conf
Inhalte: https://wiki.ubuntuusers.de/Dnsmasq/
Wozu also Debianisc-dhcp-server? Kommt sich nur in die Quere. Deinstallieren.

Code: Alles auswählen

range 10.10.10.100 10.10.10.103;
Nicht bisschen eng und DHCP witzlos?
DHCP-Server per WLAN angebunden ... ungut. Oder willst du einen Router mit DHCP und evtl. DNS basteln? Dann wäre einiges unüblich, wenn nicht gar falsch. Im Übrigen verstehe ich den Log-Auszug wie @MSFree, trotzdem WLAN0 (MAC b8:27:eb:8f:2e:f0) angeblich die fixe .6 hat, offenbar kein DHCP-Client sein soll. (Und nicht sein darf.)

Poste mal einen kleinen ASCII-Netzwerkplan mit Diensten (DHCP, DNS, Router, ...) und Adressen pro Büchse und gewünschten Subnetzen zwischen Netzwerkkomponenten! Damit der
Irrsinn!
ein Ende hat.

Edit: Owncloud überlesen. Würde dann den Raspi per LAN an (WLAN-) Router anbinden, Raspi-WLAN nicht nutzen. Ist sowieso langsam und im überlasten 2,4-GHz-Band. Auf dem wahrscheinlich schnelleren WLAN-Router laufen bereits alle benötigten Netzwerkdienste (DHCP, DNS) zentral. 2 DHCP-Server wollen gekonnt sein und dürfen nicht ein Subnetz gleichzeitig bedienen. Ist vielleicht der Fehler oben.

Raspi-WLAN - ist eine andere Geschichte;

Auf dem Telekom-Router - leider keine CISCO (LAN-Interface 10.10.10.253 und eben default route) ist der DHCP disabled, da keine FIX_IP-Adresse Vergabe möglich ist. Der einzige DHCP-Server im LAN ist Raspi; es stellt sich für mich immer noch die Frage, warum der Raspi-debian-isc... DHCP-Server und -Client ist.

Sind diese Dateien von Bedeutung?

Code: Alles auswählen

/etc/dhcp/dhclient.conf
/etc/dhcp/dhclient-enter-hooks.d/ <----  hier stehen ein paar files
/etc/dhcp/dhclient-exit-hooks.d/ <---- hier stehen ein paar files 

Geplant ist einen DNS-Cache-Server aufzusetzen, läuft schon, leider noch mit dem Mangel eines "server can't find : NXDOMAIN" . Das ist aber eine andere Geschichte. Vielleicht hängt das aber irgendwie zusammen.

more /etc/bind/named.conf

Code: Alles auswählen

#
options {
  directory "/etc/bind";
  listen-on port 53 { localhost; 10.10.10.0/24; };
  allow-query { localhost; 10.10.10.0/24; };
  forwarders { 10.10.10.253; };
  recursion yes;
};
Eventuell lohnt ein DNS-Forwarder oder rekursiver Resolver Debianunbound auf einem staendig laufenden Owncloud-Raspi. Evtl. auch PiHole als Anti-Tracking-Massnahme für alle Hosts im Netz, einschließlich Smartwanzen. Der Raspi würde in der Konstellation nur eine fixe IP erhalten. Alles andere macht der Router. Zumal wenn mehrere Subnetze existieren, würde der Raspi-DHCP nur direct connected Netzwerke erreichen. Also ohne Tricks.
Gibt es noch ein paar Tipps? - Danke

Gruß
RB

Jana66
Beiträge: 3546
Registriert: 03.02.2016 12:41:11

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von Jana66 » 02.10.2017 20:00:22

Lasse bitte sinnlose Vollzitate - insbesondere dann, wenn der Text unmittelbar darüber steht!!!
Auf dem Telekom-Router - leider keine CISCO (LAN-Interface 10.10.10.253 und eben default route) ist der DHCP disabled, da keine FIX_IP-Adresse Vergabe möglich ist.
Der letzte Teilsatz ist Quark. Ausserhalb des aktiven DHCP-Pools kannst du problemlos fixe IPs vergeben. Schaue im Manual, welcher DHCP-Pool benutzt wird oder schalte den Server ein und schaue am Smartphone (DHCP-Client) welche Adresse. Oft wird ab .101 per DHCP vergeben. Selbst wenn du einem Host eine fixe IP innerhalb des DHCP-Pools verklickerst, werden DHCP-Clients eine Lease mit vorhandener IP ablehnen, eine weitere anfordern, weil sie vorher per ARP-Request auf IP-Doppelungen prüfen. Ist aber unsauber, IPs aus dem Pool fest zu vergeben.
(Mit hoher Wahrscheinlichkeit kannst du den DHCP-Pool auch einengen und sogar DHCP-MAC-IP-Reservierungen vornehmen, so dass ein DHCP-Client entsprechend seiner MAC-Adresse immer die gleiche IP erhält.)
Also bleibt es bei meinen Tipps im vorigen Beitrag.
... es stellt sich für mich immer noch die Frage, warum der Raspi ... DHCP-Server und -Client ist.
Weil auf dem Raspi noch ein DHCP-Client läuft, ich schätze, per dnsmasq (bei Installation automatisch) konfiguriert. Aber dazu sagst du ja leider nichts. Die Konfigurationsdatei hatte ich auch (umsonst) genannt.

Code: Alles auswählen

DHCPDISCOVER from b8:27:eb:8f:2e:f0 via wlan0
Oct 02 15:06:11 klara100Cloud dhcpd[6103]: DHCPOFFER on 10.10.10.101 to b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Oct 02 15:06:12 klara100Cloud dhcpd[6103]: DHCPREQUEST for 10.10.10.101 (10.10.10.6) from b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Oct 02 15:06:12 klara100Cloud dhcpd[6103]: DHCPACK on 10.10.10.101 to b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Initiale Adresszuweisung, Lease-Vergabe.

Konfiguriere dnsmasq korrekt, deinstalliere Debianisc-dhcp-server. Wenn es nicht klappt, poste die Konfig. von Debiandnsmasq!
Geplant ist einen DNS-Cache-Server aufzusetzen, läuft schon, leider noch mit dem Mangel eines "server can't find : NXDOMAIN" .
Mit Debiandnsmasq auch gegessen. Ungut per Raspi-WLAN, da sind moderne Speedports besser!
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

mat6937
Beiträge: 940
Registriert: 09.12.2014 10:44:00

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von mat6937 » 02.10.2017 23:45:46

gosseberry hat geschrieben: ↑ zum Beitrag ↑
02.10.2017 15:47:26

Code: Alles auswählen

DHCPDISCOVER from b8:27:eb:8f:2e:f0 via wlan0
Oct 02 15:06:11 klara100Cloud dhcpd[6103]: DHCPOFFER on 10.10.10.101 to b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Oct 02 15:06:12 klara100Cloud dhcpd[6103]: DHCPREQUEST for 10.10.10.101 (10.10.10.6) from b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Oct 02 15:06:12 klara100Cloud dhcpd[6103]: DHCPACK on 10.10.10.101 to b8:27:eb:8f:2e:f0 (klara100Cloud) via wlan0
Das versteht ich nicht!

ifconfig

Code: Alles auswählen

wlan0     Link encap:Ethernet  HWaddr   b8:27:eb:8f:2e:f0
          inet addr:10.10.10.6  Bcast:10.10.10.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

Wie sind auf deinem PI, die Ausgaben von:

Code: Alles auswählen

ip a
ps aux | grep -i [d]hc
apt-cache policy dhcpcd5
?

gosseberry
Beiträge: 15
Registriert: 02.10.2017 08:54:54

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von gosseberry » 03.10.2017 09:23:54

Wie sind auf deinem PI, die Ausgaben von:

Code: Alles auswählen

ip a
ps aux | grep -i [d]hc
apt-cache policy dhcpcd5

Code: Alles auswählen

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether b8:27:eb:da:7b:a5 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:8f:2e:f0 brd ff:ff:ff:ff:ff:ff
    inet 10.10.10.6/24 brd 10.10.10.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet 169.254.94.116/16 brd 169.254.255.255 scope global wlan0   <<<<<<<<<<<<<<<<<<<<<<<<<<-----------------------  ??????????????
       valid_lft forever preferred_lft forever

Code: Alles auswählen

root       488  0.0  0.1   2560  1336 ?        Ss   21:17   0:00 /sbin/dhcpcd -q -b
root       863  0.0  0.6   9464  6172 ?        Ss   21:17   0:00 /usr/sbin/dhcpd -q -cf /etc/dhcp/dhcpd.conf -pf /var/run/dhcpd.pid wlan0

Code: Alles auswählen

apt-cache policy dhcpcd5
dhcpcd5:
  Installed: 6.7.1-1+rpi5
  Candidate: 6.7.1-1+rpi5
  Version table:
 *** 6.7.1-1+rpi5 0
        500 http://archive.raspberrypi.org/debian/ jessie/main armhf Packages
        100 /var/lib/dpkg/status
     6.0.5-2 0
        500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages


mat6937
Beiträge: 940
Registriert: 09.12.2014 10:44:00

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von mat6937 » 03.10.2017 09:59:42

gosseberry hat geschrieben: ↑ zum Beitrag ↑
03.10.2017 09:23:54

Code: Alles auswählen

3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether b8:27:eb:8f:2e:f0 brd ff:ff:ff:ff:ff:ff
    inet 10.10.10.6/24 brd 10.10.10.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet 169.254.94.116/16 brd 169.254.255.255 scope global wlan0   <<<<<<<<<<<<<<<<<<<<<<<<<<-----------------------  ??????????????
       valid_lft forever preferred_lft forever

Code: Alles auswählen

root       488  0.0  0.1   2560  1336 ?        Ss   21:17   0:00 /sbin/dhcpcd -q -b
root       863  0.0  0.6   9464  6172 ?        Ss   21:17   0:00 /usr/sbin/dhcpd -q -cf /etc/dhcp/dhcpd.conf -pf /var/run/dhcpd.pid wlan0
Wegen "fehlerhafter" Konfiguration hat der dhcpcd(-Client), dem wlan0-Interface, auch eine LL-IP-Adresse zugewiesen.

Ich denke Du hast die Frage von MSfree falsch verstanden, denn für die Zuweisung einer (einzigen) IP-Adresse, brauchst Du auf deinem PI keinen dhcp-Server. Die interfaces-Datei wird dafür auch nicht mehr benötigt. Das kannst Du z. B. mit dhcpcd und/oder mit systemd.network machen.

gosseberry
Beiträge: 15
Registriert: 02.10.2017 08:54:54

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von gosseberry » 03.10.2017 12:40:48

Code: Alles auswählen

root       488  0.0  0.1   2560  1336 ?        Ss   21:17   0:00 /sbin/dhcpcd -q -b
root       863  0.0  0.6   9464  6172 ?        Ss   21:17   0:00 /usr/sbin/dhcpd -q -cf /etc/dhcp/dhcpd.conf -pf /var/run/dhcpd.pid wlan0
/sbin/dhcpcd -q -b wird über /lib/systemd/system/dhcpcd.service gestartet
und der andere dhcp-prozess über dhcp selber.
Wegen "fehlerhafter" Konfiguration hat der dhcpcd(-Client), dem wlan0-Interface, auch eine LL-IP-Adresse zugewiesen.
Ich kenne nur die /etc/dhcp/dhcp.conf; welche Datei soll den falsch sein?
Ich denke Du hast die Frage von MSfree falsch verstanden, denn für die Zuweisung einer (einzigen) IP-Adresse, brauchst Du auf deinem PI keinen dhcp-Server. Die interfaces-Datei wird dafür auch nicht mehr benötigt. Das kannst Du z. B. mit dhcpcd und/oder mit systemd.network machen.
Es sind mehrere DHCP-MAC-Clients in der dhcp.conf. Ich habe nur nicht alle aufgeführt.
Also ich werde das nun mit dem dnsmasq versuchen.
Die Vorgehensweise:
delete dhcp : apt-get purge isc-dhcp-server
delete bind9 : apt-get purge bind9

ohne auto-remove

als opensuse 42.3 user, gefragt sind die Befehle so okay?

und install dnsmasq

Danke für weitere Informationen

Gruß
RB

mat6937
Beiträge: 940
Registriert: 09.12.2014 10:44:00

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von mat6937 » 03.10.2017 13:17:13

gosseberry hat geschrieben: ↑ zum Beitrag ↑
03.10.2017 12:40:48
Ich kenne nur die /etc/dhcp/dhcp.conf; welche Datei soll den falsch sein?
Naja, nicht falsch, .... evtl. nicht mehr erforderlich. Z. B. die "/etc/dhcpcd.conf"-Datei:

Code: Alles auswählen

noipv4ll
Don't attempt to obtain an IPv4LL address if we failed to get one via DHCP. See RFC 3927.
Aber, wenn mit dem dhcpcd-daemon keine IP-Adresse zugewiesen werden soll, stellt sich die Frage warum dhcpcd noch aktiv ist bzw. dhcpcd5 noch auf deinem PI installiert ist.

gosseberry
Beiträge: 15
Registriert: 02.10.2017 08:54:54

[ready] Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von gosseberry » 04.10.2017 13:55:06

Ich habe auf dnsmasq umgestellt und isc-dhcp-server, dhcp-(Client) und bind9 disabled. :THX:
Alles klar ist mir aber unter debian noch nicht.
Danke an alle die mich unterstützt haben. :D

Gruß
RB

Jana66
Beiträge: 3546
Registriert: 03.02.2016 12:41:11

Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von Jana66 » 04.10.2017 15:24:12

gosseberry hat geschrieben: ↑ zum Beitrag ↑
04.10.2017 13:55:06
Ich habe auf dnsmasq umgestellt und isc-dhcp-server, dhcp-(Client) und bind9 disabled. :THX:
Falls du Debiandnsmasq nur als DNS-Forwarder und nicht als DHCP-Server verwendest (hat ja dein Router), der Raspi als Server sowieso eine fixe IP hat (und haben sollte), kannst du anstelle Debiandnsmasq den Debianunbound als rekursiven und verifizierenden Resolver probieren. (Suche dir dafür ein hübsches Manual im Netz.) Debianunbound wäre ein qualitativer Unterschied zu dem sowieso vorhandenem DNS-Forwarder auf deinem Plastikrouter und würde deshalb auf dem Raspi richtig Sinn ergeben.
https://en.wikipedia.org/wiki/Unbound_(DNS_server)
Zu PiHole, DNS-Blocking und Anti-Tracking-Maßnahmen:
https://www.kuketz-blog.de/pi-hole-schw ... -pi-teil1/
Funktioniert auch für Smartwanzen mit Eintrag des Raspi-DNS im DHCP-Server.

Debianbind9 ist oversized, wenn man keinen öffentlichen DNS benötigt. Und entsprechend kompliziert zu konfigurieren. :wink:
https://de.wikipedia.org/wiki/BIND

Anmerkung: Ein DHCP-Server auf dem Router hat mehr Sinn als auf dem Raspi, falls du irgendwann mal mittels VLANs Netzwerke (Gastnetz für Gäste, neugierige Android-TVs, Smartwanzen / Büronetz / Privatnetz / Kindernetz für Windows-Viren-Schleudern, Playstations etc.) separieren möchtest. Nur der Router-DHCP-Server erreicht alle Netzwerke. Dafür benötigst du allerdings einen zusätzlichen (preiswerten) DDWRT-/OpenWrt-/LEDE-Router oder eine Firewall-Distribution wie PFSense/OPNSense/IPFire oder Debian auf einem stromsparenden Miniserver.
Z. B: http://varia-store.com/Hardware/PC-Engi ... _1085.html

Sorry, mit mir ist die ehem. Netzwerkplanerin mal wieder durchgegangen. :mrgreen:
Alles klar ist mir aber unter debian noch nicht.
https://www.debian.org/doc/manuals/debi ... 05.de.html
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

mat6937
Beiträge: 940
Registriert: 09.12.2014 10:44:00

Re: [ready] Re: isc-dhcp-server - DHCPOFFER - sehr irritierend

Beitrag von mat6937 » 05.10.2017 00:20:32

gosseberry hat geschrieben: ↑ zum Beitrag ↑
04.10.2017 13:55:06
Ich habe auf dnsmasq umgestellt ...
Wenn Du den dnsmasq auf dem PI verwendest, schau mal nach ob dieser mit "-DHAVE_BROKEN_RTC" kompiliert worden ist. Denn lt. config.h-Datei aus dem source code:
HAVE_BROKEN_RTC
define this on embedded systems which don't have an RTC
which keeps time over reboots. Causes dnsmasq to use uptime
for timing, and keep lease lengths rather than expiry times
in its leases file. This also make dnsmasq "flash disk friendly".
Normally, dnsmasq tries very hard to keep the on-disk leases file
up-to-date: rewriting it after every renewal. When HAVE_BROKEN_RTC
is in effect, the lease file is only written when a new lease is
created, or an old one destroyed. (Because those are the only times
it changes.) This vastly reduces the number of file writes, and makes
it viable to keep the lease file on a flash filesystem.
NOTE: when enabling or disabling this, be sure to delete any old
leases file, otherwise dnsmasq may get very confused.

Code: Alles auswählen

strings $(which dnsmasq) | grep -i no-rtc
dnsmasq -v

Antworten