Samba 4.7.3 - Zugriff Laufwerk

Probleme mit Samba, NFS, FTP und Co.
Foxingtion
Beiträge: 23
Registriert: 24.04.2004 19:54:36

Samba 4.7.3 - Zugriff Laufwerk

Beitrag von Foxingtion » 26.12.2017 12:29:32

Hallo zusammen,

ich arbeite gerade mit einem Debian Stretch & Samba 4.7.3 mit winbind.

Ich habe aktuell die Schwierigkeit auf Daten einer Festplatte zuzugreifen, Client ist ein Windows 7 oder 10 Rechner. Testhalber habe ich das Homeverzeichnis des AD Users eingebunden und hier erfolgt ein kompletter Zugriff, sowie es werden alle Dateien & Verzeichnisse angezeigt.

Code: Alles auswählen

root@lic-srv-file:/mnt# ls -lha /home/Domaine/testbenutzer/
total 32K
drwx------ 3 testbenutzer domänen-benutzer 4.0K Dec 26 10:18 .
drwxr-xr-x 3 root     domänen-benutzer 4.0K Dec 26 09:42 ..
-rw------- 1 testbenutzer domänen-benutzer  583 Dec 26 10:26 .bash_history
-rw------- 1 testbenutzer domänen-benutzer  220 Dec 26 09:42 .bash_logout
-rw------- 1 testbenutzer domänen-benutzer 3.5K Dec 26 09:42 .bashrc
drwx------ 3 testbenutzer domänen-benutzer 4.0K Dec 26 09:42 .gnupg
-rw------- 1 testbenutzer domänen-benutzer  675 Dec 26 09:42 .profile
-rwxr--r-- 1 testbenutzer domänen-benutzer    4 Dec 26 09:56 test.txt

Code: Alles auswählen

Festplatte:
root@lic-srv-file:/mnt# ls -lha /mnt/data7/
total 48K
drwxrwxrwx  5 testbenutzer domänen-benutzer 4.0K Oct  9  2014 .
drwxr-xr-x 10 root     root              4.0K Aug  8  2013 ..
-rwxr--r--  1 testbenutzer domänen-benutzer  265 Jan 14  2012 AD.txt
drwx------  2 testbenutzer domänen-benutzer  16K Jul 31  2013 lost+found
-rwxr--r--  1 testbenutzer domänen-benutzer   94 Oct  6  2011 netdom.txt
getent passwd <- funktioniert
getent group <- funktioniert

Vlt seh ich aktuell den Wald vor lauter Bäumen nicht mehr, aber die Berechtigung passen, das Samba auf dieses Laufwerk zugreifen kann und trotzdem wird es mir als leer in Windows angezeigt.

Habt Ihr mir noch einen Tip, wo ich noch genau ansetzen kann? Ich habe mir die Berechtigungen des share im Windows anzeigen lassen:
[TEST] <- hier wird mir der testuser & domänen-benutzer angezeigt
[DATA1] <- hier wird mir komischerweise UNIX-Group\root & die LIC-SRV-FILE\root angezeigt

smb.conf
Zuletzt geändert von KBDCALLS am 26.12.2017 15:44:22, insgesamt 1-mal geändert.
Grund: Sorry da hatte sich die 5 verkrümelt , bei der Übertragung nach NoPaste
Do not change a running System ^^

Benutzeravatar
weshalb
Beiträge: 790
Registriert: 16.05.2012 14:19:49

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von weshalb » 26.12.2017 13:57:21

Das soll deine smb.conf sein?

Foxingtion
Beiträge: 23
Registriert: 24.04.2004 19:54:36

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von Foxingtion » 26.12.2017 15:39:32

Hallo,

ja das ist meine aktuelle Variante.

Ich vermute es liegt an einer Berechtigung auf dem zusätzlichen Laufwerk, den ich habe spaßhalber mal folgendes probiert:

Code: Alles auswählen

[TEST_1]
	comment = Test - Share
	path = /mnt/
	read only = No
	create mask = 0754
	#guest ok = Yes
	hide dot files = No
	hide files = /lost+found/:2eFBCLockFolder/.FBCLockFolder/:2eFBCIndex/.FBCIndex/TheVolumeSettingsFolder/TheFindByContentFolder/Temporary Items/Network Trash Folder/.AppleDB/:2eVolumeIcon.icns/.VolumeIcon.icns/Icon/.AppleDouble/.AppleDesktop/desktop.ini/RECYCLER/.apdisk/
Damit seh ich die Übersicht unter dem Ordner "mnt", aber wenn ich hier auf die die gemountete Festplatte zugreifen will über Samba, kommt nur ein leeres Verzeichnis. Über die Konsole, etc komme ich ohne probleme auf die Festplatte und deren Inhalte.

Habt Ihr mir einen Tip, was sich hier an der Berechtigungsstruktur im Samba geändert haben kann?

Vielen Dank
Do not change a running System ^^

Benutzeravatar
weshalb
Beiträge: 790
Registriert: 16.05.2012 14:19:49

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von weshalb » 26.12.2017 19:58:52

Kannst du denn über Samba wenigstens Dateien und Ordner anlegen?

Wenn nicht, würde ich mal die Rechte auf dem Ordner selbst überprüfen. Hier kannst du mal schauen, wie Rechte beispielsweise vergeben werden.

viewtopic.php?f=9&t=167113

rendegast
Beiträge: 14731
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von rendegast » 27.12.2017 12:40:19

Ist /mnt/data7/ schon gemountet, wenn samba startet?
Resp. wird nach dem Mounten des Ziels nach /mnt/data7/ samba neu gestartet?

Du könntest im ungemounteten! Zielverzeichnis /mnt/data7/ eine Prüfdatei hinterlegen, zBsp.

Code: Alles auswählen

umount -v /mnt/data7/
ls -ld /mnt/data7

mount | grep data7  ||  touch /mnt/data7/nicht_gemountet
Zuletzt geändert von rendegast am 27.12.2017 16:49:08, insgesamt 1-mal geändert.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

Foxingtion
Beiträge: 23
Registriert: 24.04.2004 19:54:36

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von Foxingtion » 27.12.2017 15:00:36

Hallo,

also zu 1stens:
- Ja ich kann Ordner & Dateien auf dem [TEST] anlegen, ändern, löschen unter Windows

Zu 2tens:
Die zusätzliche Platte ist gemounted und ich kann unter der Konsole ohne Probleme auf diese zugreifen

Ich vermute immer stärker, das es ein Berechtigungsproblem ist, das Samba auf diese Festplatte nicht zugreifen kann. Ich habe die Berechtigung der Verzeichnisse auf der zusätzliche Platte bereits auf Domänen-User angepasst, so das ich mit dem User eigentlich ohne Probleme zugreifen müsste.

Daher, hat sich die Berechtigung von Samba in irgendeiner Weise geändert, Samba wird bei mir als root ausgeführt und selbst wenn ich den Benutzer auf root ändere, keine Chance, Samba kann nicht auf die Dateien zugreifen, bzw. zeigt mir diese an. Selbst wenn ich chmod 777 für die Festplatte ändere.
Do not change a running System ^^

Benutzeravatar
weshalb
Beiträge: 790
Registriert: 16.05.2012 14:19:49

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von weshalb » 27.12.2017 18:26:59

Ich fasse mal zusammen: Du kannst auf den Sambashare zugreifen, siehst aber keine Dateien aus dem Mount darin, kannst aber darin welche anlegen usw.

Dann mache einfach folgendes: Schau dir die Rechte der neuen Dateien an, die du über Samba erstellen kannst und gebe einfach mal einer Datei, die du nicht siehst, das gleiche Recht (wenn du es visuell brauchst, kannst du das über WinScp machen). Lass dir gleich auch noch mal die Rechte der Dateien anzeigen, die du nicht siehst.

Wenn es klappt, änderst du einfach die Rechte in die richtige Richtung ab. Es spielt nämlich keine Rolle, was du in der smb.conf für Rechte angibst, wenn sich darin bereits Dateien befinden, die völlig andere Rechte haben.

Foxingtion
Beiträge: 23
Registriert: 24.04.2004 19:54:36

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von Foxingtion » 28.12.2017 22:16:26

Hallo Nochmal,

wie du geschrieben hast, hab ich mir die neu angelegten Dateien und Verzeichnisse mit der Berechtigung angeschaut:

Group: 10000 (domain-user)
User: 10000 (testuser)
Berechtigung: 755

Exakt diese Berechtigung habe ich jetzt von /mnt bis auf das letzte Verzeichnis & Datei auf der zusätzlichen Festplatte "aufgespielt". (chown -R 10000:10000 /mnt/data*/ und chmod -R 755 /mnt/data*/)
Danach Samba neu gestartet und leider wird mir nichts angezeigt :-/

Ich bin ehrlich gesagt langsam so ziemlich ratlos.

Hab hier mal die Logfileausgabe, wenn ich auf das Verzeichnis zugreifen will, in welchem mir nichts angezeigt wird (vlt. fällt Euch hier etwas auf):
[2017/12/28 22:13:11.562499, 3] ../lib/util/access.c:361(allow_access)
Allowed connection from 192.168.100.252 (192.168.100.252)
[2017/12/28 22:13:11.562581, 3] ../libcli/security/dom_sid.c:210(dom_sid_parse_endp)
string_to_sid: SID root is not in a valid format
[2017/12/28 22:13:11.563295, 3] ../source3/passdb/lookup_sid.c:1680(get_primary_group_sid)
Forcing Primary Group to 'Domain Users' for root
[2017/12/28 22:13:11.563559, 3] ../source3/smbd/service.c:595(make_connection_snum)
Connect path is '/mnt/data1/' for service [DATA1]
[2017/12/28 22:13:11.563633, 3] ../libcli/security/dom_sid.c:210(dom_sid_parse_endp)
string_to_sid: SID root is not in a valid format
[2017/12/28 22:13:11.564208, 3] ../source3/passdb/lookup_sid.c:1680(get_primary_group_sid)
Forcing Primary Group to 'Domain Users' for root
[2017/12/28 22:13:11.564425, 3] ../source3/smbd/vfs.c:113(vfs_init_default)
Initialising default vfs hooks
[2017/12/28 22:13:11.564476, 3] ../source3/smbd/vfs.c:139(vfs_init_custom)
Initialising custom vfs hooks from [/[Default VFS]/]
[2017/12/28 22:13:11.564713, 3] ../libcli/security/dom_sid.c:210(dom_sid_parse_endp)
string_to_sid: SID root is not in a valid format
[2017/12/28 22:13:11.565270, 3] ../source3/passdb/lookup_sid.c:1680(get_primary_group_sid)
Forcing Primary Group to 'Domain Users' for root
[2017/12/28 22:13:11.565590, 2] ../source3/smbd/service.c:841(make_connection_snum)
192.168.100.252 (ipv4:192.168.100.252:30711) connect to service DATA1 initially as user DOMÄNE\testuser (uid=10000, gid=10000) (pid 2100)
[2017/12/28 22:13:11.567657, 3] ../source3/smbd/smb2_server.c:3120(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_NOT_SUPPORTED] || at ../source3/smbd/smb2_getinfo.c:154
[2017/12/28 22:13:11.568035, 3] ../source3/smbd/smb2_server.c:3120(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_NOT_SUPPORTED] || at ../source3/smbd/smb2_getinfo.c:154
[2017/12/28 22:13:11.568752, 3] ../source3/rpc_server/srv_pipe.c:748(api_pipe_bind_req)
api_pipe_bind_req: srvsvc -> srvsvc rpc service
[2017/12/28 22:13:11.568819, 3] ../source3/rpc_server/srv_pipe.c:356(check_bind_req)
check_bind_req for srvsvc context_id=0
[2017/12/28 22:13:11.568869, 3] ../source3/rpc_server/srv_pipe.c:399(check_bind_req)
check_bind_req: srvsvc -> srvsvc rpc service
[2017/12/28 22:13:11.569727, 3] ../source3/rpc_server/srv_pipe.c:1528(api_rpcTNP)
api_rpcTNP: rpc command: SRVSVC_NETSHAREGETINFO
[2017/12/28 22:13:11.571195, 3] ../source3/smbd/smb2_server.c:3120(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_FS_DRIVER_REQUIRED] || at ../source3/smbd/smb2_ioctl.c:309
[2017/12/28 22:13:11.764660, 3] ../source3/smbd/smb2_server.c:3120(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[1] status[NT_STATUS_OBJECT_NAME_NOT_FOUND] || at ../source3/smbd/smb2_create.c:293
[2017/12/28 22:13:11.765852, 3] ../source3/smbd/smb2_notify.c:250(smbd_smb2_notify_send)
smbd_smb2_notify_send: notify change called on ., filter = DIR_NAME, recursive = 0
[2017/12/28 22:13:11.766594, 3] ../source3/smbd/dir.c:657(dptr_create)
creating new dirptr 0 for path ., expect_close = 0
[2017/12/28 22:13:11.766724, 3] ../source3/smbd/dir.c:1228(smbd_dirptr_get_entry)
smbd_dirptr_get_entry mask=[*] found . fname=. (.)
[2017/12/28 22:13:11.766818, 3] ../source3/smbd/dir.c:1228(smbd_dirptr_get_entry)
smbd_dirptr_get_entry mask=[*] found .. fname=.. (..)
[2017/12/28 22:13:11.766981, 3] ../source3/smbd/smb2_server.c:3120(smbd_smb2_request_error_ex)
smbd_smb2_request_error_ex: smbd_smb2_request_error_ex: idx[9] status[STATUS_NO_MORE_FILES] || at ../source3/smbd/smb2_query_directory.c:155
[2017/12/28 22:13:11.767989, 3] ../source3/smbd/smb2_notify.c:250(smbd_smb2_notify_send)
smbd_smb2_notify_send: notify change called on ., filter = FILE_NAME|ATTRIBUTES|LAST_WRITE, recursive = 0
Do not change a running System ^^

Benutzeravatar
weshalb
Beiträge: 790
Registriert: 16.05.2012 14:19:49

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von weshalb » 28.12.2017 22:52:42

Die Dateien und die Ordner haben jetzt die gleichen Rechte, so wie die neu angelegten und du kannst sie immer noch nicht sehen?

Schonmal mit force group und valid user in der smb.conf unter der entsprechenden Freigabe probiert?

rendegast
Beiträge: 14731
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von rendegast » 28.12.2017 23:01:05

[DATA1]
comment = 2 TB Share
path = /mnt/data7/
<->
2017/12/28 22:13:11.563559, 3] ../source3/smbd/service.c:595(make_connection_snum)
Connect path is '/mnt/data1/' for service [DATA1]
Wird im falschen Verzeichnis nach erstellten Dateien gesehen?



Die effektiv gültigen Einstellungen zeigt

Code: Alles auswählen

testparm -vs
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

arnysch
Beiträge: 4
Registriert: 30.12.2017 14:28:32

Hab gleiches Problem. "mount namespace" hell?

Beitrag von arnysch » 30.12.2017 15:10:42

Verwende Debian Testing ("buster") und Samba 4.7.3, Kernel 4.14.10.
Der Samba Server wird durch systemd bei Systemboot gestartet. Nachträglich wird manuell ein Dateisystem eingebunden.
Seit einigen Tagen (wahrscheinlich nach einem Debian- oder Kernel-Update) habe ich das gleiche Problem.

Bei /proc/self/mounts in meiner SSH-Shell wird mir der Mount angezeigt.

Bei /proc/SMBDPID/mounts taucht das neu eingebundete Dateisystem nicht auf
(SMBPID ist natürlich die Process ID eines smbd-Prozesses von "ps x|grep smbd").

Hab jetzt dazugelernt, dass es schon seit einiger Zeit der Kernel sogenannte Mount Namespaces unterstützt.
Das heisst, verschiedene Prozesse können verschiedene Mount Namespaces zugeordnet haben.
Wenn ein Mount in einem Namespace nicht registriert ist, dann sieht der Prozess nur das urspüngliche Mountpoint-Verzeichnis.

Vermute mal, dass der systemd da die smbd-Prozesse mit eigenene Mount Namespaces startet, und dass da jetzt irgendwas geändert wurde.
Verstehe aber bis jetzt weder die Details von Mount Namespaces noch die Details, was/wie systemd mit Mount Namespaces umgeht.

Hab blind rumprobiert, aber noch keine Lösung gefunden. Z.B. hilft dies nicht:
mount --make-shared $DEV $MNPOINT
oder in /etc/systemd/system/multi-user.target.wants/smbd.service
[Service]
MountAPIVFS=0

Bin genervt, aber ok, selbst schuld. Wenn ich Debian Testing nutzt, dann passieren halt solche Geschichten.

arnysch
Beiträge: 4
Registriert: 30.12.2017 14:28:32

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von arnysch » 31.12.2017 00:51:28

Hi Foxington,

nochmals genauer: mein Fehlerbild schaut wohl genauso aus wie Deins.
Für meinen Fehler habe ich eine Debian-Bugmeldung gefunden: Debian Bugreport885325.

Allerdings verwendest Du Debian Stable ("stretch") im Gegensatz zu Testing ("buster") bei mir.
Insofern nehme ich an, dass bei Dir nicht irgendwelche Dateien kürzlich ausgetauscht wurden.

Trotzdem als Tip/Ansatzpunkt: Schau nach, ob es auch bei Dir an unterschiedlichen Mount-Namespaces liegt.
Also vergleiche in der Konsole den Output von:
"cat /proc/self/mounts"
"cat /proc/SMBDPID/mounts"

Foxingtion
Beiträge: 23
Registriert: 24.04.2004 19:54:36

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von Foxingtion » 31.12.2017 00:55:03

Danke für deinen Tip, ich bin leider erst nächste Woche wieder an den PC und schau mir das dann gleich an.
Do not change a running System ^^

Foxingtion
Beiträge: 23
Registriert: 24.04.2004 19:54:36

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von Foxingtion » 02.01.2018 14:02:04

Hallo arnysch,

sorry, hab ebenfalls die Testing version, stretch war mein Notebook.

Ausgabe:
cat /proc/SMBDPID/mounts
/dev/sda1 / ext3 rw,relatime,errors=remount-ro,data=ordered 0 0

Die anderen Laufwerke bzw. Festplatten werden nicht aufgeführt. Wenn ich den Bugreport richtig verstehe, scheint es am ssh daemon zu liegen, versteh ich das so richtig? Und es bleibt einem aktuell nichts anderes übrig als zu warten, bis das Problem mit dem nächsten Update behoben ist.

Die smbd.service liegt bei mir unter folgende Verzeichnissen:
/var/lib/systemd/deb-systemd-helper-enabled/multi-user.target.wants/smbd.service
/lib/systemd/system/smbd.service
/sys/fs/cgroup/pids/system.slice/smbd.service
/sys/fs/cgroup/devices/system.slice/smbd.service
/sys/fs/cgroup/systemd/system.slice/smbd.service
/sys/fs/cgroup/unified/system.slice/smbd.service
Do not change a running System ^^

arnysch
Beiträge: 4
Registriert: 30.12.2017 14:28:32

Re: Samba 4.7.3 - Zugriff Laufwerk

Beitrag von arnysch » 02.01.2018 14:51:29

> sorry, hab ebenfalls die Testing version, stretch war mein Notebook.
Ah ok, dann haben wir beide wohl wirklich das gleiche Problem und die Ursache ist dieselbe.

> Wenn ich den Bugreport richtig verstehe, scheint es am ssh daemon zu liegen, versteh ich das so richtig?
Ja, so hab ich das auch verstanden. Die vom sshd gestarteten Prozesse benutzen einen anderen Mount-Namespace.

Evtl. gibt es kein Problem, wenn man von einer direkt angeschlossenen Konsole (also Login nicht über ssh)
nachträglich etwas mountet.

Hab den Mount-Namespace-Mechanismus noch nicht so richtig verstanden.
Da gibts ja anscheinen grundsätzlich die Möglichkeit, dass ein frisch gemountes Filesystem auch in einem anderen Namespace auftaucht.
(http://man7.org/linux/man-pages/man7/mo ... ces.7.html)

Vielleicht gibts auch irgendeinen Konfigurationsparameter (in /etc/ssh/... oder /etc/systemd/...),
mit dem sich das korrigieren läßt.

Aber bevor ich jetzt selbst nach einer Lösung suche, warte ich erstmal ab, ob eine Korrektur in Debian Testing kommt.

Antworten