Keine Benutzerrechte bei Zugriff auf Laufwerksfreigaben

Probleme mit Samba, NFS, FTP und Co.
Antworten
chralt
Beiträge: 22
Registriert: 31.07.2016 10:34:14
Kontaktdaten:

Keine Benutzerrechte bei Zugriff auf Laufwerksfreigaben

Beitrag von chralt » 28.04.2021 12:01:50

Hallo Zusammen,

als erstes erlaube ich mir mal auf die bereits im Proxmox-Forum geführte Diskussion zu verweisen.
https://forum.proxmox.com/threads/benut ... mba.86780/

Kurzform des ungelösten Problems:

ich habe auf dem Proxmox-Host (Debian 10) ein Samba-Server installiert.
Grundsätzlich funktioniert das, die jeweiligen Dateien und Verzeichnisse haben die entsprechenden Rechte.
Leider werden aber die Freigaben ohne Nutzerrechte durchgereicht, soll heißen das alle Rechner die auf diese Freigaben zugreifen nur als root auch Dateien schreiben können. Lesen kann man problemlos - mit einer Ausnahme: ein Laptop läuft mit Windows 10, da kann ich (bzw. die Besitzerin) auf die Freigaben gar nicht zugreifen.

Über Nextcloud können dieselben Verzeichnisse allerdings problemlos auch mit den richten Benutzerrechten beschrieben werden.


Gruß
chralt
Zuletzt geändert von chralt am 30.04.2021 13:48:02, insgesamt 1-mal geändert.

Benutzeravatar
Blackbox
Beiträge: 3350
Registriert: 17.09.2008 17:01:20
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Keine Benutzerrechte bei Zugruff auf Laufwerksfreigaben

Beitrag von Blackbox » 28.04.2021 15:28:42

Wie sieht denn deine Sambakonfiguration genau aus?
Du wirst sicherlich nicht erwarten, dass sich die Leute die Informationen aus einem anderen Forenthread zusammen suchen.
Hast du eine Anleitung für deinen Samba share verwendet, wenn ja, welche?
Eigenbau PC: Debian Sid - Kernel: 5.10.40 - Xfce 4.16
Desktop PC: Dell Inspiron 530 - Debian Sid - Kernel: 5.10.40 - Xfce 4.16
Notebook: TUXEDO Book BU1406 - Debian Sid - Kernel: 5.10.40 - Xfce 4.16
Rootserver: Centos 8.4.2105 - Kernel: 4.18
Alles Minimalinstallationen.

Freie Software unterstützen, Datenschutz stärken!

chralt
Beiträge: 22
Registriert: 31.07.2016 10:34:14
Kontaktdaten:

Re: Keine Benutzerrechte bei Zugriff auf Laufwerksfreigaben

Beitrag von chralt » 30.04.2021 13:45:15

Hallo,

nein eine Anleitung habe ich leider nicht.

Und zu dem heraussuchen: ich dachte es wäre nicht so das Problem weil alles in einem Strang ist und ich dann nicht alles wiederholen müsste. Falsch gedacht, mea culpa.

Das Ganze lief auf früher auf demselben NUC, allerdings ohne Proxmox, also auf einem "reinen" Debian 9, ich habe die Configurationsdatei und Andere aus einer Datensicherung übernommen - für alles Andere hat das auch funktioniert - nur für Samba eben nicht.

Hier meine smb.conf in Auszügen mit den unterschiedlichen Freigabearten "global", "homes" und sonstige:

Code: Alles auswählen

[global]
        obey pam restrictions = Yes
        socket options = SO_BROADCAST TCP_NODELAY
        unix password sync = Yes
        winbind trusted domains only = yes
        log file = /var/log/samba/log.%m
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*$
        os level = 20
        panic action = /usr/share/samba/panic-action %d
        server string = %h server
        wins support = true
        dns proxy = No
        syslog = 0
        pam password change = Yes
        winbind use default domain = yes
        workgroup = ARBEITSGRUPPE
        max log size = 1000
        passwd program = /usr/bin/passwd %u
        default = homes
        follow symlinks = yes
        wide links = yes
        vfs objects = acl_xattr
        
 [homes]
        comment = private Dateien
        path = /mnt/data/%u
        valid users = %S
        read list = %u
        write list = %u
        read only = No
        create mask = 0760
        directory mask = 0760

[flac]
        comment = CD+HighRes
        path = /mnt/data/flac
        read list = @familie, @users
        write list = @familie
        writable = yes
        read only = no
        create mask = 0770
        directory mask = 0770
Es gibt weitere 12 Freigaben entsprechend der "flac".

Ein Drucker ist nicht am Server angeschlossen so das es dafür keinen Abschnitt gibt, also es nur iee oben schon genannten Bereiche "global", "home", und die sonstigen Freigaben für unterschiedliche Verzeichnisse, alle mit denselben Rechten wie "flac"

Seit gestern Abend habe ich wieder vollen Zugriff auf mein eigenes Verzeichnis (/mnt/data/ich) ich werde auch wieder als Besitzer angezeigt. Was dazu geführt hat - keine Ahnung. Alle anderen gehören nach wie vor "root" und man kann nur lesend darauf zugreife.

Es gibt 2 Benutzergruppen vorgesehen denen die Nutzer zugeordnet wurden/werden: "users" und "familie". Letztere soll schreiben und lesen können, "users" nur lesen (ja, dafür sind "create mask = 0770" und "directory mask = 0770" falsch, das hat aber noch niemand gemerkt weil alle Nutzer die aktuell zugreifen sollen und können, auch der Gruppe "familie" zugeordnet sind).

Ich hoffe das reicht als Information, ansonsten kann ich natürlich weiteres beisteuern. :wink:

Gruß und vielen Dank
chralt

chralt
Beiträge: 22
Registriert: 31.07.2016 10:34:14
Kontaktdaten:

Re: Keine Benutzerrechte bei Zugriff auf Laufwerksfreigaben

Beitrag von chralt » 06.05.2021 09:59:11

Hallo,

da niemand antwortet, antworte ich mir mal selber. 8) :wink:

Ich habe mittlerweile den Bereich "global" entschlackt:

Code: Alles auswählen

    log file = /var/log/samba/log.%m
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*$
        os level = 70
        panic action = /usr/share/samba/panic-action %d
        server string = %h server
        dns proxy = No
        workgroup = ARBEITSGRUPPE
        max log size = 500
        passwd program = /usr/bin/passwd %u
        default = homes
        security = user
Das hat leider keine wesentliche Änderung im Verhalten gebracht.

Jetzt ist es so das nur ein Laptop mit Debian 10 meinen eigenen Ordner auch mir zuordnet (siehe letzter Beitrag), dox-VMs auf dem Opensuse-Laptop ist auch nur Lesezugriff möglich. Die Einträge für die Fraigaben in der "fstab" sind auf beiden Maschinen identisch:

Code: Alles auswählen

//Samba/ich  /home/ich/Dokumente cifs rw,auto,credentials=/home/ich/.smbcredentials,iocharset=utf8,uid=1000,gid=1000 1 1
Nachtrag: ich habe eben noch einmal in allen Einträgen in der fstab ",uid=1000,gid=1000" ergänzt, und siehe da: es funktioniert wieder.

Ich werde das jetzt mal auf den anderen Linux-Rechnern ebenfalls machen und schauen was passiert. Was aber definitiv Tatsache ist(war), ist das diese Parameter auch in der ehemaligen Installation nur für das private LW benutzt (benötigt?) wurde.

Gruß
chralt

Nachtrag: auch auf dem Opensuse-Rechner als auch den Windows-VMs ist jetzt alles ok, fehlt/fehlen nur noch der/die reinen Windows-Rechner.

Antworten