Hyper Threading deaktivieren

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
debianx
Beiträge: 58
Registriert: 18.01.2017 17:04:10

Hyper Threading deaktivieren

Beitrag von debianx » 16.05.2019 15:28:11

Hallo,

da bei den Intel CPUs zum Thema Sicherheitslücken überhaupt kein Ende mehr in Sicht ist, wollte ich mal testweise Hyper Threading deaktivieren. Sinn oder Unsinn soll jetzt erstmal keine Rolle spielen.
Es gibt recht viele verschiedene Möglichkeiten und ich wollte mal fragen was so die "beste" bzw einfachste Variante wäre HT dauerhaft von on auf off zu stellen. Im Bios habe ich leider keine Option dafür.

Gefunden habe ich zwar einige Dinge, bin aber nicht sicher was von dem Allen am ehesten Sinn macht:
https://www.golinuxhub.com/2018/01/how- ... hyper.html
https://serverfault.com/questions/23582 ... ss-to-bios
https://askubuntu.com/questions/942728/ ... -in-ubuntu
https://gist.github.com/samueljon/e7818 ... 58949d04c8

Was wäre die einfachste persistente Lösung bei debian?

Danke und Grüße

Benutzeravatar
ung
Beiträge: 7
Registriert: 28.03.2017 20:56:32

Re: Hyper Threading deaktivieren

Beitrag von ung » 16.05.2019 17:09:15

Kernel Parameter:

Code: Alles auswählen

nosmt

debianx
Beiträge: 58
Registriert: 18.01.2017 17:04:10

Re: Hyper Threading deaktivieren

Beitrag von debianx » 16.05.2019 17:41:25

danke ich habe mal folgende Zeile in die Datei /etc/default/grub hinzugefügt: GRUB_CMDLINE_LINUX_DEFAULT="nosmt"
wenn ich nach neustart lscpu aufrufe steht immer noch "Thread(s) pro Kern: 2"
scheint so noch nicht funktioniert zu haben?

MSfree
Beiträge: 4555
Registriert: 25.09.2007 19:59:30

Re: Hyper Threading deaktivieren

Beitrag von MSfree » 16.05.2019 17:46:03

debianx hat geschrieben: ↑ zum Beitrag ↑
16.05.2019 17:41:25
danke ich habe mal folgende Zeile in die Datei /etc/default/grub hinzugefügt: GRUB_CMDLINE_LINUX_DEFAULT="nosmt"
nosmt ist glaube ich nicht das, was du haben willst. Das steht für no simultaneous multithreading und deaktiviert, soweit ich weiß, alle bis auf einen Kern.

Du willst eher noht, also no hyperthreading.

Hast du dich an die Anweisungen in Zeile 1 der Datei /etc/default/grub gehalten?

Code: Alles auswählen

# If you change this file, run 'update-grub'
gefolgt von einem Reboot.

debianx
Beiträge: 58
Registriert: 18.01.2017 17:04:10

Re: Hyper Threading deaktivieren

Beitrag von debianx » 16.05.2019 18:08:21

update-grub hatte ich natürlich vergessen :wink:
Aber mit noht tut sich nichts. Dann testweise nochmal mit nosmt versucht und damit funktioniert es.
Scheinbar ist nosmt doch das richtige. Damit hab ich jetzt bei lscpu "Thread(s) pro Kern: 1"

Antworten