PCIE Device Power On verhindert Shutdown

Welches Modul/Treiber für welche Hardware, Kernel compilieren...
Antworten
ddldl
Beiträge: 3
Registriert: 03.02.2020 09:40:07

PCIE Device Power On verhindert Shutdown

Beitrag von ddldl » 03.02.2020 10:11:08

Moin moin,
ich versuche bereits seit einigen Wochen ein Problem zu beheben, welches sich seit dem Upgrade meines Heimservers ergeben hat.

Ausgangslage:
Ich habe seit geraumer Zeit zwei Systeme mit Debian 9.11 auf ASUS J4105 Maiboard für diverse Spielchen wie Nextcloud und Co genutzt. Hierbei kommen auf IT-Mode geflashte Dell PERC H310 zum Einsatz, die 4x1TB an das OS durchreicht. Im BIOS hab ich zusätzlich die Funktionen PCIE Device Power On und Boot From Onboard LAN aktiviert um das Gerät über den Router per Wake-On-LAN wecken zu können. Alles funktionierte einwandfrei.

Nach Upgrade auf Debian 10 stockt es jedoch in Bezug auf die WOL-Funktionalität. Bei unveränderten Einstellungen hängt sich das System beim herunterfahren ohne Informationen zur Ursache auf und verharrt auch nach Stunden mit der Meldung [63.xxxxx] Reboot: Poweroff. Ich konnte das Problem insoweit eingrenzen, dass es explizit mit der BIOS-Einstellung von PCIE Device Power On zutun hat. Wenn ich diese deaktiviere fährt das System normal herunter, jedoch funktioniert gleichzeitig logischerweise WOL nicht mehr.

Ich habe bereits in einigen Foren gelesen, dass der Kernel 4.19 generell einige Probleme bezüglich der WOL-Funktionalität besitzen soll, jedoch noch keine Threads mit Bezug auf die PCIE-Schnittstelle gefunden. Ein Backportupgrade auf Kernelversion 5.2 oder 5.3 hat das Problem jedoch nicht behoben, auch hier hängt das System mit eingeschaltetem PCIE-Poweron. Der Raidcontroller wird jedoch vollumfänglich unterstützt und zeit keinerlei Kompatibilitätsprobleme.

Auch obligatorische Änderungen in der Grub-Config wie acpi an/aus/force, noefi,etc haben bisher nichts gebracht.

Da dir Probleme auf beiden Systemen auftreten gehe ich von keinem Hardware-Defekt aus.

rhHeini
Beiträge: 954
Registriert: 20.04.2006 20:44:10

Re: PCIE Device Power On verhindert Shutdown

Beitrag von rhHeini » 03.02.2020 21:24:00

Mach doch erst mal das Boot From Onboard LAN weg. Das dürftest Du nicht benötigen, Du willst von der Platte booten, und kein Image von einem Server laden (PXE-Boot).

Hast Du da im Shutdown irgendwo ein ethtool wol -g drin?

Gruß, Rolf

ddldl
Beiträge: 3
Registriert: 03.02.2020 09:40:07

Re: PCIE Device Power On verhindert Shutdown

Beitrag von ddldl » 03.02.2020 21:32:47

Die Boot from LAN Option muss laut diverser Foreneinträge mit gesetzt sein, habe aber auch bereits mit und ohne getestet. Macht alles keinen Unterschied.

Hab bei /etc/network/interfaces unter eth0 die beiden Einträge hinzugefügt
post-up /sbin/ethtool -s eth0 wol g
post-down /sbin/ethtool -s eth0 wol g

Wie bereits gesagt komme ich aber erst gar nicht in den Genuss WOL ansich zu testen, da das System bereits beim Herunterfahren festhängt.

rhHeini
Beiträge: 954
Registriert: 20.04.2006 20:44:10

Re: PCIE Device Power On verhindert Shutdown

Beitrag von rhHeini » 04.02.2020 20:29:14

Passt die Bezeichnung eth0 noch auf Deinen Port. Buster müsste da eigentlich eine der neuen Bezeichnungen verwenden.

Ich hab mal in einem alten Dokument nachgesehen in dem ich beschriben hab wie ich einen Fileserver auf Wheezy-Basis aufgesetzt habe. Damals habe ich noch das halt-Skript in /etc/default geändert auf:

Code: Alles auswählen

# Default behaviour of shutdown -h / halt. Set to "halt" or "poweroff".
NETDOWN=no
HALT=poweroff
Keine Ahnung ob es das noch gibt, probiers mal.

Rolf

ddldl
Beiträge: 3
Registriert: 03.02.2020 09:40:07

Re: PCIE Device Power On verhindert Shutdown

Beitrag von ddldl » 05.02.2020 09:32:06

Vielen Dank für die Mühe. Der Adapter heißt eigentlich eno1, wird ja neuerdings irgendwie durch das BIOS definiert (irgendwo mal gelesen :idea: ). Hab das Ding über etc/default/grub auf eth0 geändert (sieht schöner aus). Testweise gestern umgenannt, löst das Problem leider nicht.

Was die /etc/default/halt betrifft... die Datei gibt's bei mir gar nicht 8O lediglich in /etc/init.d/, da ist aber feinster Hieroglyphen Code versteckt

Antworten