[gelöst]Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Tuerpe
Beiträge: 11
Registriert: 14.02.2020 14:55:01

[gelöst]Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von Tuerpe » 14.02.2020 15:06:58

Moin,
Seit Tagen probiere ich Debian Buster zu installieren und ich weiß nicht mehr weiter und finde auch keinen der dasselbe Problem wie ich hat.

Benutze Rufus um den Stick bootable zu machen. Hab die "normale" CD xfce.iso genommen von der Debian Seite. Und als DD Abbild drauf gebrannt.

Jedes Mal bei der Installation scheitert es beim Laden der Komponenten. Jedes Mal kurz nach "loading partman-partitioning". Egal was ich mache es hilft nichts, hab mehrere isos probiert wie die live version oder netinst oder die DVD. Jedes mal dasselbe.

Ach ja, ziehl ist es beide Betriebssysteme installiert zu haben.

Ich hoffe ihr könnt mir helfen :)
Falls ihr noch Infos braucht sagt bescheid:)

Lg
Tuerpe
Zuletzt geändert von Tuerpe am 17.02.2020 13:42:15, insgesamt 1-mal geändert.

Benutzeravatar
willy4711
Beiträge: 3173
Registriert: 08.09.2018 16:51:16

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von willy4711 » 14.02.2020 16:30:40

Ich kenne Rufus nicht. Ich benutze dafür multibootusb
Dann wäre folgende Infos notwendig:
Tuerpe hat geschrieben: ↑ zum Beitrag ↑
14.02.2020 15:06:58
Ach ja, ziehl ist es beide Betriebssysteme installiert zu haben.
Damit meinst du wahrscheinlich Windows ?

Wenn alle Installer an der selben Stelle abbrechen ist das sehr merkwürdig.

Du installierst im UEFI- Modus (im UEFI den Stick so angewählt ?)

Was hast du denn für Hardware, vor allem:

Wie sind deine Festplatten aufgeteilt und wo willst du installieren ?

Du benutzt die CD's von Debian (URL ?) oder irgendwo anders her ?

Eine Menge Fragen :wink:

Tuerpe
Beiträge: 11
Registriert: 14.02.2020 14:55:01

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von Tuerpe » 14.02.2020 17:26:43

Hey danke für deine Antwort.
Ja genau neben Windows 10.

Also im BIOS ist uefi und legacy aktiviert.
Hardware: i5 7600k
Gtx 1070
Asus z170 p
16 GB RAM
1 TB hDD
500 GB ssd
Auf der ssd ist Windows und die hdd hab ich um 200 GB verkleinert. Und die sind momentan unallocated.
Möchte auf diesen 200 GB nach der Linux haben.

Genau von der Debian Seite. Ich geh auf CD Sätze komplett auf amd64 und lade da die CDs runter die ich ausprobiert habe.

rhHeini
Beiträge: 903
Registriert: 20.04.2006 20:44:10

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von rhHeini » 14.02.2020 18:17:13

Habe schon meine Spass mit den Installern gehabt. Also die HW sollte keine grundsätzlichen Probleme machen, die ist nicht brandaktuell was ein Problem sein könnte.

Ich würde die Buster DVD1 amd64 als ISO laden und von Windows aus mit der aktuellen Version von rufus auf den Stick schreiben. Der Stick muss mit FAT32 formatiert sein, lass rufus die Dateien extrahieren und auf den Stick schreiben, Uefi und Legacy-Modus.

Wie ist die HDD partitioniert? MBR oder GPT? Wie hast Du da Platz geschaffen? Du brauchst eigentlich GPT wegen UEFI-Bios.

Ich hab die Installer an fehlenden Partitionierunsgschemata scheitern sehen (also bei funkelnagelneuen Laufwerken), das sollte hier eigentlich nicht der Fall sein. Es könnte aber trotzdem eine Idee sein mit einer gparted-Live-CD zu booten und die freigeschaufelten 200GB mit einer ext4-Partition zu versehen und es nochmals zu versuchen.

Sonstige Idee: andere Graphikkarte zum installieren benutzen?

Wichtig: den Stick im UEFI-Modus booten.

Viel Erfolg, Rolf
Zuletzt geändert von rhHeini am 14.02.2020 19:29:31, insgesamt 1-mal geändert.

Tuerpe
Beiträge: 11
Registriert: 14.02.2020 14:55:01

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von Tuerpe » 14.02.2020 18:46:06

Hey Rolf danke für deine Antwort.
Die DVD hatte ich auch schon probiert. Und genau so verfahre ich mit Rufus.

Die HDD ist jetzt quasi 750 GB "normal" quasi eine Partition. Und 200GB sind nicht vergeben, gehören auch nicht mehr zur Partition 1. Halt nicht zugewiesen. Hab bei der datentragerverwaltung das Volumen verkleinert.

OK das werde ich probieren, danke für die Idee
Mal schauen ob es daran liegt.

Eine andere Grafikkarte habe ich leider nicht zur Verfügung.

Was meinst du genau mit letzterem? Also wenn ich im BIOS in die boot options gehe und dann wird mein Stick 3 mal angezeigt. UEFI:"Produktname", nur mit dem produktnamen und auch mit Partition 1 dahinter beschrieben. Ich hab alle ausprobiert. Bei nur produktname freezt der Bildschirm beim installer direkt ein und ich kann nicht machen, bei den anderen beiden passiert das Problem mit dem nicht laden können.

Oder meinst du von Uefi und legacy auf nur uefi um BIOS umzustellen?

Lg

rhHeini
Beiträge: 903
Registriert: 20.04.2006 20:44:10

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von rhHeini » 14.02.2020 19:39:25

Tuerpe hat geschrieben: ↑ zum Beitrag ↑
14.02.2020 18:46:06
Was meinst du genau mit letzterem? Also wenn ich im BIOS in die boot options gehe und dann wird mein Stick 3 mal angezeigt. UEFI:"Produktname", nur mit dem produktnamen und auch mit Partition 1 dahinter beschrieben. Ich hab alle ausprobiert. Bei nur produktname freezt der Bildschirm beim installer direkt ein und ich kann nicht machen, bei den anderen beiden passiert das Problem mit dem nicht laden können.
Die UEFI-Biose zeigen Dir Wechselmedien immer zweimal an. Unter dem normalen LW-Namen im Legacy Modus, und mit einem UEFI davor im UEFI-Modus. Da Du UEFI-HW hast, wird Dein W10 im UEFI-Modus installiert sein. Damit geht bei Linux auch kein Weg an GPT und UEFI-Modus vorbei. Dazu musst Du Dein Installationsmedium eben auch im UEFI-Modus booten.
Tuerpe hat geschrieben: ↑ zum Beitrag ↑
14.02.2020 18:46:06
Oder meinst du von Uefi und legacy auf nur uefi um BIOS umzustellen?
Das wäre noch eine Verzweiflungsmassnahme.

Check mal nach ob bei Dir zufälligerweise Secure Boot scharf ist. Ich schalte das bei mir immer ab, habe aber nur noch einen PC mit einem W7 parallel, und ganz anders installiert.

Vielleicht solltest Du zur Sicherheit mal die Checksum des geladenen ISO überprüfen.

Gruß, Rolf

Benutzeravatar
frox
Beiträge: 908
Registriert: 06.08.2004 16:29:44
Wohnort: Köln

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von frox » 14.02.2020 20:42:08

Parallel irgend ein anderes USB-Device drin?
Bei mir ist die Inst zuerst am noch eingesteckten Surfstick mit internem Speicher gescheitert.
(Wenn auch erst bei der APT-Konfiguration.)
Gruß, Fred

Die Zeit salzt alle Wunden

Benutzeravatar
towo
Beiträge: 3542
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von towo » 14.02.2020 22:44:55

Das Problem ist Rufus!
Wenn man hier nicht den richtigen Modus auswählt, kommt da nur Murks bei raus!

Also besser Etcher oder win32diskimager benutzen, dann passiert sowas nicht.

Benutzeravatar
orcape
Beiträge: 1401
Registriert: 07.11.2008 18:37:24
Wohnort: 50°36'23.99"N / 12°10'20.66"E

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von orcape » 15.02.2020 07:46:02

Hi,
unter Windows sollte auch UNetbootin problemlos funktionieren.
Ein Net-Image auf einen Stick schreiben, erspart Dir jede Menge Daten, die zu kopieren sind.
Beim Start des Rechners das richtige Bootmedium wählen, dann sollte das schon funktionieren.
Alternativ wäre ein ein Linux-Live und mit dd if= zu kopieren.
Gruß orcape

MSfree
Beiträge: 5301
Registriert: 25.09.2007 19:59:30

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von MSfree » 15.02.2020 09:36:22

orcape hat geschrieben: ↑ zum Beitrag ↑
15.02.2020 07:46:02
Hi,
unter Windows sollte auch UNetbootin problemlos funktionieren.
Komisch, daß hier:
https://www.debian.org/releases/stretch ... -isohybrid
explizit steht:
Important

The image must be written to the whole-disk device and not a partition, e.g. /dev/sdb and not /dev/sdb1. Do not use tools like unetbootin which alter the image.
Und da würde ich Rufus ganz klar mit einschließen.

Am einfachsten ist es doch wohl wirklich, sich einfach mal an die offizielle Anleitung zu halten und win32diskimager zu verwenden, wenn man kein Linux oder OSX zur Hand hat.

Benutzeravatar
orcape
Beiträge: 1401
Registriert: 07.11.2008 18:37:24
Wohnort: 50°36'23.99"N / 12°10'20.66"E

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von orcape » 15.02.2020 11:33:41

@MSfree
Komisch, daß hier:
https://www.debian.org/releases/stretch ... -isohybrid
explizit steht:

Important

The image must be written to the whole-disk device and not a partition, e.g. /dev/sdb and not /dev/sdb1. Do not use tools like unetbootin which alter the image.
Dann solltest Du es mal ausprobieren, denn das funktioniert sehr wohl, denn ich habe mehr wie ein System mit UNetbootin neu aufgesetzt. Leider scheint das in Debian nicht weiterentwickelt zu werden. Deshalb nutze ich seit Buster dd if=....... of=/dev/sdx.
Nur ist eines zu beachten, beim beschreiben des Sticks, musst Du explizit das Ziel als ganzes Gerät angeben, nicht als Partition.

Code: Alles auswählen

Beispiel:  
              Der zu beschreibende Stick erscheint als /dev/sdc, als Gerät mit FAT32 als ganzes mit bsp. GParted angelegt, auf Deinem PC. 
              Dann sollte als Ziel im UNetbootin auch /dev/sdc drin stehen und nicht wie Dir das UNetbootin vorschlägt, /dev/sdc1.
Wohin Du dann Dein OS vom Stick aus installierst, ist irrelevant. Berücksichtigst Du das nicht, schlägt die Installation schon beim Beginn des Bootvorganges fehl.
Das hat also nichts mit dem vom TE genannten Problemen zu tun, die sehr viel später bei der Installation auftauchen.
Gruß orcape

Tuerpe
Beiträge: 11
Registriert: 14.02.2020 14:55:01

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von Tuerpe » 15.02.2020 12:21:20

Guten Tag,
Danke für eure Antworten !!!

@rhHeini
rhHeini hat geschrieben: ↑ zum Beitrag ↑
14.02.2020 19:39:25
Die UEFI-Biose zeigen Dir Wechselmedien immer zweimal an. Unter dem normalen LW-Namen im Legacy Modus, und mit einem UEFI davor im UEFI-Modus. Da Du UEFI-HW hast, wird Dein W10 im UEFI-Modus installiert sein. Damit geht bei Linux auch kein Weg an GPT und UEFI-Modus vorbei. Dazu musst Du Dein Installationsmedium eben auch im UEFI-Modus booten.
Es wird mir 3 mal angezeigt im BIOS:
1. Nur der Produktname des Sticks mit MB Anzahl.
2. "UEFI:" Produktname und mb anzahl
3. "UEFI:" Produktname mb Anzahl und dahinter noch "Partition 1"
rhHeini hat geschrieben: ↑ zum Beitrag ↑
14.02.2020 19:39:25
Check mal nach ob bei Dir zufälligerweise Secure Boot scharf ist. Ich schalte das bei mir immer ab, habe aber nur noch einen PC mit einem W7 parallel, und ganz anders installiert.

Vielleicht solltest Du zur Sicherheit mal die Checksum des geladenen ISO überprüfen.
SecureBoot ist aus. Checksum ist ok, hatte ich schon gecheckt.

@frox
frox hat geschrieben: ↑ zum Beitrag ↑
14.02.2020 20:42:08
Parallel irgend ein anderes USB-Device drin?
Bei mir ist die Inst zuerst am noch eingesteckten Surfstick mit internem Speicher gescheitert.
(Wenn auch erst bei der APT-Konfiguration.)
Keins mit Speichermedium. Hab zur Sicherheit alles unnötige rausgezogen. Trotzdem dasselbe Ergebnis.


@towo
towo hat geschrieben: ↑ zum Beitrag ↑
14.02.2020 22:44:55
Das Problem ist Rufus!
Wenn man hier nicht den richtigen Modus auswählt, kommt da nur Murks bei raus!

Also besser Etcher oder win32diskimager benutzen, dann passiert sowas nicht.
Auch mit win32diskmanager kein Erfolg. Selbe Problem.


@orcape
orcape hat geschrieben: ↑ zum Beitrag ↑
15.02.2020 07:46:02
Hi,
unter Windows sollte auch UNetbootin problemlos funktionieren.
Ein Net-Image auf einen Stick schreiben, erspart Dir jede Menge Daten, die zu kopieren sind.
Beim Start des Rechners das richtige Bootmedium wählen, dann sollte das schon funktionieren.
Alternativ wäre ein ein Linux-Live und mit dd if= zu kopieren.
Gruß orcape
Ich habe die LiveDebian Version probiert. Geht leider auch nicht. Eben noch MXLinux Live probiert aber dort öffnet sich beim booten nur GRUB und wenn ich dort exit eingebe bin ich wieder im BIOS. Fand ich auch komisch. Der Installer ööffnet sich nicht.



Also ich bin immer noch sehr verzweifelt. Es ist schon komisch dass er IMMER am selben Punkt zusammenkracht obwohl die Checksum stimmt. Hat er vielleicht nicht genug Speicher zur Verfügung oder sowas ? Ich gehe ja davon aus dass der die ganzen Module bzw den Kernel in den RAM liest ? Ist er da vielleicht irgendwie limitiert obwohl ich 16 GB hab ? Also FastBoot ist auch aus, sodass Windows komplett aus ist und ncihts in den RAM schiebt beim Runterfahren.
Gehört dieses partman-partitioning Modul denn zu den essenziellen Dingen ? Oder in welchem Package ist das mit drin ? Würde sonst versuchen bei der advanced installation alles was man nicht runterladen muss erstmal nicht zu installieren. Wenn das Modul jedoch dafür da ist im installationsvorgang im späteren Schritt zu partitionieren dann brauch ich es auf jeden Fall. oder ?

Nochmal vielen lieben Dank für eure Beteiligung und Hilfe.

Lg

Tuerpe

uname
Beiträge: 10133
Registriert: 03.06.2008 09:33:02

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von uname » 15.02.2020 12:24:19

Du kannst ein beliebiges debianbasiertes Linux-Live inkl. Ubuntu, Mint, ... booten, Debiangrml-debootstrap per apt nachinstallieren und ohne Parameter aufrufen.

https://grml.org/grml-debootstrap/
http://manpages.ubuntu.com/manpages/bio ... rap.8.html
https://github.com/grml/grml-debootstrap

Tuerpe
Beiträge: 11
Registriert: 14.02.2020 14:55:01

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von Tuerpe » 15.02.2020 13:08:58

Update: Habe in einer VM die Live Version von Debian Buster laufen lassen und dort mit dd if= das Abbild auf den USB Stick gebrannt. Leider bleibt er wieder beim Kopieren stehen bzw sagt dass er das nicht kopieren kann. Diesmal jedoch schon bisschen früher.

@Uname
Also hätte ich dann Debian Buster installiert mit dem Befehl? Taucht dann auch der Installer auf sodass ich noch partitionieren kann usw?

Tuerpe
Beiträge: 11
Registriert: 14.02.2020 14:55:01

Re: Debian Buster installation schlägt jedes Mal beim kopieren von der CD fehl

Beitrag von Tuerpe » 15.02.2020 13:18:25

Update 2: oh man. Hatte meinen anderen USB Stick verlegt und hatte es deshalb immer mit dem gleich probiert. Hab den anderen jz gefunden und siehe da, kopieren gelingt. Ich brauche jetzt für die Hardware Erkennung nicht freie Firmware Dateien. Ich setz mich dran und schaue ob ich es durchbekomme.

Erstmal vielen Dank.

Antworten