[gelöst] Niemals 'hibernate'

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

[gelöst] Niemals 'hibernate'

Beitrag von dasebastian » 17.07.2020 15:17:50

Hallo an alle,

ich komme nicht recht weiter. Mein T420 fällt nach 10 Minuten in einen Tiefschlaf, aus dem ich ihn nicht mehr wecken kann, nur mehr abwürgen und neu starten. Ich möchte aber, dass der Rechner niemals in einen Schlafmodus geht.

Was ich gemacht habe: Debianmate-screensaver deinstalliert (ich mache das per Debianxautolock und Slock aus Debiansuckless-tools).

Einstellungen in der Energieverwaltung: Niemals für Energiesparmodus (Netz/Akku).

Einstellungen per Dconf-Editor (org/mate/power-manager): action-sleep-type-ac=nothing, action-sleep-type-battery=nothing. Ich habe das zuerst als user gemacht, und dann sogar als angemeldeter Root. Ja, ich weiss!

Wie komme ich hier weiter?
Zuletzt geändert von dasebastian am 10.08.2020 09:21:06, insgesamt 1-mal geändert.
filetiertes mate mit awesomewm auf buster.

Benutzeravatar
TRex
Moderator
Beiträge: 6775
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: Niemals 'hibernate'

Beitrag von TRex » 17.07.2020 15:35:56

Steht was in den kernel-Logs dazu? Was zeigt xset q?
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 17.07.2020 15:44:45

Code: Alles auswählen

sebastian@SebastiansT420:~$ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
sebastian@SebastiansT420:~$ 
Für /var/log/kern.log lasse ich das Ganze jetzt nochmal passieren, damit ich das sicher zuordnen kann.
filetiertes mate mit awesomewm auf buster.

Benutzeravatar
TRex
Moderator
Beiträge: 6775
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: Niemals 'hibernate'

Beitrag von TRex » 17.07.2020 16:28:11

Code: Alles auswählen

xset s 0 0
Für den screensaver. Bist du sicher, dass der Rechner in den Schlafmodus wechselt? Nach 10 Minuten sollte nämlich X den Bildschirm abschalten, und wenn der nicht mehr aktiviert wird...
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 17.07.2020 16:29:27

Okay, die kern.log durchgeschaut, elendslange in dem bestimmten Zeitraum, ich weiss allerdings nicht, wonach ich suchen soll.
filetiertes mate mit awesomewm auf buster.

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 17.07.2020 16:31:41

TRex hat geschrieben: ↑ zum Beitrag ↑
17.07.2020 16:28:11
Für den screensaver. Bist du sicher, dass der Rechner in den Schlafmodus wechselt? Nach 10 Minuten sollte nämlich X den Bildschirm abschalten, und wenn der nicht mehr aktiviert wird...
Der Bildschirm ist tatsächlich gämzlich schwarz, ich habe allerdings alle meine Fn-Tasten durchprobiert, keine hat den Bildschirm wieder eingeschalten, auch nichts anderes.
filetiertes mate mit awesomewm auf buster.

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 17.07.2020 17:10:54

:hail: Mit xset s 0 0 ist das jetzt mal nicht wieder passiert, das war jetzt genau das Verhalten, dass ich will, Slock sperrt den Bildschirm, und färbt ihn dunkel ein, mehr nicht, auf unbestimmte Zeit.

Wenn ich die man von xset aber jetzt richtig verstehe, wird das wieder resettet nach Logout? Wie sage ich dem System, dass es das machen soll?

EDIT: Für den Moment hab ich xset mal als Autostart gesetzt, an die Editierung von xorg.conf oder xorg.conf.d trau ich mich noch nicht so ganz.
filetiertes mate mit awesomewm auf buster.

Benutzeravatar
TRex
Moderator
Beiträge: 6775
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: Niemals 'hibernate'

Beitrag von TRex » 17.07.2020 19:05:49

Hast du nen zweiten Rechner, um zu schauen, ob der Patient noch per SSH erreichbar ist?

kern.log: alles Verdächtige... wobei der Verdacht langsam auch eher Richtung Xorg.0.log geht.
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 17.07.2020 19:17:15

Nein, leider kein 2. Rechner.

Ich muss das dann morgen nochmal angehen, damit ich eine genaue Uhrzeit habe, wann das so quer gegangen ist.

Wie gesagt, mit dem xset s 0 0 läuft das jetzt.

Kann es was damit zu tun haben, dass es eine Debianawesome Session ist?
filetiertes mate mit awesomewm auf buster.

Benutzeravatar
TRex
Moderator
Beiträge: 6775
Registriert: 23.11.2006 12:23:54
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: KA

Re: Niemals 'hibernate'

Beitrag von TRex » 17.07.2020 21:35:14

Meine awesome-session macht diese Probleme nicht - ich verwendete zuletzt allerdings i3lock statt slock. Wenn du von deiner Bildschirmsperre allerdings kein Feedback bekommst, könnte man den Eindruck bekommen, der Rechner wäre aus...
Jesus saves. Buddha does incremental backups.
Windows ist doof, Linux funktioniert nichtDon't break debian!

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 17.07.2020 22:39:17

Wenn Slock sperrt, sieht man, dass der Bildschirm noch läuft, es ist halt nicht ganz schwarz und du kennst Slock ja, sobald du tippst - blau (oder rot)...

In dem vorigen Fall glaube ich jetzt auch eher, dass der Bildschirm ausgeschaltet wird, der Rechner aber noch läuft. Es leuchtet auch das "WLAN-Bäumchen" unter dem Bildschirm. Seltsam.
filetiertes mate mit awesomewm auf buster.

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 18.07.2020 10:16:29

Mein Verdacht mittlerweile, das ist eine Bildschirmabschaltung und ein Überbleibsel einer Einstellung des Debianmate-screensaver, den ich gepurged habe. Irgendein Zusammenspiel unglücklicher Umstände.

Leider muss ich gleich nachschicken, dass ich in der nächsten Zeit nicht die Zeit haben werde, dem weiter auf den Grund zu gehen, ich lege das jetzt mal auf Eis, bei mir gibt's gerade anderen Stress...

Danke dir einstweilen für die Mühe, TRex, wenn ich wieder mehr Luft habe, gehe ich dem weiter auf den Grund!
filetiertes mate mit awesomewm auf buster.

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 05.08.2020 11:46:03

Hallo Trex,
ich bin jetzt dabei, zu migrieren, habe mir Debian 10 nochmals neu aufgesetzt, Netinstaller+Mate Desktop+awesome und noch nichts an Mate verändert.

Nach Einstellung des Bildschirmschoners auf so gut wie "Niemals" und der Energieverwaltung auf "Niemals irgendwas machen" läuft das jetzt. Keine Bildschirmabschaltung, Slock greift per Debianxautolock nach der angegebenen Zeit, weiter passiert nichts.

Vielleicht war das wirklich ein Konflikt mit meinem Debianmate-screensaver purge. Oder Debiantlp? Das hatte ich damals auch installiert, im Moment noch nicht.

Ich werde den screensaver auch in der finalen Installation die nächsten Tage mal einfach belassen, über tlp denke ich noch nach.
filetiertes mate mit awesomewm auf buster.

mcb
Beiträge: 544
Registriert: 25.06.2020 17:28:49

Re: Niemals 'hibernate'

Beitrag von mcb » 09.08.2020 10:39:59

dasebastian hat geschrieben: ↑ zum Beitrag ↑
05.08.2020 11:46:03
.............. auch in der finalen Installation die nächsten Tage mal einfach belassen, über tlp denke ich noch nach.
tlp macht keine Probleme mit der GUI.

dasebastian
Beiträge: 176
Registriert: 12.07.2020 11:21:17

Re: Niemals 'hibernate'

Beitrag von dasebastian » 09.08.2020 11:00:57

Stimmt, hatte ich bisher nie mit tlp, ich geh's halt langsam an... ;)
filetiertes mate mit awesomewm auf buster.

Antworten