Laptop schläft während der Benutzung ständig ein

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
CUVS
Beiträge: 6
Registriert: 13.10.2020 21:06:11

Laptop schläft während der Benutzung ständig ein

Beitrag von CUVS » 13.10.2020 21:30:55

Hallo,

ich wollte für eine Familie deren alten Laptop für deren Kinder nutzbar machen (falls mal wieder Homeschooling ansteht).

Den Hersteller gibt es scheinbar schon nicht mehr, es ist ein:
Delphin Computer
Model: M66N
Produkt-Code: M665NC
Baujahr: 05/2007
dort war noch Windows XP drauf und er ist nicht 64-bit fähig.

Habe nun debian 32-bit mit xfce installiert.

Während der Installation (im Text-Modus) gab es keine Probleme.

Mit dem 1. Start ging es aber los. Der Laptop schläft schon während des Hochfahrens ein, man kann dann die Power-Taste drücken und er macht weiter (wo er eingeschlafen ist), man kann sich auch einloggen.
Jedoch schläft er immer wieder nach wenigen Sekunden ein, auch während man z.B. im Login-Dialog die Anmeldung eingibt.
Auch bei ausgebautem Akku das gleiche Problem.

Man kann ihn zwar immer wieder aufwecken und es gibt auch keine Fehlermeldung, aber Nutzbar ist er so nicht.

Was kann ich tun?

Vielen Dank im Voraus.

CUVS

EDIT:
debian 10.5.0

Benutzeravatar
willy4711
Beiträge: 4277
Registriert: 08.09.2018 16:51:16

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von willy4711 » 13.10.2020 22:44:51

Da der Textmodus ja wohl störungsfrei funktioniert, wäre mein erster Verdacht,
das eventuell Grafiktreiber fehlen.
Über Das Grub-Menü (erweitert ..) könntest du mal den recovery mode aufrufen., um die Grafikkarte
zu erkunden:

Code: Alles auswählen

lspci -nnk | grep -i VGA -A2 
Sollte dir das Wichtigste anzeigen.
Müsstest dir die Mühe machen das abzutippen und hier einzustellen.
Dann kann man (hoffentlich) noch einen brauchbaren Treiber finden

CUVS
Beiträge: 6
Registriert: 13.10.2020 21:06:11

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von CUVS » 13.10.2020 23:07:59

Werde ich morgen Abend mal versuchen.

Falls das was zu sagen hat: Wenn ich mit Alt+F1 ist eine Terminal-Console gehe, schläft er trotzdem auch ein. Trotzdem Grafik-Treiber?

Beim Installieren, war das Gerät offline, ggf. fehlt daher ein Treiber?
Ich könnte problemlos nochmal Installieren, es sind ja noch keine Daten drauf.

Danke

Benutzeravatar
willy4711
Beiträge: 4277
Registriert: 08.09.2018 16:51:16

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von willy4711 » 13.10.2020 23:28:08

Wie war das denn mit XP ? Lief das durchgehend?
Mit der Grafik ist nur eine Vermutung, weil du ja sagtest, das der Installer im Textmodus ohne "einschlafen" lief.
Dass es einen Netzwerkkarte so was bewirken könnte, kann ich mir nicht vorstellen.
Wie gesagt, der Rettungsmodus ist reiner Text- Modus. Da kannst du wenigstens ungestört nachsehen (hoffentlich)
Hast du mal ne Live-DVD probiert?
Ich würde da Knoppix nehmen.
Wenn So einen CD startet, könnte man z.B. Von dort die Systemlogs auslesen und sich mal anschauen.

MSfree
Beiträge: 6185
Registriert: 25.09.2007 19:59:30

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von MSfree » 14.10.2020 07:58:55

willy4711 hat geschrieben: ↑ zum Beitrag ↑
13.10.2020 23:28:08
Mit der Grafik ist nur eine Vermutung, weil du ja sagtest, das der Installer im Textmodus ohne "einschlafen" lief.
Ich hatte das so verstanden, daß der Installer im Textmodus lief. Ab dem erste "richtigen" Boot ging das Theater los. Im Installer ist aber noch keine Energieverwaltung aktiv.

Ich werfe mal die Suspend-Modi in den Ring. Für mich hört sich das nach einem wild laufenden Suspend-to-RAM bzw. Suspend-to-Disk an. Beides läßt sich von der Kommandozeile abstellen, wenn man da mal für ein/zwei Minuten ohne "einschlafen" draufkommt:

Code: Alles auswählen

systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
Mir würde jedenfalls im Moment kein Treiber einfallen, der sowas verursachen könnte. Zumal der Rechner ja mit dem Anschalter immer wieder aufgeweckt werden kann.

CUVS
Beiträge: 6
Registriert: 13.10.2020 21:06:11

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von CUVS » 15.10.2020 23:37:45

Hallo,

hab's gestern leider nicht geschafft das zu testen.

Also knoppix 7.7 lief von CD ohne Probleme.

Habe nun im recovery mode (anders ging es nicht, er schlief zu schnell ein)

Code: Alles auswählen

systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
ausgeführt -> jetzt läuft er durch

aber jetzt läuft der Prozessor in Volllast (wie genau es vorher war kann ich wg. der kurzen Laufzeit nichts sagen) und der Lüfter ist sehr laut
mit htop unter Knoppix und debian verglichen, bei knoppix ist das nicht so
die Hauptlast >60% verursacht "/lib/systemd/systemd-logind" - habe leider keine Ahnung was man da machen kann

Danke schonmal Ihnen Beiden.

VG
CUVS

falls diese Info's zu Lösung noch relevant wären:

Ergebnis für lspci -nnk | grep -i VGA -A2

Code: Alles auswählen

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
        Subsystem: CLEVO/KAPOK Computer Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [1558:0600]
        Kernel driver in use: i915
gleich am Anfang des Bootvorgangs kommt folgender Fehler (falls das was zu sagen hat, startet aber weiter):

Code: Alles auswählen

[    0.488246] ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL dec
lared 5, ACPI requires 4 (20180810/nsarguments-194)
habe 2 mögliche BIOS-Einstellungen mit ACPI schon getestet, kein Unterschied

Im Bios gibt es noch eine Einstellung "CST Support" unter "Advanced CPU Control", ich konnte im I.net nicht finden wozu diese ist, auch wenn es im Bereich "Power" steht machte eine Einstellung von enabled/disabled scheinbar keinen Unterschied. Was bedeuted diese Einstellung und ist das irgendwie relevant?

MSfree
Beiträge: 6185
Registriert: 25.09.2007 19:59:30

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von MSfree » 16.10.2020 08:38:18

CUVS hat geschrieben: ↑ zum Beitrag ↑
15.10.2020 23:37:45
Habe nun im recovery mode (anders ging es nicht, er schlief zu schnell ein)

Code: Alles auswählen

systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
ausgeführt -> jetzt läuft er durch
Immerhin kommt man jetzt vernünftig an die Kiste ran, ohne daß sie einem ständig unter der Hand wegstirbt.
aber jetzt läuft der Prozessor in Volllast
Dann funktioniert das Hoch- und Runtertakten der CPU unter Last bzw. im Leerlauf nicht.
die Hauptlast >60% verursacht "/lib/systemd/systemd-logind" - habe leider keine Ahnung was man da machen kann
Das sollte aber nicht so sein. Eventuell stürzt der logind ständig ab und wird neu gestartet: Laß mal

Code: Alles auswählen

journalctl -f
in einem Terminal laufen und schau nach, ob meine Vermutung richtig ist. Sowas würde dann aber auf einen Hardwarefehler (z.B. defektes RAM) deuten.
Im Bios gibt es noch eine Einstellung "CST Support"...
Mit der Abkürzung kann ich spontan auch nichts anfangen. Oft haben die BIOSe aber ein Hilfesystem, wenn man F1 auf dem entsprechenden Menüpunkt drückt.

Was steckt denn für eine CPU in der Kiste?

Code: Alles auswählen

lscpu
?

Benutzeravatar
orcape
Beiträge: 1408
Registriert: 07.11.2008 18:37:24
Wohnort: 50°36'23.99"N / 12°10'20.66"E

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von orcape » 16.10.2020 14:55:36

Hi CUVS,
der Einwurf von @MSfree mit.....
lscpu
...ist schon mal nicht schlecht, der uns die CPU-Daten zeigt.
Dann wäre da noch....
free
..um die Speicherbelegung anzuzeigen.
Mit...
lspci
...zeigst Du und die restliche Hardware.
Ich glaube ganz einfach, das die Rechnerhardware, selbst für ein XFCE zu schwachbrünstig ist, denn wenn ein Grafiktreiber fehlt, sollte der Noveau-Treiber trotzdem eine ordentliche 2 D Grafik gewährleisten.
Ich habe hier einen alte HP-Pavilion-dm1 12", der einst ein Windows 7 64-bit on Board hatte. Ein Geschenk meines Onkels, der da an Windows10 verzweifelt ist. Der läuft mit einem AMD-E 1600MHz Prozessor, Debian-Testing und Kernel 5.8.0.2, einer alten Radeon-Grafik HD6310, allerdings mit Cinnamon-Oberfläche recht flüssig.
Ich vermute mal, das Deine Hardware-Werte noch mehr zu wünschen übrig lassen. :wink:
Gruß orcape

CUVS
Beiträge: 6
Registriert: 13.10.2020 21:06:11

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von CUVS » 16.10.2020 17:01:17

journalctl -f

Code: Alles auswählen

Okt 16 16:44:03 pkc00001 systemd-logind[403]: Suspending...
Okt 16 16:44:03 pkc00001 systemd-logind[403]: Unit suspend.target is masked, refusing operation.
Okt 16 16:44:03 pkc00001 systemd-logind[403]: Failed to execute operation: Permission denied
Okt 16 16:44:03 pkc00001 systemd-logind[403]: Suspending...
Okt 16 16:44:03 pkc00001 systemd-logind[403]: Unit suspend.target is masked, refusing operation.
Okt 16 16:44:03 pkc00001 systemd-logind[403]: Failed to execute operation: Permission denied
war
systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
vielleicht doch nicht so gut

weiteres Problem: hatte gerade vergessen den Strom anzuschließen, er ging somit einfach aus ohne Shutdown
Da der Akku vermutlich sowieso nicht mehr zu gebrauchen ist, sollte ich vielleicht den Akku ausbauen bzw. das Akku-Gehäuse innen leer machen, dann kann man es nicht mehr vergessen :-)

free

Code: Alles auswählen

              total        used        free      shared  buff/cache   available
Mem:        2574252      184056     2058872       72332      331324     2067220
Swap:       2609148           0     2609148
lscpu

Code: Alles auswählen

Architecture:        i686
CPU op-mode(s):      32-bit
Byte Order:          Little Endian
Address sizes:       32 bits physical, 32 bits virtual
CPU(s):              1
On-line CPU(s) list: 0
Thread(s) per core:  1
Core(s) per socket:  1
Socket(s):           1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               14
Model name:          Intel(R) Celeron(R) M CPU        430  @ 1.73GHz
Stepping:            8
CPU MHz:             1320.224
BogoMIPS:            3466.77
L1d cache:           32K
L1i cache:           32K
L2 cache:            1024K
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx constant_tsc arch_perfmon bts cpuid aperfmperf pni monitor tm2 xtpr pdcm pti dtherm
lspci

Code: Alles auswählen

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller (rev 10)
05:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
05:09.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
05:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
05:09.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
hier sieht man doch bestimmt auch welchen WiFi-Treiber ich noch installieren muss, vielleicht könnt Ihr mir das noch gleich mit sagen (aber eins nach dem anderen :-) )

Danke

MSfree
Beiträge: 6185
Registriert: 25.09.2007 19:59:30

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von MSfree » 16.10.2020 17:24:54

CUVS hat geschrieben: ↑ zum Beitrag ↑
16.10.2020 17:01:17
war
systemctl mask sleep.target suspend.target hibernate.target hybrid-sleep.target
vielleicht doch nicht so gut
Mit dem Befehl hast du vier Systemunits abgeschaltet. Du kannst sie ja mal eine nach der anderen wieder einschalten, aber eine der 4 war halt auch für das Absterben verantwortlich.

Code: Alles auswählen

systemctl unmask sleep.target
systemctl enable sleep.target
systemctl start sleep.target
Würde z.B. das sleep.target wieder einschalten. Genauso kannst du auch mit den suspend.target, hibernate.target und hybrid-sleep.target vorgehen. Wenn die Kiste dann wieder einschläft, weiß du ja, welches Target dein Problem ausgelöst hat und dann brauchst du auch nur dieses eine Target wieder maskieren.


free

Code: Alles auswählen

              total        used        free      shared  buff/cache   available
Mem:        2574252      184056     2058872       72332      331324     2067220
Swap:       2609148           0     2609148
RAM hat die Kiste jedenfalls genug.

lscpu

Code: Alles auswählen

...
Model name:          Intel(R) Celeron(R) M CPU        430  @ 1.73GHz...
Jo mei, 'ne Rakete ist das nicht. Für einfache Aufgaben aber immer noch brauchbar.
lspci

Code: Alles auswählen

...
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
Also Intel Onboard Graphik. Völlig OK für Linux und unproblematisch.
hier sieht man doch bestimmt auch welchen WiFi-Treiber ich noch installieren muss,
Den passenden Treiber bringt der Kernel bereits mit. Allerdings braucht man für WLAN praktisch immer auch passende Firmware:

Code: Alles auswählen

apt-get install firmware-iwlwifi
sollte das Problem lösen.

Benutzeravatar
willy4711
Beiträge: 4277
Registriert: 08.09.2018 16:51:16

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von willy4711 » 16.10.2020 17:26:47

CUVS hat geschrieben: ↑ zum Beitrag ↑
16.10.2020 17:01:17
hier sieht man doch bestimmt auch welchen WiFi-Treiber ich noch installieren muss, vielleicht könnt Ihr mir das noch gleich mit sagen (aber eins nach dem anderen :-) )
Das wäre Debianfirmware-iwlwifi zmindest gibt es da was für
Intel Wireless 3945 firmware, version 15.32.2.9
(iwlwifi-3945-2.ucode)
Ob es passt, muss man sehen.
Aber das hat aus meiner Sicht z.Z. wenig Sinn, solange nicht geklärt ist, warum der Rechner auf Suspend gehen will.
CUVS hat geschrieben: ↑ zum Beitrag ↑
13.10.2020 21:30:55
ich wollte für eine Familie deren alten Laptop für deren Kinder nutzbar machen (falls mal wieder Homeschooling ansteht).
Ich glaube nicht, dass ein Einkerner mit 32 BIT damit noch zurecht kommen würde.

Benutzeravatar
orcape
Beiträge: 1408
Registriert: 07.11.2008 18:37:24
Wohnort: 50°36'23.99"N / 12°10'20.66"E

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von orcape » 16.10.2020 17:58:45

Was mir auffällt sind die 2,5 GB RAM, also unterschiedliche RAM-Module.
Auch mit so etwas hatte ich schon meine Probleme, aber muss ja nicht zwingend sein.
Wunder solltest Du von dem Teil auf alle Fälle nicht mehr erwarten. Wenn dann minimalster grafischer Aufwand, möglichst ohne 3 D.
Gruß orcape

CUVS
Beiträge: 6
Registriert: 13.10.2020 21:06:11

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von CUVS » 16.10.2020 21:24:54

Offen ist noch die Frage warum er lt. "journalctl -f" überhaupt versucht ständig "suspend.target" aufzurufen (s.o.), was ja dann vermutlich die CPU-Last erzeugt.

Sobald ich mit "systemctl unmask suspend.target" aufrufe ist es vorbei, da brauche ich nicht mal "enable" und "start" aufrufen.

Ich denke mal dort ist irgendwo der Schlüssel zur Lösung.

habe dann mal im Linux Handbuch von Hr. Kofler nach "suspend" gesucht und den Befehl "dmesg | grep -i acpi" gefunden, dort gibt es div. Warnings (Ausgabe s. u.)

ggf. hängt es ja doch mit dem weiter oben schon beschriebenen Fehler direkt beim Booten zusammen:

Code: Alles auswählen

[    0.488246] ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL dec
lared 5, ACPI requires 4 (20180810/nsarguments-194)
@willy4711, MSfree:
apt-get install firmware-iwlwifi
hat funktioniert
willy4711 hat geschrieben: ↑ zum Beitrag ↑
16.10.2020 17:26:47
CUVS hat geschrieben: ↑ zum Beitrag ↑
13.10.2020 21:30:55
ich wollte für eine Familie deren alten Laptop für deren Kinder nutzbar machen (falls mal wieder Homeschooling ansteht).
Ich glaube nicht, dass ein Einkerner mit 32 BIT damit noch zurecht kommen würde.
Ist auch eher für etwas LibreOffice und ein wenig Recherche mit Firefox.

OffTopic:
Unsere Schule hat für jeden Schüler einen Hefter mit Aufgaben vorbereitet, falls es wieder zur Schließung kommt.
Den durch die Stadtverwaltung gebraucht bereitgestellten Server, denn ich um die Osterzeit während des Lockdowns in der Schule mit Debian + NextCloud + Mumble installiert hatte, hat man der Stadt zurückgegeben - "man bräuchte ihn nicht mehr". :facepalm:
Daher mein Plan eher Eltern zu helfen, den Schulen ist nicht mehr zu helfen. (sorry)

Danke
CUVS

Ausgabe von "dmesg | grep -i acpi" (ich kann damit leider nicht viel anfangen)
nur "ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver" fällt auf, da fehlt vielleicht doch noch irgendein Treiber

Code: Alles auswählen

[    0.000000] BIOS-e820: [mem 0x000000009f673000-0x000000009f6befff] ACPI NVS
[    0.000000] BIOS-e820: [mem 0x000000009f6bf000-0x000000009f6fffff] ACPI data
[    0.023044] ACPI: Early table checksum verification disabled
[    0.024125] ACPI: RSDP 0x00000000000FE020 000014 (v00 INTEL )
[    0.024130] ACPI: RSDT 0x000000009F6FE038 000034 (v01 INTEL  Napa     00000001 MSFT 01000013)
[    0.024140] ACPI: FACP 0x000000009F6FD000 000074 (v01 INTEL  Napa     00000001 MSFT 01000013)
[    0.024151] ACPI: DSDT 0x000000009F6F7000 005DD4 (v01 INTEL  Napa     00000001 MSFT 01000013)
[    0.024157] ACPI: FACS 0x000000009F684000 000040
[    0.024163] ACPI: APIC 0x000000009F6F5000 000068 (v01 INTEL  Napa     00000001 MSFT 01000013)
[    0.024170] ACPI: MCFG 0x000000009F6F3000 00003C (v01 INTEL  Napa     00000001 MSFT 01000013)
[    0.024176] ACPI: SLIC 0x000000009F6F2000 000176 (v01 INTEL  Napa     00000000 MSFT 01000013)
[    0.024204] ACPI: Local APIC address 0xfee00000
[    0.061929] ACPI: PM-Timer IO Port: 0x408
[    0.061933] ACPI: Local APIC address 0xfee00000
[    0.061946] ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
[    0.061948] ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
[    0.061967] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.061970] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.061973] ACPI: IRQ0 used by override.
[    0.061975] ACPI: IRQ9 used by override.
[    0.061979] Using ACPI (MADT) for SMP configuration information
[    0.317297] ACPI: Core revision 20180810
[    0.461446] PM: Registering ACPI NVS region [mem 0x9f673000-0x9f6befff] (311296 bytes)
[    0.461446] ACPI: bus type PCI registered
[    0.461446] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
[    0.463547] ACPI: Added _OSI(Module Device)
[    0.463549] ACPI: Added _OSI(Processor Device)
[    0.463551] ACPI: Added _OSI(3.0 _SCP Extensions)
[    0.463553] ACPI: Added _OSI(Processor Aggregator Device)
[    0.463555] ACPI: Added _OSI(Linux-Dell-Video)
[    0.463557] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[    0.468715] ACPI: 1 ACPI AML tables successfully acquired and loaded
[    0.474670] ACPI: EC: EC started
[    0.474672] ACPI: EC: interrupt blocked
[    0.476097] ACPI: \_SB_.PCI0.LPC_.H8EC: Used as first EC
[    0.476101] ACPI: \_SB_.PCI0.LPC_.H8EC: GPE=0x17, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.476104] ACPI: \_SB_.PCI0.LPC_.H8EC: Used as boot DSDT EC to handle transactions
[    0.476105] ACPI: Interpreter enabled
[    0.476148] ACPI: (supports S0 S3 S4 S5)
[    0.476150] ACPI: Using IOAPIC for interrupt routing
[    0.476200] PCI: Ignoring host bridge windows from ACPI; if necessary, use "pci=use_crs" and report a bug
[    0.476543] ACPI: Enabled 11 GPEs in block 00 to 1F
[    0.487731] ACPI: PCI Root Bridge [PCI0] (domain 0000 [bus 00-ff])
[    0.487739] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
[    0.487748] ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (20180810/nsarguments-164)
[    0.487925] acpi PNP0A08:00: _OSC failed (AE_TYPE); disabling ASPM
[    0.488507] acpi PNP0A08:00: host bridge window [io  0x0000-0x0cf7 window] (ignored)
[    0.488510] acpi PNP0A08:00: host bridge window [io  0x0cf8-0x0cff] (ignored)
[    0.488512] acpi PNP0A08:00: host bridge window [io  0x0d00-0xffff window] (ignored)
[    0.488514] acpi PNP0A08:00: host bridge window [mem 0x000a0000-0x000bffff window] (ignored)
[    0.488517] acpi PNP0A08:00: host bridge window [mem 0xa0000000-0xfebfffff window] (ignored)
[    0.493137] pci 0000:00:1f.0: quirk: [io  0x0400-0x047f] claimed by ICH6 ACPI/GPIO/TCO
[    0.494341] acpiphp: Slot [1] registered
[    0.495491] acpiphp: Slot [1-1] registered
[    0.495636] acpiphp: Slot [1-2] registered
[    0.497405] ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 9 10 *11 12)
[    0.497540] ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 9 *10 11 12)
[    0.497664] ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 9 10 *11 12)
[    0.497786] ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 9 10 *11 12)
[    0.497909] ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 7 9 10 11 12) *0, disabled.
[    0.498035] ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 7 9 10 11 12) *0, disabled.
[    0.498157] ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 5 7 9 10 11 12) *0, disabled.
[    0.498278] ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 7 9 10 11 12) *0, disabled.
[    0.499057] ACPI: EC: interrupt unblocked
[    0.499073] ACPI: EC: event unblocked
[    0.499083] ACPI: \_SB_.PCI0.LPC_.H8EC: GPE=0x17, EC_CMD/EC_SC=0x66, EC_DATA=0x62
[    0.499086] ACPI: \_SB_.PCI0.LPC_.H8EC: Used as boot DSDT EC to handle transactions and events
[    0.499708] PCI: Using ACPI for IRQ routing
[    0.538667] pnp: PnP ACPI init
[    0.539302] system 00:00: Plug and Play ACPI device, IDs PNP0c02 (active)
[    0.539387] pnp 00:01: Plug and Play ACPI device, IDs PNP0b00 (active)
[    0.539867] pnp 00:02: Plug and Play ACPI device, IDs PNP0501 (active)
[    0.539937] pnp 00:03: Plug and Play ACPI device, IDs PNP0303 (active)
[    0.539996] pnp 00:04: Plug and Play ACPI device, IDs PNP0f13 (active)
[    0.540125] pnp: PnP ACPI: found 5 devices
[    0.577818] clocksource: acpi_pm: mask: 0xffffff max_cycles: 0xffffff, max_idle_ns: 2085701024 ns
[    3.801484] ACPI: Power Button [PWRB]
[    3.801597] ACPI: Lid Switch [LID0]
[    3.802754] ACPI: Sleep Button [SLPB]
[    3.803653] ACPI: Power Button [PWRF]
[    3.804541] ACPI: Video Device [OVGA] (multi-head: yes  rom: yes  post: no)
[    3.804804] acpi device:19: registered as cooling_device1
[    4.013098] ACPI: bus type USB registered
[    4.013590] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMBA) (20180810/utaddress-213)
[    4.013598] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.013602] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000538-0x000000000000053A (\GPIO) (20180810/utaddress-213)
[    4.013607] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.013608] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x000000000000050E-0x000000000000050F (\GPO1) (20180810/utaddress-213)
[    4.013613] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x000000000000050C-0x000000000000050D (\GPE1) (20180810/utaddress-213)
[    4.013619] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    4.746521] ata3.00: ACPI cmd ef/10:03:00:00:00:a0 (SET FEATURES) filtered out
[    5.204227] ata3.00: ACPI cmd 00/00:00:00:00:00:a0 (NOP) rejected by device (Stat=0x51 Err=0x04)
[   13.949768] battery: ACPI: Battery Slot [BAT0] (battery present)
[   14.012000] ACPI: AC Adapter [AC] (on-line)

MSfree
Beiträge: 6185
Registriert: 25.09.2007 19:59:30

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von MSfree » 17.10.2020 14:37:02

CUVS hat geschrieben: ↑ zum Beitrag ↑
16.10.2020 21:24:54
Offen ist noch die Frage warum er lt. "journalctl -f" überhaupt versucht ständig "suspend.target" aufzurufen (s.o.), was ja dann vermutlich die CPU-Last erzeugt.

Sobald ich mit "systemctl unmask suspend.target" aufrufe ist es vorbei, da brauche ich nicht mal "enable" und "start" aufrufen.
Wenn ich das so genau wüßte. Ich hatte mal einen EeePC, der hatte 3 Sondertasten, unter anderem eine, um den Bildschirm zum Stromsparen abzuschalten. Dort hat sich auch völlig unvermittelt zwischendurch der Bildschirm abgeschaltet. Es lag da aber einfach daran, daß bei der Montage der Tasten, die Trägerplatine etwas verspannt eingebaut wurde. Es war also ein mechanisches Problem, das ich selbst beheben konnte.

In deinem Fall könnte ebenfalls ein defekter Taster für dein Problem zuständig sein. Es gibt ja an vielen Geräten Taster, um den Rechner in einen Stromsparmodus zu versetzen.

Du könntest die Überwachung dieser Taster einfach mal komplett abstellen, in dem du in der Datei /etc/systemd/logind.conf die Zeilen

Code: Alles auswählen

#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore
folgerndermassen änderst:

Code: Alles auswählen

HandleHibernateKey=ignore
HandleLidSwitch=ignore
HandleLidSwitchExternalPower=ignore
andleLidSwitchDocked=ignore
Danach versuchst du dann die maskierten Targets wieder einzuschalten.
Ausgabe von "dmesg | grep -i acpi" (ich kann damit leider nicht viel anfangen)
ACPI-Meldungen sind praktisch an der Tagesordnung und deuten eher auf unsaubere Impementierungen im BIOS hin als auf eigentlich Fehler. Linux ignoriert Fehler in der Regel, was dazu führt, daß eventuell weniger Strom gespart wird als mit anderen Betriebssystemen, der Lüfter öfter hochläuft und der Akkubetrieb kürzer ausfällt. Aber das sind Sorgen, um die man sich später oder gar nicht kümmern muß.

CUVS
Beiträge: 6
Registriert: 13.10.2020 21:06:11

Re: Laptop schläft während der Benutzung ständig ein

Beitrag von CUVS » 18.10.2020 21:59:50

Hallo MSfree,
MSfree hat geschrieben: ↑ zum Beitrag ↑
17.10.2020 14:37:02
Du könntest die Überwachung dieser Taster einfach mal komplett abstellen, in dem du in der Datei /etc/systemd/logind.conf die Zeilen

Code: Alles auswählen

#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchExternalPower=suspend
#HandleLidSwitchDocked=ignore
folgerndermassen änderst:

Code: Alles auswählen

HandleHibernateKey=ignore
HandleLidSwitch=ignore
HandleLidSwitchExternalPower=ignore
andleLidSwitchDocked=ignore
Danach versuchst du dann die maskierten Targets wieder einzuschalten.
Ausgabe von "dmesg | grep -i acpi" (ich kann damit leider nicht viel anfangen)
ACPI-Meldungen sind praktisch an der Tagesordnung und deuten eher auf unsaubere Impementierungen im BIOS hin als auf eigentlich Fehler. Linux ignoriert Fehler in der Regel, was dazu führt, daß eventuell weniger Strom gespart wird als mit anderen Betriebssystemen, der Lüfter öfter hochläuft und der Akkubetrieb kürzer ausfällt. Aber das sind Sorgen, um die man sich später oder gar nicht kümmern muß.
das war die Lösung, keine Volllast mehr und auch nach Re-Aktivierung der Targets kein Einschlafen mehr. Manuelles Suspend im Menü geht auch und reicht aus meiner Sicht aus.
Unter "journalctl -f" herrscht auch Ruhe.

Leistung passt denke ich auch für die alte Kiste:
  • 57 Sekunden zum Starten bis Login (inkl. GRUB Menü mit Enter bestätigt)
  • 13 Sekunden von Login bis Desktop
  • 18 Sekunden LibreOffice starten
  • 21 Sekunden FireFox starten
  • 10 Sekunden Shutdown
Ich denke so kann man ihn zurückgeben. Es ist zwar keine Rakete, aber man kann damit arbeiten.

Danke nochmal an alle die geholfen haben. :hail: :THX:

CUVS

Antworten