Welche Virtualisierung

Alle weiteren Dienste, die nicht in die drei oberen Foren gehören.
Antworten
flotux73
Beiträge: 15
Registriert: 10.01.2021 12:05:33

Welche Virtualisierung

Beitrag von flotux73 » 12.01.2021 23:46:29

Hallo,

Ich werde demnächst einen Ryzen 5 3400G mit 16 GB Ram zusammenstellen. In erster Linie soll OMV als Server in der Abstellkammer werkeln, dennoch möchte ich eine Linux und eine Windows 10 Instanz bereitstellen. Linux VM zu Test und Experimentierzwecke , auf der Windows VM soll Office laufen.

Ich dachte erst das Virtualboxplugin von OMV 5 zu nutzen, da das Plugin ab OMV 5 nicht mehr bereitgestellt wird, habe ich mich ein bisschen quergelesen. Es gibt div. andere Virtualisierungsmöglichen, nur welche wäre für mich die geeignete? Wie gut ist Cockpit als Frontend in Verbindung mit quemu ?

Was nutzt ihr denn so bzw. was könnt ihr mir empfehlen?

hec_tech
Beiträge: 996
Registriert: 28.06.2007 21:49:36
Wohnort: Wien
Kontaktdaten:

Re: Welche Virtualisierung

Beitrag von hec_tech » 12.01.2021 23:53:33

Ich würde mal zu KVM raten.

Was du glaube ich wirklich suchst ist eben ein Frontend. Da gibt es recht viel Auswahl.
Ich würde zu libvirt raten. Selbst verwende ich Proxmox aber das ist für größere Setups gedacht.

flotux73
Beiträge: 15
Registriert: 10.01.2021 12:05:33

Re: Welche Virtualisierung

Beitrag von flotux73 » 12.01.2021 23:58:46

hec_tech hat geschrieben: ↑ zum Beitrag ↑
12.01.2021 23:53:33
Selbst verwende ich Proxmox aber das ist für größere Setups gedacht.
Danke, werde mir KVM und libvrt genauer ansehen. Proxmox ist mir Momentan eine Nummer zu umfangreich, obwohl es sich interessant liest.

Bisher habe ich auf meinem OSX Virtualbox genutzt.

schwedenmann
Beiträge: 4834
Registriert: 30.12.2004 15:31:07
Wohnort: Wegberg

Re: Welche Virtualisierung

Beitrag von schwedenmann » 13.01.2021 07:35:57

Hallo

Wenn du in der VM debian laufen lasen willst, dann nimm qemu + virtmanager, bei meinem Debian-Sid laufen nur Debian-Installationen in Virtualbox langsamner als in qemu und ein du dauert ewig!

mfg
schwedenmann

flotux73
Beiträge: 15
Registriert: 10.01.2021 12:05:33

Re: Welche Virtualisierung

Beitrag von flotux73 » 13.01.2021 10:02:51

schwedenmann hat geschrieben: ↑ zum Beitrag ↑
13.01.2021 07:35:57
Wenn du in der VM debian laufen lasen willst, dann nimm qemu + virtmanager, bei meinem Debian-Sid laufen nur Debian-Installationen in Virtualbox langsamner als in qemu und ein du dauert ewig!
Es sollten auch andere Linuxe virtualisiert werden. :D

alex0801
Beiträge: 155
Registriert: 16.10.2005 19:46:48

Re: Welche Virtualisierung

Beitrag von alex0801 » 18.01.2021 10:42:25

schwedenmann hat geschrieben: ↑ zum Beitrag ↑
13.01.2021 07:35:57
Hallo

Wenn du in der VM debian laufen lasen willst, dann nimm qemu + virtmanager, bei meinem Debian-Sid laufen nur Debian-Installationen in Virtualbox langsamner als in qemu und ein du dauert ewig!
Ich mache gerade eine andere Erfahrung: viewtopic.php?f=32&t=180023

Wen das so weiter geht muss ich doch wieder VirtualBox nehmen... wozu ich eigentlich keine Lust habe. Der virt-manager ist um längen besser was das remote-verwalten einer VM Instanz angeht. Aber mein Default-Setup der Debian Guest VM ist so unerträglich langsam... Aber bevor ich den Thread kapere: Vielleicht hast du ja Lust in meinem verlinken Thread ein bisschen KnowHow zu verbreiten?

Gruß
Alex

flotux73
Beiträge: 15
Registriert: 10.01.2021 12:05:33

Re: Welche Virtualisierung

Beitrag von flotux73 » 18.01.2021 11:19:40

alex0801 hat geschrieben: ↑ zum Beitrag ↑
18.01.2021 10:42:25
Aber bevor ich den Thread kapere: Vielleicht hast du ja Lust in meinem verlinken Thread ein bisschen KnowHow zu verbreiten?
habe nichts dagegen, wenn Du den Threat hier "kaperst" :-) Sobald ich meinen neuen PC habe, können wir uns ggf auch austauschen.

alex0801
Beiträge: 155
Registriert: 16.10.2005 19:46:48

Re: Welche Virtualisierung

Beitrag von alex0801 » 18.01.2021 11:47:18

OK, dann fasse ich hier nochmal zusammen was ich aktuell habe:

Host:
* Debian Testing
* Intel(R) Pentium(R) CPU G4560 @ 3.50GHz
* 16GB RAM
* OS auf einer SSD
* 2x 4TB mit mdadm im RAID1 / ext4 als "großen Storage"

Guest:
* 6GB zugewiesener RAM
* 250GB qcow2 Disk-Image, nicht voll ausgereizt. Aktuell etwa 200GB frei im Image. Das Image liegt auf dem RAID1 des Hosts
* System wird als virtualisierter Root-Server am 100/40Mbit DSL (und Ende des Jahres 100/100Mbit FTTH) genutzt der mittels Portunity-VPN-Tunnel eine statische IPv4 und ein statisches IPv6 Subnetz bekommen hat
** Apache, Exim4, Dovecot, MariaDB, OpenVPN Client (für Portunity VPN Tunnel), sowie noch ein bisschen Kleinkram

virt-manager XML:

Code: Alles auswählen

<domain type="kvm">
  <name>RootServer</name>
  <uuid>a8434a69-8189-4c20-aa89-0681b1f3bc77</uuid>
  <metadata>
    <libosinfo:libosinfo xmlns:libosinfo="http://libosinfo.org/xmlns/libvirt/domain/1.0">
      <libosinfo:os id="http://debian.org/debian/10"/>
    </libosinfo:libosinfo>
  </metadata>
  <memory unit="KiB">6291456</memory>
  <currentMemory unit="KiB">6291456</currentMemory>
  <vcpu placement="static">2</vcpu>
  <os>
    <type arch="x86_64" machine="pc-q35-5.1">hvm</type>
    <boot dev="hd"/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <vmport state="off"/>
  </features>
  <cpu mode="host-model" check="partial"/>
  <clock offset="utc">
    <timer name="rtc" tickpolicy="catchup"/>
    <timer name="pit" tickpolicy="delay"/>
    <timer name="hpet" present="no"/>
  </clock>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>restart</on_reboot>
  <on_crash>destroy</on_crash>
  <pm>
    <suspend-to-mem enabled="no"/>
    <suspend-to-disk enabled="no"/>
  </pm>
  <devices>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
    <disk type="file" device="disk">
      <driver name="qemu" type="qcow2" cache="writethrough"/>
      <source file="/mnt/mirror/VMs/RootServer.qcow2"/>
      <target dev="vda" bus="virtio"/>
      <address type="pci" domain="0x0000" bus="0x04" slot="0x00" function="0x0"/>
    </disk>
    <controller type="usb" index="0" model="qemu-xhci" ports="15">
      <address type="pci" domain="0x0000" bus="0x02" slot="0x00" function="0x0"/>
    </controller>
    <controller type="sata" index="0">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x1f" function="0x2"/>
    </controller>
    <controller type="pci" index="0" model="pcie-root"/>
    <controller type="pci" index="1" model="pcie-root-port">
      <model name="pcie-root-port"/>
      <target chassis="1" port="0x10"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x0" multifunction="on"/>
    </controller>
    <controller type="pci" index="2" model="pcie-root-port">
      <model name="pcie-root-port"/>
      <target chassis="2" port="0x11"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x1"/>
    </controller>
    <controller type="pci" index="3" model="pcie-root-port">
      <model name="pcie-root-port"/>
      <target chassis="3" port="0x12"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x2"/>
    </controller>
    <controller type="pci" index="4" model="pcie-root-port">
      <model name="pcie-root-port"/>
      <target chassis="4" port="0x13"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x3"/>
    </controller>
    <controller type="pci" index="5" model="pcie-root-port">
      <model name="pcie-root-port"/>
      <target chassis="5" port="0x14"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x4"/>
    </controller>
    <controller type="pci" index="6" model="pcie-root-port">
      <model name="pcie-root-port"/>
      <target chassis="6" port="0x15"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x5"/>
    </controller>
    <controller type="pci" index="7" model="pcie-root-port">
      <model name="pcie-root-port"/>
      <target chassis="7" port="0x16"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x02" function="0x6"/>
    </controller>
    <controller type="virtio-serial" index="0">
      <address type="pci" domain="0x0000" bus="0x03" slot="0x00" function="0x0"/>
    </controller>
    <interface type="network">
      <mac address="52:54:00:d7:5a:0d"/>
      <source network="default"/>
      <model type="virtio"/>
      <address type="pci" domain="0x0000" bus="0x01" slot="0x00" function="0x0"/>
    </interface>
    <serial type="pty">
      <target type="isa-serial" port="0">
        <model name="isa-serial"/>
      </target>
    </serial>
    <console type="pty">
      <target type="serial" port="0"/>
    </console>
    <channel type="unix">
      <target type="virtio" name="org.qemu.guest_agent.0"/>
      <address type="virtio-serial" controller="0" bus="0" port="1"/>
    </channel>
    <channel type="spicevmc">
      <target type="virtio" name="com.redhat.spice.0"/>
      <address type="virtio-serial" controller="0" bus="0" port="2"/>
    </channel>
    <input type="tablet" bus="usb">
      <address type="usb" bus="0" port="1"/>
    </input>
    <input type="mouse" bus="ps2"/>
    <input type="keyboard" bus="ps2"/>
    <graphics type="vnc" port="-1" autoport="yes">
      <listen type="address"/>
    </graphics>
    <sound model="ich9">
      <address type="pci" domain="0x0000" bus="0x00" slot="0x1b" function="0x0"/>
    </sound>
    <video>
      <model type="qxl" ram="65536" vram="65536" vgamem="16384" heads="1" primary="yes"/>
      <address type="pci" domain="0x0000" bus="0x00" slot="0x01" function="0x0"/>
    </video>
    <redirdev bus="usb" type="spicevmc">
      <address type="usb" bus="0" port="2"/>
    </redirdev>
    <redirdev bus="usb" type="spicevmc">
      <address type="usb" bus="0" port="3"/>
    </redirdev>
    <memballoon model="virtio">
      <address type="pci" domain="0x0000" bus="0x05" slot="0x00" function="0x0"/>
    </memballoon>
    <rng model="virtio">
      <backend model="random">/dev/urandom</backend>
      <address type="pci" domain="0x0000" bus="0x06" slot="0x00" function="0x0"/>
    </rng>
  </devices>
</domain>
Mein Problem ist: Der Host langweilt sich, während der Guest massive io-wait Zeiten hat. Und ich komm nicht dahinter wieso. Zuvor hatte ich selbiges Setup mit VirtualBox. Da gab's keine Problem mit io-wait und Co.

Was ich bisher probiert habe:

1)

Code: Alles auswählen

<driver name="qemu" type="qcow2"/>
--> War der default nach dem Setup der Instanz.
2)

Code: Alles auswählen

<driver name="qemu" type="qcow2" cache="writethrough"/>
Ersteres war unerträglich langsam. Ein "apt install iotop" hat 2-3 Minuten gedauert.
Zweiteres sieht erstmal schneller aus, aber ein "apt dist-upgrade" führte zu 0% CPU aber mindesten 50%, meist 100% io-wait. Der ganze Vorgang der sonst wenige Minuten dauert (mache das regelmäßig), hat hier über 30min gedauert.

Antworten