[GELÖST] OpenWRT 21.02 - Network device is not present

Gemeinsam ins Internet mit Firewall und Proxy.
Antworten
BrotherJ
Beiträge: 284
Registriert: 15.11.2018 07:56:18

[GELÖST] OpenWRT 21.02 - Network device is not present

Beitrag von BrotherJ » 04.10.2021 10:25:27

Hallo,
eigentlich ist ja https://forum.openwrt.org das richtigere Forum, hier kommt jedoch kein Feedback. Ich habe einen Linksys WRT1900ACSv2-Router mit OpenWRT 21.02 und möchte hier gerne zwei separate Netzwerke (192.168.0.0/24, 192.168.1.0/24) auf jeweils zwei Ports legen. Beschrieben wird das hier https://openwrt.org/docs/guide-user/net ... d_networks.
Ich habe das nur über die Konsole konfiguriert und ich bin den Weg über die Luci-Gui gegangen. Das Netzwerk 192.168.0.0/24 lässt sich nicht einrichten. Ich sehe immer wieder in der Gui bei LAN0
Protocol: Static address
MAC: 12:F2:F1:56:EC:31
RX: 0 B (0 Pkts.)
TX: 0 B (0 Pkts.)
Error: Network device is not present
Dagegen besitzt LAN1 die bisherige Konfiguration für 192.168.1.0/24.

Das sind die Einstellungen in der CLI:

Code: Alles auswählen

root@OpenWrt:~# uci show network
network.loopback=interface
network.loopback.device='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fdbf:1af2:5c22::/48'
network.@device[0]=device
network.@device[0].name='br-home'
network.@device[0].type='bridge'
network.@device[0].ports='lan3' 'lan4'
network.lan1=interface
network.lan1.device='br-home'
network.lan1.proto='static'
network.lan1.ipaddr='192.168.1.1'
network.lan1.netmask='255.255.255.0'
network.lan1.ip6assign='60'
network.@device[1]=device
network.@device[1].name='wan'
network.@device[1].macaddr='c6:41:1e:33:b4:3b'
network.wan=interface
network.wan.device='wan'
network.wan.proto='dhcp'
network.wan6=interface
network.wan6.device='wan'
network.wan6.proto='dhcpv6'
network.@device[2]=device
network.@device[2].type='bridge'
network.@device[2].name='br-office'
network.@device[2].ports='lan1' 'lan2'
network.lan0=interface
network.lan0.proto='static'
network.lan0.device='br-office'
network.lan0.ipaddr='192.168.0.50'
network.lan0.netmask='255.255.255.0'
und

Code: Alles auswählen

root@OpenWrt:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1508 qdisc mq state UP qlen 1024
    link/ether c4:41:1e:33:b4:3b brd ff:ff:ff:ff:ff:ff
    inet6 fe80::c641:1eff:fe33:b43b/64 scope link 
       valid_lft forever preferred_lft forever
3: lan4@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-home state LOWERLAYERDOWN qlen 1000
    link/ether c4:41:1e:33:b4:3b brd ff:ff:ff:ff:ff:ff
4: lan3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-home state UP qlen 1000
    link/ether c4:41:1e:33:b4:3b brd ff:ff:ff:ff:ff:ff
5: lan2@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN qlen 1000
    link/ether c4:41:1e:33:b4:3b brd ff:ff:ff:ff:ff:ff
6: lan1@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN qlen 1000
    link/ether c4:41:1e:33:b4:3b brd ff:ff:ff:ff:ff:ff
7: wan@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state LOWERLAYERDOWN qlen 1000
    link/ether c6:41:1e:33:b4:3b brd ff:ff:ff:ff:ff:ff
8: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:25:9c:14:9a:0a brd ff:ff:ff:ff:ff:ff
9: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:25:9c:14:9a:09 brd ff:ff:ff:ff:ff:ff
10: br-home: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether c4:41:1e:33:b4:3b brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-home
       valid_lft forever preferred_lft forever
    inet6 fdbf:1af2:5c22::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::c641:1eff:fe33:b43b/64 scope link 
       valid_lft forever preferred_lft forever
13: br-office: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 4e:0d:87:35:25:a1 brd ff:ff:ff:ff:ff:ff
Ich würde sagen, dass ein entscheidender Unterschied bei lan1@eth0 und lan2@eth0 gegenüber lan3@eth0 und lan4@eth0, die beide "DOWN" gegenüber "UP" und "LOWERLAYERDOWN" sind. Was ich nicht verstehe ist, dass sich LAN0 nicht komplett einrichten lässt.

Code: Alles auswählen

root@OpenWrt:~# ubus list network.interface.*
network.interface.lan0
network.interface.lan1
network.interface.loopback
network.interface.wan
network.interface.wan6

Code: Alles auswählen

root@OpenWrt:~# ifstatus lan0
{
        "up": false,
        "pending": false,
        "available": false,
        "autostart": true,
        "dynamic": false,
        "proto": "static",
        "device": "br-office",
        "data": {

        },
        "errors": [
                {
                        "subsystem": "interface",
                        "code": "NO_DEVICE"
                }
        ]
}
Habt Ihr Ideen, die weiterführen könnten?

Vielen Dank
BrotherJ
Zuletzt geändert von BrotherJ am 05.10.2021 10:17:57, insgesamt 1-mal geändert.
Happiness is NOT a description IT'S A way of life!

BrotherJ
Beiträge: 284
Registriert: 15.11.2018 07:56:18

Re: OpenWRT 21.02 - Network device is not present

Beitrag von BrotherJ » 04.10.2021 19:06:02

Okay,
ich komme ein Stück weiter. Die Bridge "br-office" sollte zwei Interfaces (lan1, lan2) haben. Das ist aber nicht der Fall:

Code: Alles auswählen

# brctl show
bridge name     bridge id               STP enabled     interfaces
br-office               8000.000000000000       no
br-home         7fff.c4411e33b43b               no              lan4
                                                                                  lan3
Anlegen geht allerdings auch nicht:

Code: Alles auswählen

# brctl addif br-office lan1
brctl: bridge br-office: Resource busy
Ich habe auch erfolglos versucht die Bridge neu anzulegen und dann die Interfaces hinzuzufügen:

Code: Alles auswählen

# brctl delbr br-office
brctl addbr br-office
# brctl addif br-office lan1
brctl: bridge br-office: Resource busy
Irgendwelche Ideen von Eurer Seite aus, die weiterhelfen könnten?
Happiness is NOT a description IT'S A way of life!

BrotherJ
Beiträge: 284
Registriert: 15.11.2018 07:56:18

Re: OpenWRT 21.02 - Network device is not present

Beitrag von BrotherJ » 05.10.2021 10:17:34

Also wieder einmal die eigene Lösung. Ich habe jetzt diese https://openwrt.org/docs/guide-user/net ... sing_vlans umgesetzt, die da auch funktioniert.
In der vorherigen Konfiguration erschien als dmesg-Ausgabe unter anderem dieser Part:

Code: Alles auswählen

mv88e6085 f1072004.mdio-mii:00: p3: hw VLAN 1 already used by port 0 in br-home
als Zusatzinformation.
Geholfen hat also der Weg über VLANs.

Grüße

BrotherJ
Happiness is NOT a description IT'S A way of life!

Antworten