kein DVD-Automount und andere Probleme (Bullseye)

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
martinelli
Beiträge: 173
Registriert: 18.07.2005 07:00:26
Lizenz eigener Beiträge: GNU General Public License
Wohnort: RW

kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von martinelli » 22.09.2021 19:32:49

Hallo zusammen,

kann es sein, dass bei Debian 11 eingelegte Datenträger (CDs, DVDs) nicht mehr automatisch eingebunden werden und dass es generell Probleme beim Mounten gibt? Ich habe heute zum ersten Mal nach der Neuinstallation von Bullseye festgestellt, dass CDs/DVDs manuell gemounted werden müssen, was jedoch auch nicht immer funktioniert. Bei einigen Datenträgern erhalte ich beim manuellen Mounten diesen Fehler:

<Mount-Befehl>: wrong fs type, bad option, bad superblock on /dev/sr0, missing codepage or helper program, or other error.

Diese CDs/DVDs sind aber in Ordnung und unter Buster einwandfrei mountfähig. Andere CDs können bei Debian 11 einwandfrei eingehängt werden und auch USB-Sticks werden automatisch gemounted. Rechner und DVD-Laufwerk sind dasselbe.

Was könnte die Ursache für diese seltsame Verhalten sein?

Danke im Voraus für jeden Hinweis.
Gruß
martinelli

<_42_>

Benutzeravatar
jph
Beiträge: 936
Registriert: 06.12.2015 15:06:07
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Greven/Westf.

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von jph » 17.10.2021 22:48:50

Automount von Datenträgern kenne ich nur als Feature einer grafischen Umgebung. Welche verwendest du?

Benutzeravatar
martinelli
Beiträge: 173
Registriert: 18.07.2005 07:00:26
Lizenz eigener Beiträge: GNU General Public License
Wohnort: RW

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von martinelli » 18.10.2021 08:10:58

Immer Mate, auch bei Debian 10, aber dort war nie ein manuelles Mounten erforderlich...
Gruß
martinelli

<_42_>

Benutzeravatar
willy4711
Beiträge: 5973
Registriert: 08.09.2018 16:51:16

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von willy4711 » 19.10.2021 09:26:46

Eventuell fehlt dir ein fuse-Modul ?
Bei mir (Testing) zu Vergleich

Code: Alles auswählen

dpkg -l *fuse*|grep ii
ii  fuse2fs            1.46.4-1        amd64        ext2 / ext3 / ext4 file system driver for FUSE
ii  fuse3              3.10.5-1        amd64        Filesystem in Userspace (3.x version)
ii  fuseiso            20070708-3.2+b1 amd64        FUSE module to mount ISO filesystem images
ii  fuseiso9660        0.3-2           amd64        File System in User Space - Module for ISO9660
ii  gvfs-fuse          1.48.1-2        amd64        userspace virtual filesystem - fuse server
ii  libfuse2:amd64     2.9.9-5         amd64        Filesystem in Userspace (library)
ii  libfuse3-3:amd64   3.10.5-1        amd64        Filesystem in Userspace (library) (3.x version)

Benutzeravatar
smutbert
Moderator
Beiträge: 7985
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von smutbert » 19.10.2021 11:05:29

Vermutlich stört da ein fstab-Eintrag. Das automatische Mounten funktioniert in einigermaßen modernen Desktopumgebungen ohne fstab-Eintrag. Ein fstab-Eintrag mit festgelegtem Dateisystem, z.B. iso9660 wie er mitunter bei der Installation angelegt wird, verhindert, dass CDs/DVDs mit anderen Dateisystemen gemountet werden können und möglicherweise funktioniert das automatische Mounten (von CDs/DVDs) auch sonst nicht mehr.

Ich würde also testweise einen eventuell vorhandenen fstab-Eintrag für das CD/DVD-Laufwerk zumindest testweise auskommentieren.

Benutzeravatar
martinelli
Beiträge: 173
Registriert: 18.07.2005 07:00:26
Lizenz eigener Beiträge: GNU General Public License
Wohnort: RW

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von martinelli » 10.11.2021 08:44:18

willy4711 hat geschrieben: ↑ zum Beitrag ↑
19.10.2021 09:26:46
Eventuell fehlt dir ein fuse-Modul ?
Komme leider erst jetzt zum Antworten... :cry:

Habe alles auf Verdacht nachinstalliert, hat aber nichts geändert.

Danke trotzdem.
Gruß
martinelli

<_42_>

Benutzeravatar
martinelli
Beiträge: 173
Registriert: 18.07.2005 07:00:26
Lizenz eigener Beiträge: GNU General Public License
Wohnort: RW

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von martinelli » 10.11.2021 08:46:02

smutbert hat geschrieben: ↑ zum Beitrag ↑
19.10.2021 11:05:29
Vermutlich stört da ein fstab-Eintrag. Das automatische Mounten funktioniert in einigermaßen modernen Desktopumgebungen ohne fstab-Eintrag. Ein fstab-Eintrag mit festgelegtem Dateisystem, z.B. iso9660 wie er mitunter bei der Installation angelegt wird, verhindert, dass CDs/DVDs mit anderen Dateisystemen gemountet werden können und möglicherweise funktioniert das automatische Mounten (von CDs/DVDs) auch sonst nicht mehr.

Ich würde also testweise einen eventuell vorhandenen fstab-Eintrag für das CD/DVD-Laufwerk zumindest testweise auskommentieren.
Komme leider erst jetzt zum Antworten... :cry:

Habe ich versucht, hat aber nichts geändert. Es bleibt seltsam, dass es unter Debian 10 einwandfrei funktioniert hat, ohne Anpassungen und bei identischer Hardware.

Danke trotzdem.
Gruß
martinelli

<_42_>

Benutzeravatar
smutbert
Moderator
Beiträge: 7985
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von smutbert » 10.11.2021 23:44:40

Tritt das beim manuellen Mounten noch auf?
martinelli hat geschrieben: ↑ zum Beitrag ↑
22.09.2021 19:32:49
<Mount-Befehl>: wrong fs type, bad option, bad superblock on /dev/sr0, missing codepage or helper program, or other error.
Gibt bzw. gab es vielleicht mehr als einen Eintrag in der fstab für das DVD-Laufwerk, zB einmal /dev/sr0 und einmal /dev/cdrom oder etwas in der Richtung?

Benutzeravatar
martinelli
Beiträge: 173
Registriert: 18.07.2005 07:00:26
Lizenz eigener Beiträge: GNU General Public License
Wohnort: RW

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von martinelli » 11.11.2021 09:21:10

Nein, nur ein Eintrag: /dev/sr0
Gruß
martinelli

<_42_>

Benutzeravatar
smutbert
Moderator
Beiträge: 7985
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von smutbert » 24.11.2021 23:56:00

Das Thema habe ich etwas aus den Augen verloren, aber du hast die letzte Frage auch nicht beantwortet. Wenn nämlich diese Meldung

Code: Alles auswählen

<Mount-Befehl>: wrong fs type, bad option, bad superblock on /dev/sr0, missing codepage or helper program, or other error.
noch auftritt (und du weißt, dass die DVD auf anderen Systemen fehlerfrei gelesen werden kann), ist das ein Hinweis, dass versucht wird die DVD mit dem falschen Dateisystem zu mounten (und da ist ein Eintrag in der fstab der naheliegendste Verdacht).

und weil ich mir nicht mir mehr sicher bin, dass wir vom gleichen reden, was meinst du im Eröffnungsbeitrag mit
martinelli hat geschrieben: ↑ zum Beitrag ↑
22.09.2021 19:32:49
[...] dass CDs/DVDs manuell gemounted werden müssen [...]
Mounten auf der Kommandozeile (mit welchem Befehl)?
Anklicken in einem Dateimanager (welchen)?

Benutzeravatar
martinelli
Beiträge: 173
Registriert: 18.07.2005 07:00:26
Lizenz eigener Beiträge: GNU General Public License
Wohnort: RW

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von martinelli » 25.11.2021 08:59:19

Vielleicht reden wir ja tatsächlich aneinander vorbei... :?

Das Hauptproblem ist, dass bei Bullseye Automount nur sporadisch funktioniert. Nach Einlegen einer CD/DVD, Anstecken eines USB-Datenträgers oder einer SDCARD erschien bei Buster sofort das entsprechende Icon auf dem Desktop - ohne dass ich die Installation irgendwie angepasst hätte - und ich konnte von dieser Stelle aus auf die Inhalte des Mediums zugreifen.

Das funktioniert bei Bullseye nur manchmal, meist muss ich manuell mounten! Beim Mounten gibt es dann keine Probleme, aber dieser manuelle Schritt ist einfach lästig.

Die Fehlermeldung, die ich eingangs erwähnt habe, ist auf einen offensichtlich fehlerhaften Datenträger zurück zu führen. Warum der bei Debian 10 eingebunden wird, auch automatisch, habe ich nicht herausgefunden. Ist aber egal, ich habe die CD entsorgt. Auch werden bei Bullseye - im Gegensatz zu Buster - nur manche USB-Sticks automatisch eingebunden, keine Ahnung, woran das liegt.

Zusammenfassung: Debian 10 hat jeden Datenträger automatisch eingebunden, die 11er Version macht das nur gelegentlich.

Ich hoffe, ich habe es nachvollziehbar erklärt... :wink:
Gruß
martinelli

<_42_>

Benutzeravatar
MSfree
Beiträge: 7743
Registriert: 25.09.2007 19:59:30

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von MSfree » 25.11.2021 09:26:11

martinelli hat geschrieben: ↑ zum Beitrag ↑
25.11.2021 08:59:19
Nach Einlegen einer CD/DVD, Anstecken eines USB-Datenträgers oder einer SDCARD erschien bei Buster sofort das entsprechende Icon auf dem Desktop
Ich nutze Debian nun schon ungefähr 20 Jahre, aber ein Icon ist bei mir noch nie auf dem Desktop erschienen, wenn ich einen Wechseldatenträger eingelegt hatte, aber ich habe sehr wahrscheinlich ein anderes Desktopsystem verwendet als du. Da kam höchstens ein Popup-Fenster mit einer Meldung, was man mit dem Datenträger zu tun gedenkt.
Das funktioniert bei Bullseye nur manchmal, meist muss ich manuell mounten!
Dann solltest du einfach in Log schauen, warum manche Datenträger nicht automatisch gemountet werden, das wird nämlich protokolliert. journalctl und dmesg helfen auf jeden Fall.

Ich habe irgendwann mal gelesen, daß die Automounts aus Sicherheitsgründen in besimmten Situationen nicht mehr durchgeführt werden. Ob das nur für bestimmte Dateisysteme gilt oder bestimmte Medien, habe ich nicht mehr in Erinnerung. Ziel diese Vorsichtsmaßnamen ist, Schadsoftware nicht einen bequemen Autoinstall-Weg zu ebnen.
Beim Mounten gibt es dann keine Probleme, aber dieser manuelle Schritt ist einfach lästig.
Ich finde es nicht lästig sondern beruhigend, daß nicht jeder Schrott sofort eingehängt wird.

Benutzeravatar
willy4711
Beiträge: 5973
Registriert: 08.09.2018 16:51:16

Re: kein DVD-Automount und andere Probleme (Bullseye)

Beitrag von willy4711 » 25.11.2021 10:25:37

Bei mir in Xfce, sowohl früher mit Bullseye als auch jetzt mit Bookworm, funktioniert das so:

Datenträger, die beim Booten angeschlossen sind, aber nicht in der fstab stehen, werden angezeigt (im Dateimanager)
sind aber ausgegraut (also nicht gemountet)
Ob das nun auf dem Desktop erscheint oder nicht ist einen Sache der Einstellung im jeweiligen DE

Das finde ich vollkommen in Ordnung so. Ein Klick auf das Icon, mountet das Device dann unter /media/user/Device
USB-Laufwerke / DVD benötigen kein PW, fest eingebaute Laufwerke benötigen das Root-PW

Wenn ich hingegen einen Datenträger während des Betriebes einlege /einstecke wird er sofort gemountet, ebenfalls
nach /media/user/Device.

Das entspricht auch einer gewissen Logik, da man ja - wenn man es während des Betriebes einsteckt, es meist auch benutzen will.

Die Regeln (PW ja oder Nein) sind in der /usr/share/polkit-1/actions/org.freedesktop.UDisks2.policy hinterlegt
Sind ziemlich viele :lol: : NoPaste-Eintrag41535

Im Journal sieht das dann so aus (immer angeschlossenes USB- Laufwerk) :

Code: Alles auswählen

journalctl -b |grep sdc
Nov 25 09:49:53 XFCE kernel: sd 6:0:0:0: [sdc] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
Nov 25 09:49:53 XFCE kernel: sd 6:0:0:0: [sdc] Write Protect is off
Nov 25 09:49:53 XFCE kernel: sd 6:0:0:0: [sdc] Mode Sense: 43 00 00 00
Nov 25 09:49:53 XFCE kernel: sd 6:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Nov 25 09:49:53 XFCE kernel:  sdc: sdc1
Nov 25 09:49:53 XFCE kernel: sd 6:0:0:0: [sdc] Attached SCSI disk

Boot- Vorgang Ende

Nov 25 10:07:18 XFCE udisksd[874]: Mounted /dev/sdc1 at /media/willy/Video on behalf of uid 1000
Nov 25 10:07:18 XFCE kernel: EXT4-fs (sdc1): mounted filesystem with ordered data mode. Opts: errors=remount-ro. Quota mode: none.

Antworten