[Erledigt] Video: Bild und Ton passen nicht immer zusammen.

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
Benutzeravatar
ottonormal
Beiträge: 3325
Registriert: 20.01.2014 22:25:29

[Erledigt] Video: Bild und Ton passen nicht immer zusammen.

Beitrag von ottonormal » 16.06.2022 11:47:13

Hallo,

ein Freund empfahl mir kürzlich mal eine etwa 20 Jahre alte Videoserie. Auch wenn ich überhaupt kein Freund von Serien ganz allgemein bin, er meinte aber, die MUSS man gesehen haben. Der Name der Serie tut nichts zur Sache und ich will ihn hier auch nicht nennen.

Die Videos sind in recht guter 720p-Qualität, leider aber nicht in meiner Muttersprache. Dafür habe ich die gleichen Videos zusätzlich auch noch in deutsch, die Bildqualität ist bei denen aber grausig.

Nun möchte ich die deutschen Tonspuren in die englischen Videos packen. Das Anpassen der unterschiedlichen Längen mit Audacity und einfügen der Tonspuren mit MKVToolNix ist ja kein Problem, das habe ich auch schon mehrfach erfolgreich praktiziert. Bei diesen Videos ist es aber etwas anders. Bei Länge, Anfang und Ende passen Video- und Tonspur zusammen. dazwischen geht es aber teilweise ziemlich auseinander. Aber nicht immer, manchmal passt es auch da.

Mediainfo zeigt mir beim deutschen Video:
"Overall-bit-rate-mode = Variabel"
und beim Audio ebenfalls "Bit-rate-mode Variabel."

Beim englischen Videos ist:
"Frame rate mode = Constant."

Es müsste also, meiner bescheidenen Kenntnis nach, die Tonspur vom deutschen Video auch auf Constant, umgestellt werden. Ich hoffe, dass ich hier nichts durcheinandergebracht habe.

Weiss wer ob und wie das möglich ist?
Zuletzt geändert von ottonormal am 24.06.2022 09:29:02, insgesamt 1-mal geändert.

Benutzeravatar
hikaru
Moderator
Beiträge: 12474
Registriert: 09.04.2008 12:48:59

Re: Video: Bild und Ton passen nicht immer zusammen.

Beitrag von hikaru » 16.06.2022 14:05:55

Ich kenne MKVToolNix nicht, deshalb bin ich mir nicht 100%ig sicher, ob wir die selben Begriffe verwenden, aber eine konstante oder variable Bitrate hat nichts mit der Abspielgeschwindigkeit zu tun.
Variable Bitrate kann prinzipiell ein besseres Qualität/Speicherplatz-Verhältnis liefern, weil der benötigte Speicherplatz für 10 Sekunden Stille gleich Null ist, während er für 10 Sekunden weißes Rauschen maximal ist. Eine variable Codierung berücksichtigt das, eine Konstante tut das nicht und muss daher einen Kompromiss suchen um einerseits das Rauschen adäquat abzubilden, andererseits aber nicht unnötig Platz für die Stille zu verschwenden.

Ich vermute, dein Problem entsteht beim Schneiden zwecks Längenanpassung. Dabei wirst du vermutlich nicht zwangsläufig auf Keyframes schneiden, wodurch eine Reencodierung nötig wird. Dabei habe ich selbst schon festgestellt, dass sich Bild und Ton gegeneinander verschieben können, habe aber nie den Elan aufgebracht, die Ursache zu erforschen.
Du könntest testweise mal versuchen, im Videoplayer deiner Wahl zum Englischen Video das Deutsche Video als Audioquelle zu laden, den Offset zwischen den Videos anzupassen (soweit das bei Sprachsynchronisation praktikabel ist - am besten anhand von Toneffekten), und dann zu schauen, ob dieser Offset über das ganze Video hinweg konstant ist. Falls ja, könnte es sich lohnen, sich weiter mit dem Thema zu beschäftigen. Falls nein, lohnt es sich wahrscheinlich nicht, denn wenn du alle Offsets herausgefunden hast, lohnt es sich vermutlich nicht mehr, die Serie auf Genuss zu schauen, weil du dann eh schon alle Dialoge mitbeten kannst.

Benutzeravatar
ottonormal
Beiträge: 3325
Registriert: 20.01.2014 22:25:29

Re: Video: Bild und Ton passen nicht immer zusammen.

Beitrag von ottonormal » 16.06.2022 17:09:29

Geschnitten wird bei den Videos nichts, die sind ja beide fertig.
Normalerweise verfahre ich einfach so:

Das englische Video hat 23.976 FPS und damit eine Länge von 58 min und xxx sek.
Das deutsche Video hat 25 FPS und damit eine Länge von 55 min und xxx sek.

Beide Videodateien ziehe in Audacity und habe dann beide Audios in 2 übereinanderliegende Spuren.
Dann kann ich recht einfach die deutsche Audiospur auf die gleiche Länge bringen wie die englische. Manchmal genügt das schon, meist muss aber noch etwas nachgearbeitet werden weil Anfang und Ende nicht ganz genau übereinanderliegen. Das ist aber kein Problem. Die bearbeitete deutsche Spur kann ich dann exportieren und mit MKVToolNix in die (ursprünglich englische) Videodatei einfügen. Die englische Spur wird natürlich gelöscht bzw. beim Export abgewählt.
Dann exportieren und fertig!

Es ist eigentlich wirklich recht einfach und funktioniert im allgemeinen immer sehr gut. Nur wie gesagt, in diesem Falle eben nicht.

Benutzeravatar
hikaru
Moderator
Beiträge: 12474
Registriert: 09.04.2008 12:48:59

Re: Video: Bild und Ton passen nicht immer zusammen.

Beitrag von hikaru » 16.06.2022 18:52:29

ottonormal hat geschrieben: ↑ zum Beitrag ↑
16.06.2022 17:09:29
Das englische Video hat 23.976 FPS und damit eine Länge von 58 min und xxx sek.
Das deutsche Video hat 25 FPS und damit eine Länge von 55 min und xxx sek.
NTSC und PAL eben.
ottonormal hat geschrieben: ↑ zum Beitrag ↑
16.06.2022 17:09:29
Die bearbeitete deutsche Spur kann ich dann exportieren und mit MKVToolNix in die (ursprünglich englische) Videodatei einfügen. Die englische Spur wird natürlich gelöscht bzw. beim Export abgewählt.
Dann exportieren und fertig!
Und was genau passiert bei diesem "Exportieren" in MKVToolNix? Wird dabei das Video reencodiert?

Benutzeravatar
ottonormal
Beiträge: 3325
Registriert: 20.01.2014 22:25:29

Re: Video: Bild und Ton passen nicht immer zusammen.

Beitrag von ottonormal » 16.06.2022 19:25:16

hikaru hat geschrieben: ↑ zum Beitrag ↑
16.06.2022 18:52:29
Und was genau passiert bei diesem "Exportieren" in MKVToolNix? Wird dabei das Video reencodiert?
Nein, da wird nichts reencodiert. An der Videodatei selbst ändert sich ja nichts. Die bearbeitete Audiodatei wird einfach ins MKVToolNix-Fenster gezogen, die alte Audiospur wird ausgeklammert und dann wird das einfach zusammengefügt und als neue MKV-Datei exportiert (kopiert!). Das ist ein Vorgang, der nur wenige Sekunden dauert.

Benutzeravatar
king-crash
Beiträge: 644
Registriert: 08.08.2006 12:07:56
Lizenz eigener Beiträge: MIT Lizenz

Re: Video: Bild und Ton passen nicht immer zusammen.

Beitrag von king-crash » 20.06.2022 02:31:41

@hikaru
MKVToolNix kann soweit mir bekannt ist nur den Container bearbeiten. Die Inhalte werden nicht angefasst. Durch das Bearbeiten des Containers kann allerdings zum Beispiel das später abspielende Programm dazu gebracht werden das Video anstatt in 23,9 in 25 FPS abzuspielen.

@ottonormal
Wie ist denn der "Frame rate mode" für das deutsche Video?
Evtl bist du von sowas hier betroffen: https://en.wikipedia.org/wiki/Variable_frame_rate

Benutzeravatar
ottonormal
Beiträge: 3325
Registriert: 20.01.2014 22:25:29

Re: Video: Bild und Ton passen nicht immer zusammen.

Beitrag von ottonormal » 24.06.2022 09:28:12

Oh, hier kam ja noch was. :wink:
Eigentlich war das Thema ja inzwischen für mich erledigt. Ich habe mir ein paar Folgen der Serie angeschaut und dabei eben in Kauf genommen, dass Bild und Ton nicht immer ganz synchron waren. Es war aber schon noch gerade so erträglich.

Der "Frame rate mode" für das deutsche Video wird von MediaInfo nicht angezeigt. Ich hatte es aber schon getestet und das englische Video in MKVToolNix von 23.976 FPS auf 25 FPS umgestellt und dann die (unbearbeitete) deutsche Tonspur dazugepackt. Das geht zwar recht einfach und schnell, das Ergebnis ist aber ganau wie auch zu Anfang schon. Einge Stellen sind gut, andere nicht.

Dann habe ich das versuchsweise auch mal in meinem alten Windows mit Samplitude probiert. Die Tonspur in mehrere Einzelteile geschnitten und die dann nach und nach angepasst. Das Ergebnis ist damit zwar perfekt, der Zeitaufwand ist dabei aber nicht mehr akzeptabel. Der wäre nur bei einzelnen, besonderen, Videos vertretbar.

Nun ja, belassen wir's dabei.

Antworten