[gelöst] Maus/Tastatur unter KDE "tot"

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

[gelöst] Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 14:29:56

Moinsens!

Seit gestern (bemerkt, kann auch schon paar Tage länger her sein) ist nach dem Start in KDE meine Maus und Tastatur leblos. Der Mauscursor steht in der Mitte des Desktops (am linken Rand des rechten Monitors in der halben Höhe). Maus-Bewegungen oder -Klicks gehen nicht. Aber auch die Tastatur zeigt keinerlei Reaktion, also auch nichts mehr mit Ctrl-Esc oder so.

Gemerkt habe ich es gestern, weil ich per RDP und SSH ein wenig an der Config ändern wollte bzw. musste. U.a. aktuelles Update, Upgrade und Dist-Upgrade mit dem einen oder anderen Reboot. Als ich lokal (also nicht RDP) was überprüfen wollte, wunderte ich mich schon, wieso die beiden Monitore nicht aus dem standby zurück wollten, weder bei Tastendruck noch bei Mausbewegung. Ein Reboot (per SSH ausgelöst) zeigt GRUB, wo ich auch mit den Cursortasten den Balken bewegen kann. (Da ist noch kein Mauscursor, oder?). Durchstarten auf KDE und schwupps, hängt die Maus und die Tastatur macht auch nix mehr.

Maus/Key sind von Hama und hängen an einem BT-Dongle (dürfte der "MosArt xxx" sein), der wiederum in einem aktiven Hub steckt. Ändern des USB-Platzes, sowohl innerhalb des Hubs, wie auch direkt an den ThinkCentre, brachten keine Änderung.

Nun fehlt mir ein bisschen die Idee, wo (in welchen Logs usw.) ich nach dem Problem sehen kann. Mag mir hier mal jemand etwas helfen? Also wo ich schauen kann und worauf genau ich achten soll?

Gruß, Michael

Code: Alles auswählen

miriki@lxdeb1130:~$ inxi
CPU: dual core Intel Core i5-4570T (-MT MCP-)
speed/min/max: 2771/800/3600 MHz Kernel: 5.18.0-2-amd64 x86_64 Up: 2h 1m
Mem: 3004.0/7845.1 MiB (38.3%) Storage: 2.04 TiB (1.0% used) Procs: 305
Shell: Bash inxi: 3.3.19

Code: Alles auswählen

miriki@lxdeb1130:~$ lsusb
Bus 003 Device 002: ID 8087:8000 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 045b:0210 Hitachi, Ltd 
Bus 004 Device 002: ID 045b:0210 Hitachi, Ltd 
Bus 004 Device 003: ID 0bc2:2321 Seagate RSS LLC Expansion Portable
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 8087:07dc Intel Corp. Bluetooth wireless interface
Bus 002 Device 006: ID 062a:4c01 MosArt Semiconductor Corp. 2,4Ghz Wireless Transceiver [for Delux M618 Plus Wireless Vertical Mouse]
Bus 002 Device 005: ID 045b:0209 Hitachi, Ltd 
Bus 002 Device 004: ID 045b:0209 Hitachi, Ltd 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Alles auswählen

miriki@lxdeb1130:~$ ls -la /dev/input
insgesamt 0
drwxr-xr-x  4 root root     440 21. Jun 12:17 .
drwxr-xr-x 19 root root    3360 21. Jun 12:17 ..
drwxr-xr-x  2 root root     120 21. Jun 12:17 by-id
drwxr-xr-x  2 root root     140 21. Jun 12:17 by-path
crw-rw----  1 root input 13, 64 21. Jun 12:17 event0
[ . . . ]
crw-rw----  1 root input 13, 73 21. Jun 12:17 event9
crw-rw----  1 root input 13, 63 21. Jun 12:17 mice
crw-rw----  1 root input 13, 32 21. Jun 12:17 mouse0
Zuletzt geändert von miriki am 21.06.2022 22:14:08, insgesamt 1-mal geändert.

Benutzeravatar
debilian
Beiträge: 330
Registriert: 21.05.2004 14:03:04
Kontaktdaten:

Re: Maus/Tastatur unter KDE "tot"

Beitrag von debilian » 21.06.2022 16:42:29

reagiert das journal bzw. /var/log/messages auf Einschalten bzw. Einstecken der Geräte?

gruss
-- nicht bewegt Sie wie ein GNU --

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 17:12:01

debilian hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 16:42:29
reagiert das journal bzw. /var/log/messages auf Einschalten bzw. Einstecken der Geräte?
/var/log/messages hatte zunächst nicht reagiert, aber beim Einstecken in einen anderen USB-Port kam auch erstmal der "disconnect", der 22 Sek. vorher war, dann der "connect" Teil:

Code: Alles auswählen

root@lxdeb1130:~# clear && tail -f /var/log/messages
Jun 21 17:06:37 lxdeb1130 kernel: [17363.550058] usb 2-10.4: USB disconnect, device number 6
Jun 21 17:06:59 lxdeb1130 kernel: [17385.054726] usb 2-10.1.1: new full-speed USB device number 7 using xhci_hcd
Jun 21 17:06:59 lxdeb1130 kernel: [17385.157514] usb 2-10.1.1: New USB device found, idVendor=062a, idProduct=4c01, bcdDevice= 1.17
Jun 21 17:06:59 lxdeb1130 kernel: [17385.157528] usb 2-10.1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jun 21 17:06:59 lxdeb1130 kernel: [17385.157534] usb 2-10.1.1: Product: 2.4G INPUT DEVICE
Jun 21 17:06:59 lxdeb1130 kernel: [17385.157538] usb 2-10.1.1: Manufacturer: MOSART Semi.
Jun 21 17:06:59 lxdeb1130 kernel: [17385.164933] input: MOSART Semi. 2.4G INPUT DEVICE as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.0/0003:062A:4C01.0003/input/input16
Jun 21 17:06:59 lxdeb1130 kernel: [17385.223121] hid-generic 0003:062A:4C01.0003: input,hidraw0: USB HID v1.10 Keyboard [MOSART Semi. 2.4G INPUT DEVICE] on usb-0000:00:14.0-10.1.1/input0
Jun 21 17:06:59 lxdeb1130 kernel: [17385.225862] input: MOSART Semi. 2.4G INPUT DEVICE Mouse as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input17
Jun 21 17:06:59 lxdeb1130 kernel: [17385.226187] input: MOSART Semi. 2.4G INPUT DEVICE Consumer Control as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input18
Jun 21 17:06:59 lxdeb1130 kernel: [17385.283061] input: MOSART Semi. 2.4G INPUT DEVICE System Control as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input19
Jun 21 17:06:59 lxdeb1130 kernel: [17385.283381] input: MOSART Semi. 2.4G INPUT DEVICE as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input20
Jun 21 17:06:59 lxdeb1130 kernel: [17385.283930] hid-generic 0003:062A:4C01.0004: input,hiddev0,hidraw1: USB HID v1.10 Mouse [MOSART Semi. 2.4G INPUT DEVICE] on usb-0000:00:14.0-10.1.1/input1
Jun 21 17:06:59 lxdeb1130 mtp-probe: checking bus 2, device 7: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1"
Jun 21 17:06:59 lxdeb1130 mtp-probe: bus: 2, device: 7 was not an MTP device
Jun 21 17:06:59 lxdeb1130 mtp-probe: checking bus 2, device 7: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1"
Jun 21 17:06:59 lxdeb1130 mtp-probe: bus: 2, device: 7 was not an MTP device

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 18:17:10

debilian hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 16:42:29
reagiert das journal bzw. /var/log/messages auf Einschalten bzw. Einstecken der Geräte?
Ach, und:

Code: Alles auswählen

root@lxdeb1130:~# journalctl -g mouse
[ . . . ]
Jun 21 12:17:19 lxdeb1130 kernel: mousedev: PS/2 mouse device common for all mice
Jun 21 12:17:19 lxdeb1130 kernel: input: MOSART Semi. 2.4G INPUT DEVICE Mouse as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.4/>
Jun 21 12:17:19 lxdeb1130 kernel: hid-generic 0003:062A:4C01.0002: input,hiddev0,hidraw1: USB HID v1.10 Mouse [MOSART Semi. 2.4G IN>
Jun 21 17:06:59 lxdeb1130 kernel: input: MOSART Semi. 2.4G INPUT DEVICE Mouse as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/>
Jun 21 17:06:59 lxdeb1130 kernel: hid-generic 0003:062A:4C01.0004: input,hiddev0,hidraw1: USB HID v1.10 Mouse [MOSART Semi. 2.4G IN>
Wobei die letzten beiden Zeilen ja zu /var/log/messages passen.

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 18:22:21

debilian hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 16:42:29
reagiert das journal bzw. /var/log/messages auf Einschalten bzw. Einstecken der Geräte?
Schon ein paar Tage her, aber soll mir das im Journal was sagen?

Code: Alles auswählen

Jun 01 13:11:48 lxdeb1130 PackageKit[3352]: in /701_aeccaeca for update-packages package libmousepad0;0.5.9-1;amd64;debian-unstable>
Jun 01 13:11:48 lxdeb1130 PackageKit[3352]: in /701_aeccaeca for update-packages package kmousetool;4:21.12.3-1;amd64;debian-unstab>
Jun 01 13:11:48 lxdeb1130 PackageKit[3352]: in /701_aeccaeca for update-packages package libmouse-perl;2.5.10-1+b2;amd64;debian-uns>
Jun 01 13:11:48 lxdeb1130 PackageKit[3352]: in /701_aeccaeca for update-packages package mousepad;0.5.9-1;amd64;debian-unstable-mai>
Oder noch davorerer:

Code: Alles auswählen

Mai 13 12:29:08 lxdeb1130 gnome-shell[832]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proce>
Mai 13 12:31:48 lxdeb1130 gnome-shell[2108]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proc>
Mai 13 12:32:37 lxdeb1130 gnome-shell[2108]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proc>
Mai 13 12:32:41 lxdeb1130 gnome-shell[2108]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proc>
Mai 13 12:35:20 lxdeb1130 gnome-shell[2108]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proc>
Mai 13 14:12:08 lxdeb1130 gnome-shell[2108]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proc>
Mai 13 14:12:31 lxdeb1130 gnome-shell[2108]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proc>
Mai 13 14:14:07 lxdeb1130 gnome-shell[2108]: libinput error: event4  - MOSART Semi. 2.4G INPUT DEVICE Mouse: client bug: event proc>

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 18:27:20

debilian hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 16:42:29
reagiert das journal bzw. /var/log/messages auf Einschalten bzw. Einstecken der Geräte?
Vielleicht noch dmesg?

Code: Alles auswählen

root@lxdeb1130:~# dmesg
[ . . . ]
[17363.550058] usb 2-10.4: USB disconnect, device number 6
[17385.054726] usb 2-10.1.1: new full-speed USB device number 7 using xhci_hcd
[17385.157514] usb 2-10.1.1: New USB device found, idVendor=062a, idProduct=4c01, bcdDevice= 1.17
[17385.157528] usb 2-10.1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[17385.157534] usb 2-10.1.1: Product: 2.4G INPUT DEVICE
[17385.157538] usb 2-10.1.1: Manufacturer: MOSART Semi.
[17385.164933] input: MOSART Semi. 2.4G INPUT DEVICE as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.0/0003:062A:4C01.0003/input/input16
[17385.223121] hid-generic 0003:062A:4C01.0003: input,hidraw0: USB HID v1.10 Keyboard [MOSART Semi. 2.4G INPUT DEVICE] on usb-0000:00:14.0-10.1.1/input0
[17385.225862] input: MOSART Semi. 2.4G INPUT DEVICE Mouse as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input17
[17385.226187] input: MOSART Semi. 2.4G INPUT DEVICE Consumer Control as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input18
[17385.283061] input: MOSART Semi. 2.4G INPUT DEVICE System Control as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input19
[17385.283381] input: MOSART Semi. 2.4G INPUT DEVICE as /devices/pci0000:00/0000:00:14.0/usb2/2-10/2-10.1/2-10.1.1/2-10.1.1:1.1/0003:062A:4C01.0004/input/input20
[17385.283930] hid-generic 0003:062A:4C01.0004: input,hiddev0,hidraw1: USB HID v1.10 Mouse [MOSART Semi. 2.4G INPUT DEVICE] on usb-0000:00:14.0-10.1.1/input1

Benutzeravatar
debilian
Beiträge: 330
Registriert: 21.05.2004 14:03:04
Kontaktdaten:

Re: Maus/Tastatur unter KDE "tot"

Beitrag von debilian » 21.06.2022 19:54:01

keine Ahnung, erkannt werden die Geräte ja, anscheinend.
Batterien leer / schwach? (falls welche drin sind...)
-- nicht bewegt Sie wie ein GNU --

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 20:00:22

debilian hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 19:54:01
Batterien leer / schwach? (falls welche drin sind...)
nope. ;-) Batterien leer war mein 1. Gedanke. Wäre merkwürdiger Zufall, wenn sowohl Tastatur wie auch Maus gleichzeitig die Grätsche gemacht hätten. Und beide sind auch erst seit wenigen Wochen im (nicht allzu häufigen) Gebrauch. Aber auch eine neue AA und AAA brachten nichts.

Und wie gesagt: Tastatur im GRUB oder auch im BIOS kein Problem.

Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 21.06.2022 20:41:21

Hast du schonmal versucht, eine kabelgebundene (USB oder PS/2) Maus und Tastatur anzuschließen?
Funktionieren Eingaben damit?

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 20:58:59

MSfree hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 20:41:21
Hast du schonmal versucht, eine kabelgebundene (USB oder PS/2) Maus und Tastatur anzuschließen?
Hihi... Hab ich nicht mehr. ;-) Hier schwirrt noch genau eine Kabel-gebundene Tastatur herum: Eine USB Logitech G15 am Win10, auf der ich gerade tippe. Und deren Kabel ist relativ aufwändig verlegt. Die krieg ich nicht ohne Weiteres raus. Und Mäuse mit Kabel... Puha... Ich glaube, in einer Bastelkiste könnte noch eine PS/2-Maus liegen. Und irgendwo schwirrt noch ein COM Trackball herum. Aber da wäre ich nicht mal sicher, ob die überhaupt noch gehen. Und COM zu PS/2 Adapter hab ich zwar noch, aber COM oder PS/2 zu USB definitiv nicht. Und COM oder PS/2 hat der ThinkCentre nicht, nur USB.

Und nur zur Sicherheit nochmals: Im GRUB und im BIOS geht die Tastatur. Der "USB Legacy Support" im BIOS war übrigens auch die ganze Zeit aktiviert. Den hatte ich im Verdacht, aber...

Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 21.06.2022 21:13:21

miriki hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 20:58:59
Hihi... Hab ich nicht mehr. ;-)
Schade, damit hätte man nämlich testen können, ob ein Softwareproblem vorliegt.
Im GRUB und im BIOS geht die Tastatur.
Das hatte ich nicht überlesen :wink:

Mich erinnert dieser Eingabegeräteausfall an eine meiner Minimalinstallationen auf einem Laptop, bei der die Tastatur ebenfalls nur im Textmodus (BIOS, Grub, Textkonsole) funktioniert hat, in der Graphik jedoch waren Tastatur und Touchpad ohne Funktion.

Was liefert bei dir der Befehl

Code: Alles auswählen

dpkg -l | grep libinput
?

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 21:42:07

MSfree hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 21:13:21
in der Graphik jedoch waren Tastatur und Touchpad ohne Funktion.
Gerade zum Thema Touchpad hat's elend viele Treffer in Google gegeben. Aber soweit ich das gesehen habe, waren das meist Treffer aus 2003, 2004 - nach knapp 20 Jahren leider nicht mehr sehr hilfreich. Davon abgesehen, ergab sich oft ein "neue Tastatur, geht wieder alles". Nur diese Kombo hier hat ja mehrere Wochen gelaufen.

Code: Alles auswählen

root@lxdeb1130:~# dpkg -l | grep libinput
ii  libinput-bin                                  1.20.1-1                           amd64        input device management and event handling library - udev quirks
ii  libinput10:amd64                              1.20.1-1                           amd64        input device management and event handling library - shared library
Was genau wird hier angezeigt?

Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 21.06.2022 21:57:45

miriki hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 21:42:07

Code: Alles auswählen

root@lxdeb1130:~# dpkg -l | grep libinput
ii  libinput-bin                                  1.20.1-1                           amd64        input device management and event handling library - udev quirks
ii  libinput10:amd64                              1.20.1-1                           amd64        input device management and event handling library - shared library
Wir könnten auf der richtigen Spur sein.

Ich mußte bei meinem Rechner noch Debianxserver-xorg-input-libinput installieren, damit Touchpad und Tastatur in der Graphik funktioniert haben.

Code: Alles auswählen

apt-get install xserver-xorg-input-libinput
gefolgt von einem Reboot.

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 22:13:46

MSfree hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 21:57:45

Code: Alles auswählen

apt-get install xserver-xorg-input-libinput

Code: Alles auswählen

root@lxdeb1130:~# dpkg -l | grep libinput
ii  libinput-bin                                  1.20.1-1                           amd64        input device management and event handling library - udev quirks
ii  libinput10:amd64                              1.20.1-1                           amd64        input device management and event handling library - shared library
ii  xserver-xorg-input-libinput                   1.2.1-1+b1                         amd64        X.Org X server -- libinput input driver
Reboot

Maus: Geht!
Tastatur: Geht!

Wenn Du jetzt noch kochen kannst... ;-)

Trotzdem nochmal die Frage: Was wird mir da aufgelistet, was machen diese Libs?

Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 21.06.2022 22:32:24

miriki hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 22:13:46
Wenn Du jetzt noch kochen kannst... ;-)
Kochen kann doch jeder, nur schmecken tut es nicht bei jedem :mrgreen:
Was wird mir da aufgelistet
Im Grunde alle installierten Pakete, die was mit Eingabegeräten (Maus, Touchpad, Tastatur) zu tun haben. Das, was bei dir noch gefehlt hat, war die Verbindung zum X-Server, also der graphischen Oberfläche. Wie gesagt, ist mir auch schon passiert, weil ich immer ohne suggests und recommends installiere, um möglichst wenig "überflüssiges" auf der Platte zu haben. Ich habe dadurch meistens nicht mehr als 3.5GB an installierter Software auf dem Rechner.

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 21.06.2022 22:45:13

MSfree hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 22:32:24
Das, was bei dir noch gefehlt hat, war die Verbindung zum X-Server, also der graphischen Oberfläche. [...] ohne suggests und recommends installiere
Aber die Verbindung einer Maus zur grafischen Oberfläche ist ja nicht nur eine "gute Idee, wenn Du magst" oder ein "gut gemeinter Rat", sondern doch eine zwingende Notwendigkeit. Fehlt da nicht eine dependancy? Oder was verstehe ich da falsch?

Und dann frage ich mich natürlich auch, wieso diese Verbindung plötzlich gekappt worden ist, wodurch auch immer...

Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 21.06.2022 22:56:48

miriki hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 22:45:13
Aber die Verbindung einer Maus zur grafischen Oberfläche ist ja nicht nur eine "gute Idee, wenn Du magst" oder ein "gut gemeinter Rat", sondern doch eine zwingende Notwendigkeit. Fehlt da nicht eine dependancy?
Bei den Abhängikeiten gibt es drei Stufen: Dependencies, Recommends, Suggests. xserver-xorg-input-libinput ist zwar ein recommended Paket, aber eben keines, von dem andere Pakete zwingend abhängig sind. Wenn du deine Kiste planst, nur remote z.B. über VNC zu bedienen, dann brauchst du die Eingabe ja nicht zwingend auf der Maschinen selbst.
Und dann frage ich mich natürlich auch, wieso diese Verbindung plötzlich gekappt worden ist, wodurch auch immer...
Die Frage kann ich dir nicht beantworten. Bei einem Softwareupdate wird einem ja normalerweise angezeigt, was erneuert wird und welche Pakete nicht mehr nötig sind. Bei umfangreichen Updates kann die Liste lang sein und/oder man schaut nicht so genau hin, und dann ist es passiert. Ausserdem has du Testing (aka Bookworm) installiert, da kann es auch schonmal vorkommen, daß die Abhängigkeiten sich ändern oder sich Fehler einschleichen.

Was genau passiert ist, ist im Nachhinein nicht unbedingt eindeutig in Erfahrung zu bringen. Ein Installationslog findest du unter /var/log/apt, da kannst du ja mal nach libinput suchen und ob das bei dir deinstalliert wurde.

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 22.06.2022 08:12:23

MSfree hat geschrieben: ↑ zum Beitrag ↑
21.06.2022 22:56:48
Ein Installationslog findest du unter /var/log/apt, da kannst du ja mal nach libinput suchen und ob das bei dir deinstalliert wurde.
Hab da was gefunden, was mich auch etwas verwirrt...

Am 20. hatte ich (wieder mal) Probleme mit dem xrdp, bekam nur einen schwarzen Bildschirm. Und im Zuge dieser Up- und Downgrades, um es wieder zum Laufen zu kriegen, ist mehr "removed" worden, als ich vermutet hätte.

Code: Alles auswählen

Start-Date: 2022-06-20  11:59:17
Commandline: apt install ./xserver-xorg-core_1.20.11-1+deb11u1_amd64.deb
Requested-By: miriki (1000)
Downgrade: xserver-xorg-core:amd64 (2:21.1.3-2+b1, 2:1.20.11-1+deb11u1)
Remove: xserver-xorg-video-nouveau:amd64 (1:1.0.17-2), [...], xserver-xorg-input-libinput:amd64 (1.2.1-1+b1), [...]
End-Date: 2022-06-20  11:59:21
Was mich besonders verwirrt: Der hat auch alle möglichen task-xxx-desktop entfernt.

Nach

Code: Alles auswählen

Start-Date: 2022-06-20  14:09:47
Commandline: apt install ./xorgxrdp_0.2.15-1_amd64.deb
Start-Date: 2022-06-20  14:10:13
Commandline: apt install ./xrdp_0.9.15-1_amd64.deb
schien xrdp auch wieder zu laufen. Aber dann danach hab ich wohl das mit der Maus/Tastatur bemerkt. Anschließende

Code: Alles auswählen

Start-Date: 2022-06-20  16:58:07
Commandline: apt-get -y autoremove
Start-Date: 2022-06-20  16:58:25
Commandline: apt-get -y upgrade
Start-Date: 2022-06-20  17:31:26
Commandline: apt-get dist-upgrade -y
Start-Date: 2022-06-20  23:41:49
Commandline: apt upgrade
Start-Date: 2022-06-21  12:16:19
Commandline: apt upgrade
brachten da keine Besserung, bis Du mir mit

Code: Alles auswählen

Start-Date: 2022-06-21  22:07:47
Commandline: apt-get install xserver-xorg-input-libinput
aus der Patsche geholfen hast.
Ausserdem has du Testing (aka Bookworm) installiert,
Hab ich? Ach... Wie hab ich das denn gemacht? Eigentlich hab ich nur von einem USB-Stick das Bullseye 11.3.0 installiert. Ich hab mal, ich glaube wegen Sound über xrdp notwendg, was in die /etc/apt/sources.list zugefügt. Deswegen?

Code: Alles auswählen

deb http://deb.debian.org/debian/ bullseye main
deb-src http://deb.debian.org/debian/ bullseye main
deb http://security.debian.org/debian-security bullseye-security main contrib
deb-src http://security.debian.org/debian-security bullseye-security main contrib
# bullseye-updates, to get updates before a point release is made;
# see https://www.debian.org/doc/manuals/debian-reference/ch02.en.html#_updates_and_backports
deb http://deb.debian.org/debian/ bullseye-updates main contrib
deb-src http://deb.debian.org/debian/ bullseye-updates main contrib
deb http://deb.debian.org/debian bullseye-backports main contrib non-free
# deb cdrom:[Debian GNU/Linux 11.3.0 _Bullseye_ - Official amd64 DVD Binary-1 20220326-11:23]/ bullseye contrib main
# deb cdrom:[Debian GNU/Linux 11.3.0 _Bullseye_ - Official amd64 DVD Binary-1 20220326-11:23]/ bullseye contrib main
# SID
deb http://deb.debian.org/debian/ sid main contrib non-free
Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 22.06.2022 09:37:06

miriki hat geschrieben: ↑ zum Beitrag ↑
22.06.2022 08:12:23
Hab ich?
Auf Bookworm habe ich aufgrund der Version 1.20 von libinput-bin (siehe oben) geschlossen.

Du hast die Zeile

Code: Alles auswählen

deb http://deb.debian.org/debian/ sid main contrib non-free
in deiner sources.list. Das ist sogar noch eine Nummer wackeliger als Testing (Bookworm). Eine Mischung aud Bullseye und SID ist überhaupt keine gute Idee und kann dir über kurz oder lang das System gehörig durcheinander bringen. Einige hier im Forum nennen sowas auch Frankendebian

Das wieder auf ein reines Bullseye zurück zu bringen ist mindestens extrem aufwändig bis unnmöglich.

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 22.06.2022 13:10:44

MSfree hat geschrieben: ↑ zum Beitrag ↑
22.06.2022 09:37:06
Du hast die Zeile

Code: Alles auswählen

deb http://deb.debian.org/debian/ sid main contrib non-free
in deiner sources.list. Das ist sogar noch eine Nummer wackeliger als Testing (Bookworm).
Oha, na dann...

Im letzten Save vom 27. Mai waren weder Backport noch SID drin. Dafür war CDROM noch drin, was auf den schon lange nicht mehr eingesteckten USB-Stick zeigen sollte. Das kann dann nur ab dann bis zum letzten Edit-Stand vom 30. Mai passiert sein. Wenn ich mich recht entsinne, hatte ich Ende Mai mit LibreOffice Calc herumprobiert, eine MS-Excel-Mappe nachzubauen, die ich im Zuge von Arduino, RasPi, Fritzing usw. benutze. Hmmm... Kann das irgendwie mit "flatpak" zusammen hängen? Wollte es laut irgendeinem Tut benutzen, hab dann aber doch irgendwie einen anderen Weg genommen. In der apt-History sehe ich das Install vom LibreOffice.

Ich hab SID jetzt mal wieder mit # auskommentiert. Ich kann mich nicht mehr erinnern, wann und warum genau ich das da rein gepackt habe. Aber ich schätze, die diversen Upgrade und Dist-Upgrade in den letzten Wochen haben das jetzt eh schon vermurkst, oder?

Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 22.06.2022 13:42:09

miriki hat geschrieben: ↑ zum Beitrag ↑
22.06.2022 13:10:44
Ich hab SID jetzt mal wieder mit # auskommentiert. .... Aber ich schätze, die diversen Upgrade und Dist-Upgrade in den letzten Wochen haben das jetzt eh schon vermurkst, oder?
Das Problem ist, daß das Auskommentieren von SID dazu führt, daß du für die Pakete, die du aus SID installiert hast, keine Updates mehr bekommst, also auch keine Sicherheitsupdates. Die Pakete aus Bullseye sind von der Versionsnummer alle älter als die schon installierten SID-Pakete, so daß du auch von Bullseye für viele Pakete keine Updates bekommst. Im Grunde hast du dich damit in eine Zwickmühle manövriert.

Der beste Weg wäre, deine eigenen Dateien zu sichern und Bullseye sauber neu aufzusetzen. Alternativ kannst du auch versuchen, herauszubekommen, welche SID-Pakete bereits installiert sind, die mit apt-get purge zu löschen und später nach der Bereinigung der sources.list mit apt-get install wieder (aus Bullseye) zu installieren. Bei mehr als 1000 isntallierter Pakete macht aber der manuelle Abgleich von Paketversionsnummern keinen Spaß und ein automatischer Weg für ein Downgrade ist mir unbekannt.

Für eine Neuinstallation empfehle ich allerdings nicht, die "normalen" Installations-CDs/DVDs sondern den inoffiziellen netinstaller. Der ist nur etwa 400MB groß und lädt die Pakete grundsätzlich über das Internet. Das hat den Vorteil, daß nur das durch Internet gezogen wird, was wirklich installiert wird und du automatisch auf dem aktuellsten Stand nach der Installation bist. Den "inoffical" empfehle ich, weil der bereits Firmware für diverse Geräte (WLAN, Graphik,...) mitbringt und du sie hinterher nicht nachziehen mußt. Das Löschen von CD/DVD-Einträgen aus der sources.list ist dann auch nicht nötig, das erledigt der netinstaller automatisch.

KP97
Beiträge: 2666
Registriert: 01.02.2013 15:07:36

Re: Maus/Tastatur unter KDE "tot"

Beitrag von KP97 » 22.06.2022 13:50:49

miriki hat geschrieben: ↑ zum Beitrag ↑
22.06.2022 13:10:44
Aber ich schätze, die diversen Upgrade und Dist-Upgrade in den letzten Wochen haben das jetzt eh schon vermurkst, oder?
Ja, Du hast jetzt ein Sid mit einigen älteren Komponenten. Das ist aber eine schlechte Idee, daher würde ich jetzt auf ein sauberes Sid gehen, indem die sources.list bereinigt wird.

Ich nutze Sid schon seit vielen Jahren, so "wackelig" ist das gar nicht. Einem Anfänger würde ich aber trotzdem nicht dazu raten, ein gutes Basiswissen sollte schon vorhanden sein.
Ein Downgrade kannst Du da vergessen, das ist bei Debian auch nicht vorgesehen.
Wenn es denn ein Stable sein soll, hilft nur eine Neuinstallation. Wie es geht, weißt Du ja jetzt...

miriki
Beiträge: 44
Registriert: 19.05.2022 10:49:21
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Kiel

Re: Maus/Tastatur unter KDE "tot"

Beitrag von miriki » 22.06.2022 16:58:46

KP97 hat geschrieben: ↑ zum Beitrag ↑
22.06.2022 13:50:49
daher würde ich jetzt auf ein sauberes Sid gehen, indem die sources.list bereinigt wird.
Wie meinst Du das jetzt? SID wieder rein, aktivieren?
Ich nutze Sid schon seit vielen Jahren, so "wackelig" ist das gar nicht. Einem Anfänger würde ich aber trotzdem nicht dazu raten, ein gutes Basiswissen sollte schon vorhanden sein.
Ich bin sicher kein "Anfänger" mehr, aber ob mein Basiswissen "gut" ist, weiss ich jetzt auch nicht.

Ich tendiere schon fast dazu, SID deaktiviert zu lassen, trotz
MSfree hat geschrieben:Das Problem ist, daß das Auskommentieren von SID dazu führt, daß du für die Pakete, die du aus SID installiert hast, keine Updates mehr bekommst, also auch keine Sicherheitsupdates. Die Pakete aus Bullseye sind von der Versionsnummer alle älter als die schon installierten SID-Pakete, so daß du auch von Bullseye für viele Pakete keine Updates bekommst. Im Grunde hast du dich damit in eine Zwickmühle manövriert.
Wenn ich es richtig verstehe, mal mit einem Beispiel:
  • bislang:
    pgm "stable" in Version 1.2.3 installiert
    (sid in sources aktiviert)
    pgm "sid" upgrade auf 1.2.5 installiert
    (neues sid release)
    pgm "sid" upgrade auf 1.2.9 installiert
  • ab z.B. heute:
    (sid in sources deaktiviert)
    pgm "sid" upgrade auf 1.2.11, nicht installiert
    pgm "sid" upgrade auf 1.2.13, nicht installiert
    pgm "sid" upgrade auf "stable" in 1.2.15
    --> upgrade pgm "stable" auf 1.2.15 installiert
Dann müßte ich doch im catch-up letztendlich wieder "auf Spur" sein, oder? Das würde ja heissen, dass sich die "sid" Pakete nach und nach rauswachsen. Ok, wenn Pakete auf Jahre unstable sind, hab ich mit Zitronen gehandelt, aber sonst... ?

Gruß, Michael

Benutzeravatar
MSfree
Beiträge: 8429
Registriert: 25.09.2007 19:59:30

Re: Maus/Tastatur unter KDE "tot"

Beitrag von MSfree » 22.06.2022 19:09:56

miriki hat geschrieben: ↑ zum Beitrag ↑
22.06.2022 16:58:46
Wenn ich es richtig verstehe, mal mit einem Beispiel:
  • bislang:
    pgm "stable" in Version 1.2.3 installiert
    (sid in sources aktiviert)
    pgm "sid" upgrade auf 1.2.5 installiert
    (neues sid release)
    pgm "sid" upgrade auf 1.2.9 installiert
Das Beispiel in insofern falsch, da die Versionenummer zwischen "Stable", "Testing" und SID in der Regel weiter auseinander liegen, also eher sowas

Code: Alles auswählen

bislang:
pgm "stable" in Version 1.2.3
pgm "testing" in Version 1.3.1
pgm "sid" in Version 1.4.1
Mit deinem stable/SID-Mix wäre bei dir 1.4.1 isntalliert. Kommt nun ein Upgrade für stable zur Version 1.2.4, dann bekommst du die nicht mit, weil du bereits 1.4.1 installiert hast. War 1.2.4 ein Sicherheitsupdate, fehlt dir der Fix, weil es für SID noch nichts neueres gibt.

Du kannst jetzt natürlich komplett auf SID schwenken, wie KP97 es vorgeschlagen hat. Das würde zumindest zu einem konsistenten System führen. Alles was dazu nötig ist, wäre die sources.list komplett auf SID umzustellen und dann update/dist-upgrade auszuführen.

SID ist immer dann problematisch, wenn mal wieder was im Repository kaputt ist, also Pakete eingepflegt wurden, die sich mit dem Rest von SID nicht vertragen. In Stable passiert sowas äusserst selten (nobody is perfect), in Testing passiert das meiner Erfahrung nach 2-3 mal im Jahr, in SID muß man mit sowas eigentlich immer rechnen. Zwar sind die Entwickler nicht darauf aus, möglichst viel Durcheinander zu produzieren, es herrscht in SID aber ein laxerer Umgang mit Konflikten. Sowas wird einfach hingenommen und in der Regel auch ziemlich schnell repariert.

Zurück auf ein pures Stable kommst du jedenfalls durch anpassen der sources.list nicht mehr. Da würde eine Neuinstallation der einfachere Weg sein.

Antworten