Kernel abhängig touchpad Einstellungen (gelöst)

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
Benutzeravatar
whisper
Beiträge: 2793
Registriert: 23.09.2002 14:32:21
Lizenz eigener Beiträge: GNU Free Documentation License
Kontaktdaten:

Kernel abhängig touchpad Einstellungen (gelöst)

Beitrag von whisper » 29.07.2022 12:34:35

Leute,
ich habe mit eigenen Kernel versuche angestellt.
Eigentlich geht es mir um S3 Suspend to RAM.
Das soll hier nicht das Thema sein.

Mir ist folgendes aufgefallen, seht selbst.
Die Folge, kein Bildlauf rechts im 5.18
die CMD Line sieht für beide Kernel gleich aus, dennoch dieses unterschiedliche verhalten.

Code: Alles auswählen

BOOT_IMAGE=/vmlinuz-5.10.0-16-amd64 root=/dev/mapper/Debian-root ro quiet psmouse.proto=bare mem_sleep_default=disk acpi_sleep=s3_bios,s3_mode
 
3728
3729

Lasse ich den parameter

Code: Alles auswählen

psmouse.proto=bare
weg, dann habe ich überhaupt keine Funktion des Touchpad beim 5.18

Es ist ein Tuxedo Aura Gen2

Code: Alles auswählen

dmesg |grep -i touchp
[    3.176464] input: ELAN0415:00 04F3:316F Touchpad as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0415:00/0018:04F3:316F.0001/input/input11
[    6.147047] input: ELAN0415:00 04F3:316F Touchpad as /devices/platform/AMDI0010:00/i2c-0/i2c-ELAN0415:00/0018:04F3:316F.0001/input/input21
b
Der neue Kernel wurde mit oldconfig gebaut...
Jamand eine Idee oder ähnliche Erfahrungen?
Zuletzt geändert von whisper am 01.08.2022 17:19:53, insgesamt 1-mal geändert.

Benutzeravatar
Tintom
Moderator
Beiträge: 2745
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Kernel abhängig touchpad Einstellungen

Beitrag von Tintom » 29.07.2022 19:52:33

Die Kernel-Option, mit der du bootest, bewirkt, dass das Touchpad mit dem niedrigsten Protokollstandard angesprochen wird. Moderne Features des Touchpads wie Multitouch o.ä. wären damit wohl eher nicht unterstützt. Anscheinend läuft bei der Initialisierung des Moduls etwas schief. Dem Output nach hast du ein Elantech-Touchpad und in dem Modul gab es laut kernel-git zwischen Kernel 5.10 und 5.18 vier Änderungen. Ich würde den Fehler eingrenzen, in dem ich mir die jeweiligen Kernelversionen von http://snapshot.debian.org installiere, jeweils schaue, ob es funktioniert und falls ja anschließend einen Bugreport gegen den aktuellen Kernel schreibe.

Die Änderungen:
Kernel 5.11 Commit e4c906271
Kernel 5.13 Commit 9d383e964
Kernel 5.16 Commit be896bd3b und Commit 1d72d9f96

edit: zur Kontrolle kannst du auch noch den debian-kernel 5.18 nehmen

Benutzeravatar
whisper
Beiträge: 2793
Registriert: 23.09.2002 14:32:21
Lizenz eigener Beiträge: GNU Free Documentation License
Kontaktdaten:

Re: Kernel abhängig touchpad Einstellungen

Beitrag von whisper » 30.07.2022 08:17:08

Habe mal einen Debian Kernel linux-image-5.19.0-rc6-amd64_5.19_rc6-1_exp1_amd64.deb
probiert, ohne extra cmdline optionen, also auch kein psmouse.proto=bare.
Touchpad wird erkannt, funktioniert aber exakt so wie oben beschrieben.
Ja da muss ich wohl systematisch vorgehen.
Danke für deine Hinweise auf die Bugs

Benutzeravatar
whisper
Beiträge: 2793
Registriert: 23.09.2002 14:32:21
Lizenz eigener Beiträge: GNU Free Documentation License
Kontaktdaten:

Re: Kernel abhängig touchpad Einstellungen

Beitrag von whisper » 31.07.2022 14:47:57

Mit dem 5.18 aus bookworm scheint alles zu laufen 8-)

Benutzeravatar
whisper
Beiträge: 2793
Registriert: 23.09.2002 14:32:21
Lizenz eigener Beiträge: GNU Free Documentation License
Kontaktdaten:

Re: Kernel abhängig touchpad Einstellungen

Beitrag von whisper » 01.08.2022 17:19:30

um das hier abzuschliessen.
Ich bin auf bookworm umgestiegen.
Gnome ist wieder ein wenig anders... aber nicht schlecht
Suspend to RAM arbeitet jetzt perfekt.

Antworten