[erledigt] Kamera wird falsch gemounted

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
Benutzeravatar
GregorS
Beiträge: 1497
Registriert: 05.06.2008 09:36:37
Wohnort: Freiburg

[erledigt] Kamera wird falsch gemounted

Beitrag von GregorS » 15.09.2022 20:48:50

Hallo zusammen!

Ich habe eine ältere Digiknipse, die ich als „Massenspeicher“ mounten kann. Wenn ich sie unter XFCE4 mit Linksklick mounte, wird sie jedoch nicht dort gemounted, wo sie lt. fstab gemounted werden sollte, sondern anderswo. Was muss ich tun, damit das am gewünschten Platz und v.A. mit den passenden Rechten eingehängt wird? So meldet mir gThumb nämlich, dass es in der Kamera keine Bilder gebe.
In /etc/fstab:

Code: Alles auswählen

...
UUID="2052-3246" /media/pentax_WS80 vfat noauto,user 0 0
...
ls -l /media:

Code: Alles auswählen

...
drwxr-x--- 3 root root      4096 15. Sep 20:30 gszaktilla
...
Ausgabe von mount:

Code: Alles auswählen

/dev/sde1 on /media/gszaktilla/2052-3246 type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)


TIA

Gregor
Zuletzt geändert von GregorS am 16.09.2022 19:40:53, insgesamt 1-mal geändert.
Ohne Computer hätte ich andere Probleme. Außerdem versichere ich, dass ich mindestens so alt bin wie 'oldstable'.

TuxPeter
Beiträge: 1774
Registriert: 19.11.2008 20:39:02
Lizenz eigener Beiträge: MIT Lizenz

Re: Kamera wird falsch gemounted

Beitrag von TuxPeter » 16.09.2022 09:15:51

Bei mir geht das mit den Kameras und anderen Massenspeicher-Geräten ganz ohne Eintrag in die fstab.
Aber das Verzeichnis für den automount /media/username/ steht nicht auf root:root sondern auf username:username

Benutzeravatar
Tintom
Moderator
Beiträge: 2797
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Kamera wird falsch gemounted

Beitrag von Tintom » 16.09.2022 10:05:34

Das Einbinden von Datenträgern wird bei grafischen Oberflächen von Debianudisks2 beeinflusst. Um die Partition davon auszunehmen könntest du z.B. mit einer udev-Regel arbeiten:
SUBSYSTEM=="block", ENV{ID_FS_UUID}=="2052-3246", ENV{UDISKS_IGNORE}="1"

Benutzeravatar
GregorS
Beiträge: 1497
Registriert: 05.06.2008 09:36:37
Wohnort: Freiburg

Re: Kamera wird falsch gemounted

Beitrag von GregorS » 16.09.2022 19:40:40

Nochmal hallo!

Danke für Eure Antworten. Nachdem ich den Eintrag in /etc/fstab gelöscht habe, funktioniert's.

Gruß

Gregor
Ohne Computer hätte ich andere Probleme. Außerdem versichere ich, dass ich mindestens so alt bin wie 'oldstable'.

Antworten