Neuer Kernel Grub defekt efi

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
rhHeini
Beiträge: 1513
Registriert: 20.04.2006 20:44:10

Re: Neuer Kernel Grub defekt efi

Beitrag von rhHeini » 10.09.2022 11:11:12

oln hat geschrieben: ↑ zum Beitrag ↑
10.09.2022 09:32:23
Neuinstallation vom Grub brachte keine Veränderung.
Keine Ahnung wo ich jetzt noch suchen soll.
Dann siehe mal meinen Post ein paar Einträge zurück ....

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 12.09.2022 08:17:53

rhHeini hat geschrieben: ↑ zum Beitrag ↑
10.09.2022 11:11:12
Dann siehe mal meinen Post ein paar Einträge zurück ....
Moin,
sorry deinen Beitrag hab ich komplett überlesen.
rhHeini hat geschrieben: ↑ zum Beitrag ↑
09.09.2022 14:16:42
Dann würd ich halt mal bei der /etc/default/grub anfangen und kontrollieren was da drin steht?
Eigentlich identisch bis auf den neuen Eintrag des hinzugekommenen Kernels.
rhHeini hat geschrieben: ↑ zum Beitrag ↑
09.09.2022 14:16:42
Was steht in /etc/modules? Irgendetwas geblacklistet? Was steht in den confs in /etc/initramfs-tools?
In /etc/modules steht nichts drin. Die Files unter /etc/initramfs-tools sind unverändert.

Nach nun einigem rum probieren habe ich den Grub dazu bekommen einen Fehler auszugeben. Leider konnte ich das nur fotografieren.
Bild

Mhh... was soll mir das sagen? Fsck ist unauffällig.
Gruß Ole
AbuseIPDB

nudgegoonies
Beiträge: 908
Registriert: 16.02.2009 09:35:10

Re: Neuer Kernel Grub defekt efi

Beitrag von nudgegoonies » 12.09.2022 10:53:42

Diese Fehlermeldung kling eher, als ob das BIOS nicht an der Stelle lesen kann, wo der Kernel und/oder initrd auf der Platte liegt. Partition wo Kernel und initrd liegen zu groß?
IDE wie hier kann es ja bei einem EFI System nicht sein: viewtopic.php?t=172176
Soft: Bullseye AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 12.09.2022 12:46:57

nudgegoonies hat geschrieben: ↑ zum Beitrag ↑
12.09.2022 10:53:42
Diese Fehlermeldung kling eher, als ob das BIOS nicht an der Stelle lesen kann, wo der Kernel und/oder initrd auf der Platte liegt. Partition wo Kernel und initrd liegen zu groß?
Es gibt keine extra Boot-Partition. Die Partition wo boot drauf ist, ist ~4TB groß. Aber es wird ja gpt benutzt. Also sollte das kein Problem darstellen. Oder doch? Wie kann ich das prüfen?
Gruß Ole
AbuseIPDB

nudgegoonies
Beiträge: 908
Registriert: 16.02.2009 09:35:10

Re: Neuer Kernel Grub defekt efi

Beitrag von nudgegoonies » 12.09.2022 14:04:03

oln hat geschrieben: ↑ zum Beitrag ↑
12.09.2022 12:46:57
Es gibt keine extra Boot-Partition. Die Partition wo boot drauf ist, ist ~4TB groß. Aber es wird ja gpt benutzt. Also sollte das kein Problem darstellen. Oder doch? Wie kann ich das prüfen?
Im Prinzip sollten die maximalen GPT Partitionsgrößen vom BIOS und vom GRUB geschluckt werden. Aber wer weiß, welche Bugs sich in BIOSen und GRUB so verbergen.

Gerade der GRUB muss das Dateisystem der Partition, auf der sich das /boot Verzeichnis befindet, lesen können um auf Kernel und initrd zugreifen zu können. Auf unseren Servern ist die /boot Partition immer die zweite auf der Platte nach der EFI Partition und auch nur mit EXT formatiert und nicht XFS, BTRFS oder gar ZFS.
Soft: Bullseye AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

Benutzeravatar
schorsch_76
Beiträge: 2238
Registriert: 06.11.2007 16:00:42
Lizenz eigener Beiträge: MIT Lizenz

Re: Neuer Kernel Grub defekt efi

Beitrag von schorsch_76 » 12.09.2022 17:20:02

Ist eine andere Platte oder ein USB Stick angeschlossen? Entferne den mal ....

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 13.09.2022 07:16:08

schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
12.09.2022 17:20:02
Ist eine andere Platte oder ein USB Stick angeschlossen?
Tatsächlich ist dort ein bootfähiger USB-Stick angeschlossen. Das ist mein Rettungsanker denn ich sitze rund 600km von dem Server entfernt.
Hast du ähnliche Erfahrungen mit angestecktem Stick oder Platte erlebt?
Gruß Ole
AbuseIPDB

Benutzeravatar
Tintom
Moderator
Beiträge: 2785
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Neuer Kernel Grub defekt efi

Beitrag von Tintom » 13.09.2022 09:19:25

oln hat geschrieben: ↑ zum Beitrag ↑
09.09.2022 11:40:00
cosinus hat geschrieben: ↑ zum Beitrag ↑
09.09.2022 11:20:36
Ist denn auch grub-efi installiert?
Bitte schön:

Code: Alles auswählen

# dpkg -l | grep grub
ii  grub-common                          2.02+dfsg1-20+deb10u4                   amd64        GRand Unified Bootloader (common files)
ii  grub-efi-amd64                       2.02+dfsg1-20+deb10u4                   amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 version)
ii  grub-efi-amd64-bin                   2.02+dfsg1-20+deb10u4                   amd64        GRand Unified Bootloader, version 2 (EFI-AMD64 modules)
ii  grub-efi-amd64-signed                1+2.02+dfsg1+20+deb10u4                 amd64        GRand Unified Bootloader, version 2 (amd64 UEFI signed by Debian)
ii  grub2-common
Beim grub gab's letzten Monat ein Sicherheitsupdate, weshalb in buster und bullseye nun neue Versionen gelandet sind: https://security-tracker.debian.org/tra ... 2022-28736

Im Changelog gibt's neben dem behobenen Fix einen interessanten Eintrag:

Code: Alles auswählen

   * Re-enable os-prober by default, don't make that change in a stable
     update.
Vielleicht würde das bei dir schon helfen, wenn du grub aus den regulären Repos für buster installierst.

Benutzeravatar
schorsch_76
Beiträge: 2238
Registriert: 06.11.2007 16:00:42
Lizenz eigener Beiträge: MIT Lizenz

Re: Neuer Kernel Grub defekt efi

Beitrag von schorsch_76 » 13.09.2022 10:20:37

oln hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 07:16:08
schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
12.09.2022 17:20:02
Ist eine andere Platte oder ein USB Stick angeschlossen?
Tatsächlich ist dort ein bootfähiger USB-Stick angeschlossen. Das ist mein Rettungsanker denn ich sitze rund 600km von dem Server entfernt.
Hast du ähnliche Erfahrungen mit angestecktem Stick oder Platte erlebt?
Ja, es kann sein das die Erkennung der Reihenfolge der Platten nicht passt. So sieht für mich die Meldung aus. Normalerweise wird über die UUID die Platte gesucht. Fals die nicht gefunden wird wird der Fallback verwendet mit der fixen Kennung wie hd0.

Zeig doch mal die grub.cfg und die Ausgabe von "blkid" (als root).

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 13.09.2022 10:41:34

schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 10:20:37
Ja, es kann sein das die Erkennung der Reihenfolge der Platten nicht passt. So sieht für mich die Meldung aus. Normalerweise wird über die UUID die Platte gesucht. Fals die nicht gefunden wird wird der Fallback verwendet mit der fixen Kennung wie hd0.

Zeig doch mal die grub.cfg und die Ausgabe von "blkid" (als root).
Ok das kann ich mal probieren wenn ich wieder vor Ort bin.
Hier die gewünschten ausgaben:

Code: Alles auswählen

[root@sv1 ~]# blkid
/dev/sda1: UUID="6258-DA06" TYPE="vfat" PARTUUID="f930288c-4578-45e0-b571-890c70f656ff"
/dev/sda2: UUID="6884d85a-5689-4fb9-a699-9b708caf27e2" TYPE="ext4" PARTUUID="54e0e3c6-d654-48a4-b4a8-07924943d540"
/dev/sda3: UUID="469a761f-a324-4364-ad82-01dd243d3328" TYPE="swap" PARTUUID="a618dc8b-a8a1-41db-84dd-f44daead02ac"
/dev/sdb1: UUID="55f564ef-a79b-4fc4-9711-4d4f9cd025e0" TYPE="ext4" PARTLABEL="primary" PARTUUID="6998c6ad-36f7-4f2c-9fd5-790fdcdc0ed7"
/dev/sdc1: LABEL="DEBIAN 10_7" UUID="36DA-332E" TYPE="vfat" PARTUUID="13ef5afc-01"

Code: Alles auswählen

[root@sv1 grub]# cat grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}
function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  6884d85a-5689-4fb9-a699-9b708caf27e2
else
  search --no-floppy --fs-uuid --set=root 6884d85a-5689-4fb9-a699-9b708caf27e2
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=C
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ] ; then
  set timeout=30
else
  if [ x$feature_timeout_style = xy ] ; then
    set timeout_style=menu
    set timeout=5
  # Fallback normal timeout code in case the timeout_style feature is
  # unavailable.
  else
    set timeout=5
  fi
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=cyan/blue
set menu_color_highlight=white/blue
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
function gfxmode {
        set gfxpayload="${1}"
}
set linux_gfx_mode=
export linux_gfx_mode
menuentry 'Debian GNU/Linux' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-6884d85a-5689-4fb9-a699-9b708caf27e2' {
        load_video
        insmod gzio
        if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  6884d85a-5689-4fb9-a699-9b708caf27e2
        else
          search --no-floppy --fs-uuid --set=root 6884d85a-5689-4fb9-a699-9b708caf27e2
        fi
        echo    'Linux 4.19.0-16-amd64 wird geladen …'
        linux   /boot/vmlinuz-4.19.0-16-amd64 root=UUID=6884d85a-5689-4fb9-a699-9b708caf27e2 ro  quiet
        echo    'Initiale Ramdisk wird geladen …'
        initrd  /boot/initrd.img-4.19.0-16-amd64
}
submenu 'Erweiterte Optionen für Debian GNU/Linux' $menuentry_id_option 'gnulinux-advanced-6884d85a-5689-4fb9-a699-9b708caf27e2' {
        menuentry 'Debian GNU/Linux, mit Linux 4.19.0-16-amd64' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19.0-16-amd64-advanced-6884d85a-5689-4fb9-a699-9b708caf27e2' {
                load_video
                insmod gzio
                if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
                insmod part_gpt
                insmod ext2
                set root='hd0,gpt2'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  6884d85a-5689-4fb9-a699-9b708caf27e2
                else
                  search --no-floppy --fs-uuid --set=root 6884d85a-5689-4fb9-a699-9b708caf27e2
                fi
                echo    'Linux 4.19.0-16-amd64 wird geladen …'
                linux   /boot/vmlinuz-4.19.0-16-amd64 root=UUID=6884d85a-5689-4fb9-a699-9b708caf27e2 ro  quiet
                echo    'Initiale Ramdisk wird geladen …'
                initrd  /boot/initrd.img-4.19.0-16-amd64
        }
        menuentry 'Debian GNU/Linux, with Linux 4.19.0-16-amd64 (recovery mode)' --class debian --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19.0-16-amd64-recovery-6884d85a-5689-4fb9-a699-9b708caf27e2' {
                load_video
                insmod gzio
                if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
                insmod part_gpt
                insmod ext2
                set root='hd0,gpt2'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  6884d85a-5689-4fb9-a699-9b708caf27e2
                else
                  search --no-floppy --fs-uuid --set=root 6884d85a-5689-4fb9-a699-9b708caf27e2
                fi
                echo    'Linux 4.19.0-16-amd64 wird geladen …'
                linux   /boot/vmlinuz-4.19.0-16-amd64 root=UUID=6884d85a-5689-4fb9-a699-9b708caf27e2 ro single
                echo    'Initiale Ramdisk wird geladen …'
                initrd  /boot/initrd.img-4.19.0-16-amd64
        }
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###

### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'System setup' $menuentry_id_option 'uefi-firmware' {
        fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
Gruß Ole
AbuseIPDB

Benutzeravatar
schorsch_76
Beiträge: 2238
Registriert: 06.11.2007 16:00:42
Lizenz eigener Beiträge: MIT Lizenz

Re: Neuer Kernel Grub defekt efi

Beitrag von schorsch_76 » 13.09.2022 13:39:26

Hmmm ... deine UUID 6884d85a-5689-4fb9-a699-9b708caf27e2 würde soweit passen. Das wäre (vermutlich) deine root partition sda2.

Code: Alles auswählen

if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  6884d85a-5689-4fb9-a699-9b708caf27e2
else
  search --no-floppy --fs-uuid --set=root 6884d85a-5689-4fb9-a699-9b708caf27e2
fi
Sehe auch keinen Fehler ... aber irgendwo hier muss der Fehler liegen. UEFI lädt grub. grub lädt die grub.cfg. Dann wird root gesucht und der Kernel + initrd geladen und los gehts.

Benutzeravatar
cosinus
Beiträge: 608
Registriert: 08.02.2016 13:44:11
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Bremen

Re: Neuer Kernel Grub defekt efi

Beitrag von cosinus » 13.09.2022 13:42:01

Wäre hier ein Bug in der Firmware möglich? Ist das UEFI-BIOS aktuell?
Arne

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 13.09.2022 14:40:02

schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 13:39:26
UEFI lädt grub. grub lädt die grub.cfg. Dann wird root gesucht und der Kernel + initrd geladen und los gehts.
Und dort bekomme ich ja dann den Fehler, das hd0 nicht gelesen werden kann.
cosinus hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 13:42:01
Wäre hier ein Bug in der Firmware möglich? Ist das UEFI-BIOS aktuell?
Das Bios ist nicht ganz aktuell.
Allerdings habe ich hier noch eine identische Maschine mit dem selben Bios wo der Fehler nicht auftritt. Das ist ja das Merkwürdige.
Gruß Ole
AbuseIPDB

AxelMD
Beiträge: 1128
Registriert: 15.03.2009 08:02:11

Re: Neuer Kernel Grub defekt efi

Beitrag von AxelMD » 13.09.2022 14:58:11

Stimmt die Partionierung. Formatierung, UUID's usw.?

Wie wurde das System erstmalig aufgesetzt?
Evtl.mit EFISTUB vermischt?
Allerdings habe ich hier noch eine identische Maschine mit dem selben Bios wo der Fehler nicht auftritt. Das ist ja das Merkwürdige.
Dann hast Du an dem Problemsystem evtl. etwas verbastelt.

Setze das Bios doch mal auf Default zurückt.

Benutzeravatar
schorsch_76
Beiträge: 2238
Registriert: 06.11.2007 16:00:42
Lizenz eigener Beiträge: MIT Lizenz

Re: Neuer Kernel Grub defekt efi

Beitrag von schorsch_76 » 13.09.2022 18:06:50

oln hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 14:40:02
schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 13:39:26
UEFI lädt grub. grub lädt die grub.cfg. Dann wird root gesucht und der Kernel + initrd geladen und los gehts.
Und dort bekomme ich ja dann den Fehler, das hd0 nicht gelesen werden kann.
cosinus hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 13:42:01
Wäre hier ein Bug in der Firmware möglich? Ist das UEFI-BIOS aktuell?
Das Bios ist nicht ganz aktuell.
Allerdings habe ich hier noch eine identische Maschine mit dem selben Bios wo der Fehler nicht auftritt. Das ist ja das Merkwürdige.

Code: Alles auswählen

                insmod part_gpt
                insmod ext2
Stupid question: Welches Filesystem nutzt du? (ext2 deckt hier auch ext4 ab)

Benutzeravatar
cosinus
Beiträge: 608
Registriert: 08.02.2016 13:44:11
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Bremen

Re: Neuer Kernel Grub defekt efi

Beitrag von cosinus » 13.09.2022 19:23:55

Andere blöde Idee: SSD/Festplatte wirklich in Ordnung? Hab hier auf einer Samsung 870 EVO auch sehr merkwürdige Fehler entdeckt, die dazu führten, dass einige Dateien nicht mehr gelesen werden konnten. Das Samsungtool unter Windows zeigte dann an einem anderen Rechner etliche defekte Blöcke, zufällig über die SSD verstreut. :evil:
Arne

Benutzeravatar
schorsch_76
Beiträge: 2238
Registriert: 06.11.2007 16:00:42
Lizenz eigener Beiträge: MIT Lizenz

Re: Neuer Kernel Grub defekt efi

Beitrag von schorsch_76 » 13.09.2022 20:29:01

Nochmal ein Gedanke:

Code: Alles auswählen

/dev/sda2: UUID="6884d85a-5689-4fb9-a699-9b708caf27e2" TYPE="ext4" PARTUUID="54e0e3c6-d654-48a4-b4a8-07924943d540"
/dev/sdb1: UUID="55f564ef-a79b-4fc4-9711-4d4f9cd025e0" TYPE="ext4" PARTLABEL="primary" PARTUUID="6998c6ad-36f7-4f2c-9fd5-790fdcdc0ed7"
sda2 + sdb1 sind ext4. sda2 hat die UUID die auf der cmdline übergeben wird. Stimmt das aber auch? Laut blkid sind 3 block Devices vorhanden. sda, sdb und sdc (Stick).

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 14.09.2022 07:29:59

Moin,
ganz schön was los in dem Thread.
schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 18:06:50

Code: Alles auswählen

                insmod part_gpt
                insmod ext2
Wann sollte ich das machen? Das System booted ja mit dem neuen Kernel nicht. Und die besagte Fehlermeldung ergibt nach einigen Recherchen nichts gutes.
schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 18:06:50
Stupid question: Welches Filesystem nutzt du? (ext2 deckt hier auch ext4 ab)
Dumme Fragen gibt es nicht. Ich benutze Ext4.
AxelMD hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 14:58:11
Stimmt die Partionierung. Formatierung, UUID's usw.?
Ja, sonst würde das System nicht mit dem alten Kernel starten.
AxelMD hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 14:58:11
Wie wurde das System erstmalig aufgesetzt?
Netinstall-Iso auf Buster.
AxelMD hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 14:58:11
Dann hast Du an dem Problemsystem evtl. etwas verbastelt.
Setze das Bios doch mal auf Default zurückt.
Nein habe ich nicht. Weis auch nicht wie das zu meinem Problem führen sollte.
schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 20:29:01
sda2 + sdb1 sind ext4. sda2 hat die UUID die auf der cmdline übergeben wird. Stimmt das aber auch? Laut blkid sind 3 block Devices vorhanden. sda, sdb und sdc (Stick).
Ja das ist korrekt. Sda1 ist die Root-Partition mir allem drauf. Dies ist ein Raid5 über einen Raidcontroller.
Sdb1 ist eine Backupplatte am Sata-Port des Mainbords.
Hier mal die Ausgabe von fdisk:

Code: Alles auswählen

# fdisk -l
Disk /dev/sda: 3,7 TiB, 3999688294400 bytes, 7811891200 sectors
Disk model: MR9363-4i
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 262144 bytes / 262144 bytes
Disklabel type: gpt
Disk identifier: 82A30451-B244-413A-8417-82B85ABCA037

Device          Start        End    Sectors  Size Type
/dev/sda1        2048    1050623    1048576  512M EFI System
/dev/sda2     1050624 7809890303 7808839680  3,7T Linux filesystem
/dev/sda3  7809890304 7811889151    1998848  976M Linux swap


Disk /dev/sdb: 5,5 TiB, 6001175126016 bytes, 11721045168 sectors
Disk model: WDC WD60EFRX-68L
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: AFD06961-ED45-4E59-899D-05CC7C1262ED

Device     Start         End     Sectors  Size Type
/dev/sdb1   2048 11721043967 11721041920  5,5T Linux filesystem


Disk /dev/sdc: 3,8 GiB, 4009754624 bytes, 7831552 sectors
Disk model: USB Flash Disk
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x13ef5afc

Device     Boot Start     End Sectors  Size Id Type
/dev/sdc1  *     2048 7831551 7829504  3,8G  c W95 FAT32 (LBA)
cosinus hat geschrieben: ↑ zum Beitrag ↑
13.09.2022 19:23:55
Andere blöde Idee: SSD/Festplatte wirklich in Ordnung?
Da kann ich mich aus der Ferne nur auf fsck verlassen. Wie gesagt, zwischen mir und den Server liegen ~600km(BER-MUC).
Gruß Ole
AbuseIPDB

Benutzeravatar
schorsch_76
Beiträge: 2238
Registriert: 06.11.2007 16:00:42
Lizenz eigener Beiträge: MIT Lizenz

Re: Neuer Kernel Grub defekt efi

Beitrag von schorsch_76 » 14.09.2022 07:41:38

Kopier doch mal auf die Backup Platte deinen boot Ordner ..... und probier es nochmal .....

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 14.09.2022 07:50:11

schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
14.09.2022 07:41:38
Kopier doch mal auf die Backup Platte deinen boot Ordner ..... und probier es nochmal .....
Gute Idee. :THX: Auf die war ich schon selbst gekommen. Leider ohne Erfolg. :oops:
Gruß Ole
AbuseIPDB

Benutzeravatar
schorsch_76
Beiträge: 2238
Registriert: 06.11.2007 16:00:42
Lizenz eigener Beiträge: MIT Lizenz

Re: Neuer Kernel Grub defekt efi

Beitrag von schorsch_76 » 15.09.2022 06:11:33

Welcher RAID Kontroller ist das denn?

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 15.09.2022 07:53:24

schorsch_76 hat geschrieben: ↑ zum Beitrag ↑
15.09.2022 06:11:33
Welcher RAID Kontroller ist das denn?
Moin,
die genaue Bezeichnung ist Broadcom (LSI/Avago) MegaRAID 9361-4i SAS3 4x intern
Gruß Ole
AbuseIPDB

Benutzeravatar
cosinus
Beiträge: 608
Registriert: 08.02.2016 13:44:11
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Bremen

Re: Neuer Kernel Grub defekt efi

Beitrag von cosinus » 21.09.2022 14:41:55

Biste schon weiter gekommen?
Arne

Benutzeravatar
oln
Beiträge: 250
Registriert: 05.01.2021 09:41:24

Re: Neuer Kernel Grub defekt efi

Beitrag von oln » 22.09.2022 07:46:42

Moin,
Leider nicht. Werde wohl oder übel die Kiste neu aufsetzen müssen. Muss nur ein Zeitfenster finden.
Gruß Ole
AbuseIPDB

Benutzeravatar
cosinus
Beiträge: 608
Registriert: 08.02.2016 13:44:11
Lizenz eigener Beiträge: GNU General Public License
Wohnort: Bremen

Re: Neuer Kernel Grub defekt efi

Beitrag von cosinus » 24.09.2022 03:28:22

Meinst du eine Neuinstallation behebt das Problem?
Arne

Antworten