[erledigt] echo -e "\a" bleibt stumm

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
Benutzeravatar
GregorS
Beiträge: 2599
Registriert: 05.06.2008 09:36:37
Wohnort: Freiburg
Kontaktdaten:

[erledigt] echo -e "\a" bleibt stumm

Beitrag von GregorS » 01.03.2024 08:50:10

Guten Morgen allerseits!

Ich möchte, dass mein Notebook täglich zu einer bestimmten Uhrzeit einen Ton von sich gibt, um mich an etwas zu erinnern.

Mit cron und ffplay kann ich zwar eine mp3-Datei abspielen, aber das kommt nur sehr leise. Der Piep, der gleich nach dem Einschalten ertönt, ist deutlich lauter und auch zu hören, wenn das Notebook gerade im Rucksack steckt.

Wenn ich in der Konsole

Code: Alles auswählen

echo -e "\a"
eingebe, bleibt das Notebook allerdings stumm.

Was ist der Grund hierfür und wie kann ich dafür sorgen, dass das Notebook piept?

TIA

Gregor

PS: Das Notebook ist ein HP Elite X2, DE ist XFCE.
Zuletzt geändert von GregorS am 01.03.2024 21:24:51, insgesamt 3-mal geändert.
Wenn man keine Probleme hat, kann man sich welche machen. ("Großes Lötauge", Medizinmann der M3-Hopi [und sog. Maker])

inne
Beiträge: 3281
Registriert: 29.06.2013 17:32:10
Lizenz eigener Beiträge: GNU General Public License
Kontaktdaten:

Re: echo -e "\a" bleibt stumm

Beitrag von inne » 01.03.2024 09:11:48

Guten Morgen,

bestimmt steht der Regler auf Mute oder Level 0... schau mal in alsamixer nach (mit F6 ggf. die richtige Soundkarte auswählen).

Code: Alles auswählen

alsamixer
PS: So kann ich es zumindest nachstellen.

Benutzeravatar
GregorS
Beiträge: 2599
Registriert: 05.06.2008 09:36:37
Wohnort: Freiburg
Kontaktdaten:

Re: echo -e "\a" bleibt stumm

Beitrag von GregorS » 01.03.2024 09:49:22

inne hat geschrieben: ↑ zum Beitrag ↑
01.03.2024 09:11:48
bestimmt steht der Regler auf Mute oder Level 0... schau mal in alsamixer nach (mit F6 ggf. die richtige Soundkarte auswählen).
Das scheint's nicht zu sein. Im Mixer ist nichts stumm gestellt oder steht auf 0.

Hat jemand eine andere Idee?

Gruß

Gregor

PS: Dass es ansonsten funktioniert, habe ich gerade noch einmal probiert. Wenn ich im Display-Manager die Rückschritttaste drücke, anstatt einen Namen einzugeben, piept's.
Wenn man keine Probleme hat, kann man sich welche machen. ("Großes Lötauge", Medizinmann der M3-Hopi [und sog. Maker])

Benutzeravatar
Meillo
Moderator
Beiträge: 8813
Registriert: 21.06.2005 14:55:06
Wohnort: Balmora
Kontaktdaten:

Re: echo -e "\a" bleibt stumm

Beitrag von Meillo » 01.03.2024 09:56:48

In Terminals kann man normalerweise einstellen, was im Falle eines Piepsens gemacht werden soll. Ich lasse beispielsweise lieber den Bildschirm flashen, statt dass es piepst.

Soweit ich sehe, musst du in deinem XFCE-Terminal die Option ``Audible Bell'' anhaken, dann koennte es gehen.

Bild
Use ed once in a while!

ernohl
Beiträge: 1181
Registriert: 04.07.2002 08:11:56
Wohnort: HL

Re: echo -e "\a" bleibt stumm

Beitrag von ernohl » 01.03.2024 13:06:10

Evtl. hilft:

Code: Alles auswählen

beep - Erweiterter Piepser (PC-Lautsprecher)

Benutzeravatar
GregorS
Beiträge: 2599
Registriert: 05.06.2008 09:36:37
Wohnort: Freiburg
Kontaktdaten:

Re: echo -e "\a" bleibt stumm

Beitrag von GregorS » 01.03.2024 14:19:21

ernohl hat geschrieben: ↑ zum Beitrag ↑
01.03.2024 13:06:10
Evtl. hilft:

Code: Alles auswählen

beep - Erweiterter Piepser (PC-Lautsprecher)
Super, das funktioniert! Danke!

Gruß

Gregor
Wenn man keine Probleme hat, kann man sich welche machen. ("Großes Lötauge", Medizinmann der M3-Hopi [und sog. Maker])

Antworten