VLC spielt keine Opus-kodierten 5.1-Audiostreams mehr

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
kreuzschnabel
Beiträge: 233
Registriert: 24.09.2020 14:51:14

VLC spielt keine Opus-kodierten 5.1-Audiostreams mehr

Beitrag von kreuzschnabel » 13.06.2024 21:01:16

Eben gerade fällt mir auf, dass VLC auf meinen Debianen derzeit bei allen Videodateien mit folgenden Merkmalen:
  • Container: mkv
  • Audiocodec: Opus
  • Audiokanäle: 5.1
kein Audio mehr abspielt. Audio ist stumm, als sei keine Audiospur vorhanden. Unter „Codec-Informationen“ wird der Audiostream zwar aufgeführt, aber ohne Channel-Layout; das wird offenbar nicht erkannt.

Das ging vor zwei Tagen aber noch problemlos!

AC3-Streams mit 5.1-Layout werden einwandfrei abgespielt, nur Opus scheint nicht mehr zu gehen.

Software ist Debian stable aktuell, auf einem Rechner aus dem Multimedia-Repo, auf dem anderen aus den Standardrepos, kein Unterschied. Auch Debian testing verhält sich ebenso. Ein virtualisiertes Ubuntu dagegen spielt das Audio tadellos ab.

Ist das bekannt, wo könnte man mal gucken?

--ks
Hier so: Debian Stable – KDE Plasma – Lenovo Thinkpad T470p – i7-7700HQ – 32GB RAM

kreuzschnabel
Beiträge: 233
Registriert: 24.09.2020 14:51:14

Re: VLC spielt keine Opus-kodierten 5.1-Audiostreams mehr

Beitrag von kreuzschnabel » 13.06.2024 21:23:05

Erkenntnisse:

Debian hat VLC aktuell in der Version 3.0.21. Mit der geht’s nicht.
Ubuntu hat noch die 3.0.20, mit der läuft’s.

Dann ist das wohl ein Fall für ein VLC-Forum.

--ks
Hier so: Debian Stable – KDE Plasma – Lenovo Thinkpad T470p – i7-7700HQ – 32GB RAM

Antworten