Socketproblem bei X-server

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Benutzeravatar
shyryuken
Beiträge: 34
Registriert: 29.08.2004 12:03:10
Wohnort: Homburg im Saarland

Socketproblem bei X-server

Beitrag von shyryuken » 29.09.2004 00:06:24

Hallo,

hab mein System neuinstalliert (Sarge) und hab mir nun den Kernel 2.6.8.1 compiliert und geladen. Leider scheint jetzt X nicht mehr zu starten. Ich bekomme folgende Fehlermeldung

Code: Alles auswählen

_XSERVTransSocketOpen: socket() failed for local
_XSERVTransSocketOpenCOTSServer: Unable to open socket for local
_XSERVTransOpen: transport open failed for local/chris3:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for local

Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't already run
ning
Vor der Neuinstallation des Systems hatte ich den besagten Kernel bereits selbst kompiliert und installiert gehabt und damals ist X noch gelaufen. Hab einfach die damalige Kernel-config geladen und den Kernel kompiliert. Aber nun erhalte ich obige Fehlermeldung. Hab schon mehrere Male 'dpkg-reconfigure xserver-xfree86' und 'dpkg-reconfigure kdm' durchgeführt um sicher zugehen, dass alles richtig konfiguriert ist.
Wenn ich den mitgelieferte 2.4er Kernel von Sarge starte funktioniert alles prima.
:?: :?: :?:
Richtig dosierte Faulheit ist ein Stück Lebenskunst!

Benutzeravatar
mistersixt
Beiträge: 6529
Registriert: 24.09.2003 14:33:25
Lizenz eigener Beiträge: GNU Free Documentation License

Beitrag von mistersixt » 29.09.2004 09:21:04

Vergessen, "UNIX socket support" mit reinzucompilieren? Schau dazu mal hier:

http://lists.debian.org/debian-user/200 ... 00472.html

Ansonsten habe ich das hier noch gefunden:

http://www.groupsrv.com/linux/viewtopic.php?t=16148

Sprich, mal versuchen, den X-Server mit "-nolisten inet6" zu starten.


Gruss, mistersixt.
--
System: Debian Buster, 4.19.x.-x-amd64, ext4, AMD Ryzen 7, 8 x 3.7 Ghz., NV-GTX 1060, 16 GB Ram, XFCE

Benutzeravatar
shyryuken
Beiträge: 34
Registriert: 29.08.2004 12:03:10
Wohnort: Homburg im Saarland

Beitrag von shyryuken » 29.09.2004 20:51:03

THX.
Es hat geklappt - es war tatsächlich der "UNIX socket suppor"t, der nur als Modul gebacken wurde. Mich wundert es nur, dass es vorher mit der gleichen .config geklappt hat??? Naja, leider nimmt KDE jetzt nicht mehr meine Maus, Synaptic und Soundtreiber an... Irgendwo ist da der Wurm drinne....
Richtig dosierte Faulheit ist ein Stück Lebenskunst!

Benutzeravatar
mistersixt
Beiträge: 6529
Registriert: 24.09.2003 14:33:25
Lizenz eigener Beiträge: GNU Free Documentation License

Beitrag von mistersixt » 30.09.2004 07:31:46

Die Kernel-Entwickler modularisieren seit Kernel-2.6 ohne Ende, ich hatte mich mal beim Upgrade von ca. 2.6.2 auf 2.6.3 gewundert, warum mein interner PC-Speaker nicht mehr ging - bis ich gemerkt habe, dass es plötzlich ein Modul "pcspkr" gibt - hat mich ca. 3 Stunden Suche gekostet ;) !

Ansonsten nimm halt einfach einen Debian-Kernel, da sind gleich sämtliche Module vorhanden, und wenn Du dann noch hotplug installierst, sollten alle Deine Probleme verschwunden sein.

Gruss, mistersixt.
--
System: Debian Buster, 4.19.x.-x-amd64, ext4, AMD Ryzen 7, 8 x 3.7 Ghz., NV-GTX 1060, 16 GB Ram, XFCE

Kanses
Beiträge: 1
Registriert: 30.10.2004 13:38:00

gleiches problem

Beitrag von Kanses » 30.10.2004 14:22:53

Hallo,

ich habe leider das gleiche Problem!
Leider bin ich ein totaler Newbie und deshalb auf Hilfe angewiesen ;)

Ich habe auch den Kernel 2.6.8 neu kompiliert und dann installiert.

Sobald ich damit starte, bekomme ich auch die Fehlermeldung wie oben, sprich das ein XServer schon laufen würde.

Jetzt könnt ihr mir sagen, wie diese Modul "UNIX socket support" genau heisst, damit ich es manuell laden kann?

Oder sonst auch wo ich es unter "make menuconfig" finden kann.
Damit ich es aktivieren kann und einen neuen Kernel kompilieren.

Danke

AKey
Beiträge: 15
Registriert: 29.12.2004 04:56:38
Kontaktdaten:

Beitrag von AKey » 29.12.2004 05:03:48

Hallo @all,
erstmal vielem dank für dieses Forum!!! Ohne das Forum wäre ich verloren :wink:

Aber nun zu dem Problem, auch wenn es wohl mittlerweile gelöst wurde.

Bei mir war der Unix Socket Support auch nur als modul in der Kernel Config. Lösung:

/usr/src/linux-"wasauchimmer"
make menuconfig
Device Drivers-->Networking support-->Networking options--> <*> Unix domain sockets

Und schon gehts!

In diesem Sinne

bye

Antworten