[gelöst] Problem mit USB Soundkarte

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
Linuxhai

[gelöst] Problem mit USB Soundkarte

Beitrag von Linuxhai » 01.03.2012 13:01:41

Hallo,

ich habe eine Terratec Aureon Dual USB Sondkarte und bekomme einfach keinen Ton unter Wheezy mit Xfce
obwohl sie unter der Laurstärkeregelung angezeigt wird
Wenn ich dann auf den internen Soundship umschalte habe ich Ton.
Was könnte denn da für ein Paket fehlen ?


MfG Linuxhai
Zuletzt geändert von Linuxhai am 02.03.2012 09:21:51, insgesamt 1-mal geändert.

Cae
Moderator
Beiträge: 6349
Registriert: 17.07.2011 23:36:39
Wohnort: 2130706433

Re: Problem mit USB Soundkarte

Beitrag von Cae » 01.03.2012 16:41:39

Schau' mal mit

Code: Alles auswählen

$ alsamixer
nach, ob auch der letzte Regler oben ist. Falls nicht, wäre sicherlich ein lsusb von dem Teil hilfreich.

Gruß Cae
If universal surveillance were the answer, lots of us would have moved to the former East Germany. If surveillance cameras were the answer, camera-happy London, with something like 500,000 of them at a cost of $700 million, would be the safest city on the planet.

—Bruce Schneier

Linuxhai

Re: Problem mit USB Soundkarte

Beitrag von Linuxhai » 01.03.2012 19:38:47

Cae hat geschrieben:Schau' mal mit

Code: Alles auswählen

$ alsamixer
nach, ob auch der letzte Regler oben ist.
Die Schieber sind natürlich alle auf.
Wie geschrieben mit dem Soundchip onboard geht es ja.
Falls nicht, wäre sicherlich ein lsusb von dem Teil hilfreich

Code: Alles auswählen

  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 003: ID 04f9:0172 Brother Industries, Ltd FAX-1940CN Printer
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 005: ID 046d:c025 Logitech, Inc. MX500 Optical Mouse
Bus 001 Device 006: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 007: ID 0ccd:0077 TerraTec Electronic GmbH Aureon Dual USB
Bus 001 Device 008: ID 13fd:2040 Initio Corporation 
Bus 001 Device 009: ID 0557:2407 ATEN International Co., Ltd
Erkannt wird die USB Soundkarte ja, aber eben kein Ton.



MfG Linuxhai

Benutzeravatar
towo
Beiträge: 3501
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Problem mit USB Soundkarte

Beitrag von towo » 01.03.2012 19:49:30

Da fehlt kein Paket. Das Problem ist nur, daß deine Onboardcard als default gesetzt ist, was ein

cat /proc/asound/cards

auch zeigen wird.

Linuxhai

Re: Problem mit USB Soundkarte

Beitrag von Linuxhai » 01.03.2012 21:34:39

towo hat geschrieben:Das Problem ist nur, daß deine Onboardcard als default gesetzt ist.
Und wie schalte ich das ab und mache die USB Soundkarte zum Standard ?
Im Bios habe ich da keine Möglichkeit gefunden die onbord Karte abzuschalten.


MfG Linuxhai

Benutzeravatar
towo
Beiträge: 3501
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Problem mit USB Soundkarte

Beitrag von towo » 01.03.2012 21:58:34

Als Erstes entfernst Du

Code: Alles auswählen

options snd-usb-audio index=-2
aus /etc/modprobe.d/alsa-base.conf
Dann machst Du

Code: Alles auswählen

touch /etc/modprobe.d/mysound.conf
Und in dieses neue File malst Du

Code: Alles auswählen

options snd-usb-audio index=1
Nun sollte nach einem Reboot die USB-Soundkarte die Default-Card sein, wenn nich, darfst Du kein Geheimnis aus
cat /proc/asound/cards
machen.
Und btw, ich hab noch kein BIOS gesehen, wo sich der Onboard-Sound nicht hat abschalten lassen.

Linuxhai

Re: Problem mit USB Soundkarte

Beitrag von Linuxhai » 02.03.2012 09:21:02

towo hat geschrieben:ich hab noch kein BIOS gesehen, wo sich der Onboard-Sound nicht hat abschalten lassen.
Stimmt !
Habe es gefunden.
Vielen Dank.

MfG Linuxhai

Antworten