[gelöst] Samba start nicht möglich da es maskiert wurde

Probleme mit Samba, NFS, FTP und Co.
Antworten
s837ubc
Beiträge: 130
Registriert: 23.07.2013 14:17:01

[gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von s837ubc » 13.06.2015 19:56:52

Hallo,

unter Debian Jessie ist Samba 4.1.17 mit allen Updates installiert worden.

Wenn der Service "Samba.service gestartet werden soll, wird angegeben, dass der Service maskiert wurde:

Code: Alles auswählen

$ sudo systemctl status samba.service
● samba.service
   Loaded: masked (/dev/null)
   Active: inactive (dead)
Im Web wird u.a. auf der Webseite

https://www.digitalocean.com/community/ ... -and-units

erläutert wie man verfahren kann um einen Service zu maskieren bzw. wieder demaskieren.

Nach deren Information sollte ein Service mit dem nachstehenden Befehl demaskiert werden können:

Code: Alles auswählen

$ sudo systemctl unmask samba.service
Jedoch kann der Service auch nach dem Demaskieren nicht gestartet werden:

Code: Alles auswählen

$ sudo systemctl status samba.service
● samba.service
   Loaded: masked (/dev/null)
   Active: inactive (dead)
Zur Information: Beim Demaskieren wird im Syslog immer die nachstehende Maldung protokolliert:

rsyslogd-2007: action 'action 17' suspended, next retry is Sat Jun 13 19:35:02 2015 [try http://www.rsyslog.com/e/2007 ]

Auch ein Reboot des Systems hat keine Veränderung gebracht.

Hingegegen scheint ein Teil des Services normal zu starten:

Code: Alles auswählen

 $ sudo /etc/init.d/samba start
[ ok ] Starting nmbd (via systemctl): nmbd.service.
[ ok ] Starting smbd (via systemctl): smbd.service.
[ ok ] Starting samba-ad-dc (via systemctl): samba-ad-dc.service.

$ sudo /etc/init.d/samba-ad-dc start
[ ok ] Starting samba-ad-dc (via systemctl): samba-ad-dc.service.
Hat jemand eine Idee?
Zuletzt geändert von s837ubc am 16.06.2015 18:49:58, insgesamt 1-mal geändert.

Benutzeravatar
towo
Beiträge: 4063
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Samba start nicht möglich da es maskiert wude

Beitrag von towo » 13.06.2015 20:02:22

Und dein Problem ist?
Deine Ausgaben sind völlig normal und sehen hier nicht anders aus,
Samba läuft aber trotzdem.

s837ubc
Beiträge: 130
Registriert: 23.07.2013 14:17:01

Re: Samba start nicht möglich da es maskiert wude

Beitrag von s837ubc » 13.06.2015 20:20:12

Hallo Towo,

vielen Dank für Deine Antwort.

Samba läuft nur zum Teil.

Es werden keine Freigaben aufgelistet, wenn man z.B. mit Windows alle Freigaben anzeigen lassen will.

Auch kann auf keine Freigabe zugegriffen werden.

meine Samba Configuration:

Code: Alles auswählen

[global]
        unix password sync = yes
        server string = System A
        load printers = no

        name resolve order = lmhosts bcast host

        printing = bsd

        printcap name = /dev/null

        disable spoolss = yes

        log file = /var/log/samba/log.%m
        available = no
        guest account = nobody
        server role = standalone server
        workgroup = clh-net
        browseable = no

[homes]
comment = Home Directories
browsable = no
read only = no
create mode = 0750

[public]
path = /home/guests/
public = yes
writable = yes
comment = smb share
guest ok = no

[web]
        browsable = no
        writeable = yes
        valid users = @users
        comment = Apache-Seite A
        path = /var/lib/SiteProd/

[webTest]
path = /var/lib/SiteTest/
comment = Apache Testseite
browsable = yes
read only = no
guest ok = no
Nachtrag:
========

Habe soeben bemerkt, dass beim Starten des Service smbd und nmbd jeweils ein Fehler protokolliert wird:

Code: Alles auswählen

$ tail log.smbd
[2015/06/13 20:21:54.319109,  0] ../lib/util/become_daemon.c:136(daemon_ready)
  STATUS=daemon 'smbd' finished starting up and ready to serve connectionsopen_socket_in(): setsockopt: SO_REUSEPORT = true on port 445 failed with error = Protocol not available

$ tail log.nmbd
[2015/06/13 20:21:51.499517,  0] ../source3/lib/util_sock.c:446(open_socket_in)
  open_socket_in(): setsockopt: SO_REUSEPORT = true on port 137 failed with error = Protocol not available
[2015/06/13 20:21:51.502332,  0] ../lib/util/become_daemon.c:136(daemon_ready)

Benutzeravatar
habakug
Moderator
Beiträge: 4313
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: Samba start nicht möglich da es maskiert wurde

Beitrag von habakug » 14.06.2015 09:19:01

Hallo!

Die Konfiguration sollte auch mit

Code: Alles auswählen

# testparm
geprüft werden.
Der Fehler könnte auch daher kommen, das der Administrator nicht auf root gemapt wurde.

Code: Alles auswählen

# smbpasswd -a root
# cat /etc/samba/smbusers
root = Administrator
Für den Samba root-Account kann man ein anderes Passwort vergeben, als für den Systemuser root ;-)

Gruss, habakug
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

s837ubc
Beiträge: 130
Registriert: 23.07.2013 14:17:01

Re: Samba start nicht möglich da es maskiert wurde

Beitrag von s837ubc » 15.06.2015 18:47:04

Hallo habakug,

vielen Dank für Deine Hinweise :-)

Der Befehl "testparm" wirft in der Tat einige Fehler aus:

Code: Alles auswählen

$ testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
NOTE: Service homes is flagged unavailable.
Processing section "[public]"
NOTE: Service public is flagged unavailable.
Processing section "[web]"
NOTE: Service web is flagged unavailable.
Processing section "[webTest]"
NOTE: Service webTest is flagged unavailable.
Loaded services file OK.
ERROR: the 'unix password sync' parameter is set and there is no valid 'passwd program' parameter.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions
Muss mich erst mal schlau machen, welche Ursache der Fehler hat:
ERROR: the 'unix password sync' parameter is set and there is no valid 'passwd program' parameter.

Nehme an, dass die anderen Hinweise ein Folgefehler vom ersten Fehler sind:
NOTE: Service homes is flagged unavailable.
NOTE: Service public is flagged unavailable.
NOTE: Service web is flagged unavailable.
NOTE: Service webTest is flagged unavailable


Nachtrag:
========
Mir ist aufgefallen, dass der Befehl smbpasswd -a root die Datei "/etc/samba/smbusers" nicht füllt.

Nachdem nach der Quelle https://www.samba.org/samba/docs/using_samba/ch12.html in der Configuration in jede Freigabe die Option available = yes eigesetzt wurde, werden keine Note-Informationen vom testparm Befehl mehr ausgegeben.

Nachtrag 2:
=========
Erst nachdem der Service smbd explizit neu gestartet wurde, werden wieder die Freigaben angezeigt.

Weitere Anpassungen wurden via Webmin durchgeführt.

Der Service nmbd verursacht hingegen weiterhin Fehler beim Starten:

Code: Alles auswählen

$ service nmbd status
● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
   Loaded: loaded (/etc/init.d/nmbd)
   Active: active (running) since Mo 2015-06-15 20:20:46 CEST; 8min ago
  Process: 18124 ExecStop=/etc/init.d/nmbd stop (code=exited, status=0/SUCCESS)
  Process: 18128 ExecStart=/etc/init.d/nmbd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/nmbd.service
           └─18139 /usr/sbin/nmbd -D

<snip>
nmbd[18139]: open_socket_in(): setsockopt: SO_REUSEPORT = true on port 137 failed with error = Protocol not available
nmbd[18139]: [2015/06/15 20:20:46.923057,  0] ../lib/util/become_daemon.c:136(daemon_ready)

Benutzeravatar
pangu
Beiträge: 1400
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von pangu » 04.09.2015 11:57:15

Hi,

ich denke das von dir geschilderte Problem hängt nicht (nur) mit einer fehlerhaften samba-Konfiguration zusammen, sondern auch mit folgendem:

Laut diesem Debian-Bug-Report wurde das samba init Skript absichtlich deaktiviert aus Gründen wie sie im bugreport nachzulesen sind.
---
commit 8828d90daf00d46cb95086af5e417a0701b57575
Author: Ivo De Decker <ivodd@debian.org>
Date: Fri Oct 24 22:39:29 2014 +0200

Mask /etc/init.d/samba init script for systemd

diff --git a/debian/changelog b/debian/changelog
index 4d63958..59c73b8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+samba (2:4.1.13+dfsg-2) UNRELEASED; urgency=medium
+
+ * Mask /etc/init.d/samba init script for systemd. This should make systemd
+ ignore the samba init script. Thanks to Michael Biebl for the suggestion.
+ Closes: #740942
+
+ -- Ivo De Decker <ivodd@debian.org> Fri, 24 Oct 2014 22:29:49 +0200
+
samba (2:4.1.13+dfsg-1) unstable; urgency=medium

* New upstream release.
Deshalb auch der Symlink nach /dev/null :

Code: Alles auswählen

/lib/systemd/system/samba.service -> /dev/null
mit

Code: Alles auswählen

systemctl list-unit-files
kannst du dir alle service units des systemd anzeigen lassen. Dort wirst du auch sehen, dass der samba.service als maskiert angegeben ist.

Selbst ein

Code: Alles auswählen

systemctl unmask samba.service
wird aus dem oben genannten Umstand keine Besserung bringen.

Viele Erfolg und viele Grüße,
Pangu.
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

herrmeier
Beiträge: 41
Registriert: 04.12.2007 23:57:18

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von herrmeier » 12.10.2015 12:53:23

Hi,

wie sieht denn nun die Lösung für das Problem aus?
Ich habe leider ebenfalls:

Code: Alles auswählen

sudo service samba status
● samba.service
   Loaded: masked (/dev/null)
   Active: inactive (dead)
Warning: samba.service changed on disk. Run 'systemctl daemon-reload' to reload units.

Code: Alles auswählen

$ systemctl list-unit-files|grep samba
samba.service                              masked
Debian etch - testing

Benutzeravatar
pangu
Beiträge: 1400
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von pangu » 15.10.2015 00:08:39

pangu hat geschrieben: Laut diesem Debian-Bug-Report wurde das samba init Skript absichtlich deaktiviert aus Gründen wie sie im bugreport nachzulesen sind.
herrmeier hat geschrieben: wie sieht denn nun die Lösung für das Problem aus?
mit dem Service "nmbd" und "smbd" arbeiten, vergiss den service "samba" ;)
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

Benutzeravatar
MSfree
Beiträge: 8836
Registriert: 25.09.2007 19:59:30

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von MSfree » 15.10.2015 08:28:41

pangu hat geschrieben:mit dem Service "nmbd" und "smbd" arbeiten, vergiss den service "samba" ;)
Man sollte vielleicht auch mal schauen, wofür smbd, nmbd und samba gut sind.

smbd und nmbd sind ein Team, mit dem einfaches Filesharung auf Basis des Microsoft-Protokolls ermöglicht wird. Mit diesem Team ist es möglich, Mitglied eine Windows Domäne zu werden, sofern ein Domain-Controller im Netz hängt.

samba ist ein Domain-Controller, der nebenbei smbd und nmbd ersetzt. Wenn man also ohne einen Microsoft Windows-Server einen Domain-Controller einrichten möchte, braucht man samba. Allerdings braucht man dann auch die Professional bzw. die Enterprise Versionen für die Windows-Clients, sonst ist eine Windows-Domäne sinnlos.

herrmeier
Beiträge: 41
Registriert: 04.12.2007 23:57:18

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von herrmeier » 15.10.2015 17:46:40

Danke Euch...service samba schon vergessen;-)
Debian etch - testing

Benutzeravatar
pangu
Beiträge: 1400
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von pangu » 16.10.2015 15:24:47

MSfree hat geschrieben:Man sollte vielleicht auch mal schauen, wofür smbd, nmbd und samba gut sind.
Genau das würde ich dir empfehlen.
MSfree hat geschrieben:smbd und nmbd sind ein Team, mit dem einfaches Filesharung auf Basis des Microsoft-Protokolls ermöglicht wird. Mit diesem Team ist es möglich, Mitglied eine Windows Domäne zu werden, sofern ein Domain-Controller im Netz hängt.
Blödsinn! lies dir bitte durch was smbd und nmbd tun und lerne verstehen wie diese zwei Dienste miteinander arbeiten. Du nutzt nmbd genauso auf einem standalone file server (der kein DC sein muss!), sonst kannst du mit einem anderen Windows-Client nicht auf die SMB/CIFS Dienste (welche vom smbd-Dienst übrigens bereitgestellt werden) zugreifen.
MSfree hat geschrieben:samba ist ein Domain-Controller, der nebenbei smbd und nmbd ersetzt. Wenn man also ohne einen Microsoft Windows-Server einen Domain-Controller einrichten möchte, braucht man samba. Allerdings braucht man dann auch die Professional bzw. die Enterprise Versionen für die Windows-Clients, sonst ist eine Windows-Domäne sinnlos.
"samba" sollte hier erstmal klar differenziert werden, damit keine Mißverständnisse entstehen. "samba" gibt es als Prozess, aber "samba" ist auch der Name eines Init-Skriptes (/etc/init.d/samba). Du kannst dir die Skripte mit einfachen Linux-Bordmitteln betrachten, sie liegen meist unter /etc/init.d Wenn du das tust, wirst du feststellen, dass seit Samba4 Version "/etc/init.d/samba" ein überarbeitetes Init-Skript ist, welches automatisch und selbständig die bisher alten bekannten Dienste "nmbd", "smbd" und "samba-ad-dc" steuert. Es ist völlig egal, ob der Samba-Server als Domänencontroller oder nicht konfiguriert wurde, denn das Init-Skript "samba" checkt automatisch die smb.conf und startet entsprechend dann auch die notwendigen Dienste, die es benötigt und zwar wie folgt:

Beispiele:
  • wenn Samba4 als Domänencontroller konfiguriert wurde und demnach in der smb.conf eine bestimmte Zeile beinhaltet ist (server role = active directory domain controller), und du das Init-Skript "/etc/init.d/samba start" aufrufen würdest, dann wird der Dienst "nmbd" nicht gestartet sondern nur der Prozess "samba". Die haben in der neuen Samba4-Version diese Sachen in einen einzigen Prozess reingehauen. Natürlich wird auch der Prozess "smbd" gestartet und arbeiten. Du wirst also lediglich mehrere "samba" Prozesse sehen und womöglich nur einen einzigen "smbd" Prozess wenn du danach suchst.
  • wenn Samba4 als standalone file server konfiguriert wurde und du /etc/init.d/samba aufrufen würdest, dann starten die Prozesse "nmbd" und "smbd". Nmbd ist nämlich verantwortlich damit via Netbios überhaupt Infos durchs Netz gesendet werden und du an einem entfernten (z.B.) Windows-PC den Samba-Fileserver überhaupt aufgelistet bekommst. Ohne den Dienst "nmbd" würde die Auflösung und Bekanntgabe im Subnet nicht stattfinden können (!). Der smbd Prozess muss auch hier laufen, denn der ist zuständig für die SMB/CIFS Geschichte.
Resumée: das Init-Skript "samba" (siehe /etc/init.d/samba) ist ein neues Skript, welches das Samba4-Developer-Team erstellt hat und es somit erst ab Samba4 gibt. Es ist ein tolles Skript, der dem User eigentlich viel Arbeit abnimmt da dieser lediglich ein "/etc/init.d/samba start (stop, oder was auch immer...)" ausführen muss. Der Rest wird automatisch erledigt.

Und das Problem bei uns Debianern ist ==> dieses neue überarbeitete modernere Skript "samba" tut halt nicht aus den bereits oben erwähnten und verlinkten Gründen

Schönes Wochenende wünscht,
Pangu
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

Benutzeravatar
MSfree
Beiträge: 8836
Registriert: 25.09.2007 19:59:30

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von MSfree » 16.10.2015 15:32:42

pangu hat geschrieben:
MSfree hat geschrieben:Man sollte vielleicht auch mal schauen, wofür smbd, nmbd und samba gut sind.
Genau das würde ich dir empfehlen.
MSfree hat geschrieben:smbd und nmbd sind ein Team, mit dem einfaches Filesharung auf Basis des Microsoft-Protokolls ermöglicht wird. Mit diesem Team ist es möglich, Mitglied eine Windows Domäne zu werden, sofern ein Domain-Controller im Netz hängt.
Blödsinn! lies dir bitte durch was smbd und nmbd tun und lerne verstehen wie diese zwei Dienste miteinander arbeiten. Du nutzt nmbd genauso auf einem standalone file server (der kein DC sein muss!), sonst kannst du mit einem anderen Windows-Client nicht auf die SMB/CIFS Dienste (welche vom smbd-Dienst übrigens bereitgestellt werden) zugreifen.
MSfree hat geschrieben:samba ist ein Domain-Controller, der nebenbei smbd und nmbd ersetzt. Wenn man also ohne einen Microsoft Windows-Server einen Domain-Controller einrichten möchte, braucht man samba. Allerdings braucht man dann auch die Professional bzw. die Enterprise Versionen für die Windows-Clients, sonst ist eine Windows-Domäne sinnlos.
"samba" sollte hier erstmal klar differenziert werden, damit keine Mißverständnisse entstehen. "samba" gibt es als Prozess, aber "samba" ist auch der Name eines Init-Skriptes (/etc/init.d/samba). Du kannst dir die Skripte mit einfachen Linux-Bordmitteln betrachten, sie liegen meist unter /etc/init.d Wenn du das tust, wirst du feststellen, dass seit Samba4 Version "/etc/init.d/samba" ein überarbeitetes Init-Skript ist, welches automatisch und selbständig die bisher alten bekannten Dienste "nmbd", "smbd" und "samba-ad-dc" steuert. Es ist völlig egal, ob der Samba-Server als Domänencontroller oder nicht konfiguriert wurde, denn das Init-Skript "samba" checkt automatisch die smb.conf und startet entsprechend dann auch die notwendigen Dienste, die es benötigt und zwar wie folgt:

Beispiele:
  • wenn Samba4 als Domänencontroller konfiguriert wurde und demnach in der smb.conf eine bestimmte Zeile beinhaltet ist (server role = active directory domain controller), und du das Init-Skript "/etc/init.d/samba start" aufrufen würdest, dann wird der Dienst "nmbd" nicht gestartet sondern nur der Prozess "samba". Die haben in der neuen Samba4-Version diese Sachen in einen einzigen Prozess reingehauen. Natürlich wird auch der Prozess "smbd" gestartet und arbeiten. Du wirst also lediglich mehrere "samba" Prozesse sehen und womöglich nur einen einzigen "smbd" Prozess wenn du danach suchst.
  • wenn Samba4 als standalone file server konfiguriert wurde und du /etc/init.d/samba aufrufen würdest, dann starten die Prozesse "nmbd" und "smbd". Nmbd ist nämlich verantwortlich damit via Netbios überhaupt Infos durchs Netz gesendet werden und du an einem entfernten (z.B.) Windows-PC den Samba-Fileserver überhaupt aufgelistet bekommst. Ohne den Dienst "nmbd" würde die Auflösung und Bekanntgabe im Subnet nicht stattfinden können (!). Der smbd Prozess muss auch hier laufen, denn der ist zuständig für die SMB/CIFS Geschichte.
Resumée: das Init-Skript "samba" (siehe /etc/init.d/samba) ist ein neues Skript, welches das Samba4-Developer-Team erstellt hat und es somit erst ab Samba4 gibt. Es ist ein tolles Skript, der dem User eigentlich viel Arbeit abnimmt da dieser lediglich ein "/etc/init.d/samba start (stop, oder was auch immer...)" ausführen muss. Der Rest wird automatisch erledigt.

Und das Problem bei uns Debianern ist ==> dieses neue überarbeitete modernere Skript "samba" tut halt nicht aus den bereits oben erwähnten und verlinkten Gründen

Schönes Wochenende wünscht,
Pangu
Vielen Dank für die Blumen. :facepalm:

Erzähl mir bitte keine Blödsinn.

Die Skripte unter /etc/init.d sind zwar leider auf Jessie noch vorhanden, werden jedoch überhaupt nicht mehr verwendet, Stichwort Systemd.

Hätte ich nicht vor 2 erst einen Samba-Domaincontroller aufgesetzt, hätte ich auch meine Klappe gehalten, aber da du so dermassen quer schießt, nochmal für dich:

Samba mit Workgroup: smbd, nmbd
Samba mit Domain: samba

Und, ja, es gibt seit samba4 ein eigenes Executable, das "samba" heißt, als Domaincontroller fungiert, nicht mit nmbd und smbd zusammen arbeitet...

Benutzeravatar
pangu
Beiträge: 1400
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von pangu » 16.10.2015 16:07:47

MSfree hat geschrieben: Samba mit Workgroup: smbd, nmbd
Samba mit Domain: samba
wenn du "mit" ersetzt durch "als" dann deckt sich das auch mit ...
Pangu hat geschrieben: - wenn Samba4 als Domänencontroller konfiguriert wurde und demnach in der smb.conf eine bestimmte Zeile beinhaltet ist (server role = active directory domain controller), und du das Init-Skript "/etc/init.d/samba start" aufrufen würdest, dann wird der Dienst "nmbd" nicht gestartet sondern nur der Prozess "samba". Die haben in der neuen Samba4-Version diese Sachen in einen einzigen Prozess reingehauen. Natürlich wird auch der Prozess "smbd" gestartet und arbeiten. Du wirst also lediglich mehrere "samba" Prozesse sehen und womöglich nur einen einzigen "smbd" Prozess wenn du danach suchst.

- wenn Samba4 als standalone file server konfiguriert wurde und du /etc/init.d/samba aufrufen würdest, dann starten die Prozesse "nmbd" und "smbd". Nmbd ist nämlich verantwortlich damit via Netbios überhaupt Infos durchs Netz gesendet werden und du an einem entfernten (z.B.) Windows-PC den Samba-Fileserver überhaupt aufgelistet bekommst. Ohne den Dienst "nmbd" würde die Auflösung und Bekanntgabe im Subnet nicht stattfinden können (!). Der smbd Prozess muss auch hier laufen, denn der ist zuständig für die SMB/CIFS Geschichte.
du hast verstanden worum es in diesem Thread geht? Scroll doch nochmal ganz nach oben, lies dir das durch, atme tief durch und entspann dich. Da fehlen einem echt die Worte ... :facepalm:

Schönes weekend @ll
.klick.
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

Benutzeravatar
habakug
Moderator
Beiträge: 4313
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von habakug » 16.10.2015 16:21:49

Hallo!

Ausserdem hat @s837ubc oben dies gepostet:

Code: Alles auswählen

Server role: ROLE_STANDALONE
Das spricht für eine Samba 3 Konfiguration, z.B. als File-Server.
Ich kann die Aufregung auch nicht ganz verstehen. Ein security = ads stand hier bis jetzt jedenfalls nicht zur Debatte.

Gruss, habakug
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

Benutzeravatar
pangu
Beiträge: 1400
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von pangu » 16.10.2015 16:40:43

Hallo Habakug,

der Threadersteller hat Samba4 am Laufen, schreibt er ja gleich in seinem ersten Satz.

Grüße und schönes weekend,
Pangu
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

Benutzeravatar
habakug
Moderator
Beiträge: 4313
Registriert: 23.10.2004 13:08:41
Lizenz eigener Beiträge: MIT Lizenz

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von habakug » 16.10.2015 20:24:18

Hallo!
der Threadersteller hat Samba4 am Laufen
Jupp, ich wollte nur nochmal klarstellen, das der, der in einem aktuellen Jessie Samba mit dem Befehl

Code: Alles auswählen

# apt-get install samba
[...]
Vormals nicht ausgewähltes Paket samba wird gewählt.
Vorbereitung zum Entpacken von .../samba_2%3a4.1.17+dfsg-2_amd64.deb ...
[...]
installiert, einen Standalone Server erhält. Siehe hier:

Code: Alles auswählen

root@hawk:~# samba-tool testparm --parameter-name="server role"  2>/dev/null | tail -1
standalone server
Systemd ist auf Eis gelegt:

Code: Alles auswählen

root@hawk:~# ls -lisa /lib/systemd/system/samba.service 
27893 0 lrwxrwxrwx 1 root root 9 Mär  7  2015 /lib/systemd/system/samba.service -> /dev/null
root@hawk:~# systemctl status smbd
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd)
   Active: active (running) since Fr 2015-10-16 20:00:22 CEST; 9min ago
   CGroup: /system.slice/smbd.service
           ├─2348 /usr/sbin/smbd -D
           └─2468 /usr/sbin/smbd -D

Okt 16 20:00:22 debefi smbd[2339]: Starting SMB/CIFS daemon: smbd.
Der Dienst samba-ad-dc ist angehalten,

Code: Alles auswählen

root@hawk:~# systemctl status samba-ad-dc
● samba-ad-dc.service - LSB: start Samba daemons for the AD DC
   Loaded: loaded (/etc/init.d/samba-ad-dc)
   Active: active (exited) since Fr 2015-10-16 20:00:26 CEST; 18min ago
denn das Skript fragt ab:

Code: Alles auswählen

case "$1" in
	start)
		SERVER_ROLE=`samba-tool testparm --parameter-name="server role"  2>/dev/null | tail -1`
		if [ "$SERVER_ROLE" != "active directory domain controller" ]; then
		    exit 0
Ein Standalone Server ist das hier [1].

Gruss, habakug

[1] https://www.samba.org/samba/docs/man/Sa ... erver.html
( # = root | $ = user | !! = mod ) (Vor der PN) (Debianforum-Wiki) (NoPaste)

Benutzeravatar
pangu
Beiträge: 1400
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von pangu » 21.10.2015 09:40:53

Jup, richtig.
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

letzter3
Beiträge: 377
Registriert: 16.07.2011 22:07:31

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von letzter3 » 19.03.2017 17:26:34

Ich muss diesen 2 Jahre alten thread leider ausgraben.

Update von wheezy auf Jessie.
Samba streikt.
Nach durchlesen des Fadens war ich der Meinung, dass ich nicht samba starten muss, sondern smbd.
Leider schlägt das fehl:

Code: Alles auswählen

root@ptLWL01:~# systemctl start smbd.service
Job for smbd.service failed. See 'systemctl status smbd.service' and 'journalctl -xn' for details.
root@ptLWL01:~# 

Code: Alles auswählen

root@ptLWL01:~# systemctl status smbd.service
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd)
   Active: failed (Result: exit-code) since So 2017-03-19 17:17:48 CET; 5s ago
  Process: 6946 ExecStart=/etc/init.d/smbd start (code=exited, status=1/FAILURE)

Mär 19 17:17:48 ptLWL01 smbd[6946]: Starting SMB/CIFS daemon: smbd failed!
Mär 19 17:17:48 ptLWL01 systemd[1]: smbd.service: control process exited, code=exited status=1
Mär 19 17:17:48 ptLWL01 systemd[1]: Failed to start LSB: start Samba SMB/CIFS daemon (smbd).
Mär 19 17:17:48 ptLWL01 systemd[1]: Unit smbd.service entered failed state.

Code: Alles auswählen

root@ptLWL01:~# testparm
Load smb config files from /etc/samba/smb.conf
WARNING: Ignoring invalid value 'share' for parameter 'security'
Error loading services.
root@ptLWL01:~# 
Okay, da müsste ich wohl noch security = user setzen, dürfte aber mit meinem Problem weniger zu tun haben.

Wie bekomme ich smbd an's Laufen?

letzter3
Beiträge: 377
Registriert: 16.07.2011 22:07:31

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von letzter3 » 19.03.2017 17:41:46

Okay, also der smbd startet wieder, nachdem ich security = user setzen gesetzt habe.

Leider kann sich jetzt nieman mehr ohne Password anmelden.

Code: Alles auswählen

root@ptLWL01:~# testparm
Load smb config files from /etc/samba/smb.conf
WARNING: The "acl check permissions" option is deprecated
Processing section "[homes]"
Processing section "[public]"
Loaded services file OK.
WARNING: socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384
This warning is printed because you set one of the
following options: SO_SNDBUF, SO_RCVBUF, SO_SNDLOWAT,
SO_RCVLOWAT
Modern server operating systems are tuned for
high network performance in the majority of situations;
when you set 'socket options' you are overriding those
settings.
Linux in particular has an auto-tuning mechanism for
buffer sizes (SO_SNDBUF, SO_RCVBUF) that will be
disabled if you specify a socket buffer size. This can
potentially cripple your TCP/IP stack.

Getting the 'socket options' correct can make a big
difference to your performance, but getting them wrong
can degrade it by just as much. As with any other low
level setting, if you must make changes to it, make
 small changes and test the effect before making any
large changes.

Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

# Global parameters
[global]
        workgroup = SMB
        security = USER
        socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384
        idmap config * : backend = tdb
        acl check permissions = No


[homes]
        comment = Home Directories
        read only = No
        create mask = 0750
        browseable = No


[public]
        comment = Tauschlaufwerk
        path = /home/public/
        read only = No
        create mask = 0777
        directory mask = 0777
        guest ok = Yes

Code: Alles auswählen

root@ptLWL01:~# systemctl start smbd nmbd
root@ptLWL01:~# systemctl status smbd nmbd samba-ad-dc
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd)
   Active: active (running) since So 2017-03-19 17:38:54 CET; 4s ago
  Process: 7068 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/smbd.service
           ├─7089 /usr/sbin/smbd -D
           └─7091 /usr/sbin/smbd -D

Mär 19 17:38:54 ptLWL01 smbd[7068]: Starting SMB/CIFS daemon: smbd.
Mär 19 17:38:54 ptLWL01 systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
Mär 19 17:38:55 ptLWL01 smbd[7089]: [2017/03/19 17:38:55.008568,  0] ../lib/util/become_daemon.c:124(daemon_ready)
Mär 19 17:38:55 ptLWL01 smbd[7089]: STATUS=daemon 'smbd' finished starting up and ready to serve connections

● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
   Loaded: loaded (/etc/init.d/nmbd)
   Active: active (running) since So 2017-03-19 17:38:54 CET; 4s ago
  Process: 7069 ExecStart=/etc/init.d/nmbd start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/nmbd.service
           └─7088 /usr/sbin/nmbd -D

Mär 19 17:38:54 ptLWL01 nmbd[7069]: Starting NetBIOS name server: nmbd.
Mär 19 17:38:54 ptLWL01 systemd[1]: Started LSB: start Samba NetBIOS nameserver (nmbd).
Mär 19 17:38:54 ptLWL01 nmbd[7088]: [2017/03/19 17:38:54.571093,  0] ../lib/util/become_daemon.c:124(daemon_ready)
Mär 19 17:38:54 ptLWL01 nmbd[7088]: STATUS=daemon 'nmbd' finished starting up and ready to serve connections

● samba-ad-dc.service - LSB: start Samba daemons for the AD DC
   Loaded: loaded (/etc/init.d/samba-ad-dc)
   Active: inactive (dead)

Mär 19 17:32:44 ptLWL01 systemd[1]: Stopped LSB: start Samba daemons for the AD DC.
root@ptLWL01:~# 

letzter3
Beiträge: 377
Registriert: 16.07.2011 22:07:31

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von letzter3 » 19.03.2017 17:50:57

letzter3 hat geschrieben:
Leider kann sich jetzt nieman mehr ohne Password anmelden.
Okay.

Code: Alles auswählen

map to guest = Bad User
in Verbindung mit

Code: Alles auswählen

guest ok = yes
Löst das Problem.

scientific
Beiträge: 3019
Registriert: 03.11.2009 13:45:23
Lizenz eigener Beiträge: Artistic Lizenz
Kontaktdaten:

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von scientific » 19.03.2017 19:46:56

smbd.service suchst du.
dann putze ich hier mal nur...

Eine Auswahl meiner Skripte und systemd-units.
https://github.com/xundeenergie

auch als Debian-Repo für Testing einbindbar:
deb http://debian.xundeenergie.at/xundeenergie testing main

Benutzeravatar
pangu
Beiträge: 1400
Registriert: 15.11.2011 20:50:52
Lizenz eigener Beiträge: GNU General Public License
Wohnort: /proc/1

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von pangu » 31.08.2017 18:10:03

@letzter3: du solltest dich definitiv mit dem Samba auseinandersetzen, denn irgendwie scheint es als ob du an Schrauben drehst von denen du nicht verstehst was sie bewirken. Trial and Error ist hier nicht die richtige Vorgehensweise. Aber gut, wenn du das zwischenzeitlich gelöst hast ;)

PS: Logfiles sind dein Freund.
Man gibt Geld aus, das man nicht hat, um damit Dinge zu kaufen, die man nicht braucht, um damit Leute zu beeindrucken, die man nicht mag.

letzter3
Beiträge: 377
Registriert: 16.07.2011 22:07:31

Re: [gelöst] Samba start nicht möglich da es maskiert wurde

Beitrag von letzter3 » 31.08.2017 20:48:03

Ist jetzt schon ne Weile her, daher versuche ich mal zu rekonstruieren.
Mit dem Wechsel der sambaversionen wurde ein Teil meiner alten conf obsolet und musste geändert werden.
Und zwar die beiden von mir zitierten Zeilen.

Habe ich da was falsch verstanden?
Wenn ja, was?

Antworten