Konnektivität nach (Neu-)Start -- Internetverbindung -- WLAN -- Frequenzen

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
EinSteiGer
Beiträge: 24
Registriert: 10.12.2016 18:07:39

Konnektivität nach (Neu-)Start -- Internetverbindung -- WLAN -- Frequenzen

Beitrag von EinSteiGer » 21.06.2018 16:46:22

Wertes Forum,

ich habe dank des Forums mein Problem mit dem erkennen der Hardware bzw. Installieren erledigt (viewtopic.php?f=30&t=170064).

Dennoch habe ich ein W-Lan Problem: Immer nach dem (Neu-)Start von Debian 9 mit KDE wird eine Verbindung zum Netzwerk hergestellt, aber es gibt dann keine Internetverbindung. Nach ein (bis mehrmaligem) Trennen der Verbindung und erneutem Verbinden habe ich dann eine Internetverbindung.

Ich nutze neben der Realtek RTL8821AU Wireless LAN einen O2-Router HomeBox 6641.

Welche Informationen kann ich hier posten, um das Problem zu präzisieren?

Mit freundlichen Grüßen
Einsteiger

Nachtrag:
Vielleicht hilft Folgendes weiter um das Problem einzugrenzen:

Vor dem gelungenen Verbinden ist eine andere Frequenz als bei der dann tatsächlich möglichen Verbindung bei iwconfig zu finden:

Vorher (trotz Verbindung keine Internetverbindung)

Code: Alles auswählen

# iwconfig
lo        no wireless extensions.

wlx74da3896b828  IEEE 802.11AC  ESSID:"XXXXX"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:5.18 GHz  Access Point: 58:8B:F3:56:EE:2A   
          Bit Rate:434 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=96/100  Signal level=75/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

enp2s0    no wireless extensions.
Nachher (mit Internetverbindung)

Code: Alles auswählen

# iwconfig                                                                                                                                            
lo        no wireless extensions.                                                                                                                                                  
                                                                                                                                                                                   
wlx74da3896b828  IEEE 802.11bgn  ESSID:"XXXXX"  Nickname:"<WIFI@REALTEK>"                                                                                                      
          Mode:Managed  Frequency:2.452 GHz  Access Point: 58:8B:F3:56:EE:29                                                                                                       
          Bit Rate:150 Mb/s   Sensitivity:0/0                                                                                                                                      
          Retry:off   RTS thr:off   Fragment thr:off                                                                                                                               
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open                                                                                              
          Power Management:off                                                                                                                                                     
          Link Quality=71/100  Signal level=100/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

enp2s0    no wireless extensions.
Laut Beschreibung (http://www.zyxel.de/uploads/images/spha ... 1_v3.1.pdf) sollte der Router beides können.

Mit Bezug auf https://forum.ubuntuusers.de/topic/wlan ... abbrueche/ frage ich mich ob es am Network-Manager liegen könnte. Ich verwende NM-Version: 1.6.2
Gibt es eine Möglichkeit das herauszufinden ohne ihn gleich zu ersetzen?

Nachtrag 2:

Ich habe jetzt im NM gefunden, wo ich die Frequenz festlegen kann.
Aber was mir noch unklar ist, ist warum das ein Problem geben kann, wenn sie nicht auf 2,452 GHz eingestellt ist.

rendegast
Beiträge: 14795
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Konnektivität nach (Neu-)Start -- Internetverbindung -- WLAN -- Frequenzen

Beitrag von rendegast » 23.06.2018 15:33:52

802.11AC ist imo noch neu für linux,
also evtl. Treiberinstabilität?

Zudem scheint der wlan-Adapter generell noch nicht so lange unterstützt.


Vielleicht hilft die Umstellung der Encryption von hard auf soft? (evtl. per Modulparameter)

Vielleicht hilft die Beschränkung auf 802.11bgn / 802.11n?
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

EinSteiGer
Beiträge: 24
Registriert: 10.12.2016 18:07:39

Re: Konnektivität nach (Neu-)Start -- Internetverbindung -- WLAN -- Frequenzen

Beitrag von EinSteiGer » 12.08.2018 18:02:54

Vielen Dank für die Tipps.
Vor allem Folgendes würde ich gerne machen bzw. ausprobieren:
rendegast hat geschrieben: ↑ zum Beitrag ↑
23.06.2018 15:33:52
Vielleicht hilft die Umstellung der Encryption von hard auf soft? (evtl. per Modulparameter)
Vielleicht hilft die Beschränkung auf 802.11bgn / 802.11n?
Kann mir jemand einen Tipp geben, wo ich mich einlesen kann, wie ich das probieren kann?

Jana66
Beiträge: 3728
Registriert: 03.02.2016 12:41:11

Re: Konnektivität nach (Neu-)Start -- Internetverbindung -- WLAN -- Frequenzen

Beitrag von Jana66 » 12.08.2018 18:45:57

EinSteiGer hat geschrieben: ↑ zum Beitrag ↑
12.08.2018 18:02:54
rendegast hat geschrieben: Sa 23. Jun 2018, 15:33
...
Vielleicht hilft die Beschränkung auf 802.11bgn / 802.11n?
Kann mir jemand einen Tipp geben, wo ich mich einlesen kann, wie ich das probieren kann?
Kannst du im Router (O2-Box) grafisch machen, der WLAN-Client passt sich an.
Kannst bei der Gelegenheit versuchen, das WLAN zu optimieren. Hier stehen viele Tipps/Tests dazu: viewtopic.php?f=30&t=170263&hilit=Wlan
(Ich würde erst WLAN optimieren, dann Tipps von @rendegast, die u. U. Durchsatz etwas verschlechtern. Stabilität ist jedoch wichtiger.)
Viel Erfolg und lies dir zuerst die Gebrauchsanleitung (im Internet) deines Routers durch!

(Zur Encryption kann ich nichts sagen, Änderung nach o. g. Optimierung vlt. nicht mehr notwendig?)

Edit:

Code: Alles auswählen

su -
journalctl -b
oder
journalctl -b | grep -i network
durchforsten: Versucht das System, WLAN zu aktivieren und schafft es nicht, evtl. Grund aufgeführt? Oder versucht das System gar nicht, WLAN zu aktivieren?
Nach ein (bis mehrmaligem) Trennen der Verbindung und erneutem Verbinden habe ich dann eine Internetverbindung.
Sinnvoll bei mehrfach notwendigem Verbinden, demzufolge Fehler: Vorher Terminal aufrufen und

Code: Alles auswählen

su -
journalctl -f
(zeigt aktuelle Meldungen)
Wenn keiner was sagt, wird sich nichts ändern. Wenn alle nur reden ebenfalls nicht.

Antworten