QEMU

Alle weiteren Dienste, die nicht in die drei oberen Foren gehören.
Antworten
jcw
Beiträge: 25
Registriert: 10.01.2016 17:11:46

QEMU

Beitrag von jcw » 08.07.2018 16:22:16

Hallo!

Ich habe seit Kurzem ein Problem mit QEMU. Ich denke, es hat mit einem der letzten Updates zu tun. Nun läuft bei mir:

Code: Alles auswählen

uname -a
Linux jw09 3.16.0-6-686-pae #1 SMP Debian 3.16.56-1+deb8u1 (2018-05-08) i686 GNU/Linux

dpkg -l 'qemu'
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
||/ Name                                         Version                     Architektur                 Beschreibung
+++-============================================-===========================-===========================-==============================================================================================
ii  qemu                                         1:2.1+dfsg-12+deb8u6        i386                        fast processor emulator


Bisher konnte ich Windows7 mit folgendem Befehl starten:

Code: Alles auswählen

qemu-system-i386 --enable-kvm Windows7-01.ovl -m 1536 -vga std -usb -usbdevice tablet -rtc base=localtime -soundhw ac97 &
Dies funktioniert nun nicht mehr. Das QEMU-Fenster öffnet sich, bleibt jedoch 'schwarz' und bleibt hängen. Nur durch entfernen der Option

Code: Alles auswählen

--enable-kvm
kann Windows gestartet werden. Leider läuft es dann so langsam, dass kein Arbeiten mehr möglich ist.

Lösungen zum Problem habe ich gesucht, aber leider nichts Passendes gefunden:
https://bbs.archlinux.org/viewtopic.php?id=203840
https://bbs.archlinux.org/viewtopic.php?id=203548

Von den vorgeschlagenen drei Lösungsmöglichkeiten habe ich folgende versucht:

Code: Alles auswählen

qemu-system-i386 --enable-kvm Windows7-03.ovl -machine pc-i440fx-2.3 -m 1536 -vga std -usb -usbdevice tablet -rtc base=localtime -soundhw ac97 &

qemu-system-i386: -machine pc-i440fx-2.3: Unsupported machine type
Use -machine help to list supported machines!
Mit einer anderen 'machine' zum Beispiel:
pc-0.13 Standard PC (i440FX + PIIX, 1996)
pc-i440fx-2.0 Standard PC (i440FX + PIIX, 1996)
pc-1.0 Standard PC (i440FX + PIIX, 1996)
pc Standard PC (i440FX + PIIX, 1996) (alias of pc-i440fx-2.1)
pc-i440fx-2.1 Standard PC (i440FX + PIIX, 1996) (default)
pc-q35-1.7 Standard PC (Q35 + ICH9, 2009)
pc-1.1 Standard PC (i440FX + PIIX, 1996)
pc-i440fx-1.4 Standard PC (i440FX + PIIX, 1996)
pc-q35-2.0 Standard PC (Q35 + ICH9, 2009)
pc-0.14 Standard PC (i440FX + PIIX, 1996)
pc-i440fx-1.5 Standard PC (i440FX + PIIX, 1996)
pc-0.15 Standard PC (i440FX + PIIX, 1996)
xenfv Xen Fully-virtualized PC
pc-q35-1.4 Standard PC (Q35 + ICH9, 2009)
isapc ISA-only PC
pc-1.2 Standard PC (i440FX + PIIX, 1996)
pc-0.10 Standard PC (i440FX + PIIX, 1996)
pc-0.11 Standard PC (i440FX + PIIX, 1996)
q35 Standard PC (Q35 + ICH9, 2009) (alias of pc-q35-2.1)
pc-q35-2.1 Standard PC (Q35 + ICH9, 2009)
pc-i440fx-1.7 Standard PC (i440FX + PIIX, 1996)
xenpv Xen Para-virtualized PC
pc-i440fx-1.6 Standard PC (i440FX + PIIX, 1996)
none empty machine
pc-q35-1.5 Standard PC (Q35 + ICH9, 2009)
pc-q35-1.6 Standard PC (Q35 + ICH9, 2009)
pc-1.3 Standard PC (i440FX + PIIX, 1996)
pc-0.12 Standard PC (i440FX + PIIX, 1996)
funktioniert es auch nicht.

Die anderen beiden vorgeschlagenen Lösungen, wie Kernel Downgraden, kommen für mich nicht in Frage.

Hat jemand eine Idee, wie das Problem zu lösen ist?

Danke und Gruß.

maledora4
Beiträge: 349
Registriert: 10.11.2010 21:02:43

Re: QEMU

Beitrag von maledora4 » 08.07.2018 20:54:00

Wenn die Fehlermeldung lautet: Could not access KVM kernel module: Permission denied, dann hilft mir seit ~Mai'18 dieser Workaround mit der 99-kvm.rules .

jcw
Beiträge: 25
Registriert: 10.01.2016 17:11:46

Re: QEMU

Beitrag von jcw » 10.07.2018 20:50:48

Hallo!

Danke für die Rückmeldung. Es gibt gar keine(!) Fehlermeldung. Der QEMU-Bildschirm bleibt einfach schwarz und es geht nicht vorwärts. Ich habe trotzdem den vorgeschlagenen Workaround versucht. Leider erfolglos!

Gibt es denn keine Möglichkeit, diesen Fehler zu beheben?

rendegast
Beiträge: 14846
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: QEMU

Beitrag von rendegast » 10.07.2018 23:22:38

Es heißt '-enable-kvm', kein Doppel-Minus.

Du könntest es mal mit '-vga qxl' oder '-vga vmware' versuchen.

Statt '-machine ...' vielleicht '-cpu host'?



Es gäbe qemu 2.8 in jessie-backports.
Es gäbe kernel 4.9 in jessie-backports.
Das sollte imo keine Auswirkung auf das Problem haben. (bis zur Gegenprobe)
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

jcw
Beiträge: 25
Registriert: 10.01.2016 17:11:46

Re: QEMU

Beitrag von jcw » 13.07.2018 23:06:03

Stimmt, das war ein Tippfehler meinerseits. Trotzdem funktioniert es nicht mit der korrekten Eingabe. Und leider auch nicht mit den genannten Vorschlägen.
Gibt es denn niemanden, der das gleiche Problem hat? Der Fehler müsste doch bei vielen anderen Usern in gleicher Form auftreten.
Vielen Dank für die weitere Hilfen.

KP97
Beiträge: 1418
Registriert: 01.02.2013 15:07:36

Re: QEMU

Beitrag von KP97 » 14.07.2018 12:57:08

Doch, ich hatte auch Probleme mit Qemu. Da ich aber ein Sid habe und auch aqemu benutzt habe, kann man das evtl. nicht so ganz vergleichen.
Fakt ist aber, daß eine xxx.iso (egal von welcher Distri) nicht mehr startete. Der Startbefehl wurde noch angenommen, danach blieb der Monitor dunkel und es tat sich nichts mehr.
Dann habe ich noch zum Testen auf der Konsole mit qemu-img create einen Container angelegt und in diesen eine neue VM. Auch hier das gleiche Verhalten.
Der Startbefehl wird abgesetzt, danach passiert nichts mehr.
In den Logs gibt es keinerlei Einträge.

Da ich eine VM aber nicht so oft benutze, habe ich da auch nicht so ganz große Recherche betrieben, nachdem ich keinen Bugreport und auch keine anderen Hinweise gefunden habe.
Nach langer Zeit habe ich mal wieder eine Virtualbox eingerichtet. Na ja, um nur mal ein anderes System anzusehen, war qemu allerdings bequemer.

jcw
Beiträge: 25
Registriert: 10.01.2016 17:11:46

Re: QEMU

Beitrag von jcw » 14.07.2018 21:06:08

Danke für die Rückmeldung. Dann scheint das ja ein allgemeines Problem zu sein, und nicht nur bei meiner Konfiguration aufzutreten. Schade, dass es dazu keine verlässliche Lösung gibt. Vielleicht fällt ja jemandem noch was ein.

jcw
Beiträge: 25
Registriert: 10.01.2016 17:11:46

Re: QEMU

Beitrag von jcw » 16.07.2018 21:14:41

Niemand hat eine Idee.....?

jcw
Beiträge: 25
Registriert: 10.01.2016 17:11:46

Re: QEMU

Beitrag von jcw » 24.08.2018 17:26:42

Habe nun versucht, das 'backported packages' von 'qemu' zu installieren mittels:

Code: Alles auswählen

apt-get -t jessie-backports install "qemu"
.

Code: Alles auswählen

jw@jw09:/backup-laptop$ dpkg -l 'qemu'
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
||/ Name                                         Version                     Architektur                 Beschreibung
+++-============================================-===========================-===========================-==============================================================================================
ii  qemu                                         1:2.8+dfsg-3~bpo8+1         i386                        fast processor emulator
Leider bekomme ich weiterhin nur einen 'Black Screen'. Auch wundert mich, dass ich mit der höheren QEMU-Version nicht die Maschine 'pc-i440fx-2.3' auswählen kann, so wie in dem Artikel https://bbs.archlinux.org/viewtopic.php?id=203548 beschrieben. Dort hat das mit der QEMU-Version 2.3 schon funktioniert.

Auch gibt es den Parameter 'smm' nicht:

Code: Alles auswählen

qemu-system-i386: -machine smm=off: Invalid parameter 'smm'
Gibt es denn keine Möglichkeit, den Fehler zu beheben?

Antworten