NFS4/Kerberos mount funktioniert beim booten nur sporadisch

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
Antworten
joe2017
Beiträge: 77
Registriert: 07.08.2017 14:29:51

NFS4/Kerberos mount funktioniert beim booten nur sporadisch

Beitrag von joe2017 » 13.07.2018 08:53:06

Guten morgen zusammen,

ich hab einen LDAP/Kerberos Server und einen NFS Server mit dieversen Freigaben. Wenn ich meinen Client starte wird die Freigabe nur ab und zu gemountet. Wenn ich anschließend am client mit sudo mount -a alle fstab mountpoints mounte funktioniert das ohne Probleme. Was könnte hier das Problem beim Rechnerstart sein. Muss dies irgendwie verzögert gestartet werden?

Server/Client Debian 9.4.0 Stretch

Server mount
sudo nano /etc/exports

Code: Alles auswählen

/folder/	192.168.1.0/24(sec=krb5i,rw,sync,secure,no_subtree_check,no_root_squash)
Client mount
sudo nano /etc/fstab

Code: Alles auswählen

server.domain:/folder /local-mount-folder/	nfs4	sec=krb5i,rw,sync,nouser	0	2

schwedenmann
Beiträge: 4005
Registriert: 30.12.2004 15:31:07
Wohnort: Wegberg

Re: NFS4/Kerberos mount funktioniert beim booten nur sporadisch

Beitrag von schwedenmann » 13.07.2018 09:04:53

Hallo


Was sagt denn systemctl status derentsprechendedienstfürnfs4 ?

mfg
schwedenmann

joe2017
Beiträge: 77
Registriert: 07.08.2017 14:29:51

Re: NFS4/Kerberos mount funktioniert beim booten nur sporadisch

Beitrag von joe2017 » 13.07.2018 09:15:21

systemctl status "xxxxxxxxxxxxx.mount"

Code: Alles auswählen

— xxxxxxxxxxxxx.mount - /mount/folder
   Loaded: loaded (/etc/fstab; generated; vendor preset: enabled)
   Active: failed (Result: timeout) since Tue 2018-07-17 10:47:35 CEST; 4min 28s
    Where: /mount/folder
     What: NFSserver.local.net:/files/data
     Docs: man:fstab(5)
           man:systemd-fstab-generator(8)
  Process: 584 ExecMount=/bin/mount NFSserver.local.net:/files/d
    Tasks: 0 (limit: 4915)
   CGroup: /system.slice/xxxxxxxxxxxxx.mount
Zuletzt geändert von joe2017 am 17.07.2018 10:55:39, insgesamt 2-mal geändert.

joe2017
Beiträge: 77
Registriert: 07.08.2017 14:29:51

Re: NFS4/Kerberos mount funktioniert beim booten nur sporadisch

Beitrag von joe2017 » 17.07.2018 09:54:59

Ich hab folgendes in meinem /var/log/syslog.1 gelesen

Code: Alles auswählen

Unit entered failed state.
Mounting time out. Stopping.
Mount process exited, code=killed status=15
Failed to mount
Ich habe hier noch ein Auszug aus einem Log:

Code: Alles auswählen

Jul 16 09:13:10 ems-b-9999d940a systemd[1]: xxxxxxxxxxxxx.mount: Mounting timed out. Stopping.
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: xxxxxxxxxxxxx.mount: Mount process exited, code=killed status=15
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: Failed to mount /mount/folder.
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: Dependency failed for Remote File Systems.
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: remote-fs.target: Job remote-fs.target/start failed with result 'dependency'.
Jul 16 09:13:10 ems-b-9999d940a kernel: [  112.008728] NFS: nfs4_discover_server_trunking unhandled error -512. Exiting with error EIO
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: xxxxxxxxxxxxx.mount: Unit entered failed state.
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: home-users.mount: Mounting timed out. Stopping.
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: home-users.mount: Mount process exited, code=killed status=15
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: Failed to mount /home/users.
Jul 16 09:13:10 ems-b-9999d940a kernel: [  112.015880] NFS: nfs4_discover_server_trunking unhandled error -512. Exiting with error EIO
Jul 16 09:13:10 ems-b-9999d940a systemd[1]: home-users.mount: Unit entered failed state.


Jul 17 09:41:49 ems-b-9999d940a systemd[1]: home-users.mount: Mounting timed out. Stopping.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: home-users.mount: Mount process exited, code=killed status=15
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: Failed to mount /home/users.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: Dependency failed for Remote File Systems.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: remote-fs.target: Job remote-fs.target/start failed with result 'dependency'.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: home-users.mount: Unit entered failed state.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: xxxxxxxxxxxxx.mount: Mounting timed out. Stopping.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: Starting LSB: Start NTP daemon...
Jul 17 09:41:49 ems-b-9999d940a kernel: [  112.166044] NFS: nfs4_discover_server_trunking unhandled error -512. Exiting with error EIO
Jul 17 09:41:49 ems-b-9999d940a kernel: [  112.166742] NFS: nfs4_discover_server_trunking unhandled error -512. Exiting with error EIO
Jul 17 09:41:49 ems-b-9999d940a e.ms_bash_computer_start_script.sh[530]: mount.nfs4: mount system call failed
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: Starting Permit User Sessions...
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: Starting LSB: Speech Dispatcher...
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: xxxxxxxxxxxxx.mount: Mount process exited, code=killed status=15
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: Failed to mount /mount/folder.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: xxxxxxxxxxxxx.mount: Unit entered failed state.
Jul 17 09:41:49 ems-b-9999d940a systemd[1]: Started Permit User Sessions.


Antworten