Bootverzögerung beim Start

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 10.08.2018 17:37:49

journalctl -b |grep crng -a5
Aug 09 17:20:42 FNL4 kernel: PM: Registered nosave memory: [mem 0x0009f000-0x0009ffff]
Aug 09 17:20:42 FNL4 kernel: PM: Registered nosave memory: [mem 0x000a0000-0x000fffff]
Aug 09 17:20:42 FNL4 kernel: e820: [mem 0x80000000-0xf7ffffff] available for PCI devices
Aug 09 17:20:42 FNL4 kernel: Booting paravirtualized kernel on bare hardware
Aug 09 17:20:42 FNL4 kernel: clocksource: refined-jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645519600211568 ns
Aug 09 17:20:42 FNL4 kernel: random: get_random_bytes called from start_kernel+0x94/0x52e with crng_init=0
Aug 09 17:20:42 FNL4 kernel: setup_percpu: NR_CPUS:512 nr_cpumask_bits:512 nr_cpu_ids:2 nr_node_ids:1
Aug 09 17:20:42 FNL4 kernel: percpu: Embedded 44 pages/cpu @ (ptrval) s142360 r8192 d29672 u1048576
Aug 09 17:20:42 FNL4 kernel: pcpu-alloc: s142360 r8192 d29672 u1048576 alloc=1*2097152
Aug 09 17:20:42 FNL4 kernel: pcpu-alloc: [0] 0 1
Aug 09 17:20:42 FNL4 kernel: Built 1 zonelists, mobility grouping on. Total pages: 513546
--
Aug 09 17:21:18 FNL4 nm-dispatcher[733]: req:3 'dhcp6-change' [wlan0]: start running ordered scripts...
Aug 09 17:21:18 FNL4 NetworkManager[455]: <info> [1533828078.3771] dhcp6 (wlan0): client pid 833 exited with status 0
Aug 09 17:21:18 FNL4 NetworkManager[455]: <info> [1533828078.3771] dhcp6 (wlan0): state changed bound -> done
Aug 09 17:21:40 FNL4 wpa_supplicant[548]: wlan0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-55 noise=9999 txrate=48000
Aug 09 17:21:43 FNL4 systemd-timesyncd[410]: Synchronized to time server 146.0.32.144:123 (0.debian.pool.ntp.org).
Aug 09 17:24:53 FNL4 kernel: random: crng init done
Aug 09 17:24:53 FNL4 kernel: random: 7 urandom warning(s) missed due to ratelimiting
Aug 09 17:24:53 FNL4 /usr/lib/gdm3/gdm-x-session[845]: (--) Log file renamed from "/home/ralf/.local/share/xorg/Xorg.pid-847.log" to "/home/ralf/.local/share/xorg/Xorg.0.log"
Aug 09 17:24:53 FNL4 /usr/lib/gdm3/gdm-x-session[845]: X.Org X Server 1.20.0
Aug 09 17:24:53 FNL4 /usr/lib/gdm3/gdm-x-session[845]: X Protocol Version 11, Revision 0
Aug 09 17:24:53 FNL4 /usr/lib/gdm3/gdm-x-session[845]: Build Operating System: Linux 4.9.0-6-amd64 x86_64 Debian

mat6937
Beiträge: 1020
Registriert: 09.12.2014 10:44:00

Re: Bootverzögerung beim Start

Beitrag von mat6937 » 10.08.2018 17:38:17

fnliner hat geschrieben: ↑ zum Beitrag ↑
10.08.2018 17:34:48
root@FNL4:/home/ralf# ping6 -c 3 ::1
PING ::1(::1) 56 data bytes

--- ::1 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2027ms
Wie ist die Ausgabe von:

Code: Alles auswählen

ip a
?

Benutzeravatar
geier22
Beiträge: 3498
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: Bootverzögerung beim Start

Beitrag von geier22 » 10.08.2018 19:35:22

3. und letzte Mal:

Code: Alles auswählen

systemctl status haveged.service
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 10.08.2018 20:07:55

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
link/ether 00:1d:09:c8:78:21 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:1f:3c:12:fb:f7 brd ff:ff:ff:ff:ff:ff
inet 192.168.2.42/24 brd 192.168.2.255 scope global dynamic noprefixroute wlan0
valid_lft 86399941sec preferred_lft 86399941sec
inet6 2a01:5c0:e08a:4f51:855e:39a1:1631:fbfd/64 scope global temporary dynamic
valid_lft 7144sec preferred_lft 3544sec
inet6 2a01:5c0:e08a:4f51:21f:3cff:fe12:fbf7/64 scope global dynamic mngtmpaddr noprefixroute
valid_lft 7144sec preferred_lft 3544sec
inet6 fe80::21f:3cff:fe12:fbf7/64 scope link noprefixroute
valid_lft forever preferred_lft forever

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 10.08.2018 20:12:04

systemctl status haveged.service
● haveged.service - Entropy daemon using the HAVEGE algorithm
Loaded: loaded (/lib/systemd/system/haveged.service; disabled; vendor preset: disabled)
Active: inactive (dead)
Docs: man:haveged(8)
http://www.issihosts.com/haveged/

mat6937
Beiträge: 1020
Registriert: 09.12.2014 10:44:00

Re: Bootverzögerung beim Start

Beitrag von mat6937 » 10.08.2018 21:00:31

fnliner hat geschrieben: ↑ zum Beitrag ↑
10.08.2018 20:07:55
$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:1f:3c:12:fb:f7 brd ff:ff:ff:ff:ff:ff
inet 192.168.2.42/24 brd 192.168.2.255 scope global dynamic noprefixroute wlan0
valid_lft 86399941sec preferred_lft 86399941sec
inet6 2a01:5c0:e08a:4f51:855e:39a1:1631:fbfd/64 scope global temporary dynamic
valid_lft 7144sec preferred_lft 3544sec
inet6 2a01:5c0:e08a:4f51:21f:3cff:fe12:fbf7/64 scope global dynamic mngtmpaddr noprefixroute
valid_lft 7144sec preferred_lft 3544sec
inet6 fe80::21f:3cff:fe12:fbf7/64 scope link noprefixroute
valid_lft forever preferred_lft forever
Wie ist die Ausgabe von:

Code: Alles auswählen

sysctl net.ipv6.conf.lo.disable_ipv6
?

Benutzeravatar
geier22
Beiträge: 3498
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: Bootverzögerung beim Start

Beitrag von geier22 » 10.08.2018 21:24:16

fnliner hat geschrieben: ↑ zum Beitrag ↑
10.08.2018 20:12:04
systemctl status haveged.service
● haveged.service - Entropy daemon using the HAVEGE algorithm
Loaded: loaded (/lib/systemd/system/haveged.service; disabled; vendor preset: disabled)
Active: inactive (dead)
Docs: man:haveged(8)
Mal bittte

Code: Alles auswählen

#systemctl start haveged.service

Code: Alles auswählen

# systemctl enable haveged.service
Anschließend Neustart
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 11.08.2018 10:25:19

Wow ... jetzt läuft die Kiste wieder flüssig. :THX:

...danke an alle die hier bei der Lösung des Problems mitgewirkt haben.

Ich hoffe dass das Problem nach dem nächsten Upgrade nicht wieder kommt.

Der Thin - Server ist gepurgt ... ich denke der ist für mich nicht erforderlich.

Hier noch mal die Ausgabe ... von blame :!:

systemd-analyze blame
2.667s networking.service
1.247s dev-sda1.device
456ms keyboard-setup.service
440ms systemd-timesyncd.service
435ms systemd-journald.service
336ms upower.service
283ms accounts-daemon.service
260ms ModemManager.service
227ms NetworkManager.service
223ms udisks2.service
216ms systemd-logind.service
203ms user@1000.service
202ms stunnel4.service
199ms packagekit.service
181ms colord.service
177ms systemd-rfkill.service
159ms systemd-udev-trigger.service
133ms systemd-tmpfiles-setup.service
115ms bolt.service
111ms systemd-udevd.service
90ms binfmt-support.service
72ms console-setup.service
69ms systemd-update-utmp.service
68ms rsyslog.service
67ms pppd-dns.service
59ms dev-disk-by\x2duuid-02171796\x2d66cd\x2d4b27\x2daee7\x2d20f7c0a
59ms gdm.service
51ms systemd-modules-load.service
50ms systemd-journal-flush.service
50ms dev-mqueue.mount
49ms kmod-static-nodes.service
48ms sys-kernel-debug.mount
45ms polkit.service
38ms systemd-sysusers.service
37ms systemd-remount-fs.service
37ms systemd-tmpfiles-setup-dev.service
36ms proc-sys-fs-binfmt_misc.mount
34ms dev-hugepages.mount
32ms systemd-update-utmp-runlevel.service
30ms systemd-backlight@backlight:intel_backlight.service
30ms systemd-random-seed.service
25ms systemd-sysctl.service
24ms wpa_supplicant.service
16ms sys-fs-fuse-connections.mount
13ms systemd-user-sessions.service
9ms rtkit-daemon.service
lines 24-46/46 (END)

Benutzeravatar
geier22
Beiträge: 3498
Registriert: 23.02.2014 09:43:01
Wohnort: Berlin

Re: Bootverzögerung beim Start

Beitrag von geier22 » 11.08.2018 10:36:25

Das hättest du auch schon früher haben können:
niemand hat geschrieben: ↑ zum Beitrag ↑
06.08.2018 08:21:37
Der Gedanke ist einfach: gerade in der jüngeren Vergangenheit hat sich gezeigt, dass ein Mangel an Entropie für viele Startverzögerungen ursächlich war – und haveged kann das halt beheben. Zudem kostet ’n Test etwa 5 Minuten Arbeit (je ein Befehl zur Installation und für Reboot), und wenn’s dann doch nix bringen sollte, weiß man einerseits, dass es nicht an der Entropie liegt, andererseits ist’s mit ähnlich geringem Aufwand wieder deinstalliert.
geier22 hat geschrieben: ↑ zum Beitrag ↑
09.08.2018 13:44:13
Bitte mal die Ausgabe von

Code: Alles auswählen

systemctl status haveged.service
einstellen.
Listening to: 'Maggot Brain' from 'Maggot Brain' by 'Funkadelic' with JRiver Media Center 24
Nur Testing und sonst nix Xfce / KDE / Gnome / Asrock Fatal1ty 970 Performance 3.1 / AMD FX-6300 / 16GB RAM / Nvidia GTX 750 TI / HP LP3065

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start

Beitrag von fnliner » 11.08.2018 16:16:39

Hi ... haveged.service läuft jetzt und wird mit dem System geladen.

systemctl status haveged.service
● haveged.service - Entropy daemon using the HAVEGE algorithm
Loaded: loaded (/lib/systemd/system/haveged.service; enabled; vendor preset:
Active: active (running) since Sat 2018-08-11 16:12:41 CEST; 3min 38s ago
Docs: man:haveged(8)
http://www.issihosts.com/haveged/
Main PID: 425 (haveged)
Tasks: 1 (limit: 2342)
Memory: 3.7M
CGroup: /system.slice/haveged.service
└─425 /usr/sbin/haveged --Foreground --verbose=1 -w 1024

fnliner
Beiträge: 39
Registriert: 16.10.2017 09:41:35

Re: Bootverzögerung beim Start / gelöst

Beitrag von fnliner » 17.08.2018 14:56:19

Bis auf ping6 localhost funktioniert wieder alles😁!

Antworten