parted/fdisk kann kein Label/Partition erstellen

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
zelle97
Beiträge: 7
Registriert: 28.07.2018 12:09:23

parted/fdisk kann kein Label/Partition erstellen

Beitrag von zelle97 » 05.08.2018 12:53:38

Hallo zusammen,

ich bin dabei meinen home-server neu aufzusetzen. Zuvor hatte ich ein FreeNAS mit dem integrierten FreeNAS RAID 5 (5x2 TB).
Nun wollte ich aber umsteigen, das RAID selbst bauen (mit mdadm) und das OS auf Debian umstellen.

Alle Daten des RAIDs sind gebackupt.

Also habe ich alle HDDs des RAIDs (alle über SATA angeschlossen) entfernt und das neue OS auf der SSD installiert.

Soweit keine Probleme. Ich habe dann nach und nach alle HDDs wieder angeschlossen und mit parted die vorhandenen Partitionen und die Partitions-Tabelle gelöscht.
Ich wollte die HDDs clean haben befor ich mein eigenes RAID baue.

Das hat auch wunderbar funktioniert bei jeder HDD, keine Fehler oder Error meldungen.

Befehle die ich ausgeführt habe um eine HDD vorzubereiten:

Code: Alles auswählen

sudo parted /dev/sdX
(rm X falls eine Partition vorhanden war)  
mklabel gpt
mkpart primary 0% 100%
quit
Als ich dann aber die HDDs in das RAID einbinden wollte haben 2 davon gesagt das sie kein Label haben.
Zuerst dachte ich das ich sie vergessen habe und habe die Befehle erneut ausgeführt. Selbes Ergebnis.

parted sagt alles erfolgreich und mit

Code: Alles auswählen

print
zeigt es mir das Label und die Partition an. Sobald ich aber parted verlasse hat die HDD weder ein Label noch eine Partition.

Schritte die ich bisher versucht habe:

Das selbe Verfahren mit fdsik. Selbes Ergebnis. fdsik sagt alles ok und zeigt das Label etc an aber sobald ich fdisk verlasse ist es wieder weg.
Ich dachte die HDDs sind vielleicht in irgendeiner Art und Weise corruped. Also habe ich mit smartctl und badblocks nach fehlern gesucht. Kein Ergebnis.
Ich habe die HDDs komplett mit 0 überschrieben

Code: Alles auswählen

dd if=/dev/zero of=/dev/sdX bs=1M
. (Mit hexdump sogar überprüft), Keine Verbesserung.

Als nächstes dachte ich vielleicht es ist ein Hardware Problem. Wenn ich die Platten aber an meinen Windows PC anschließe kann ich darauf ganz normal Partitionen erstellen und sie verwenden.

Nun bin ich leider ratlos was ich als nächstes versuchen könnte.

bullgard
Beiträge: 1378
Registriert: 14.09.2012 23:03:01

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von bullgard » 08.08.2018 12:16:15

Ich würde es einmal mit dem Werkzeug GParted versuchen, Das ist schön übersichtlich. Vielieicht hast Du da mehr Glück.
Ansonsten solltest Du versuchen, Fehlermeldungen herauszukitzeln und hier zu veröffentlichen. Damit der potentielle Helfer nicht so lange rätseln muß.
Gruß
bullgard

Benutzeravatar
niemand
Beiträge: 11954
Registriert: 18.07.2004 16:43:29

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von niemand » 08.08.2018 23:39:17

Vorweg: ich nutze das nicht, aber da hier weiter keiner antwortet, ein paar Schüsse ins Blaue:

Kann’s sein, dass mdadm etwas anderes als das, was mit parted via mklabel erstellt wird (also die Partitionstabelle), mit Label meint? Etwa den Partitionsnamen (analog eines Dateisystem-Labels)? Die Bezeichnung „Disklabel“ für „Partitionstabelle“ ist mir bislang auch nur unter parted vorgekommen.

Ist’s möglich, dass du eine ältere Version von mdadm fährst, die noch nicht mit GPT umgehen kann?

Ist der Partitionstyp richtig gesetzt (fd00, „Linux RAID“)?

Beim Versuch mit fdisk: die neue Partitionstabelle wurde auch mit ›w‹ geschrieben? (Ob’s bei parted notwendig ist, weiß ich nicht).

Ansonsten:
Als ich dann aber die HDDs in das RAID einbinden wollte haben 2 davon gesagt das sie kein Label haben.
Zum Nachstellen wäre es immer gut, die genaue Ein- und Ausgabe, statt einer groben Beschreibung und Interpretation, zu haben. Beteiligte Softwareversionen zu kennen, ist auch immer hilfreich.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

zelle97
Beiträge: 7
Registriert: 28.07.2018 12:09:23

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von zelle97 » 09.08.2018 20:40:49

Ich würde es einmal mit dem Werkzeug GParted versuchen, Das ist schön übersichtlich. Vielieicht hast Du da mehr Glück.
Ansonsten solltest Du versuchen, Fehlermeldungen herauszukitzeln und hier zu veröffentlichen. Damit der potentielle Helfer nicht so lange rätseln muß.
Gruß
bullgard
Da ich Debian ohne Gui installiert habe habe ich einen GParted Live bootable USB-Stick gemacht. Dort konnte ich auch ein Label und Partitionen erstellen.
Diese sind auch auf den HDDs vorhanden wenn ich mir parted draufschauen

Code: Alles auswählen

sudo parted /dev/sda ... print
Wenn ich diese HDDs dann aber mit parted wieder bearbeite (also zb ein raid flag setze

Code: Alles auswählen

sudo parted /dev/sde set 1 raid on 
) verliert die HDD das Label und die partition.
Vorweg: ich nutze das nicht, aber da hier weiter keiner antwortet, ein paar Schüsse ins Blaue:

Kann’s sein, dass mdadm etwas anderes als das, was mit parted via mklabel erstellt wird (also die Partitionstabelle), mit Label meint? Etwa den Partitionsnamen (analog eines Dateisystem-Labels)? Die Bezeichnung „Disklabel“ für „Partitionstabelle“ ist mir bislang auch nur unter parted vorgekommen.

Ist’s möglich, dass du eine ältere Version von mdadm fährst, die noch nicht mit GPT umgehen kann?

Ist der Partitionstyp richtig gesetzt (fd00, „Linux RAID“)?

Beim Versuch mit fdisk: die neue Partitionstabelle wurde auch mit ›w‹ geschrieben? (Ob’s bei parted notwendig ist, weiß ich nicht).
Ob mdadm mit label etwas anderes meint als parted mit partitionstabelle weiß ich ehrlich gesagt nicht... Bei parted in der Ausgabe bei print steht gpt aber auch bei disklabel daher meine Annahme.

Den partitionstypt habe ich mit parted gesetzt (

Code: Alles auswählen

sudo parted /dev/sde set 1 raid on
) bzw mit GParted Live als Flag raid bei dem neuen versuch.

Jup, bei fdisk habe ich auch mit w geschrieben. parted hat kein schreiben daher meine annahme das es dort nicht nötig ist.

Hier noch ein paar Systemversionen:

mdadm: v3.4
parted: 3.2
fdisk: 2.29.2
Debian 9.5

Es tut mir Leid das ich keine genaueren Errors o.ä zur verfügung stellen kann.. Aber ich wüsste nicht welche.

Code: Alles auswählen

smartctl -d ata -a /dev/sdb
Liefert kein Errors und auch badblocks nicht.

Danke für die bisherigen Tipps schonmal :)

Benutzeravatar
niemand
Beiträge: 11954
Registriert: 18.07.2004 16:43:29

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von niemand » 09.08.2018 20:49:00

zelle97 hat geschrieben: ↑ zum Beitrag ↑
09.08.2018 20:40:49
Es tut mir Leid das ich keine genaueren Errors o.ä zur verfügung stellen kann.
Naja, statt „Als ich dann aber die HDDs in das RAID einbinden wollte haben 2 davon gesagt das sie kein Label haben.” einfach komplett die Ein- und Ausgabe hier posten. Idealerweise mit LANG=C, damit man die Ausgabe ggf. direkt in eine Suchmaschine werfen kann.
Zuletzt geändert von niemand am 09.08.2018 20:56:20, insgesamt 1-mal geändert.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

zelle97
Beiträge: 7
Registriert: 28.07.2018 12:09:23

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von zelle97 » 09.08.2018 20:55:05

Code: Alles auswählen

zelle@Izanagi:~$ sudo parted /dev/sda
GNU Parted 3.2
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
Error: /dev/sda: unrecognised disk label
Model: ATA WDC WD20EZRZ-60Z (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: unknown
Disk Flags:
(parted)
Das ist die Ausgabe von parted. /dev/sdb ist identisch.

Benutzeravatar
niemand
Beiträge: 11954
Registriert: 18.07.2004 16:43:29

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von niemand » 09.08.2018 20:59:45

(Edit oben gelöscht)

Leg mal bitte ’ne ordentliche Partitionstabelle samt Partition und passendem Typ an, und prüfe im jeweils anderen Programm (also fdisk, wenn du parted verwendet hast, oder andersrum), ob das passt. Dann mit mdadm hantieren, dabei die Partition als Ziel angeben (nicht das blanke Device, also sde1 statt sde). Wenn’s dann zum Fehler kommt, mal alles hier reinkopieren (also nicht deine Interpretation hier schreiben, sondern tatsächlich das, was du in der Shell gemacht hast, komplett kopieren und hier reinstellen – idealerweise zwischen [​code] und [/code], dann ist’s besser lesbar).
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

Benutzeravatar
jph
Beiträge: 424
Registriert: 06.12.2015 15:06:07
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Greven/Westf.

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von jph » 09.08.2018 21:10:55

zelle97 hat geschrieben: ↑ zum Beitrag ↑
05.08.2018 12:53:38
Das selbe Verfahren mit fdsik. Selbes Ergebnis. fdsik sagt alles ok und zeigt das Label etc an aber sobald ich fdisk verlasse ist es wieder weg.
Du musst den Kernel möglicherweise mit partprobe explizit anweisen, die neuen Partitionstabellen einzulesen.

zelle97
Beiträge: 7
Registriert: 28.07.2018 12:09:23

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von zelle97 » 09.08.2018 21:13:24

Das habe ich leider schon mehrfach gemacht. Hier meine Vorgehensweise:

Code: Alles auswählen

zelle@Izanagi:~$ sudo parted /dev/sda
GNU Parted 3.2
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) mklabel gpt
(parted) mkpart primary 0% 100%
(parted) print
Model: ATA WDC WD20EZRZ-60Z (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name     Flags
 1      1049kB  2000GB  2000GB               primary

(parted)
wenn ich dann parted allerdings verlasse:

Code: Alles auswählen

(parted) quit
Information: You may need to update /etc/fstab.

zelle@Izanagi:~$ sudo parted /dev/sda
GNU Parted 3.2
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
Error: /dev/sda: unrecognised disk label
Model: ATA WDC WD20EZRZ-60Z (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: unknown
Disk Flags:
(parted)
fdisk liefert mir wenn ich die platte überprüfe dann das hier:

Code: Alles auswählen

zelle@Izanagi:~$ sudo fdisk /dev/sda

Welcome to fdisk (util-linux 2.29.2).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Device does not contain a recognized partition table.
Created a new DOS disklabel with disk identifier 0x50353b3f.

Command (m for help): p
Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x50353b3f

Command (m for help):
mdadm liefert dann folgendes wenn ich versuche das RAID anzulegen:

Code: Alles auswählen

zelle@Izanagi:~$ sudo mdadm --create /dev/md0 --auto md --level=5 --raid-devices=5 /dev/sde1 /dev/sdd1 /dev/sdb1 /dev/sda1 /dev/sdf1
mdadm: /dev/sde1 appears to contain an ext2fs file system
       size=1953513472K  mtime=Thu Jan  1 01:00:00 1970
mdadm: /dev/sde1 appears to be part of a raid array:
       level=raid5 devices=5 ctime=Thu Aug  9 17:24:56 2018
mdadm: /dev/sdd1 appears to contain an ext2fs file system
       size=1953513472K  mtime=Thu Jan  1 01:00:00 1970
mdadm: /dev/sdd1 appears to be part of a raid array:
       level=raid5 devices=5 ctime=Thu Aug  9 17:24:56 2018
mdadm: /dev/sdb1 appears to contain an ext2fs file system
       size=1953513472K  mtime=Thu Jan  1 01:00:00 1970
mdadm: cannot open /dev/sda1: No such file or directory
Was ja auch richtig ist da /dev/sda1 nicht mehr existiert obwohl ich es mit parted angelegt habe. Das problem ist das mir weder parted noch fdisk irgendwelche Errors geben aber die HDD nicht so ist wie ich sie konfigueriere. Oder habe ich irgendwo einen Denkfehler?

Benutzeravatar
niemand
Beiträge: 11954
Registriert: 18.07.2004 16:43:29

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von niemand » 09.08.2018 21:16:24

Ich denke, der Hinweis von jph wird zielführend sein. Ich hatte da nun auch nicht mehr dran gedacht, weil meine Versionen der Werkzeuge das selbst triggern.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

zelle97
Beiträge: 7
Registriert: 28.07.2018 12:09:23

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von zelle97 » 12.08.2018 11:52:39

Du musst den Kernel möglicherweise mit partprobe explizit anweisen, die neuen Partitionstabellen einzulesen.
Ich habe partprobe manuell getriggered mit

Code: Alles auswählen

sudo partprobe
und

Code: Alles auswählen

sudo partprobe /dev/sda
das war allerdings leider nicht zielführend (keine Änderung, keine Ausgabe).
wenn ich mir allerdings mir

Code: Alles auswählen

sudo partprobe -s
die devices anzeigen lasse sagt es mir das /dev/sda eine msdos partition hat:

Code: Alles auswählen

zelle@Izanagi:/dev$ sudo partprobe -s
/dev/sda: msdos partitions
/dev/sdb: gpt partitions 1
/dev/sdc: gpt partitions 1 2 3
/dev/sdd: gpt partitions 1
/dev/sde: gpt partitions 1
/dev/sdf: gpt partitions 1
fdsik liefert mir bei dem erstellen von labeln und partitionen außerdem folgende meldung:

Code: Alles auswählen

Command (m for help): w
The partition table has been altered.
Calling ioctl() to re-read partition table.
Syncing disks.

Was ja eigentlich bedeuten sollte das die partitionen schon eingelesen wurden.

Benutzeravatar
niemand
Beiträge: 11954
Registriert: 18.07.2004 16:43:29

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von niemand » 12.08.2018 12:09:14

Das erscheint mir gerade mysteriös. An was für einem Controller hängen die Platten? Gibt es in den Logs irgendwelche Hinweise, dass die Devices auf readonly gesetzt wurden? Zum Testen könnte man auch mal ein Livesystem hernehmen und gucken, ob sich die Platte damit partitionieren lässt.

OT: ich empfehle, statt sudo vor alles Mögliche zu malen lieber direkt als Root zu arbeiten. Mit sudo gibt’s einige Fallstricke, die später auch gerne mal zu „unerklärlichen“ Fehlern führen können.
Hardware: dunkelgrauer Laptop mit buntem Display (zum Aufklappen!) und eingebauter Tastatur; beiger Klotz mit allerhand Kabeln und auch mit Farbdisplay und Tastatur (je zum auf’n Tisch Stellen)
Am 7. Tag aber sprach der HERR: „QWNoIFNjaGVpw58sIGtlaW5lbiBCb2NrIG1laHIgYXVmIGRlbiBNaXN0ISBJY2ggbGFzcyBkYXMgamV0enQgZWluZmFjaCBzbyDigKYK“

zelle97
Beiträge: 7
Registriert: 28.07.2018 12:09:23

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von zelle97 » 12.08.2018 12:19:28

Die Platten hängen alle direkt am Motherboard (gigabyte 970a ds3p).
In den syslogs gibt es wirklich null :/ ich habe dort schon nach jeglichen warnungen oder errors gesucht.
Hier mal ein auszug was ich zu den Platten gefunden habe (Auf Wunsch kann ich auch gerne bestimmte logs komplett hochstellen):

Code: Alles auswählen

Aug 12 10:34:07 Izanagi kernel: [    1.783287] ata3.00: ATA-9: Samsung SSD 850 EVO 250GB, EMT02B6Q, max UDMA/133
Aug 12 10:34:07 Izanagi kernel: [    1.783288] ata3.00: 488397168 sectors, multi 1: LBA48 NCQ (depth 31/32), AA
Aug 12 10:34:07 Izanagi kernel: [    1.784049] ata3.00: supports DRM functions and may not be fully accessible
Aug 12 10:34:07 Izanagi kernel: [    1.784670] ata3.00: disabling queued TRIM support
Aug 12 10:34:07 Izanagi kernel: [    1.784880] ata6: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
Aug 12 10:34:07 Izanagi kernel: [    1.785102] ata3.00: configured for UDMA/133
Aug 12 10:34:07 Izanagi kernel: [    1.785313] scsi 2:0:0:0: Direct-Access     ATA      Samsung SSD 850  2B6Q PQ: 0 ANSI: 5
Aug 12 10:34:07 Izanagi kernel: [    1.785338] ata6.00: ATA-9: WDC WD20EZRZ-00Z5HB0, 80.00A80, max UDMA/133
Aug 12 10:34:07 Izanagi kernel: [    1.785339] ata6.00: 3907029168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
Aug 12 10:34:07 Izanagi kernel: [    1.785915] ata6.00: configured for UDMA/133
Aug 12 10:34:07 Izanagi kernel: [    1.817480] scsi 3:0:0:0: Direct-Access     ATA      WDC WD20EZRZ-00Z 0A80 PQ: 0 ANSI: 5
Aug 12 10:34:07 Izanagi kernel: [    1.849415] scsi 4:0:0:0: Direct-Access     ATA      WDC WD20EZRZ-00Z 0A80 PQ: 0 ANSI: 5
Aug 12 10:34:07 Izanagi kernel: [    1.881204] scsi 5:0:0:0: Direct-Access     ATA      WDC WD20EZRZ-00Z 0A80 PQ: 0 ANSI: 5
Aug 12 10:34:07 Izanagi kernel: [    1.914637] sd 0:0:0:0: [sda] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
Aug 12 10:34:07 Izanagi kernel: [    1.914639] sd 0:0:0:0: [sda] 4096-byte physical blocks
Aug 12 10:34:07 Izanagi kernel: [    1.914691] sd 0:0:1:0: [sdb] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
Aug 12 10:34:07 Izanagi kernel: [    1.914693] sd 0:0:1:0: [sdb] 4096-byte physical blocks
Aug 12 10:34:07 Izanagi kernel: [    1.914693] sd 0:0:0:0: [sda] Write Protect is off
Aug 12 10:34:07 Izanagi kernel: [    1.914695] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
Aug 12 10:34:07 Izanagi kernel: [    1.914710] sd 2:0:0:0: [sdc] 488397168 512-byte logical blocks: (250 GB/233 GiB)
Aug 12 10:34:07 Izanagi kernel: [    1.914739] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Aug 12 10:34:07 Izanagi kernel: [    1.914745] sd 3:0:0:0: [sdd] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
Aug 12 10:34:07 Izanagi kernel: [    1.914746] sd 3:0:0:0: [sdd] 4096-byte physical blocks
Aug 12 10:34:07 Izanagi kernel: [    1.914765] sd 2:0:0:0: [sdc] Write Protect is off
Aug 12 10:34:07 Izanagi kernel: [    1.914768] sd 2:0:0:0: [sdc] Mode Sense: 00 3a 00 00
Aug 12 10:34:07 Izanagi kernel: [    1.914776] sd 0:0:1:0: [sdb] Write Protect is off
Aug 12 10:34:07 Izanagi kernel: [    1.914779] sd 0:0:1:0: [sdb] Mode Sense: 00 3a 00 00
Aug 12 10:34:07 Izanagi kernel: [    1.914786] sd 4:0:0:0: [sde] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
Aug 12 10:34:07 Izanagi kernel: [    1.914787] sd 2:0:0:0: [sdc] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Aug 12 10:34:07 Izanagi kernel: [    1.914789] sd 4:0:0:0: [sde] 4096-byte physical blocks
Aug 12 10:34:07 Izanagi kernel: [    1.914803] sd 0:0:1:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Aug 12 10:34:07 Izanagi kernel: [    1.914824] sd 5:0:0:0: [sdf] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
Aug 12 10:34:07 Izanagi kernel: [    1.914826] sd 5:0:0:0: [sdf] 4096-byte physical blocks
Aug 12 10:34:07 Izanagi kernel: [    1.914828] sd 3:0:0:0: [sdd] Write Protect is off
Aug 12 10:34:07 Izanagi kernel: [    1.914832] sd 3:0:0:0: [sdd] Mode Sense: 00 3a 00 00
Aug 12 10:34:07 Izanagi kernel: [    1.914864] sd 3:0:0:0: [sdd] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Aug 12 10:34:07 Izanagi kernel: [    1.914872] sd 4:0:0:0: [sde] Write Protect is off
Aug 12 10:34:07 Izanagi kernel: [    1.914874] sd 4:0:0:0: [sde] Mode Sense: 00 3a 00 00
Aug 12 10:34:07 Izanagi kernel: [    1.914910] sd 4:0:0:0: [sde] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Aug 12 10:34:07 Izanagi kernel: [    1.914913] sd 5:0:0:0: [sdf] Write Protect is off
Aug 12 10:34:07 Izanagi kernel: [    1.914915] sd 5:0:0:0: [sdf] Mode Sense: 00 3a 00 00
Aug 12 10:34:07 Izanagi kernel: [    1.914940] sd 5:0:0:0: [sdf] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Aug 12 10:34:07 Izanagi kernel: [    1.917738]  sdc: sdc1 sdc2 sdc3
Aug 12 10:34:07 Izanagi kernel: [    1.918017] sd 2:0:0:0: [sdc] Attached SCSI disk
Aug 12 10:34:07 Izanagi kernel: [    1.932879] tsc: Refined TSC clocksource calibration: 4018.432 MHz
Das mit dem Livesystem habe ich schon ausprobiert (mit dem Gparted-Live-Boot-Stick).

Ok danke für den Tipp mit root ich versuche damit mal noch etwas weiter :)

geier22

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von geier22 » 12.08.2018 13:56:51

zelle97 hat geschrieben: ↑ zum Beitrag ↑
09.08.2018 21:13:24
wenn ich dann parted allerdings verlasse:


(parted) quit

Code: Alles auswählen

Information: You may need to update /etc/fstab.
zelle@Izanagi:~$ sudo parted /dev/sda
GNU Parted 3.2
Using /dev/sda
Welcome to GNU Parted! Type 'help' to view a list of commands.
(parted) print
Error: /dev/sda: unrecognised disk label
Model: ATA WDC WD20EZRZ-60Z (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: unknown
Disk Flags:
(parted)
Hast du denn die
fstab geändert?
Wenn du einen neue Partitionstabelle erstellst oder Partition formatierst wird in der Regel auch die UUID geändert.
herauszufinden mit

Code: Alles auswählen

# blkid
Wenn du neu bootest kann das System die naturgemäß nicht mehr mounten.
so sollte es aussehen:

Code: Alles auswählen

Aug 12 06:22:35 sparkykde kernel: EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: errors=remount-ro
Aug 12 06:22:35 sparkykde kernel: EXT4-fs (sdb3): mounted filesystem with ordered data mode. Opts: (null)
Aug 12 06:22:35 sparkykde kernel: EXT4-fs (sdb4): mounted filesystem with ordered data mode. Opts: (null)
Aug 12 06:22:35 sparkykde kernel: EXT4-fs (sdd1): mounted filesystem with ordered data mode. Opts: (null)
Aug 12 06:22:35 sparkykde kernel: EXT4-fs (sde1): mounted filesystem with ordered data mode. Opts: (null)
Ich würde dir raten mit einer Live-CD und gparted die Platten einzurichten, die UUID's festzustellen und mit der Live-CD auch gleich die fstab zu ändern.

zelle97
Beiträge: 7
Registriert: 28.07.2018 12:09:23

Re: parted/fdisk kann kein Label/Partition erstellen

Beitrag von zelle97 » 10.09.2018 21:39:12

Ich habe es mit der Live-CD von Gparted hinbekommen.

Ich musste nicht nur die fstab direkt mit der Live CD bearbeiten sondern auch das Array mit mdadm dort erstellen.

Das fertige Array wurde dann von Debian erkannt. Die einzelnen HDDs habe ich nicht mehr angefasst.

Dankeschön für die Tipps und Hilfe :D

Antworten