Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
CrimsonKing
Beiträge: 106
Registriert: 30.08.2009 08:08:53
Lizenz eigener Beiträge: Artistic Lizenz

Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von CrimsonKing » 13.10.2018 02:33:48

Ich wollte mir gerade aus Langeweile mal Debian GNU/Hurd (ihr immer mit eurem Linux :)) in einer VirtualBox installieren. Das klappt auch alles ganz gut - aber nach dem Aufruf tasksel steigt der Installateur mit der wenig zielführenden Information aus, es sei ein Fehler "bei einem Schritt" (hier: Installation von zusätzlichen Paketen) aufgetreten. Egal, was ich dort auswähle.

Kann mir jemand erklären, warum?

rendegast
Beiträge: 14938
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von rendegast » 13.10.2018 11:35:44

Code: Alles auswählen

apt-get update

apt-cache policy
?
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

CrimsonKing
Beiträge: 106
Registriert: 30.08.2009 08:08:53
Lizenz eigener Beiträge: Artistic Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von CrimsonKing » 13.10.2018 16:24:54

So weit komme ich ja nicht mal, ich bin noch im Installer und nicht in der Shell...

eggy
Beiträge: 1559
Registriert: 10.05.2008 11:23:50

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von eggy » 13.10.2018 16:34:04

Du kannst auf die Shell wechseln (strg/alt und F-Tasten), in einer der shells läuft das Log durch, evtl sieht man da was.
https://www.debian.org/releases/stable/ ... 01.html.en
https://www.debian.org/releases/stable/ ... 01.html.de

CrimsonKing
Beiträge: 106
Registriert: 30.08.2009 08:08:53
Lizenz eigener Beiträge: Artistic Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von CrimsonKing » 13.10.2018 17:58:52

Ah, TTY4 hat was für mich:

Bild

Und nun? :?

rendegast
Beiträge: 14938
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von rendegast » 14.10.2018 02:46:56

dep. liblognorm2 (>= 1.2.1)
das spricht für den (so imo kaputten) Debianrsyslog aus sid.

https://cdimage.debian.org/cdimage/port ... 386/README

Du hast bei der Installation nicht das Netzwerk deaktiviert (wozu in der README geraten wird).
Hier gerade mit hurd-i386 Version 9.0 und 10.0 (current) ausprobiert.

->
(Basis-)Installation ohne Netzwerk machen,
oder bei der Installation bei Einrichtung des Mirror auf diese verzichten
(sodaß das Netzwerk dennoch eingerichtet wird, was mit normalen debian-Kentnissen gar nicht so einfach ist,
es gibt zBsp. kein ip / ifconfig / lsmod),
später sources.list korrigieren und Installation komplettieren.

https://www.debian.org/ports/hurd/hurd-install
Es gibt nur das Repo unter sid:

Code: Alles auswählen

deb http://lokal_mirror.debian.org/debian unstable main
Um zBsp. sowas wie liblognorm2 zu bekommen

Code: Alles auswählen

deb http://snapshot.debian.org/archive/debian/20170612T094249Z/ sid main

(mit Acquire::Check-Valid-Until "false";)
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

CrimsonKing
Beiträge: 106
Registriert: 30.08.2009 08:08:53
Lizenz eigener Beiträge: Artistic Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von CrimsonKing » 14.10.2018 02:57:54

rendegast hat geschrieben: ↑ zum Beitrag ↑
14.10.2018 02:46:56
Du hast bei der Installation nicht das Netzwerk deaktiviert (wozu in der README geraten wird).
:facepalm: Das habe ich jetzt von meinem Glauben an meine eigene Unfehlbarkeit. Andererseits steht in dem README nicht "NETZWERK WIRD NICHT KLAPPEN" drin, sondern nur so Wischiwaschi. :mrgreen:

Die Installation hat funktioniert und ich kann reinbooten, aber jetzt ist natürlich nur das Nötigste da. Es wäre sonst wahrscheinlich auch zu einfach gewesen. :roll:
Mal gucken, wie ich da jetzt nachträglich das Netzwerk reingedengelt bekomme.
(mit Acquire::Check-Valid-Until "false";)
Entschuldigung, aber: hä?
(Ich habe seit sechs Jahren nichts mehr von Debian genutzt...)

rendegast
Beiträge: 14938
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von rendegast » 14.10.2018 04:25:06

Da das snapshot-Target veraltet ist wird es von apt abgelehnt,
diese Prüfung wird mit
Acquire::Check-Valid-Until "false";
in apt.conf[.d/foobar] unterbunden.
Weiterhin empfehle ich wegen des regulären sid-Target die recommends zu deaktivieren:
APT::Install-Recommends "0";


Zum Netzwerk habe ich oben schon meine alternative Vorgehensweise geschildert.
Ich mußte dann halt das sid-Target nach der Ersteinrichtung mit dem editor in sources.list eintragen.
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

CrimsonKing
Beiträge: 106
Registriert: 30.08.2009 08:08:53
Lizenz eigener Beiträge: Artistic Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von CrimsonKing » 14.10.2018 17:58:29

Durch das Deaktivieren des Netzwerks, wie von dir als eine der beiden Möglichkeiten vorgeschlagen, während der Installation habe ich ja nicht mal ein eth0. Nichts in der verlinkten "hurd-install"-Seite bringt mir dieses eth0 zurück, ich habe immer nur Loopback.

Ich gebe einfach auf und versuche es vielleicht in zehn Jahren noch mal. Das ist mir, ehrlich gesagt, einfach zu viel "aber vorher musst du noch...".
Trotzdem danke.

rendegast
Beiträge: 14938
Registriert: 27.02.2006 16:50:33
Lizenz eigener Beiträge: MIT Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von rendegast » 14.10.2018 19:40:54

CrimsonKing hat geschrieben: Durch das Deaktivieren des Netzwerks, wie von dir als eine der beiden Möglichkeiten vorgeschlagen, während der Installation habe ich ja nicht mal ein eth0. Nichts in der verlinkten "hurd-install"-Seite bringt mir dieses eth0 zurück, ich habe immer nur Loopback.
Dazu habe ich ja auch geschrieben, daß diese Variante tricky ist, da auf hurd die üblichen Tools ifconfig / ip nicht zur Verfügung stehen.
Ich habe das auch nicht hinbekommen.

Dann wählte ich die zweite Variante,
die Installation bis zur Abfrage zur Verwendung eines Mirrors durchgeführt.
Diese Abfrage verneint, der Installer hat dann noch unsinnigerweise debian-security/sid abgefragt.
Das Netzwerk war damit aber eingerichtet, inklusive dhcp-Eintrag in network/interfaces.



----------------------------------------------------
EDIT
Es gibt kein 'ifconfig', aber ein 'inetutils-ifconfig' aus Debianinetutils-tools und 'dhclient'.
Es gibt im Gegensatz zu linux kein
/etc/modules
/etc/modprobe*
/etc/initramfs-tools/modules
und kein udev ((nur?) nach der Basisinstallation).
mfg rendegast
-----------------------
Viel Eifer, viel Irrtum; weniger Eifer, weniger Irrtum; kein Eifer, kein Irrtum.
(Lin Yutang "Moment in Peking")

CrimsonKing
Beiträge: 106
Registriert: 30.08.2009 08:08:53
Lizenz eigener Beiträge: Artistic Lizenz

Re: Debian GNU/Hurd scheitert bei der Installation an Zusatzpaketen?

Beitrag von CrimsonKing » 14.10.2018 20:56:58

Zu den "üblichen Tools": Ich vergleiche Hurd nicht mit Linux, dafür habe ich Linux zu lange hinter mir gelassen. Aber danke für die Tipps.
Mir müsste wahrscheinlich erst wieder jemand Linux erklären. :lol:

Der merkwürdige Umweg hat anscheinend funktioniert. Bin trotzdem genervt. :|

Antworten