Grafikproblem Radeon (gelöst)

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
gemifa
Beiträge: 7
Registriert: 09.08.2013 21:54:01

Grafikproblem Radeon (gelöst)

Beitrag von gemifa » 08.11.2018 15:33:33

Hallo Forum,
sicherlich ein altes Problem, aber mein "Freund" Google" und Suche im Forum und Wiki haben mich leider nicht weitergebracht (kann auch an meinen mangelnden Kenntnissen liegen)

Ich habe auf einem älteren Rechner mit Quadcore Intel CPU das neueste Debian Stretch installiert. Klappte, aber der Monitor und damit die richtige Auflösung wurden nicht erkannt.

dmesg teilt mir mit, dass ich ab R600 die firmware-amd-graphics benötige.
Ich schreibe von einem anderen Rechner, daher kein Code möglich.
Ich habe dann über non-free sowohl firmware-linux-nonfree und nach einer Neuinstallation nur firmware-amd-graphics installiert.
Nach einem Neustart fror jedes mal der xserver ein. Grauer Bildschirm, der Mauszeiger ist zu sehen - aber nichts tut sich. Mauszeiger nicht beweglich, keine Reaktion auf die Tastatur. Ich kann nicht auf eine andere Konsole wechseln - mir bleibt nur ein Reset.

Beim nächsten Start habe ich über die Revovery-Option die Pakete entsprechend wieder deinstalliert. Aber der Effekt ist der gleiche.
Da ich das jetzt 4 mal hinter mir habe - wollte ja aus eigener Kraft dazulernen - gebe ich jetzt auf.Daher meine Fragen:
1. Wie kann ich denn den ursprünglichen Zustand wieder herstellen (außer durch Neuinstallation :-) )? purge reichte ja nicht.
2. Was kann ich noch machen?

lspci lieferte mir zur Grafik --- AMD/ATI Cedar Radeon HD5000/6000/7350/8350 Series

Ich hoffe die Infos sind ausreichend. Nach "purge gdm3" komme ich jetzt wenigstens sofort auf die Konsole.

Danke für hilfreiche Tipps (bitte nicht schlagen)

Michael

Nachtrag:

Die Lösung von Frage 1 habe ich herausgefunden:
dpkg-reconfigure Xorg - dann reboot,

Jetzt habe ich wieder mein Grafiksystem, aber mit der falschen Auflösung.
Zuletzt geändert von gemifa am 11.11.2018 09:24:50, insgesamt 1-mal geändert.

pferdefreund
Beiträge: 3194
Registriert: 26.02.2009 14:35:56

Re: Grafikproblem Radeon

Beitrag von pferdefreund » 09.11.2018 09:10:43

dann schau mal mit xrandr was da möglich ist. Damit kann man das dann auch einstellen, so da mehr angeboten wird.

gemifa
Beiträge: 7
Registriert: 09.08.2013 21:54:01

Re: Grafikproblem Radeon

Beitrag von gemifa » 09.11.2018 10:28:50

@pferdefreund

Danke für den Tipp - liefert leider nichts Besseres als auch die Systemeinstellungen (eigentlich logisch?).

Code: Alles auswählen

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 400, current 1280 x 1024, maximum 1280 x 1024
default connected primary 1280x1024+0+0 0mm x 0mm
   1280x1024      0.00* 
   1280x960       0.00  
   1152x864       0.00  
   1024x768       0.00  
   800x600        0.00  
   640x480        0.00  
   720x400        0.00  


Es handelt sich um ein Samsung TFT mit 1680*1050 Auflösung.

Mit xvidtunes konnte ich den Hsync und Vsync Bereich auslesen.
Mit dem XFree86 Modeline Generator habe ich für diese Auflösung Modelines generiert.
Kann ich diese Daten einfach in der xorg.conf einsetzen (ohne den Monitor zu schlachten) um eine entsprechende Darstellung zu erreichen?

Benutzeravatar
hikaru
Beiträge: 9985
Registriert: 09.04.2008 12:48:59

Re: Grafikproblem Radeon

Beitrag von hikaru » 09.11.2018 10:38:13

Wenn xrandr einen Grafikausgang als "default" bezeichnet, bedeutet das für gewöhnlich, dass die Grafikkarte nicht richtig erkannt wurde.
Ohne das Xorg.0.log werden wir hier nicht weiterkommen.

gemifa
Beiträge: 7
Registriert: 09.08.2013 21:54:01

Re: Grafikproblem Radeon

Beitrag von gemifa » 09.11.2018 19:42:50

@hikaru

Kannst Du mit dieser Xorg.0.log etwas anfangen (nach einem startx als user)?

http://nopaste.debianforum.de/40472

Ich habe verschieden Versuche gemacht . X zu starten. Mit und ohne firmware-amd-graphics, mit eigener xorg.conf etc.
Leider werde ich aus den Zeiten (ls -l) bei den log-Dateien nicht schlau (wird die Datei Xorg.0.log nicht bei jedem Start von X in mein .local/share/xorg geschrieben?)
Würde auch die Xorg.0.log bei einem "Xorg -configure" helfen? Das wird wohl jedes mal geschrieben?!
Wäre die dann sinnvoll mit oder ohne firmware-amd-graphics?

Die letzten Male hat sich nach dem Hängen des xservers die Maus bewegen lassen und ich konnte auch auf eine andere Konsole wechseln (bin mir aber keiner unterschiedlichen Vorgehensweise bewusst).

Danke für Eure Bemühungen!

Benutzeravatar
towo
Beiträge: 3195
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Grafikproblem Radeon

Beitrag von towo » 09.11.2018 20:04:42

Du hast eine /etc/X11/xorg.conf wo mit Sicherheit Müll wie vesa drin steht.
Ergo lösche den Unsinn, reboote und X sollte laufen.

Benutzeravatar
hikaru
Beiträge: 9985
Registriert: 09.04.2008 12:48:59

Re: Grafikproblem Radeon

Beitrag von hikaru » 09.11.2018 20:09:44

gemifa hat geschrieben: ↑ zum Beitrag ↑
09.11.2018 19:42:50
Kannst Du mit dieser Xorg.0.log etwas anfangen (nach einem startx als user)?

http://nopaste.debianforum.de/40472
Da wird nicht mal versucht, den Radeon-Treiber zu laden.

Meine einzige AMD/ATI-Karte ist 20 Jahre alt, daher bin ich nicht so sattelfest, aber am sinnvollsten wäre es wohl den Standardfall zu testen, also bei installierten Debianxserver-xorg-video-radeon und Debianfirmware-amd-graphics und ohne xorg.conf den X-Server durch root starten zu lassen.
Dann sollte man zumindest ein Log bekommen, in dem das eigentlichen Problem ersichtlich ist.

gemifa
Beiträge: 7
Registriert: 09.08.2013 21:54:01

Re: Grafikproblem Radeon

Beitrag von gemifa » 09.11.2018 22:25:00

Ich habe noch einmal probiert.

Hier eine Xorg.0.log ohne firmware-amd-graphics (wurde nach /var/log geschrieben) -
X lief normal mit der falschen Auflösung

http://nopaste.debianforum.de/40473

Und hier eine mit firmware-amd-graphics (wurde nach ~/.local/share/xorg geschrieben)
X hing - grauer Bildschirm mit beweglichem Mauszeiger, sonst nichts, konnte zu anderer Konsole wechseln

http://nopaste.debianforum.de/40474

Benötigt Ihr noch andere Infos?

Benutzeravatar
MartinV
Beiträge: 577
Registriert: 31.07.2015 19:38:52
Wohnort: Hyperion
Kontaktdaten:

Re: Grafikproblem Radeon

Beitrag von MartinV » 09.11.2018 22:42:11

Auf Anhieb sehe ich nichts verdächtiges im letzten Log (http://nopaste.debianforum.de/40474).
Der Radeon Treiber wird geladen, keine offensichtlichen Fehler.
Die größtmögliche Auflösung sollte 1680x1050 sein.

Nur ein Verdacht: Vielleicht spinnt Dein Display Manager. Ich vermute, es ist Debiangdm3. Versuch es mal mit Debiansddm oder Debianlightdm.
Die Vernunft kann einem schon leidtun. Sie verliert eigentlich immer.

gemifa
Beiträge: 7
Registriert: 09.08.2013 21:54:01

Re: Grafikproblem Radeon

Beitrag von gemifa » 10.11.2018 11:29:31

@hikaru

hier noch einmal ein log.
Beide Treiber sind installiert, Der Bildschirm ist grau, die Maus bewegt sich und ich kann die Konsole wechseln

http://nopaste.debianforum.de/40475

@MartinV

Mit gdm3 scheint es auch ein Problem zu geben, denn wenn ich den installiert habe, dann friert der Bildschirm komplett ein, sodass mir nur ein reset bleibt. Ohne Displaymanager mit startx bleiben Tastatur und Maus eisatzbereit - aber der Bildschirm auch nur grau.
Um hier zu schreiben etc. habe ich also firmware-amd-graphics wiedr deinstalliert und entsprechend falsche Auflösung. (max. 1280x1024)

Danke für Eure Bemühungen!!! Ich gebe also noch nicht auf.

Benutzeravatar
MartinV
Beiträge: 577
Registriert: 31.07.2015 19:38:52
Wohnort: Hyperion
Kontaktdaten:

Re: Grafikproblem Radeon

Beitrag von MartinV » 10.11.2018 12:32:15

Welchen Desktop hast Du installiert?
Wenn es Gnome 3 ist, könnte es ein Problem mit Wayland und Deiner Grafikkarte sein. Dazu würde auch das gdm3-Problem passen. (gdm3 läuft meist auf Wayland).
Probier mal Debianxfce4 und starte es mit startxfce4.
Zuletzt geändert von MartinV am 10.11.2018 15:28:53, insgesamt 1-mal geändert.
Die Vernunft kann einem schon leidtun. Sie verliert eigentlich immer.

gemifa
Beiträge: 7
Registriert: 09.08.2013 21:54:01

Re: Grafikproblem Radeon

Beitrag von gemifa » 10.11.2018 12:51:32

@towo

Zwischendurch auch mal eine xorg.conf mit vesa ausprobiert, aber die letzten drei Xorg.0.log mit Sicherheit ohne jede manuelle EInmischung!

gemifa
Beiträge: 7
Registriert: 09.08.2013 21:54:01

Re: Grafikproblem Radeon

Beitrag von gemifa » 10.11.2018 18:56:05

@MartinV

Ich habe Gnome installiert - jetzt mit xfce klappt alles einwandfrei!

Ganz herzlichen Dank!!!

Michael

Antworten