für apache php Version ändern

Debian macht sich hervorragend als Web- und Mailserver. Schau auch in den " Tipps und Tricks"-Bereich.
Antworten
cabanni
Beiträge: 3
Registriert: 14.03.2015 17:14:38

für apache php Version ändern

Beitrag von cabanni » 13.07.2019 17:39:27

Moin,

nach update auf debian 10 laufen meine Webanwendungen auf dem lokalen Apache nicht mehr. Unter Jesse war bei mir bereits php 7.3 installiert. Nach update läuft der Apache mit php 7.2 einige Erweiterungen wie Imagemagick lassen sich nicht mehr installieren da sie für 7.3 bereits installiert sind aber apache sie nicht nutzt.

Code: Alles auswählen

php --version
PHP 7.3.4-2 (cli) (built: Apr 13 2019 19:05:48) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.4, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.4-2, Copyright (c) 1999-2018, by Zend Technologies
Das bringt nur in der Konsole den gewünschten Erfolg, phpinfo() zeigt mir auch nach neustart von apache weiter an er nutzt php7.2:

Code: Alles auswählen

sudo a2enmod php7.3 
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "de",
        LC_ALL = (unset),
        LANG = "de_DE.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Considering dependency mpm_prefork for php7.3:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.3:
Enabling module php7.3.
Im Eclipse-server nutze ich die php7.3 cli binarys und alles läuft dort wie vor dem Update wunderbar.

Wie bekomme ich nun meinen apache dazu das er auch php7.3 nutzt.Bild

schwedenmann
Beiträge: 4385
Registriert: 30.12.2004 15:31:07
Wohnort: Wegberg

Re: für apache php Version ändern

Beitrag von schwedenmann » 13.07.2019 18:30:57

Hallo


Ev. mußt du in den sites-available php7.3 reinschreiben (da wo php + fpm definiert wird, da steht bestimmt noch 7.2 drin


mfg
schwedenmann

cabanni
Beiträge: 3
Registriert: 14.03.2015 17:14:38

Re: für apache php Version ändern

Beitrag von cabanni » 13.07.2019 19:05:13

hab alle php versionen gepurged und 7.3 allein neu installiert, nu gehts.

Benutzeravatar
AspeLin
Beiträge: 660
Registriert: 19.06.2003 16:06:16
Wohnort: Berlin

Re: für apache php Version ändern

Beitrag von AspeLin » 14.07.2019 09:45:34

Ich hatte ein ähnliches Problem. PHP 7.0 war installiert, PHP 7.3 wurde mit dem Upgrade auf Buster installiert. Danach entfernte ich PHP 7.0 und die Konfigurationsdateien des Apache 2 mussten angepasst werden. Irgendwo klemmte es und er konnte mysqli nicht finden. Die Neuinstallation von libapache2-mod-php7.3 aktualisierte die Modulkonfiguration. Ein manueller Neustart des Apache 2 war notwendig.
Täuschung ist das Silikon der Postmoderne.

Antworten