[gelöst]Problem bei Druckerinstallation

Einrichten des Druckers und des Drucksystems, Scannerkonfiguration und Software zum Scannen und Faxen.
Antworten
Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

[gelöst]Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 18:52:00

Hallo,

ich möchte auf meinem jessie-Laptop einen neuen Drucker installieren. Die .deb-Datei vo Hersteller hab ich in den Ordner /var/lib/dpkg/ u. im home-Ordner gespreichert. Der Drucker als auch mein LT haben feste IP's befinden sich im selben Subnet. Als grafische Oberfläche verwende ich XFCE. Ich hab versucht, Anwendungsmenü/Einstellungen/Druckereinstellungen den Drucker (Lexmark CS 317) hinzuzufügen: hinzufügen/Netzwerkdrucker/Netzwerkdrucker finden. Er sucht u. findet nichts. Hat jemand ne Idee wie's gehen könnte?

gruß paul!
sorry, hier der Insatll-Bericht:

Code: Alles auswählen

# dpkg -i /var/lib/dpkg/Lexmark-ADX-PPD-Files-1.0-02242017.amd64.deb
(Lese Datenbank ... 450454 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../Lexmark-ADX-PPD-Files-1.0-02242017.amd64.deb ...

Uninstalling Lexmark Printer Driver...
Model: Lexmark-ADX-PPD-Files
x86_64 / unknown
CUPS Version: PPD_1_4
Uninstallation successful... :)
Entpacken von lexmark-adx-ppd-files (1.0-02242017) über (1.0-02242017) ...
lexmark-adx-ppd-files (1.0-02242017) wird eingerichtet ...

Copyright 2012, 2016-2017 Lexmark International, Inc.
All rights reserved.


Installing Lexmark Print Driver...
Model Detail: Lexmark-ADX-PPD-Files
x86_64 / unknown
CUPS Version: PPD_1_4
cat: /usr/local/Lexmark/ppd/Lexmark-ADX-PPD-Files/License.txt: Datei oder Verzeichnis nicht gefunden
Restarting CUPS...
[ ok ] Restarting Common Unix Printing System: cupsd.
Restarting CUPS... Done!
Restarting CUPS... Done!

Installation complete... :)
ich hab jetzt noch versucht, das über die Cups-Browserseite zu machen: http://127.0.0.1:631
da bekomme ich auch einen Fehler:

Code: Alles auswählen

Drucker hinzufügen Error

Unable to add printer

    Verboten

Zuletzt geändert von paul1234 am 13.07.2019 20:29:19, insgesamt 2-mal geändert.
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

Benutzeravatar
prox
Beiträge: 100
Registriert: 08.07.2019 18:50:34
Lizenz eigener Beiträge: MIT Lizenz

Re: Problem bei Druckerinstallation

Beitrag von prox » 13.07.2019 18:57:00

Hast Du schon die .deb-Dateien für Deinen Drucker mit

Code: Alles auswählen

dpkg -i <Datei_1.deb> <Datei_2.deb> usw.
oder, wenn die .deb-Dateien für Deinen Drucker sich in einem einzigen Ordner befinden:

Code: Alles auswählen

dpkg -i *
installiert und dann XFCE neu gestartet?

Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

Re: Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 19:08:42

prox hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 18:57:00
installiert und dann XFCE neu gestartet?
hmm, Neustart bei debian wegen Installation?
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

Benutzeravatar
prox
Beiträge: 100
Registriert: 08.07.2019 18:50:34
Lizenz eigener Beiträge: MIT Lizenz

Re: Problem bei Druckerinstallation

Beitrag von prox » 13.07.2019 19:12:37

paul1234 hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 19:08:42
prox hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 18:57:00
installiert und dann XFCE neu gestartet?
hmm, Neustart bei debian wegen Installation?
Besser wär's, weil der Druckerserver cupsd neu gestartet werden muss, damit er Deinen Drucker erkennt. Und der Drucker somit in den Druckereinstellungen von XFCE erscheint.

Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

Re: Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 19:23:25

also Neustart erledigt. Wie geht's jetzt weiter? über Anwendungsmenü (hab ich gerade versucht, geht nicht), Konsole oder Cups-Weboberfläche (hab ich gerade versucht, geht nicht). Der Drucker ist über ping erreichbar

Code: Alles auswählen

# cupsctl
_debug_logging=0
_remote_admin=1
_remote_any=0
_share_printers=1
_user_cancel_any=0
BrowseLocalProtocols=dnssd
DefaultAuthType=Basic
JobPrivateAccess=default
JobPrivateValues=default
MaxLogSize=0
SubscriptionPrivateAccess=default
SubscriptionPrivateValues=default
WebInterface=Yes
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

Benutzeravatar
Teddybear
Moderator
Beiträge: 3155
Registriert: 07.05.2005 13:52:55
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Altomünster
Kontaktdaten:

Re: Problem bei Druckerinstallation

Beitrag von Teddybear » 13.07.2019 19:44:20

Dann gehen wir mal zu Fuss auf die Suche.
Bitte suche mal in der Konsole nach dem Drucker, natürlich mit root Rechten.

Code: Alles auswählen

lpinfo --include-schemes dnssd -v
Versuchungen sollte man nachgeben. Wer weiß, ob sie wiederkommen!
Oscar Wilde

Mod-Voice / My Voice

Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

Re: Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 19:46:10

Code: Alles auswählen

network dnssd://Lexmark%20CS317dn._ipp._tcp.local/
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

MSfree
Beiträge: 4646
Registriert: 25.09.2007 19:59:30

Re: Problem bei Druckerinstallation

Beitrag von MSfree » 13.07.2019 19:46:54

paul1234 hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 19:23:25
also Neustart erledigt.
War aber überflüssig. Mit

Code: Alles auswählen

systemctl restart cups
wäre das schneller erledigt gewesen. :wink:

Benutzeravatar
Teddybear
Moderator
Beiträge: 3155
Registriert: 07.05.2005 13:52:55
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Altomünster
Kontaktdaten:

Re: Problem bei Druckerinstallation

Beitrag von Teddybear » 13.07.2019 19:50:27

OK.. Also ist der Drucker gefunden..
Nun mit root Rechten

Code: Alles auswählen

lpadmin -p Lexmark -v dnssd://Lexmark%20CS317dn._ipp._tcp.local/
sollte man den Drucker hinzufügen können.
Versuchungen sollte man nachgeben. Wer weiß, ob sie wiederkommen!
Oscar Wilde

Mod-Voice / My Voice

Benutzeravatar
prox
Beiträge: 100
Registriert: 08.07.2019 18:50:34
Lizenz eigener Beiträge: MIT Lizenz

Re: Problem bei Druckerinstallation

Beitrag von prox » 13.07.2019 19:52:41

MSfree hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 19:46:54
paul1234 hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 19:23:25
also Neustart erledigt.
War aber überflüssig. Mit

Code: Alles auswählen

systemctl restart cups
wäre das schneller erledigt gewesen. :wink:
Ich kenne mich mit systemd noch nicht aus, aber danke für den Hinweis. Wo ist für diesen Befehl noch Platz in meiner Birne? :mrgreen:

Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

Re: Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 20:09:09

Teddybear hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 19:50:27
OK.. Also ist der Drucker gefunden..
Nun mit root Rechten

Code: Alles auswählen

lpadmin -p Lexmark -v dnssd://Lexmark%20CS317dn._ipp._tcp.local/
sollte man den Drucker hinzufügen können.

Code: Alles auswählen

# lpadmin -p Lexmark -v dnssd://Lexmark%20CS317dn._ipp._tcp.local/
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

Re: Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 20:09:50

MSfree hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 19:46:54
paul1234 hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 19:23:25
also Neustart erledigt.
War aber überflüssig. Mit

Code: Alles auswählen

systemctl restart cups
wäre das schneller erledigt gewesen. :wink:
hatte ich auch schon gemacht:

Code: Alles auswählen

# systemctl restart cups
Failed to get D-Bus connection: Unbekannter Fehler -1
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

Re: Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 20:17:49

also auf der Browser-Cups-Seite wird der Lexmark jetzt angezeigt. Ich hab versucht, ne pdf zu drucken, ging aber nicht:

Code: Alles auswählen

Konnte /home/user/Dokument1.pdf nicht drucken
Wenn ich den Lexmark-Link auf der Cups-Seite unter verfügbar anklicke, dann steht da:

Code: Alles auswählen

Lexmark (Angehalten, Aufträge werden ablehnt
****edit***:
gelöst: ich mußte noch über Anwendungsmenü/Einstellungen/Druckereinstellunge den Drucker aktivieren u. noch neustarten. Jetzt geht es

@all: Danke!

bG. paul
Zuletzt geändert von paul1234 am 13.07.2019 20:30:46, insgesamt 1-mal geändert.
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

Benutzeravatar
Teddybear
Moderator
Beiträge: 3155
Registriert: 07.05.2005 13:52:55
Lizenz eigener Beiträge: GNU Free Documentation License
Wohnort: Altomünster
Kontaktdaten:

Re: [gelöst]Problem bei Druckerinstallation

Beitrag von Teddybear » 13.07.2019 20:30:14

Was gibt denn lpoptions aus?

Tante Edit sagt, dann ist ja alles in Butter, :D
Versuchungen sollte man nachgeben. Wer weiß, ob sie wiederkommen!
Oscar Wilde

Mod-Voice / My Voice

Benutzeravatar
paul1234
Beiträge: 1584
Registriert: 28.06.2014 15:41:15

Re: [gelöst]Problem bei Druckerinstallation

Beitrag von paul1234 » 13.07.2019 20:34:07

Teddybear hat geschrieben: ↑ zum Beitrag ↑
13.07.2019 20:30:14
Was gibt denn lpoptions aus?
läuft Teddybär, Danke nochmal für die Tipps!

bG. paul
Thinkpad T520; i7 2670QM; Intel QM67 Express; NVIDIA NVS 4200M + Intel HD3000; Buster; XFCE

Antworten