(gelöst) bluetooth-Voraussetzungen

Einrichten des lokalen Netzes, Verbindung zu anderen Computern und Diensten.
guennid
Beiträge: 12974
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

(gelöst) bluetooth-Voraussetzungen

Beitrag von guennid » 13.09.2019 11:18:15

Ich versuch' mich mal wieder mit bluetotooth, und zwar mit meinem einfachen bluetooth-Lautsprecher (war wohl mal Werbegeschenk einer Bierfirma). Versuchsrechner ist ein TP T430 mit stretch, Für den Versuch benutzt wird Backports-Standard-Kern 4.19. bluetooth ist im BIOS aktiviert.
Debianbluetooth ist installiert.

Code: Alles auswählen

hcitool scan
findet kein device. Ich habe noch so'n bluetooth-USB-Dongle (für insider:darf ich jetzt die Bezeichnung „Dongle“ verwenden? :mrgreen: ). Wenn ich den an das T430 anstecke, findet hcitool scan einen BT-Speaker. Zunächst mal versteh' ich das nicht. Ich gehe eigentlich davon aus, dass wenn rechner-firmwareseitig bluetooth aktiviert ist, ich dann doch kein USB-Gerät mehr dafür benötige?

Grüße, Günther
Zuletzt geändert von guennid am 13.09.2019 20:59:53, insgesamt 1-mal geändert.

debianoli
Beiträge: 3353
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: bluetooth-Voraussetzungen

Beitrag von debianoli » 13.09.2019 11:26:00

guennid hat geschrieben: ↑ zum Beitrag ↑
13.09.2019 11:18:15
Ich gehe eigentlich davon aus, dass wenn rechner-firmwareseitig bluetooth aktiviert ist, ich dann doch kein USB-Gerät mehr dafür benötige?
Ich würde mal tippen, dass da kein Bluetooth im Rechner vorhanden ist oder der Treiber nicht geladen ist. Ebenso könnte das eingebaute Bluetooth deaktiviert sein, per BIOS oder per Schalter.

Was zeigt dir denn Debianrfkill an?

Code: Alles auswählen

rfkill list

guennid
Beiträge: 12974
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: bluetooth-Voraussetzungen

Beitrag von guennid » 13.09.2019 11:30:43

Ebenso könnte das eingebaute Bluetooth deaktiviert sein, per BIOS
Dazu hatte ich aber was gesagt! :wink: Welcher (andere) Schalter könnte involviert sein? rfkill kommt gleich.

guennid
Beiträge: 12974
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: bluetooth-Voraussetzungen

Beitrag von guennid » 13.09.2019 11:37:21

rfkill list ohne dongle:

Code: Alles auswählen

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
mit dongle:

Code: Alles auswählen

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

Benutzeravatar
hikaru
Beiträge: 10616
Registriert: 09.04.2008 12:48:59

Re: bluetooth-Voraussetzungen

Beitrag von hikaru » 13.09.2019 11:55:51

Es wurden T430 mit und ohne Bluetooth verkauft. Das ist eine Frage des verbauten WLAN-Moduls (lspci). Manche haben Bluetooth integriert, andere nicht.

Benutzeravatar
kalle123
Beiträge: 774
Registriert: 28.03.2015 12:27:47
Wohnort: Mönchengladbach

Re: bluetooth-Voraussetzungen

Beitrag von kalle123 » 13.09.2019 12:11:25

Wie sieht es denn im TP Bios aus? BT dort vorhanden?

cu KH
ASUS PRIME X370-A + AMD Ryzen 5-2600, Nvidia GEFORCE GT1030
16GB DDR4-2666, DEBIAN-Buster Xfce

guennid
Beiträge: 12974
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: bluetooth-Voraussetzungen

Beitrag von guennid » 13.09.2019 12:15:25

Sacht mal Leute: Lest ihr nicht? Im ersten Post steht:
bluetooth ist im BIOS aktiviert.
:evil:
Und ich hab' schon mal drauf verwiesen.

Benutzeravatar
hikaru
Beiträge: 10616
Registriert: 09.04.2008 12:48:59

Re: bluetooth-Voraussetzungen

Beitrag von hikaru » 13.09.2019 12:43:18

Und du gehst davon aus, dass das BIOS schlau genug ist zu erkennen, ob das WLAN-Modul überhaupt Bluetooth kann?

Benutzeravatar
CH777
Beiträge: 1270
Registriert: 27.05.2008 16:37:17

Re: bluetooth-Voraussetzungen

Beitrag von CH777 » 13.09.2019 12:48:22

In jedem Falle wirst du irgendwann Debianpulseaudio-module-bluetooth (und damit auch pulseaudio) installieren müssen, ist die einzige Möglichkeit für Audioausgabe über bluetooth.

debianoli
Beiträge: 3353
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: bluetooth-Voraussetzungen

Beitrag von debianoli » 13.09.2019 12:53:22

Welcher Bluetooth-Chip ist denn da verbaut? Also lspci oder lsusb
Dann würde ich noch bei den Modulen nach Bluetooth suchen:

Code: Alles auswählen

lsmod | grep -i blu

debianoli
Beiträge: 3353
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: bluetooth-Voraussetzungen

Beitrag von debianoli » 13.09.2019 12:54:26

guennid hat geschrieben: ↑ zum Beitrag ↑
13.09.2019 12:15:25
Sacht mal Leute: Lest ihr nicht? Im ersten Post steht:
bluetooth ist im BIOS aktiviert.
:evil:
Und ich hab' schon mal drauf verwiesen.
Hatte ich tatsächlich überlesen. Wenn du das auch immer so hinflüstern musst beim Schreiben... :mrgreen:

guennid
Beiträge: 12974
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: bluetooth-Voraussetzungen

Beitrag von guennid » 13.09.2019 12:59:48

hikaru hat geschrieben:Und du gehst davon aus, dass das BIOS schlau genug ist zu erkennen, ob das WLAN-Modul überhaupt Bluetooth kann?
Nein, gehe ich nicht. Aber ich weiß nun mal nix und deswegen frage ich. Und mehr, als das was ich weiß, mitzuteilen, vermag ich nun mal nicht. Vielleicht endet der Versuch eh wieder im Chaos. Ich sehe gerade, dass ich den Brauereilautsprecher nach früheren Versuchen mit einer anderen Maschine bereits im März schon mal mit den gleichen Hardwarekomponenten vergeblich mit dem T430 zu pairen versucht habe.(1).

Eine Idee hätte ich noch: Könnte es helfen, die WLAN-NIC des T430 in Stretch zu konfigurieren? Wie weit?

Das ist sie nämlich nicht, weil ich momentan Kabel benutze.

(1) viewtopic.php?f=25&t=172604&hilit=bluetooth

debianoli
Beiträge: 3353
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: bluetooth-Voraussetzungen

Beitrag von debianoli » 13.09.2019 13:10:27

guennid hat geschrieben: ↑ zum Beitrag ↑
13.09.2019 12:59:48
Eine Idee hätte ich noch: Könnte es helfen, die WLAN-NIC des T430 in Stretch zu konfigurieren? Wie weit?

Das ist sie nämlich nicht, weil ich momentan Kabel benutze.
Hast du irgendwo geschrieben, welcher Chip das ist? Ich habe nämlich einen Wlan/Bluetooth-Kombi-Chip im Laptop, der Kombi nicht wirklich kann. Ist so ein Broadcom-Teil

Benutzeravatar
hikaru
Beiträge: 10616
Registriert: 09.04.2008 12:48:59

Re: bluetooth-Voraussetzungen

Beitrag von hikaru » 13.09.2019 13:15:40

War mir doch so, das wir das Thema Bluetooth auf T430 schon mal hatten! Leider haben wir damals nicht geklärt, welches WLAN-Modul bei dir verbaut ist. Oder hatten wir das in einem dritten Thread getan? Mir schwirrt da was im Hinterstübchen tum.
Am einfachsten wäre es, du postest mal den relevanten Teil von lspci.

Lenovo verbaut meines Wissens nach nur Intel Module.* Zumindest Debianfirmware-iwlwifi solltest du wohl installieren, falls du von dem Modul was willst.

Edit: @guennid: Du nutzt doch Selbstbau-Kernels, oder? Vielleicht solltest du da auch noch in die Config schauen. Das aber nur als beiläufigen Einwurf eines Ahnungslosen betrachten!

*) @debianoli: Ja, Broadcom ist die Pest!

guennid
Beiträge: 12974
Registriert: 31.10.2002 19:15:35
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: bei Marburg

Re: bluetooth-Voraussetzungen

Beitrag von guennid » 13.09.2019 13:21:45

Code: Alles auswählen

lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C216 Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C216 Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C216 Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C216 Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C216 Chipset Family SMBus Controller (rev 04)
02:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 [Taylor Peak] (rev 34)
Ich vermute, die letzte Zeile ist zuständig. Debianfirmware-iwlwifi ist installiert. Ab und an benutze ich die NIC ja.

Grüße, Günther

Antworten