[gelöst] Fetchmail Openssl Problem seit Buster zu Debian 7 extendedLTS

Du hast Probleme mit Deinem eMail-Programm, Webbrowser oder Textprogramm? Dein Lieblingsprogramm streikt?
Antworten
Benutzeravatar
xcomm
Beiträge: 715
Registriert: 21.09.2003 05:12:01
Wohnort: Europe
Kontaktdaten:

[gelöst] Fetchmail Openssl Problem seit Buster zu Debian 7 extendedLTS

Beitrag von xcomm » 15.09.2019 11:47:44

Hallo Gemeinde,

habe nach Upgrade des Clients von Stretch auf Buster, Probleme per Fetchmail Mails von einem Debian 7 Frexian Extended LTS Server abholt.
Intessanterweise betrifft das nicht Thunderbird etc, sonsern nur Fetchmail. Eventuell ist auch eine Fetchmail Einstellung schuld.

In der .fetchmailrc stand bisher:
sslproto 'TLS1'

Nach dem Upgrade gibt es nun leider einen OpenSSL/TLS Fehler.

Sep 15 11:38:02 boark fetchmail[18946]: Versuche, mit x.x.x.x/143 zu verbinden...verbunden.
Sep 15 11:38:02 boark fetchmail[18946]: Geladene OpenSSL-Bibliothek 0x1010103f neuer als Header 0x1010101f, versuche, weiterzumachen.
Sep 15 11:38:02 boark fetchmail[18946]: Warnung: SSL_set_tlsext_host_name(0xa543d0, \"\") fehlgeschlagen (code 0), versuche fortzusetzen.
Sep 15 11:38:02 boark fetchmail[18946]: OpenSSL berichtete: error:140D513F:SSL routines:ssl3_ctrl:ssl3 ext invalid servername
Sep 15 11:38:02 boark fetchmail[18946]: OpenSSL berichtete: error:1408F10B:SSL routines:ssl3_get_record:wrong version number
Sep 15 11:38:02 boark fetchmail[18946]: SSL-Verbindung fehlgeschlagen.
Sep 15 11:38:02 boark fetchmail[18946]: Socket-Fehler beim Abholen von mail@example.com@server.ecample.com
Sep 15 11:38:02 boark fetchmail[18946]: 6.4.0.beta4 fragt ab server.example.com (Protokoll IMAP) um So 15 Sep 2019 11:38:02 CEST: Abfrage beendet

Ich vermute, das neue OpenSSL erlaubt keine Verbindung mehr mit dem alten SSLv3 oder TLS 1.1 dort? Wie kann ich das lösen?
(Ich kann den Server wegen einer Legacy Anwendung dort nicht sofort hochziehen.)

Danke, xcomm
Zuletzt geändert von xcomm am 15.09.2019 18:42:42, insgesamt 2-mal geändert.

Benutzeravatar
xcomm
Beiträge: 715
Registriert: 21.09.2003 05:12:01
Wohnort: Europe
Kontaktdaten:

Re: Fetchmail Openssl Problem seit Buster zu Debian 7 extendedLTS

Beitrag von xcomm » 15.09.2019 18:06:15

fetchmail: Loaded OpenSSL library 0x1010103f newer than headers 0x1010101f, trying to continue.

Geladene OpenSSL-Bibliothek 0x1010103f neuer als Header 0x1010101f, versuche, weiterzumachen.

https://bugs.debian.org/cgi-bin/bugrepo ... bug=931568

Benutzeravatar
xcomm
Beiträge: 715
Registriert: 21.09.2003 05:12:01
Wohnort: Europe
Kontaktdaten:

Re: Fetchmail Openssl Problem seit Buster zu Debian 7 extendedLTS

Beitrag von xcomm » 15.09.2019 18:42:06

Konnte den Fehler durch Downgrade von fetchmail erst einmal umgehen.

Code: Alles auswählen

vi /etc/apt/sources.list
deb http://ftp.de.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.de.debian.org/debian/ stretch main non-free contrib
apt-get update
apt-get install fetchmail/stretch
Apt-Pinning, damit fetchmail bei Updates erstmal bei stretch bleibt.

Code: Alles auswählen

vi /etc/apt/preferences

Package: fetchmail
Pin: release a=stretch
Pin-Priority: 600

Package: *
Pin: release a=buster
Pin-Priority: 500

Benutzeravatar
Huck Fin
Beiträge: 1073
Registriert: 10.03.2008 17:10:30

Re: [gelöst] Fetchmail Openssl Problem seit Buster zu Debian 7 extendedLTS

Beitrag von Huck Fin » 17.09.2019 16:32:06

Warum steigst du nicht auf Getmail um ?
Getmail hat glaube ich viel mehr Optionen.

https://de.wikipedia.org/wiki/Getmail

Antworten