[Gelöst] Warum sind die Bilder Grün ???

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
Benutzeravatar
willy4711
Beiträge: 2085
Registriert: 08.09.2018 16:51:16

[Gelöst] Warum sind die Bilder Grün ???

Beitrag von willy4711 » 12.10.2019 15:48:13

Es passiert mir immer häufiger (Browser - unabhängig), dass auf manchen Webseiten die Darstellung von Bildern grün ist.
Erst hatte ich gedacht, es ist Übermüdung ( :mrgreen: :facepalm: ). Aber heute bin ich nicht müde.
Ist das eine Art Kopierschutz ??
Bild
Zuletzt geändert von willy4711 am 13.10.2019 10:07:04, insgesamt 1-mal geändert.

Benutzeravatar
smutbert
Beiträge: 6737
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Warum sind die Bilder Grün ???

Beitrag von smutbert » 12.10.2019 15:58:28

Also bei dem rechten Screenshotausschnitt sind im wesentlich die Farbkanäle rot und grün vertauscht. Tauscht man sie wieder zurück ist das rechte Bild nur mehr etwas stärke gesättigt als das linke.

Wenn das kein Scherz von dir ist (oder einer, den dir jemand mit dir treibt), dann tippe ich auf die Farbverwaltung als Ursache. Zu Testzwecken gibt es beispielsweise Profile, die Farbkanäle vertauschen.

Benutzeravatar
willy4711
Beiträge: 2085
Registriert: 08.09.2018 16:51:16

Re: Warum sind die Bilder Grün ???

Beitrag von willy4711 » 12.10.2019 16:13:36

Ist kein Scherz
Google Bildersuche:
https://www.google.com/search?q=Ilana+K ... 1030&dpr=1
Bild

Gleich das erste Bild:
Vorschau ---> OK
Angeklickt --> (Rechte Seite mit vergrößertem Bild und Quelle): grün :twisted:
Kann ja schlecht dem Browser sagen links bitte dieses und rechts jenes Profil
Egal, in welchen Browser ich das anklicke.
Wie gesagt, das passiert mir öfter mal, auch auf normalen Webseiten.
Kann ja nicht am Farbprofil liegen, da es nicht durchgängig ist. Oder ??
Firefox ---> dto.
Chrom und Chromium --> auch die kleinen Vorschaubilder grün :facepalm:
Der Tor Browser verhält sich als einziger "normal": Angeklickt, wird das Bild ganz kurz grün, wechselt dann aber zu normaler Darstellung.

Den Test hab ich in allen Browsern mir der gleichen URL gemacht.

Wo soll ich da ein Farbprofil einstellen ?

Benutzeravatar
smutbert
Beiträge: 6737
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Warum sind die Bilder Grün ???

Beitrag von smutbert » 12.10.2019 16:49:28

Das Verhalten kann ich zwar nicht nachvollziehen und ich weiß nicht wie es bei dir dazu kommt, aber zwei weitere Puzzlesteine, die vielleicht irgendwann zu einer Erklärung führen:
In der Seitenleiste mit der größeren Vorschau lädt Google, abhängig vom Browser mit Verzögerung das originalgroße Bild nach – das erklärt wieso die Anzeige dort „springen“ kann.

In den Metadaten des Originalbild deines Beispiels steht (laut Debianeog) ein fehlerhafter Farbprofileintrag.
willy4711 hat geschrieben: ↑ zum Beitrag ↑
12.10.2019 16:13:36
Wo soll ich da ein Farbprofil einstellen ?
Selbst wenn du kein Farbprofil selbst eingestellt hast, hast du damit zu tun. Default, also wenn desktopweit (Debiancolord) oder im Programm nichts anderes eingestellt ist, wird für die Darstellung von sRGB ausgegangen. Bilder liegen ebenfalls in einem bestimmten Farbraum vor, dessen Profil entweder eingebettet ist oder es steht zumindest ein hoffentlich bekannter Name in der Bilddatei (oder es wird ebenfalls von sRGB ausgegangen).

Die meisten Browser konvertieren das Bild also bei der Darstellung vom im Bild vorliegenden Farbraum in den Farbraum des Displays um (und selbst dafür gibt es mindestens 3 verschiedene Herangehensweisen).

Wenn du weder colord installiert hast, noch sonst irgendetwas mit Farbprofilen gemacht hast, würde ich in dem Fall von einem unerwünschten Fehlverhalten aufgrund des fehlerhaften Eintrags in der Bilddatei vermuten.

Um welche Debianversion und welches DE handelt es sich denn?
Hast du ein zweites Beispiel, nur um zu sehen ob dort ebenfalls ein fehlerhafter Eintrag in der Bilddatei ist?

Benutzeravatar
willy4711
Beiträge: 2085
Registriert: 08.09.2018 16:51:16

Re: Warum sind die Bilder Grün ???

Beitrag von willy4711 » 12.10.2019 18:15:53

Hallo smubert,
wäre ja schön, wenn ich da dahinter kommen würde.
Also erstmal die Maschine: kopieren geht schneller:

Code: Alles auswählen

System:    Host: debianxfce Kernel: 5.2.0-3-amd64 x86_64 bits: 64 Desktop: Xfce 4.14.1 
           Distro: Debian GNU/Linux bullseye/sid 
Machine:   Type: Desktop Mobo: ASRock model: 970 Performance/3.1 serial: <root required> 
           UEFI [Legacy]: American Megatrends v: P1.10 date: 01/26/2016 
CPU:       Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP L2 cache: 2048 KiB 
           Speed: 2272 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1993 2: 1993 3: 1395 
           4: 1396 5: 1395 6: 1396 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] driver: nvidia v: 430.50 
           Display: x11 server: X.Org 1.20.4 driver: nvidia resolution: 2560x1600~60Hz 
           OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 430.50 
Ich muss dazu sagen ich habe mich um diese Sachen bisher überhaupt nicht gekümmert.
Aber vor kurzem ist mir via Debianxfce4-settings so ein Color- Manager untergejubelt worden.
nennt sich: xfce4-color-settings.
Gut möglich dass seitdem das so ist, ich weiss es aber nicht genau.
Wie auch immer:
Da gibt es 4 Profile da ist folgendes eingestellt::
HP LP3065 (Monitor) ------------------> Best RGB
Generic Cups PDF----------------------> Standard RGB
HP-Laserjet ---------------------------- > Standard Grau
Boomaga Printer-----------------------> Standard Grau

Mein Drucker ist ein schwarz weißer.

Dieses xfce4-color-settings Dings arbeitet anscheinend mit dem von dir erwähnten colord zusammen, auf jeden Fall ist das Ding aktiv:

Code: Alles auswählen

 systemctl status colord
● colord.service - Manage, Install and Generate Color Profiles
   Loaded: loaded (/lib/systemd/system/colord.service; static; vendor preset: enabled)
   Active: active (running) since Sat 2019-10-12 10:32:00 CEST; 7h ago
 Main PID: 1275 (colord)
    Tasks: 3 (limit: 4915)
   Memory: 24.4M
   CGroup: /system.slice/colord.service
           └─1275 /usr/lib/colord/colord

Okt 12 10:32:00 debianxfce systemd[1]: Starting Manage, Install and Generate Color Profiles...
Okt 12 10:32:00 debianxfce systemd[1]: Started Manage, Install and Generate Color Profiles.
Okt 12 10:32:00 debianxfce colord[1275]: failed to get session [pid 1195]: Keine Daten verfügbar
Okt 12 10:32:00 debianxfce colord[1275]: failed to get session [pid 1195]: Keine Daten verfügbar
Okt 12 10:32:00 debianxfce colord[1275]: failed to get session [pid 1195]: Keine Daten verfügbar
Nun kann ich darüber dutzende von Profilen auswählen, deren Existenz mir gänzlich unbekannt ist,
und ich daher nicht weiß , was sie bewirken. BILD;

Bild
smutbert hat geschrieben: ↑ zum Beitrag ↑
12.10.2019 16:49:28
Die meisten Browser konvertieren das Bild also bei der Darstellung vom im Bild vorliegenden Farbraum in den Farbraum des Displays um (und selbst dafür gibt es mindestens 3 verschiedene Herangehensweisen).
Aber dann sollte man doch erwarten, dass sich jeder Browser gleich verhält in identischer Umgebung ?

Ist doch komisch: Chrom und Chromium ----> bei der obigen URL sind selbst die Vorschaubildchen durchwegs grün.
Die drei Mozillas (FF 68.1.0esr / Waterfox 56.2.14 / Tor 8.5.5) verhalten sich zumindest ähnlich.
Allerdings wird beim Tor Browser nach einem kurzem Ausflug ins grüne das Bild dann richtig dargestellt.

Benutzeravatar
smutbert
Beiträge: 6737
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: Warum sind die Bilder Grün ???

Beitrag von smutbert » 12.10.2019 18:59:00

Hinter dem Fenster im Screenshot ist glaube ich das Testprofil zu erahnen, das ich gemeint habe „Testprofil - Swapped Red and Green“ (zu sehen ist nur der Teil, den ich fett geschrieben habe).
Wenn das in xfce möglich ist entferne dieses Profil vom Monitor und stell sicher, dass das einfache sRGB hinzugefügt und ausgewählt/aktiv ist.
Mit etwas Glück hat es sich dann schon erledigt, auch wenn die Ursache zumindest zum Teil im Dunkeln bleibt.

Ansonsten:
Ist dir das schon einmal bei einem Bild aus dem Forum (zB bei einem Screenshot) passiert?
Ein zweites Beispiel wäre vielleicht wirklich auch hilfreich, nur um zu sehen ob das dann ebenfalls in Farprofilhinsicht kaputte Metadaten hat.

Benutzeravatar
willy4711
Beiträge: 2085
Registriert: 08.09.2018 16:51:16

Re: Warum sind die Bilder Grün ???

Beitrag von willy4711 » 13.10.2019 09:57:15

smutbert hat geschrieben: ↑ zum Beitrag ↑
12.10.2019 18:59:00
Wenn das in xfce möglich ist entferne dieses Profil vom Monitor und stell sicher, dass das einfache sRGB hinzugefügt und ausgewählt/aktiv ist.
Mit etwas Glück hat es sich dann schon erledigt, auch wenn die Ursache zumindest zum Teil im Dunkeln bleibt.
Jupp das war es wohl gewesen :THX:

Hab die anderen Profile im Fenster gelöscht und nur noch sRGB drin. Erstmal ist alles "entgrünt" :mrgreen:

Bild

Wenn ich auch keine Ahnung habe, was denn nun der Unterschied zwischen "Best RGB" und "sRGB" ist,
und ob das gar nicht aktivierte „Testprofil - Swapped Red and Green“ da dazwischen gefunkt hat (das war da schon).

Was denn nun Best RGB" ist, konnte mir selbst Tante Google nicht weiterhelfen.
Immerhin bin ich aber etwas über sRGB "erhellt"
https://www.karsten-kettermann.com/blog/farbraum schreibt ganz nett:
Wir schreiben das Jahr 1996. Vor wenigen Wochen hat sich der örtliche Fensterrat der Microsoft-Galaxie mit Vertretern der HewlettPackard’schen Produktionsstätte für Tintenpiesler getroffen und dem Universum Heilung versprochen: Endlich sollten Fotos auf allen Geräten im ganzen Universum gleich aussehen! Man will dafür den sRGB-Farbraum einführen und allen soll geholfen sein.
Na dann werde ich mal das Thema für erledigt erklären.
Hab Dank für deinen Tipps smutbert, hat mal wieder geholfen :THX:
smutbert hat geschrieben: ↑ zum Beitrag ↑
12.10.2019 18:59:00
Ist dir das schon einmal bei einem Bild aus dem Forum (zB bei einem Screenshot) passiert?
Ein zweites Beispiel wäre vielleicht wirklich auch hilfreich, nur um zu sehen ob das dann ebenfalls in Farprofilhinsicht kaputte Metadaten hat.
Ich werde mal weiter beobachten. Vielleicht auch noch mal umstellen. Und ja Irgendwann war mal das Logo von Forum links oben
grün. Dann denkt man man hat es mit den Augen :facepalm:

Benutzeravatar
smutbert
Beiträge: 6737
Registriert: 24.07.2011 13:27:39
Wohnort: Graz

Re: [Gelöst] Warum sind die Bilder Grün ???

Beitrag von smutbert » 13.10.2019 11:05:09

Wenn das Debianlogo auch schon einmal grün war, dann sind die kaputten Metadaten der ersten Beispieldatei kaum schuld daran, sondern vermutlich irgendein Fehler von xfce4-color-settings oder colord oder einer der beteiligten Bibliotheken, der in testing wahrscheinlich genauso wieder verschwinden wird wie er gekommen ist.


„Best RGB“ ist größer (in Richtung auch intensivere Farbtöne) als sRGB. „Best RGB“ ist Teil des Pakets Debiancolord-data (/usr/share/color/icc/colord/BestRGB.icc) und enthält sogar eine Beschreibung
Dieser Bearbeitungsraum kann gesättigtere Farben wiedergeben als Adobe RGB und ist für Bilder mit stark gesättigten Farben geeignet, wie sie in der Werbung oft erscheinen. Er ist sehr ähnlich zu DonRGB4, kann aber extrem gesättigte rote Farben darstellen, wie sie manchmal in Fujichrome Velvia vorhanden sind.
Nachdem du mit dem Profil aber sozusagen die Fähigkeiten deines Geräts zur Darstellung, in dem Fall also deines Monitors angibst, sollten mit „Best RGB“ die Farben etwas flauer, weniger gesättigt aussehen (als zB mit sRGB).

Und es steht auch in der Beschreibung, was der Name nahelegt („Bearbeitungsraum“):
Das Profil ist nicht als Monitorprofil gedacht sondern dazu da, dass darin Bilder bearbeitet und gegebenenfalls auch gespeichert werden, damit man bei der Bearbeitung und Speicherung möglichst alle Farben zur Verfügung hat, selbst wenn diese dann auf keinem oder kaum einem Ausgabegerät dargestellt werden können.


Warum deinem Monitor also ausgerechnet zwei vollkommen ungeeignete Farbprofile zugeordnet waren, Best RGB und das Testprofil mit vertauschtem Rot und Grün, verstehe ich nicht im geringsten. Wenn das die Standardeinstellungen nach der Installation von xfce4-color-settings/colord sind, sollten die Entwickler auch daran noch einmal arbeiten :wink:

Antworten