PHP7.2 auf Debian 10 installieren

Debian macht sich hervorragend als Web- und Mailserver. Schau auch in den " Tipps und Tricks"-Bereich.
Antworten
DebianFan89
Beiträge: 8
Registriert: 10.11.2019 14:27:22

PHP7.2 auf Debian 10 installieren

Beitrag von DebianFan89 » 10.11.2019 14:31:20

Hallo

Ich benötige für eine bestimmte Software php7.2-fpm.

APT lässt mich allerdings nur 7.3 installieren.

"apt install php7.2-fpm" wirft aus:
E: Unable to locate package php7.2-fpm
E: Couldn't find any package by glob 'php7.2-fpm'
E: Couldn't find any package by regex 'php7.2-fpm'

Wie bekomme ich php7.2 installiert? Ich verwende Debian 10.1

Danke sehr.

Benutzeravatar
feltel
Webmaster
Beiträge: 9747
Registriert: 20.12.2001 13:08:23
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Leipzig, Germany
Kontaktdaten:

Re: PHP7.2 auf Debian 10 installieren

Beitrag von feltel » 10.11.2019 15:56:02

Schau mal auf https://deb.sury.org/. Dort müsste es einen sog. Backport von PHP 7.2 auch für Debian Buster geben. Die Pakete baut der "originale" Maintainer der Debian-PHP-Pakete, die Quelle ist also vertrauenswürdig.

DebianFan89
Beiträge: 8
Registriert: 10.11.2019 14:27:22

Re: PHP7.2 auf Debian 10 installieren

Beitrag von DebianFan89 » 10.11.2019 16:37:59

Danke

Ich nehme an, ich füge die dann damit hinzu oder?
> https://packages.sury.org/php/README.txt

/edit ok hab es, danke nochmal

Benutzeravatar
feltel
Webmaster
Beiträge: 9747
Registriert: 20.12.2001 13:08:23
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Leipzig, Germany
Kontaktdaten:

Re: PHP7.2 auf Debian 10 installieren

Beitrag von feltel » 10.11.2019 16:43:46

Ja, das lässt sich in Deinem Fall aber auf den folgenden Dreizeiler als root auszuführen einkürzen:

Code: Alles auswählen

apt-get -y install apt-transport-https lsb-release ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg
echo "deb https://packages.sury.org/php/ buster main" > /etc/apt/sources.list.d/php.list
Danach ein "apt-get update" und schon sollte sich PHP 7.2 mit "apt-get install php7.2" installieren lassen.

Antworten