`ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ? [Gelöst]

Warum Debian? Was muss ich vorher wissen? Wo geht's nach der Installation weiter?
Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ? [Gelöst]

Beitrag von jmar83 » 15.01.2020 16:33:13

Was passiert, war ja schon klar und offensichtlich. Die Frage war eher "Warum ist das so, was ist die Idee/Logik resp. das Konzept dahinter?"

Habe seit ca. 1995 mit Computern zu tun, 2008 habe ich als Informatiker die Ausbildung gemacht (Im Lehrbetrieb als Applikationsentwickler) und seit ca. 2010 mittelmässig intensiver Linux-Benutzer. Seit 2018 habe ich damit RICHTIG zu tun (Gebäudeautomation mit Raspi und Raspbian als Basis) und seit dann bringt es mich regelmässig "auf die Palme".

Window$ natürlich sowieso, aber zuhause bekommt davon kaum jemand was mit über! ;-)

Aber sowas ist mir, ganz ehrlich gesagt, noch nie aufgefallen...!?

Linux ist im Prinzip absolut logisch aufgebaut, aber diese Logik ist oft nicht sofort ersichtlich / ergründlich. Und Linux kann man ABSOLUT UNMÖGLICH* über Intuition lernen (deshalb ist es auch nicht "Mainstream", aber es ist ja auch nicht das Ziel das zu werden), so wie ich es damals 1997 mit Win95 gemacht habe mit dem AMD K6 mit 200MHz und 32MB RAM... natürlich ohne Internet, bestenfalls mit ein paar Zeitschriften. "Dicke" IT-Bücher konnte ich mir damals als Schüler eh nicht leisten! ;-)
Zuletzt geändert von jmar83 am 16.01.2020 15:14:01, insgesamt 1-mal geändert.
Freundliche Grüsse, Jan

uname
Beiträge: 10174
Registriert: 03.06.2008 09:33:02

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von uname » 15.01.2020 16:35:49

Vielleicht könntest du mal die Ausgabe von env (bzw. genauer /usr/bin/env) sowohl in der Shell als auch im Script ausführen lassen und hier jeweils posten. Danke. Vielleicht kann dir geholfen werden, wenn die Shell verändert wird (/etc/passwd) bzw. wenn du einen Shebang benutzt.
Zuletzt geändert von uname am 15.01.2020 16:36:44, insgesamt 1-mal geändert.

Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von jmar83 » 15.01.2020 16:36:18

SSH-Keys habe ich dem Vorgesetzten vorgeschlagen, inzwischen habe ich ja eine "Lösung" (na ja) ohne SSH-Keys gefunden und es wurde gemeint man könne das dann eines Tages, "wenn Zeit dafür besteht", anschauen. So long...
Freundliche Grüsse, Jan

uname
Beiträge: 10174
Registriert: 03.06.2008 09:33:02

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von uname » 15.01.2020 16:37:58

Das mit den SSH-Keys dauert nur Minuten. Schade drum. Aber poste trotzdem mal die Ausgaben von "env". Evtl. entferne vertrauliche Informationen. Mich interessieren vor allen die Pfade und die Shell. Poste weitere interessante Inhalte falls vorhanden.

Code: Alles auswählen

env|grep SHELL
env|grep PATH

Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von jmar83 » 15.01.2020 16:44:19

Ausgabe von env` des lokalen Servers (vor Ort) des MariaDB-Master/Master-Clusters unter der aktuellsten Version von Debian 9:

Code: Alles auswählen

root@xili:/etc/mysql# env
SSH_CONNECTION=*.*.*.* 52732 *.*.*.* 22
LANG=de_CH.UTF-8
XDG_SESSION_ID=3
USER=root
PWD=/etc/mysql
HOME=/root
SSH_CLIENT=*.*.*.* 52732 22
SSH_TTY=/dev/pts/0
MAIL=/var/mail/root
TERM=xterm
SHELL=/bin/bash
SHLVL=1
LANGUAGE=de_CH:de
LOGNAME=root
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/0/bus
XDG_RUNTIME_DIR=/run/user/0
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
_=/usr/bin/env
OLDPWD=/etc/mysql/test

Ausgabe von env` des remote-Servers (Strato-VServer) des MariaDB-Master/Master-Clusters unter Ubuntu 18.x LTS:

Code: Alles auswählen

root@xxx:/etc/mysql# env
LC_ALL=de_DE.utf8
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
SSH_CONNECTION=*.*.*.* 6251 *.*.*.* 22
LESSCLOSE=/usr/bin/lesspipe %s %s
LANG=de_DE.utf8
USER=root
PWD=/etc/mysql
HOME=/root
SSH_CLIENT=*.*.*.* 6251 22
SSH_TTY=/dev/pts/0
MAIL=/var/mail/root
TERM=xterm
SHELL=/bin/bash
SHLVL=1
LANGUAGE=de_DE.utf8
LOGNAME=root
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
LESSOPEN=| /usr/bin/lesspipe %s
_=/usr/bin/env
OLDPWD=/etc/mysql/test
IPs habe ich zensiert.

(Und der MariaDB Master/Master-Cluster läuft einwandfrei auf beiden Serverm MariaDB 10.x mit geringem Versionsunterschied. Klar, besser wäre alles gleich: Linux, DBMS etc. pp.)
Freundliche Grüsse, Jan

Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von jmar83 » 15.01.2020 16:46:12

Strato:

Code: Alles auswählen

root@xxx:~# env|grep SHELL
SHELL=/bin/bash
root@xxx:~# env|grep PATH
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games

Lokal:

Code: Alles auswählen

root@xili:~# env|grep SHELL
SHELL=/bin/bash
root@xili:~# env|grep PATH
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
root@xili:~#
Freundliche Grüsse, Jan

uname
Beiträge: 10174
Registriert: 03.06.2008 09:33:02

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von uname » 15.01.2020 16:56:15

Aufgrund der Pfade hätte es funktionieren müssen. Die Wahl der Shell Bash ist auch nicht schlecht.
Sieht die Ausgabe anders aus, wenn du /usr/bin/env im Script aufrufst (also dort wo dein ssh stand, also clientseitig)?
Serverseitig war es ja eigentlich gar nicht interessant, da ssh ja eine Clientanwendung ist. War mein Fehler.

Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von jmar83 » 15.01.2020 19:07:03

Ja, auf dem Client (der das Client-SSL-Zerti zu anderen MySQL-Cluster-Teilnehmer übermitteln soll) trat das Problem auf. Und zwar auf dem Ubuntu 18.x LTS/Plesk Obsidian-VServer bei Strato.

Bei uns lokal habe ich es noch nicht getestet mit Debian 9, habe das Skript dann einfach mit dem abs. Pfad laufen lassen und gut ist. Werde ich aber auch noch anschauen was Sache ist.

Werde morgen auch noch schauen was mir `/usr/bin/env` ausgibt auf beiden Servern ausgibt, vielen Dank noch mal! :-)
Freundliche Grüsse, Jan

Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von jmar83 » 16.01.2020 15:17:53

Hier noch die Ausgabe von `/usr/bin/env` vom lok. Server / Deb9:

Code: Alles auswählen

root@xili:/etc/mysql/client_cert# /usr/bin/env
SSH_CONNECTION=*.*.*.* 50697 *.*.*.* 22
LANG=de_CH.UTF-8
XDG_SESSION_ID=126
USER=root
PWD=/etc/mysql/client_cert
HOME=/root
SSH_CLIENT=*.*.*.* 50697 22
SSH_TTY=/dev/pts/0
MAIL=/var/mail/root
TERM=xterm
SHELL=/bin/bash
SHLVL=1
LANGUAGE=de_CH:de
LOGNAME=root
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/0/bus
XDG_RUNTIME_DIR=/run/user/0
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
_=/usr/bin/env
OLDPWD=/etc/mysql


Strato-Vserver / Ubuntu 18.x LTS:

Code: Alles auswählen

 /usr/bin/env
LC_ALL=de_DE.utf8
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
SSH_CONNECTION=*.*.*.* 50701 *.*.*.* 22
LESSCLOSE=/usr/bin/lesspipe %s %s
LANG=de_CH.UTF-8
OLDPWD=/etc/mysql
USER=root
PWD=/etc/mysql/client_cert
HOME=/root
SSH_CLIENT*.*.*.* 50701 22
SSH_TTY=/dev/pts/0
MAIL=/var/mail/root
TERM=xterm
SHELL=/bin/bash
SHLVL=1
LANGUAGE=de_CH:de
LOGNAME=root
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
LESSOPEN=| /usr/bin/lesspipe %s
_=/usr/bin/env

Noch mal vielen vielen Dank für deine Hilfe!!
Freundliche Grüsse, Jan

KP97
Beiträge: 2106
Registriert: 01.02.2013 15:07:36

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von KP97 » 16.01.2020 15:29:05

@jmar83
Nicht alles sind Grundsatzfragen, schon mal den erklärenden Text für den Forenbereich gelesen?
Wenn das so wäre, bräuchte es keine Unterteilungen, sondern nur einen Bereich, wo jeder seinen Kram ablädt.

uname
Beiträge: 10174
Registriert: 03.06.2008 09:33:02

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von uname » 16.01.2020 16:31:29

@KP97 Manchmal ist es schwer zuzurdnen. Aber so schlecht ist "Grundsatzfragen" auch nicht.

@jmar83
Ich verstehe immer noch nicht, warum das Programm einen absoluten Pfad benötigt.
Aber du kannst das Problem ja durch Angabe von /usr/bin/ssh lösen. Ist auch grundsätzlich die bessere Vorgehensweise.

Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von jmar83 » 16.01.2020 16:52:04

Ich sehe sowas als etwas absolut grundlegendes, auch wenn ich mit meinen mittelmässigen Linux-Kenntnissen nie damit konfrontiert wurde.
"Aber du kannst das Problem ja durch Angabe von /usr/bin/ssh lösen. Ist auch grundsätzlich die bessere Vorgehensweise."
Mach ich jetzt auch so, und wohl auch des öfteren in Zukunft - selbst wenn kein abs. Pfad benötigt wird! ;-)
Freundliche Grüsse, Jan

uname
Beiträge: 10174
Registriert: 03.06.2008 09:33:02

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von uname » 16.01.2020 16:57:37

Ich glaube es fehlt noch die Ausgabe von /usr/bin/env direkt im Script eingetragen, wo jetzt /usr/bin/ssh steht.
Vielleicht weicht dort ja was ab.

Benutzeravatar
jmar83
Beiträge: 568
Registriert: 20.06.2013 20:20:15

Re: `ssh`-Befehl in Shell-Skript ohne absoluten Pfad - "Befehl nicht gefunden" ?

Beitrag von jmar83 » 16.01.2020 17:10:52

OK, Shellskript ist folgendes, inkl. meinem Standard-Bash-Header, falls man es mit bash DATEI.SH ausführt wird `+x` automatisch gesetzt - na ja, mehr oder weniger nützlich, schaden tut es aber nicht. und `set -e` erhöht meiner Meindung nach die Qualität von Shell-Skripts ;-) Allerdings ist es ziemlich doof, wenn z.B. ls nix findet und dann einen error code unglich 0 zurückgibt... dann muss man halt Sachen machen wie `BEFEHL ... ||:` - na ja, bekanntlich hat alle seine Vor- und Nachteile. Fragt sich nur was von beidem überwiegt! ;-)

Inhalt test.sh:

Code: Alles auswählen

set -e > /dev/null 2>&1 && set +x > /dev/null 2>&1;
FILE="$(basename "$(test -L "$0" && readlink "$0" || echo "$0")")";
DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" >/dev/null 2>&1 && pwd )" && chmod +x "$DIR/$FILE";
/usr/bin/env

Und so reagiert's:

Strato VServer / Ubuntu 18.x LTS:

Code: Alles auswählen

root@xxx:~# ./test.sh
LC_ALL=de_DE.utf8
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.zst=01;31:*.tzst=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.wim=01;31:*.swm=01;31:*.dwm=01;31:*.esd=01;31:*.jpg=01;35:*.jpeg=01;35:*.mjpg=01;35:*.mjpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=00;36:*.au=00;36:*.flac=00;36:*.m4a=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:*.oga=00;36:*.opus=00;36:*.spx=00;36:*.xspf=00;36:
SSH_CONNECTION=*.*.*.* 51133 *.*.*.* 22
LESSCLOSE=/usr/bin/lesspipe %s %s
LANG=de_DE.utf8
USER=root
PWD=/root
HOME=/root
SSH_CLIENT=*.*.*.* 51133 22
SSH_TTY=/dev/pts/1
MAIL=/var/mail/root
SHELL=/bin/bash
TERM=xterm
SHLVL=2
LANGUAGE=de_DE.utf8
LOGNAME=root
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
LESSOPEN=| /usr/bin/lesspipe %s
_=/usr/bin/env
root@xxx:~#

Lokaler Server Debian 9:

Code: Alles auswählen

root@xili:/etc/mysql# ./test.sh
SSH_CONNECTION=*.*.*.* 50697 *.*.*.* 22
LANG=de_CH.UTF-8
OLDPWD=/etc/php/7.0/cli
XDG_SESSION_ID=126
USER=root
PWD=/etc/mysql
HOME=/root
SSH_CLIENT=*.*.*.* 50697 22
SSH_TTY=/dev/pts/0
MAIL=/var/mail/root
SHELL=/bin/bash
TERM=xterm
SHLVL=2
LANGUAGE=de_CH:de
LOGNAME=root
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/0/bus
XDG_RUNTIME_DIR=/run/user/0
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
_=/usr/bin/env
root@xili:/etc/mysql#
Freundliche Grüsse, Jan

Antworten