Bullseye gdm3 startet nicht mehr

KDE, Gnome, Windowmanager, X11, Grafiktreiber und alles was dazu notwendig ist. Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Artim
Beiträge: 30
Registriert: 22.11.2019 11:33:28

Bullseye gdm3 startet nicht mehr

Beitrag von Artim » 16.01.2020 16:52:32

Seit einem gestrigen Neustart will auf unserem Rechner mit Bullseye gdm3 nicht mehr starten. So wirklich einen Grund finde ich nicht. journalctl gibt zwar

Code: Alles auswählen

systemd: Dependency failed for GNOME Wayland Session
zurück, was nach einem Fehler mit Wayland klingt, aber es einfach zu deaktivieren erzeugt nur

Code: Alles auswählen

/usr/lib/gdm3/gdm-x-session Unable to run X server
Oder etwas ausführlicher

Code: Alles auswählen

Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         AMD Radeon HD 6300 Series Graphics,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         AMD Radeon HD 6200 Series Graphics, PALM, CYPRESS,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         AMD Firestream 9350, ATI Radeon HD 5800 Series,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ATI Radeon HD 5670, ATI Radeon HD 5570, ATI Radeon HD 5500 Series,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         REDWOOD, ATI Mobility Radeon Graphics, CEDAR, ATI FirePro 2270,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ATI Radeon HD 5450, CAYMAN, AMD Radeon HD 6900 Series,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series, BARTS,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         AMD Radeon HD 6800 Series, AMD Radeon HD 6700 Series, TURKS, CAICOS,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ARUBA, TAHITI, PITCAIRN, VERDE, OLAND, HAINAN, BONAIRE, KABINI,
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         MULLINS, KAVERI, HAWAII
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) modesetting: Driver for Modesetting Kernel Drivers: kms
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) FBDEV: driver for framebuffer: fbdev
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) VESA: driver for VESA chipsets: vesa
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (EE) open /dev/dri/card0: No such file or directory
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (WW) Falling back to old probe method for modesetting
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (EE) open /dev/dri/card0: No such file or directory
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) Loading sub module "fbdevhw"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) LoadModule: "fbdevhw"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) Module fbdevhw: vendor="X.Org Foundation"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         compiled for 1.20.6, module version = 0.0.2
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ABI class: X.Org Video Driver, version 24.0
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (EE) Unable to find a valid framebuffer device
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (WW) Falling back to old probe method for fbdev
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) Loading sub module "fbdevhw"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) LoadModule: "fbdevhw"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) Module fbdevhw: vendor="X.Org Foundation"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         compiled for 1.20.6, module version = 0.0.2
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]:         ABI class: X.Org Video Driver, version 24.0
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) FBDEV(2): using default device
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (EE) Screen 0 deleted because of no matching config section.
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) UnloadModule: "modesetting"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (EE) Screen 0 deleted because of no matching config section.
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) UnloadModule: "fbdev"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (II) UnloadSubModule: "fbdevhw"
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (EE)
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: Fatal server error:
Jan 16 16:34:11 pc01 /usr/lib/gdm3/gdm-x-session[2472]: (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
Ein Neuinstallieren der diversen Grafiktreiber (es kommen die non-free zum Einsatz, da die Standard Treiber zumindest das gleiche Bild zeigen, also schwarzer Bildschrim mit blinkendem Cursor, bei den Fehlermeldungen kann ich nichts zu sagen) und er Pakete für Weston, XWayland und den X Server haben bisher nichts gebracht.
Als Kernel läuft 5.3.0.2, ein Update ist aktuell nicht möglich, wird aber schon in einem anderen Beitrag diskutiert.
Hat jemand eine Idee was da aktuell schief läuft? Wie gesagt, es sind alle aktuellen Pakete installiert, apt-get -f install findet auch nichts und es wollte einfach nach einem reboot nicht mehr.

Benutzeravatar
towo
Beiträge: 3491
Registriert: 27.02.2007 19:49:44
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Bullseye gdm3 startet nicht mehr

Beitrag von towo » 16.01.2020 16:55:58

1. Mit dem halben Logfile kann niemand etwas anfangen!
2. Du hast ATI Grafik, da gibts keinen unfreien Treiber, nur unfreie Firmware!
3. Es wäre halt von Vorteil zu wissen, was zuvor Du gemacht hast, dass es nicht mehr funktionierte.

Artim
Beiträge: 30
Registriert: 22.11.2019 11:33:28

Re: Bullseye gdm3 startet nicht mehr

Beitrag von Artim » 16.01.2020 19:06:44

towo hat geschrieben: ↑ zum Beitrag ↑
16.01.2020 16:55:58
1. Mit dem halben Logfile kann niemand etwas anfangen!
2. Du hast ATI Grafik, da gibts keinen unfreien Treiber, nur unfreie Firmware!
3. Es wäre halt von Vorteil zu wissen, was zuvor Du gemacht hast, dass es nicht mehr funktionierte.
1. Es bringt kaum etwas hier einen kompletten journalctl dump hier rein zu schmeißen. Alles an Fehler was da aufkam steht eigentlich drin.

2. Gut, dann halt so rum. Ich meine halt firmware-linux-nonfree und firmware-amd-graphics

3. Wie gesagt, den PC neu gestartet. Klar, das war entsprechend viewtopic.php?f=34&t=176042 um Änderungen zu übernehmen damit wie ganz am Ende .cache nach /tmp gemounted wird und vorher das Skript ausgeführt wird um den Ordner zu erzeugen. Aber die dafür zuständigen Änderungen habe ich bereits alle deaktiviert, sogar die zum erstellen der ramdisk. Sonst nichts.

Artim
Beiträge: 30
Registriert: 22.11.2019 11:33:28

Re: Bullseye gdm3 startet nicht mehr

Beitrag von Artim » 17.01.2020 14:19:12

Hab mal einen detailierten Log vom Neustart von GDM3 mit systemctl aufgenommen. Beim Anonymisieren sind mir noch ein paar LDAP Fehler aufgefallen. Die sollte man aber ignorieren können, hätten die eine Relevanz könnten wir uns nicht zumindest in der Bash in unsere Accounts einloggen.
https://pastebin.com/6RMYiVgn

Edit: im Log wird erwähnt Gnome habe keinen Zugriff auf die Framebuffer. /dev/fb0 ist aber vorhanden

Artim
Beiträge: 30
Registriert: 22.11.2019 11:33:28

Re: Bullseye gdm3 startet nicht mehr

Beitrag von Artim » 18.01.2020 17:44:13

Ok, ich habe heute noch ein bisschen herumprobiert. in einer Debian Mailing-List bin ich auch den Befehl "Xorg -configure" gestoßen, der zwar nur selten etwas bewirkt, aber da ich dort eine Fehlermeldung erhalten habe, habe ich journalctl wieder befragt und bin auf

Code: Alles auswählen

AMDGPU[KMS] drm report modesetting isn't supported.
gestoßen (https://pastebin.com/erjbzzde). Wirklich hilfreich war das bisher aber noch nicht. Damit bin ich z.B. darauf gestoßen die Blacklists in /etc/modprobe.d/ rauszuschmeißen. ein Umbenennen von blacklist-radeon.conf und amd64-microcode-blacklist.conf hat aber scheinbar nichts geändert, daher habe ich beide auch wieder zurückgeändert. Der Hinweis Pakete wie libgl1-fglrx-glx, xserver-xorg-video-amdgpu, xorg-video-abi* und xserver-xorg-core rauszuschmeißen und xserver-xorg-video-ati und firmware-linux-nonfree (neu) zu installieren hat aber bisher nichts gebracht.
Bin zwar über ähnliche Probleme gestoßen, etwas hilfreiches war aber bisher leider nicht dabei: https://bugs.debian.org/cgi-bin/bugrepo ... bug=927219

Antworten