STRG-Tasten funktionieren nicht

Hast Du Probleme mit Hardware, die durch die anderen Foren nicht abgedeckt werden? Schau auch in den "Tipps und Tricks"-Bereich.
vdvogt
Beiträge: 301
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

STRG-Tasten funktionieren nicht

Beitrag von vdvogt » 16.01.2020 19:04:15

Hallo,
ich habe ein Tuxedo Book BC1707 v2 von 2017.
Darauf laeuft Debian 10 mit KDE.
Vor ein paar Tagen habe ich mir von Tuxedo einen Tastaturtreiber heruntergeladen und installiert.
(siehe diese Anleitung:
https://www.tuxedocomputers.com/de/Info ... ren.tuxedo)

Seitdem funktionieren die STRG-Tasten nicht mehr. Nirgendwo.
Weder in Firefox, Kate, LibreOffice noch in der Konsole oder im XTerminal versucht. Nichts!

Ich habe bisher das halbe Internet durchsucht und auch hier das debian-forum, aber bisher habe ich keine Loesung gefunden, wie ich die STRG-Tasten wiederbekomme.

Wer kann mir helfen?

Viele Gruesse
Veit

eggy
Beiträge: 2024
Registriert: 10.05.2008 11:23:50

Re: STRG-Tasten funktionieren nicht

Beitrag von eggy » 16.01.2020 22:14:49

Versuch mal, ob "rmmod tuxedo_keyboard" (als root) hilft.
Dann deren Support kontaktieren, die werden da eher weiterhelfen können.

vdvogt
Beiträge: 301
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: STRG-Tasten funktionieren nicht

Beitrag von vdvogt » 16.01.2020 22:33:34

Hallo eggy,
ich habe rmmod ausprobiert.
Im anschliessenden lsmod war tuxedo_keyboard nicht mehr gelistet.
Trotzdem funktionieren die STRG-Tasten immer noch nicht.

Den Tuxedo-Support hatte ich diesbezueglich schon kontaktiert, sie schrieben mir, dass sie Debian nicht unterstuetzen und sie nichts fuer mich tun koennen. (Die haben nur Ubuntu-Support, oder fuer ihre eigene Linux-Distribution).
Eigentlich schade, denn die Laptops von Tuxedo sind wirklich gut.

Daher jetzt meine Anfrage hier im Forum.

Gruesse
Veit

eggy
Beiträge: 2024
Registriert: 10.05.2008 11:23:50

Re: STRG-Tasten funktionieren nicht

Beitrag von eggy » 16.01.2020 23:52:31

Du könntest mal ausprobieren, was passiert, wenn Du die Deinstallationsanweisungen von der Seite befolgst (dann reboot). Wenns dann immer noch nicht funktioniert, mal ne Live CD ausprobieren.

vdvogt
Beiträge: 301
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: STRG-Tasten funktionieren nicht

Beitrag von vdvogt » 20.01.2020 18:56:05

Hallo eggy,
sorry, dass ich jetzt erst antworte, ich war uebers WE weg.

Ich habe den Tuxedo Tastaturtreiber vollstaendig deinstalliert und anschliessend ein reboot gemacht.
Trotzdem sind weiterhin beide STRG-Tasten deaktiviert.

Gibt es irgendeine Tastenkombination auf die ich zufaelligerweise getappt bin, die die STRG-Tasten deaktivieren?

Ich habe mir auch mal meine Systemeinstellungen zu "Eingabegeraete -> Tastatur-Hardware und -belegung" angeschaut.
Tastatur-Modell steht auf: Generic | generische PC-Tastatur mit 105 Tasten (Intl).
Unter dem Reiter Hardware habe ich den Zehnerblock und die Tastenwiederholung eingeschaltet.
Unter Belegungen habe ich Belegungsanzeige und Beschriftungen aktiviert; Umschaltregelung steht auf Global; bei Kurzbefehle zum Belegungswechsel sind alle drei Einstellungen aus "keine".

Bevor ich jetzt wild drauflos alle moeglichen Einstellungen durchprobiere, haette ich gerne Vorschlaege von Experten fuer ein planvolles Vorgehen.

Vielen Dank im Voraus!

Gruesse
Veit

Benutzeravatar
king-crash
Beiträge: 544
Registriert: 08.08.2006 12:07:56
Lizenz eigener Beiträge: MIT Lizenz

Re: STRG-Tasten funktionieren nicht

Beitrag von king-crash » 20.01.2020 20:26:11

Du könntest als Erstes mit

Code: Alles auswählen

xinput test-xi2 --root
schauen ob tatsächlich kein Key Event kommt.
Als Nächstes würde ich auch einen Test mit einem Livesystem vorschlagen.

vdvogt
Beiträge: 301
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: STRG-Tasten funktionieren nicht

Beitrag von vdvogt » 21.01.2020 03:51:51

Hallo king-crash,
ich habe xinput installiert und wie Du vermutet hast, kommt kein Key Event wenn ich die STRG-Tasten druecke. Bei allen anderen Tasten wird was angezeigt.
Den Test mit Knoppix mache ich gleich...

Gruesse
Veit

vdvogt
Beiträge: 301
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: STRG-Tasten funktionieren nicht

Beitrag von vdvogt » 21.01.2020 04:38:26

Hallo king-crash,
ich habe gerade den Test mit Knoppix gemacht:
Leider auch hier funktionieren die STRG-Tasten nicht!

Heisst das jetzt, dass die Tastaut kaputt ist, oder gibt es eine Moeglichkeit, das zu reparieren.

Kann man den Tastaturtreiber etwa neu installieren?

Oder stimmt was mit meinen Systemeinstellungen nicht?

Gruesse
Veit

Benutzeravatar
CH777
Beiträge: 1310
Registriert: 27.05.2008 16:37:17

Re: STRG-Tasten funktionieren nicht

Beitrag von CH777 » 21.01.2020 10:00:32

vdvogt hat geschrieben: ↑ zum Beitrag ↑
21.01.2020 04:38:26
ich habe gerade den Test mit Knoppix gemacht:
Leider auch hier funktionieren die STRG-Tasten nicht!
Dann ist es jedenfalls kein Debian-Problem. Du solltest den Tuxedo-Support nochmal darauf hinweisen.

pferdefreund
Beiträge: 3539
Registriert: 26.02.2009 14:35:56

Re: STRG-Tasten funktionieren nicht

Beitrag von pferdefreund » 21.01.2020 12:22:46

Eventuell ist die Taste ja wirklich kaputt. Was ist das eigentlich für eine Tastatur - kann man da gegebenfalls was aufmachen, reinigen oder so ? Ein Krümel zwischen den Kontakten langt schon, dass die Taste nicht mehr geht, so er zwischen den Kontakten liegt.

Benutzeravatar
Heliosstyx
Beiträge: 185
Registriert: 14.03.2019 13:25:59

Re: STRG-Tasten funktionieren nicht

Beitrag von Heliosstyx » 21.01.2020 13:24:45

Stecke einfach eine externe Tastatur an und prüfe, ob da alles funktioniert? Wenn ja, dann reinige mit Druckluft Deine Notebook-Tastatur und falls das nichts hilft, öffne das Notebook und prüfe die Flachbandkabelverbindung zum Mainboard und der Tastatur. Ansonsten wenn Du keine Garantie mehr hast und ein Servicecenter in Deiner Nähe mehr verlangt, als das Gerät wert ist, dann entsorge das Gerät fachgerecht. :mrgreen:
8)

Benutzeravatar
snyborg
Beiträge: 226
Registriert: 08.08.2007 22:07:32
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: 127.0.0.1

Re: STRG-Tasten funktionieren nicht

Beitrag von snyborg » 21.01.2020 13:34:02

vllt. hilft xev aus Debianx11-utils zur weiteren Analyse?
Wenn deine Freunde Linux haben, wechsel zu Linux.
Wenn deine Freunde BSD haben, wechsel zu BSD.
Wenn deine Freunde Windows haben, wechsel deine Freunde.

vdvogt
Beiträge: 301
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: STRG-Tasten funktionieren nicht

Beitrag von vdvogt » 22.01.2020 13:25:23

Hallo,
1. es sind beide STRG-Tasten, die nicht funktionieren, das schliesst es aus, dass irgendwelche Kruemel in der Tastatur sind.
Ausserdem esse ich nicht am Arbeitsplatz.
2. Das Laptop ist grade mal drei Jahre alt und durchaus noch einiges Wert, also Entsorgen kommt ueberhaupt nicht in Frage.

3. xev:
Folgende Ausgabe in Bezug zur Tastatur habe ich bekommen, als ich die STRG-Tasten gedrueckt habe:

Code: Alles auswählen

KeymapNotify event, serial 32, synthetic NO, window 0x0,
    keys:  34  0   0   0   16  0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0 

KeyRelease event, serial 36, synthetic NO, window 0x6c00001,
    root 0x5a1, subw 0x0, time 582258, (1142,962), root:(1142,999),
    state 0x10, keycode 36 (keysym 0xff0d, Return), same_screen YES,
"   XLookupString gives 1 bytes: (0d) "
    XFilterEvent returns: False

KeyPress event, serial 40, synthetic NO, window 0x6c00001,
    root 0x5a1, subw 0x0, time 588443, (1142,962), root:(1142,999),
    state 0x10, keycode 52 (keysym 0x79, y), same_screen YES,
    XLookupString gives 1 bytes: (79) "y"
    XmbLookupString gives 1 bytes: (79) "y"
    XFilterEvent returns: False

KeyRelease event, serial 40, synthetic NO, window 0x6c00001,
    root 0x5a1, subw 0x0, time 588573, (1142,962), root:(1142,999),
    state 0x10, keycode 52 (keysym 0x79, y), same_screen YES,
    XLookupString gives 1 bytes: (79) "y"
    XFilterEvent returns: False
Ich kann mit der Ausgabe nicht anfangen.
Wer kennt sich damit aus!
Aber auf jeden Fall macht mir das "false" Angst!

Gruesse
Veit

MSfree
Beiträge: 4971
Registriert: 25.09.2007 19:59:30

Re: STRG-Tasten funktionieren nicht

Beitrag von MSfree » 22.01.2020 13:38:06

xev liefert alles, was unter X11 an sogenannten Events, also Ereignissen passiert, solange man mit der Maus im xev-Fenster bleibt. Das "false" hat nichts zu sagen, es sind halt keine gefilterten Ereignisse. Aber hier ins Detail zu gehen wäre abendfüllend.

Wenn ich bei mir die Strg-Tasten betätige, sehe ich (neben hunderten weiteren Events) folgendes:

Code: Alles auswählen

KeyPress event, serial 32, synthetic NO, window 0x3200001,
    root 0x2e, subw 0x3200002, time 3443269125, (47,46), root:(1053,73),
    state 0x0, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x3200001,
    root 0x2e, subw 0x3200002, time 3443269238, (47,46), root:(1053,73),
    state 0x4, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 32, synthetic NO, window 0x3200001,
    root 0x2e, subw 0x3200002, time 3443270589, (47,46), root:(1053,73),
    state 0x0, keycode 109 (keysym 0xffe4, Control_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 32, synthetic NO, window 0x3200001,
    root 0x2e, subw 0x3200002, time 3443270645, (47,46), root:(1053,73),
    state 0x4, keycode 109 (keysym 0xffe4, Control_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Sehr schön zu sehen sind das jeweilige KeyPress- und KeyRelease Event für die Control-L und Control-R Tasten. Bei dir sehe ich nur die Betätigung der Enter- und "y"-Tasten. Also, nochmal versuchen und auf die Control-Tasten achten.

vdvogt
Beiträge: 301
Registriert: 22.12.2012 14:55:17
Lizenz eigener Beiträge: GNU Free Documentation License

Re: STRG-Tasten funktionieren nicht

Beitrag von vdvogt » 22.01.2020 20:32:23

Hallo,
ich habe jetzt mal eine externe Tastatur drangehaengt.

Das sind die Ausgaben, wenn ich auf dieser Tastatur die beiden STRG-Tasten druecke:

Code: Alles auswählen


KeyPress event, serial 42, synthetic NO, window 0x6400001,
    root 0x5a1, subw 0x0, time 330493, (97,74), root:(1252,137),
    state 0x10, keycode 105 (keysym 0xffe4, Control_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 42, synthetic NO, window 0x6400001,
    root 0x5a1, subw 0x0, time 330587, (97,74), root:(1252,137),
    state 0x14, keycode 105 (keysym 0xffe4, Control_R), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 42, synthetic NO, window 0x6400001,
    root 0x5a1, subw 0x0, time 335055, (97,74), root:(1252,137),
    state 0x10, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyRelease event, serial 42, synthetic NO, window 0x6400001,
    root 0x5a1, subw 0x0, time 335111, (97,74), root:(1252,137),
    state 0x14, keycode 37 (keysym 0xffe3, Control_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

Wenn ich auf der Laptop-Tastatur die STRG-Tasten druecke, dann ergibt das gar keinen Output.
Heisst das jetzt, dass die Tastatur defekt ist?
Oder koennte da ein Softwarefehler dahinterstecken?

Gruesse
Veit

Antworten