Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
ht81
Beiträge: 7
Registriert: 19.03.2020 12:27:57

Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von ht81 » 19.03.2020 12:33:55

Hallo zusammen,

ich besitze ein HP Elitebook 840 G1 auf dem ich gerne Debian 10 installieren möchte. Mein Problem ist, das wenn ich via Live CD (NON-FREE) boote, dreht sich während dem Bootvorgang bereits der Bildschirm und steht kopfüber. Also schon bevor ich den Desktop sehe. Natürlich kann ich auch dan Laptop auf den Kopf stellen und in der GDM Shell die "Rotation" locken. Aber das kann es doch nicht sein.....
Hat noch jemand dieses Problem und könnte mir hilfestellung geben?

Ich habe noch ein HP ProBook 4530s, da funktioniert es normal.

Grüße Thomas

nudgegoonies
Beiträge: 869
Registriert: 16.02.2009 09:35:10

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von nudgegoonies » 23.03.2020 12:48:01

Da scheint scheint mit dem Gyro was nicht zu funktionieren. Vom Verein haben wir so einen ähnlichen Laptop, wo das darauf installierte Ubuntu den Gyro zwar erkennt. Der Bildschirm steht auch richtig in der Anmeldung. Aber wenn man den Laptop mal trägt oder bewegt, dann spingt er sehr schnell um. Vielleicht hilft Dir dieser Ubuntuthread weiter:
https://bugs.launchpad.net/ubuntu/+sour ... ug/1767650

Von iio-sensor-proxy gibt es in Debian 10 auch eine aktuellere Backport Version:
https://packages.debian.org/buster-back ... nsor-proxy
Soft: Buster AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

ht81
Beiträge: 7
Registriert: 19.03.2020 12:27:57

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von ht81 » 25.03.2020 08:06:33

Hallo nudgegoonies,

hab jetzt das Backport installiert. Version ist nun 2.8-1. Leider noch immer keine Verbesserung.
Sensor meldet nach wie vor "bottom-up". :roll:
Da es sich "noch" um das Testsystem handelt, habe ich gestern sogar auf sid umgestellt damit ich alles up-to-date habe. Brachte aber leider auch nichts.
Manjaro als Live System funktioniert hingegen.

Ich denke ich werde das Paket einfach komplett deinstallieren. Entstehen mir dadurch irgendwelche Nachteile wenn das Paket nicht mehr vorhanden ist?

nudgegoonies
Beiträge: 869
Registriert: 16.02.2009 09:35:10

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von nudgegoonies » 25.03.2020 08:21:29

Deinstallieren kann man es. Es gibt keine harte Abhängigkeit von anderen Paketen. Aber gnome-settings-daemon (der dürfte verbreitet sein - auch bei nicht-gnome-desktops), die gnome-shell und komischerweise geoclue empfehlen es.
Soft: Buster AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

ht81
Beiträge: 7
Registriert: 19.03.2020 12:27:57

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von ht81 » 25.03.2020 10:20:12

Ok,

gibt es den nicht die Möglichkeit via modprobe nur den Sensor zu deaktivieren? Also das es für iio-sensor-proxy so aussieht das keiner verbaut wäre?
Wenn ja, könntest Du mir kurz Beschreiben wie das funktionieren würde?

ht81
Beiträge: 7
Registriert: 19.03.2020 12:27:57

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von ht81 » 25.03.2020 11:22:51

Ich würde dann mit lsmod alles auflisten lassen und mit modinfo die Einträge durchsehen, wie die genaue Bezeichnung des Lagesensors ist.
Und mit modprobe -r würde ich das entsprechend entfernen / entladen. Oder gibt es eine bessere / elegantere Vorgehensweise?
Das hinzufügen des Moduls in /etc/modprobe.d/blacklist.conf verhindert dann das laden schon beim Bootvorgang, oder?

nudgegoonies
Beiträge: 869
Registriert: 16.02.2009 09:35:10

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von nudgegoonies » 26.03.2020 11:19:58

Das Modul müsste iio heißen:
https://github.com/torvalds/linux/tree/ ... rivers/iio
Wenn ich das hier sehe, scheint es aber ein bisschen komplizierter zu sein:
https://www.kernel.org/doc/html/latest/ ... h-hid.html
Aber einen Versuch ist es wert. Und ja, in die Blaklist aufnehmen reicht. Aber nicht update-initramfs -kall -u vergessen.
Soft: Buster AMD64, MATE Desktop. Repo's: Backports, kein Proposed, eigene Backports. Grafik: Radeon R7 360 MESA.
Hardware: Thinkstation S20, Intel X58, 8GB, Xeon W3530, BCM5755 NIC, EMU10K1 SND, SATA SSD+HD und DVD+RW.

ht81
Beiträge: 7
Registriert: 19.03.2020 12:27:57

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von ht81 » 27.03.2020 07:31:12

Als Modul habe ich hp_accel ausfindig gemacht. Habe dieses in die Blackliste aufgenommen
Das "update-initramfs -kall -u" habe ich allerdings vergessen gehabt, fällt mir grade auf. Muss ich nochmal machen.

ht81
Beiträge: 7
Registriert: 19.03.2020 12:27:57

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von ht81 » 30.03.2020 13:36:39

Also das Modul das ich nun ausfindig gemacht habe lautet "LIS3LV02DL" aber es reicht nicht dieses in die Blacklist aufzunehmen und einen "update-initramfs -kall -u" drüber laufen zu lassen.

Ich beschäftige mich nun schon Tagelang mit diesem Thema um es vernünftig lösen zu können, scheitere aber daran. Und langsam gehen mir die Ideen aus.

Als Workaround habe ich jetzt erstmal
"systemctl stop iio-sensor-proxy.service"
"systemctl disbale iio-sensor-proxy-servcie"

Das komische ist, das der Service trotzdem nach einem Neustart wieder aktiv ist obwohl ich diesen auf disable gesetzt habe.

KP97
Beiträge: 2018
Registriert: 01.02.2013 15:07:36

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von KP97 » 30.03.2020 15:08:12

ht81 hat geschrieben: ↑ zum Beitrag ↑
30.03.2020 13:36:39
Das komische ist, das der Service trotzdem nach einem Neustart wieder aktiv ist obwohl ich diesen auf disable gesetzt habe.
Wenn es denn der richtige Service ist und auch sonst keine Nachteile im System festzustellen sind, kannst Du den Service dauerhaft mit einem umask ausschalten:

Code: Alles auswählen

systemctl mask iio-sensor-proxy-servcie
Mit systemctl unmask kannst Du den Service zurückholen.

MSfree
Beiträge: 5279
Registriert: 25.09.2007 19:59:30

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von MSfree » 30.03.2020 15:21:23

Ich würde mir mal das hier durchlesen:
https://gitlab.freedesktop.org/hadess/iio-sensor-proxy/

Man kann sich seine eigenen Sensortransformation definieren, siehe hier:
https://github.com/systemd/systemd/blob ... ensor.hwdb

Besonders interessant hier: Zeilen 25-30 und Zeilen 42-68.
Interessant auch, daß für HP (ab Zeile 319) keine Einheitsmatrix definiert ist. Und genau da wird der Wurm für deine spezielles Gerät liegen.

ht81
Beiträge: 7
Registriert: 19.03.2020 12:27:57

Re: Debian 10 HP Elitebook 840 G1 Monitor kopfüber

Beitrag von ht81 » 31.03.2020 18:26:26

@KP97: Scheint zu funktionieren. Dankr für den Tipp
@MSfree: Das wäre auch eine Option und wahrscheinlich die richtigere. Momentan würde ich mir mit dem Tipp von KP97 behelfen, werde mir das aber von Dir nochmal ansehen. :THX:

Antworten