Spotify in Clementine: "Invalid signature: blob"

Sound, Digitalkameras, TV+Video und Spiele.
Antworten
spucky
Beiträge: 3
Registriert: 24.03.2020 15:19:27

Spotify in Clementine: "Invalid signature: blob"

Beitrag von spucky » 24.03.2020 15:23:32

Beim Versuch das Spotify-Plugin für Clementine herunterzuladen wird mir diese Fehlermeldung angezeigt: "Invalid signature: blob".
Clementine-Version ist 1.3.1, sollte also eigentlich funktionieren.

Jemand eine Idee?

Benutzeravatar
willy4711
Beiträge: 3108
Registriert: 08.09.2018 16:51:16

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von willy4711 » 24.03.2020 15:39:29


spucky
Beiträge: 3
Registriert: 24.03.2020 15:19:27

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von spucky » 24.03.2020 17:50:25

willy4711 hat geschrieben: ↑ zum Beitrag ↑
24.03.2020 15:39:29
Vielleicht hilft das weiter:
https://forums.linuxmint.com/viewtopic.php?t=270525
Leider nein, nach dem Problem gesucht hab ich natürlich schon. ;)
Die Version ist ja wie erwähnt 1.3.1 und damit sollte es gehen. Andere Tipps wie config löschen und neu installieren hab ich auch schon versucht, der Fehler tritt direkt nach frischer Neuinstallation bereits auf.

Benutzeravatar
willy4711
Beiträge: 3108
Registriert: 08.09.2018 16:51:16

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von willy4711 » 24.03.2020 19:32:05

Ich meinte an sich die weiter unten aufgeführten Player
Harmony und TOMAHAWK

debianoli
Beiträge: 3730
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von debianoli » 25.03.2020 06:34:18

Es gibt eine aktuellere Version in Debian Sid, denn ich denke, dass das Spotify-Plugin in 1.31 zu alt ist. Die Clementine-Entwicklung war einige Zeit etwas ruhig.

[deb]https://packages.debian.org/sid/clementine[/deb]

Du kannst die selber Backporten oder davor die Distribution Siduction als Linux-Live-System testen. Wenn da Clementine plus Spitify läuft, dann macht der selbstgemachte Backport sicher Sinn. Siduction basiert auf Debian Sid.

https://forum.siduction.org/?page=download-mirrors-en

spucky
Beiträge: 3
Registriert: 24.03.2020 15:19:27

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von spucky » 25.03.2020 10:23:03

willy4711 hat geschrieben: ↑ zum Beitrag ↑
24.03.2020 19:32:05
Ich meinte an sich die weiter unten aufgeführten Player
Harmony und TOMAHAWK
Die Player will ich aber nicht. Ich mag Clementine.

debianoli hat geschrieben: ↑ zum Beitrag ↑
25.03.2020 06:34:18
Es gibt eine aktuellere Version in Debian Sid, denn ich denke, dass das Spotify-Plugin in 1.31 zu alt ist. Die Clementine-Entwicklung war einige Zeit etwas ruhig.

[deb]https://packages.debian.org/sid/clementine[/deb]

Du kannst die selber Backporten oder davor die Distribution Siduction als Linux-Live-System testen. Wenn da Clementine plus Spitify läuft, dann macht der selbstgemachte Backport sicher Sinn. Siduction basiert auf Debian Sid.

https://forum.siduction.org/?page=download-mirrors-en
Danke für den Tipp. Hab ich mal versucht, aber auch mit der 1.4 in Seduction gibt es genau das gleiche Problem mit der selben Fehlermeldung. :/

Benutzeravatar
willy4711
Beiträge: 3108
Registriert: 08.09.2018 16:51:16

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von willy4711 » 25.03.2020 10:44:32

spucky hat geschrieben: ↑ zum Beitrag ↑
25.03.2020 10:23:03
Die Player will ich aber nicht. Ich mag Clementine.
Na dann ist halt nix mit Spotify :roll:

Benutzeravatar
niemand
Beiträge: 13365
Registriert: 18.07.2004 16:43:29

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von niemand » 25.03.2020 17:36:57

@willy4711: „Das Radio in meinem Polo geht nicht“ → „Hier hast ’nen Forenthread, in dem steht, dass es im Corsa und im A3 geht“ → „Ich möchte aber meinen Polo benutzen“ → „Na dann ist halt nix mit Radio :roll:

… muss das wirklich sein?

On-Topic: ich kann bestätigen, dass es kein debianspezifisches Problem ist, und auch nix mit einer zu alten Version zu tun hat. Clementine unter Arch bringt die gleiche Fehlermeldung, hervorgerufen durch:

Code: Alles auswählen

17:31:47.143 INFO  SpotifyBlobDownloader:96         Downloading QUrl("https://spotify.clementine-player.org/version16-64bit/blob")
17:31:47.144 INFO  SpotifyBlobDownloader:96         Downloading QUrl("https://spotify.clementine-player.org/version16-64bit/blob.sha512")
17:31:47.145 INFO  SpotifyBlobDownloader:96         Downloading QUrl("https://spotify.clementine-player.org/version16-64bit/libspotify.so.12.1.51")
17:31:47.145 INFO  SpotifyBlobDownloader:96         Downloading QUrl("https://spotify.clementine-player.org/version16-64bit/libspotify.so.12.1.51.sha512")
17:32:00.306 DEBUG SpotifyBlobDownloader:217        Verifying "blob" against "blob.sha512" false
17:32:00.307 WARN  SpotifyBlobDownloader:264        "Invalid signature: blob"
Ich dachte zunächst, dass es an libspotify selbst liegen könnte, deren Benutzung ja nun schon länger deprecated ist und von der Spotify angekündigt hat, sie aus dem Support fallen zu lassen. Andererseits tun andere Sachen mit libspotify noch, und die Fehlermeldung weist auf ein Problem mit der Signatur des Blobs hin. Ich werde nachher mal bei den Clementine-Leuten gucken, ob man das Problem schon erkannt hat, und ggf. einen Bugreport hinstellen. Und ich möchte an dieser Stelle ausdrücklich betonen, dass ich es gut finde, dass es diese Prüfung gibt. Andere sind schon an weit geringeren Standards gescheitert …
Zuletzt geändert von niemand am 25.03.2020 19:27:05, insgesamt 1-mal geändert.
non serviam.

debianoli
Beiträge: 3730
Registriert: 07.11.2007 13:58:49
Wohnort: Augschburg

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von debianoli » 25.03.2020 17:47:05

Es gibt da noch eine Seite

https://spotify.clementine-player.org/

Bei der Wahl von Debian erhält man eine Vielzahl von .deb Dateien zum Download. In jeder steckt ein clementine-binary

Ich habe gerade kein Testsystem zum Installieren und auch keinen Spotify Account. Kann also nicht nachsehen, ob die darin enthalten e Clementine Version Spotify richtig einbinden kann.

Clemetine selber zu bauen ist mir zu aufwendig, um zu testen, ob es da geht.

Benutzeravatar
niemand
Beiträge: 13365
Registriert: 18.07.2004 16:43:29

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von niemand » 25.03.2020 20:03:37

Als möglichen Workaround hätte ich bislang: Dateien unter https://spotify.clementine-player.org/version16-64bit/ laden und in ~/.config/Clementine/spotifyblob/version16-64bit/ legen, Datei blob ausführbar machen, einen Link libspotify.so.12 anlegen, der auf libspotify.so.12.1.51 zeigt.

Damit wird’s zumindest als „installiert“ angezeigt. Allerdings habe ich bei mir dann folgendes Problem:

Code: Alles auswählen

/home/niemand/.config/Clementine/spotifyblob/version16-64bit/blob: error while loading shared libraries: libQtCore.so.4: cannot open shared object file: No such file or directory
An der Stelle bin ich leider raus, betreffende Lib ist für mein System auf normalem Weg nicht mehr zu haben; für Buster werden jedoch noch allerhand libqt4-Pakete gelistet. Möglicherweise ist die betreffende Lib dort verfügbar – damit ließe sich das zumindest mit Debian noch eine Weile nutzen. Jemand, der Buster fährt und Zeit hat, kann’s ja mal probieren.
non serviam.

WMKdebian2020
Beiträge: 1
Registriert: 26.03.2020 18:41:18

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von WMKdebian2020 » 26.03.2020 19:14:31

Hallo,

diese Fehlermeldung "invalid signature: blob" versuche ich auch seit Tagen weg zu bekommen - ohne Erfolg.
Meine Kommandoliste:

Code: Alles auswählen

mkdir ~/.config/Clementine/spotifyblob/version16-64bit
mv ~/Download/* ~/.config/Clementine/spotifyblob/version16-64bit    ; Vorspann "version16-64bit_" in den Namen abschneiden
cd ~/.config/Clementine/spotifyblob/version16-64bit
openssl dgst -sha512 -verify /media/sdf1/Clementine/clementine-spotify-public.pem -signature blob.sha512 blob ; aus der Readme-Datei
  Verified OK
chmod o+x blob
ln -s libspotify.so.12.1.51 libspotify.so.12
...nicht mal der Effekt wie 'niemand' beschrieben hat ("Erweiterungsstatus: installiert"?), ist da.
Ach und libQtCore.so.4 ist mit libqtcore4 auch vorhanden.
Kann es sein, dass das Problem schon mal gelöst wurde und nun wieder auftaucht?

Danke

Benutzeravatar
niemand
Beiträge: 13365
Registriert: 18.07.2004 16:43:29

Re: Spotify in Clementine: "Invalid signature: blob"

Beitrag von niemand » 27.03.2020 07:14:53

WMKdebian2020 hat geschrieben: ↑ zum Beitrag ↑
26.03.2020 19:14:31
...nicht mal der Effekt wie 'niemand' beschrieben hat ("Erweiterungsstatus: installiert"?), ist da.
Um zu gucken, was bei dir schieflaufen könnte, müsste man mal die Konsolenausgaben beim Versuch, zu Spotify zu verbinden, sehen. Am besten gleich die gesamte Ausgabe nach pastebin/ oder so hochladen.
non serviam.

Antworten