Upgrade stretch->buster schlägt fehl

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Benutzeravatar
Mebus
Beiträge: 112
Registriert: 02.04.2008 21:34:32
Wohnort: Niederrhein
Kontaktdaten:

Re: Upgrade stretch->buster schlägt fehl

Beitrag von Mebus » 30.06.2020 19:42:30

Moin,
willy4711 hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 19:28:44

Code: Alles auswählen

aptitude update && aptitude full-upgrade
ergibt:

Code: Alles auswählen

# aptitude full-upgrade
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
0 B an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 0 B zusätzlich belegt sein.
Eigentlich möchte ich den Server auf Buster upgraden und hatte dazu die Paketquellen auf buster umgestellt.

Mebus
http://www.lugmoe.de/ - Linux User Group Mönchengladbach

Der letzte räumt die Erde auf !

Benutzeravatar
willy4711
Beiträge: 3745
Registriert: 08.09.2018 16:51:16

Re: Upgrade stretch->buster schlägt fehl

Beitrag von willy4711 » 30.06.2020 19:50:02

Mebus hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 19:42:30
ergibt:

Code: Alles auswählen

# aptitude full-upgrade
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
0 B an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 0 B zusätzlich belegt sein.
Eigentlich möchte ich den Server auf Buster upgraden und hatte dazu die Paketquellen auf buster umgestellt.
Dann hast du das Dist-Upgrade also schon gemacht ohne es zu merken ?
Anders kann ich die Terminal Meldung von aptitude dann nicht interpretieren. :facepalm:

Benutzeravatar
Mebus
Beiträge: 112
Registriert: 02.04.2008 21:34:32
Wohnort: Niederrhein
Kontaktdaten:

Re: Upgrade stretch->buster schlägt fehl

Beitrag von Mebus » 30.06.2020 20:57:27

willy4711 hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 19:50:02
Mebus hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 19:42:30
ergibt:

Code: Alles auswählen

# aptitude full-upgrade
Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
0 B an Archiven müssen heruntergeladen werden. Nach dem Entpacken werden 0 B zusätzlich belegt sein.
Eigentlich möchte ich den Server auf Buster upgraden und hatte dazu die Paketquellen auf buster umgestellt.
Dann hast du das Dist-Upgrade also schon gemacht ohne es zu merken ?
Anders kann ich die Terminal Meldung von aptitude dann nicht interpretieren. :facepalm:
Nein, die Paketquellen standen wir von dir verlangt noch auf stretch. Wenn ich das auf buster Umstelle, dann bekomme ich die Fehlermeldungen wie im ersten Post.

Mebus
http://www.lugmoe.de/ - Linux User Group Mönchengladbach

Der letzte räumt die Erde auf !

cronoik
Beiträge: 1985
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Upgrade stretch->buster schlägt fehl

Beitrag von cronoik » 30.06.2020 21:04:27

Dann folge doch jetzt einmal der sehr guten Anleitung von Tintom [1]. Danach koennen wir weitersehen (Fremdpakete entfernen/upgraden...).
willy4711 hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 19:50:02
Dann hast du das Dist-Upgrade also schon gemacht ohne es zu merken ?
Anders kann ich die Terminal Meldung von aptitude dann nicht interpretieren. :facepalm:
Nein hat er nicht. Wenn er aktuell noch die stretch liste hat (also seine buster eintraege aus dem ersten Post wieder entfernt hat), dann ist die Ausgabe bei einem aktuellen System wohl die einzige die man erwarten kann.

[1] viewtopic.php?f=12&t=177889#p1242732
Hilf mit unser Wiki zu verbessern!

Benutzeravatar
Tintom
Beiträge: 1842
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Upgrade stretch->buster schlägt fehl

Beitrag von Tintom » 30.06.2020 21:52:52

willy4711 hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 15:38:21

Code: Alles auswählen

$ apt depends libgcc-s1
libgcc-s1
  Hängt ab von: gcc-10-base (= 10.1.0-1)
  Hängt ab von: libc6 (>= 2.14)
  Beschädigt: cryptsetup-initramfs (<< 2:2.2.2-3~)
  Ersetzt: libgcc1 (<< 1:10)

Ich denke -- bin mit aber mangels Erfahrung in solchen Verwicklungen nicht sicher -- dass apt trotz Pinning dort hängen bleiben wird.
Ich habe es nicht ausprobiert, aber theoretisch sollte folgendes passieren:
Das Paket ersetzt libgcc1< Version 10, wenn aber mind. ein Programm libgcc1 in seinen Abhängigkeiten drin hat, wird zwangsweise libgcc1 aus Buster installiert. Da in Buster Version 8 enthalten ist, ist die Abhängigkeit zu libgcc-s1 spätestens dann verletzt (Version 8 wird immer ggü. Version 10 bevorzugt). Ausweg: Deinstallation von libgcc-s1.

Bei mir wäre das z.B.:
$ aptitude why libgcc1
i pdf2htmlex Depends libgcc1 (>= 1:3.0)

Das beantwortet dann auch deine Frage:
Die Gretchenfrage ist natürlich, in welchem Zusammenhang die Paket bei dir gelandet sind.
man aptitude hat geschrieben:why, why-not
Explains the reason that a particular package should or cannot be installed on the system.

Benutzeravatar
willy4711
Beiträge: 3745
Registriert: 08.09.2018 16:51:16

Re: Upgrade stretch->buster schlägt fehl

Beitrag von willy4711 » 30.06.2020 22:02:31

Dann sollte er aber apt full-upgrade bzw. aptitude full-upgrade ausführen
Ein einfaches upgrade kann sowas eh nicht auflösen.

Tut mir leid, hab noch keine sources.list mit Buster in diesem Thread geortet.
Alles was bisher vom TE gepostet wurde, hat Stretch und alles mögliche Anderes zum Inhalt.
Testing wollte er ja auch noch einfügen .

Benutzeravatar
Tintom
Beiträge: 1842
Registriert: 14.04.2006 20:55:15
Wohnort: Göttingen

Re: Upgrade stretch->buster schlägt fehl

Beitrag von Tintom » 30.06.2020 22:34:29

willy4711 hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 22:02:31
Dann sollte er aber apt full-upgrade bzw. aptitude full-upgrade ausführen
Ein einfaches upgrade kann sowas eh nicht auflösen.
Tut mir leid, ich bin noch von der alten Schule! :)
apt-get dist-upgrade sollte dem full-upgrade von apt entsprechen.

Benutzeravatar
Mebus
Beiträge: 112
Registriert: 02.04.2008 21:34:32
Wohnort: Niederrhein
Kontaktdaten:

Re: Upgrade stretch->buster schlägt fehl

Beitrag von Mebus » 30.06.2020 22:51:59

Code: Alles auswählen

....
  python-webencodings python-wheel python-xdg python-yaml python-zope.interface python2.7 python2.7-dev python2.7-minimal python3-minimal qdbus qt-at-spi qtchooser qtcore4-l10n rake readline-common redis-tools rename ri rrdtool rsync
  rsyslog ruby ruby-did-you-mean ruby-ffi ruby-full ruby-minitest ruby-power-assert ruby-test-unit rubygems-integration samba-common samba-libs screen sed sensible-utils shared-mime-info sipcalc sl smbclient snmp snmpd socat sqlite3
  ssh sshfs startpar strace sudo systemd systemd-sysv sysv-rc sysvinit-utils tar tasksel tasksel-data tcl tcl8.6 tcpd tcpdump telnet tex-common texinfo tk tk8.6 tk8.6-blt2.5 tmux tzdata ucf udev ufraw-batch unixodbc unzip update-inetd
  usbutils util-linux vim vim-addon-manager vim-common vim-haproxy vim-runtime vim-tiny w3m wamerican wget whiptail whois wipe x11-utils x11proto-core-dev x11proto-input-dev x11proto-kb-dev xauth xaw3dg xdg-user-dirs xkb-data xl2tpd
  xml-core xml2 xsel xterm xxd xz-utils zlib1g zlib1g-dev zsh zsh-common
1107 aktualisiert, 167 neu installiert, 108 zu entfernen und 15 nicht aktualisiert.
Es müssen 731 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 778 MB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] 
apt full-upgrade sieht gut aus. Ich probiere das mal.

Mebus
http://www.lugmoe.de/ - Linux User Group Mönchengladbach

Der letzte räumt die Erde auf !

Benutzeravatar
Mebus
Beiträge: 112
Registriert: 02.04.2008 21:34:32
Wohnort: Niederrhein
Kontaktdaten:

Re: Upgrade stretch->buster schlägt fehl

Beitrag von Mebus » 30.06.2020 23:32:02

Ok, das hat soweit funktioniert, aber es gibt ein Problem:

Code: Alles auswählen

apt install matrix-synapse                                                                                                                                                                    :(
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 matrix-synapse : Hängt ab von: libpython3-stdlib (< 3.6.4~rc1-2~) aber 3.7.3-1 soll installiert werden oder
                                 python3-distutils soll aber nicht installiert werden
                  Hängt ab von: python3-systemd soll aber nicht installiert werden
                  Hängt ab von: python3-attr (>= 17.4.0) soll aber nicht installiert werden
                  Hängt ab von: python3-bcrypt soll aber nicht installiert werden
                  Hängt ab von: python3-canonicaljson (>= 1.1.3) soll aber nicht installiert werden
                  Hängt ab von: python3-daemonize soll aber nicht installiert werden
                  Hängt ab von: python3-frozendict (>= 1) soll aber nicht installiert werden
                  Hängt ab von: python3-jsonschema (>= 2.5.1) soll aber nicht installiert werden
                  Hängt ab von: python3-msgpack (>= 0.5.0) soll aber nicht installiert werden
                  Hängt ab von: python3-nacl (>= 1.2.1) soll aber nicht installiert werden
                  Hängt ab von: python3-netaddr (>= 0.7.18) soll aber nicht installiert werden
                  Hängt ab von: python3-openssl (>= 0.14) soll aber nicht installiert werden
                  Hängt ab von: python3-phonenumbers soll aber nicht installiert werden
                  Hängt ab von: python3-pil soll aber nicht installiert werden
                  Hängt ab von: python3-prometheus-client soll aber nicht installiert werden
                  Hängt ab von: python3-psutil soll aber nicht installiert werden
                  Hängt ab von: python3-pyasn1 (>= 0.1.9) soll aber nicht installiert werden
                  Hängt ab von: python3-pyasn1-modules soll aber nicht installiert werden
                  Hängt ab von: python3-pymacaroons (>= 0.13.0) soll aber nicht installiert werden
                  Hängt ab von: python3-service-identity (>= 16.0.0) soll aber nicht installiert werden
                  Hängt ab von: python3-signedjson (>= 1.0.0) soll aber nicht installiert werden
                  Hängt ab von: python3-six (>= 1.10) soll aber nicht installiert werden
                  Hängt ab von: python3-sortedcontainers soll aber nicht installiert werden
                  Hängt ab von: python3-treq (>= 18) soll aber nicht installiert werden
                  Hängt ab von: python3-twisted (>= 18.7.0) soll aber nicht installiert werden
                  Hängt ab von: python3-unpaddedbase64 (>= 1.0.1) soll aber nicht installiert werden
                  Hängt ab von: python3-yaml soll aber nicht installiert werden
                  Hängt ab von: python3:any
                  Empfiehlt: python3-lxml soll aber nicht installiert werden
                  Empfiehlt: python3-psycopg2 (>= 2.6) soll aber nicht installiert werden
                  Empfiehlt: python3-bleach (>= 1.4.2) soll aber nicht installiert werden
                  Empfiehlt: python3-jinja2 (>= 2.9) soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
Und

Code: Alles auswählen

apt upgrade                                                                                                                                                                                   :(
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc6-dev : Beschädigt: python3.7 (< 3.7.7-1+b1) aber 3.7.3-2+deb10u1 soll installiert werden
E: Beschädigte Pakete
Mebus
http://www.lugmoe.de/ - Linux User Group Mönchengladbach

Der letzte räumt die Erde auf !

cronoik
Beiträge: 1985
Registriert: 18.03.2012 21:13:42
Lizenz eigener Beiträge: GNU Free Documentation License

Re: Upgrade stretch->buster schlägt fehl

Beitrag von cronoik » 30.06.2020 23:52:23

Mebus hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 23:32:02
Ok, das hat soweit funktioniert, aber es gibt ein Problem:
Was hat funktioniert? Hast du die Anleitung von Tintom komplett ausgefuehrt? Was hat sagt denn jetzt:

Code: Alles auswählen

apt-cache policy
?
Hilf mit unser Wiki zu verbessern!

Benutzeravatar
Mebus
Beiträge: 112
Registriert: 02.04.2008 21:34:32
Wohnort: Niederrhein
Kontaktdaten:

Re: Upgrade stretch->buster schlägt fehl

Beitrag von Mebus » 01.07.2020 00:18:23

cronoik hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 23:52:23
Mebus hat geschrieben: ↑ zum Beitrag ↑
30.06.2020 23:32:02
Ok, das hat soweit funktioniert, aber es gibt ein Problem:
Was hat funktioniert? Hast du die Anleitung von Tintom komplett ausgefuehrt? Was hat sagt denn jetzt:

Code: Alles auswählen

apt-cache policy
?
So, mit ein weniger manueller Trickserei habe ich das Upgrade jetzt durch bekommen und alles läuft wieder :THX: Sogar mit Linux Kernel 5.6 für Wireguard :D

apt-cache policy: https://termbin.com/govkh

Danke für die Hilfe!

Mebus
http://www.lugmoe.de/ - Linux User Group Mönchengladbach

Der letzte räumt die Erde auf !

Antworten