Debian Testing: Keymaps verschwunden

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
Sturmkind
Beiträge: 98
Registriert: 02.10.2002 05:43:31
Wohnort: 69436 Haag

Debian Testing: Keymaps verschwunden

Beitrag von Sturmkind » 18.07.2004 23:17:59

Hallo,

ich habe hier Debian Sarge laufen und nach dem letzten *apt-get update && apt-get dist-upgrade* und einen Neustart war auf einmal die Keymap verschollen. Sprich ich bekomme mit *dpkg-reconfigure console-common* nur noch folgende Ausgabe:

root@workstation:/home/sturmkind> dpkg-reconfigure console-common Looking for keymap to install:
NONE
root@workstation:/home/sturmkind>

Das hier (Gnome Desktop) nun alles in Englisch ist brauche ich wohl nicht weiter zu erwähnen. Ich kann zwar bei Gnomeprogrammen noch Umlaute schreiben, in der Console geht es jedoch nicht mehr.

Als Notlösung habe ich via apt-get die console-data die ja auch die keymaps enthalten dürfte deinstalliert, den apt-cache mit *apt-get clean* geleert und die zuvor deinstallierten Pakete noch einmal via apt-get installiert. Allerdings brachte das keinerlei Verbeserung.

Weis einer von Euch wo es hängt?

Danke für Eure Hilfe im Voraus

Grüße
Sturmkind
nobody is perfect! ;-)

/ajk
Beiträge: 86
Registriert: 03.04.2002 14:45:58
Wohnort: Schweiz

Beitrag von /ajk » 19.07.2004 07:30:56

Und nun bist Du bereits der Dritte im Bunde bei welchem die Keymap verschwindet und immer wieder auf Englisch umstellt..

Wilkommen im Club.. :(

/ajk

Benutzeravatar
zaphod
Beiträge: 141
Registriert: 07.07.2002 14:48:31
Wohnort: Konstanz
Kontaktdaten:

Beitrag von zaphod » 19.07.2004 07:42:55

Also ich hatte das Problem mit den falschen Keymaps nach einem update von Gnome2.4
auf Gnome2.6! Da habe ich das Keyboardswitcherplugin von Gnome2.6 installiert und
die richtige Keymap eingestellt. Und siehe da: Das Layout stimmt wieder - und zum coden kann man auf
US-ENG umstellen.
Naja vielleicht hilft euch das weiter?!

gruß zaphod

Sturmkind
Beiträge: 98
Registriert: 02.10.2002 05:43:31
Wohnort: 69436 Haag

Beitrag von Sturmkind » 19.07.2004 08:28:38

Das hilft leider recht wenig da ich in Gnome-Programmen ja die deutschen Umlaute/Sonderzeichen habe. Nur bringt es mir nichts wen sich Gnome aufgrund der Tatsache das die Keymaps verschwunden sind alles in englisch darstellt und in der Konsole keine Umlaute und Sonderzeichen gehen.

Das Problem scheint aber offenbar weiter verbreitetet zu sein als ich bisher so dachte. Mir war ist es schon zwei mal untergekommen, einmal bei Debian Woody und einmal bei Debian Sid. Aufgrund dessen das man nirgendwo Antworten bekam half jedes mal nur das System neu zu installieren was aber nicht des Rätsels Lösung sein kann/darf!

EDIT: Ich habe jetzt erst mal beim GDM manuell deutsche Sprache eingestellt. Dadurch ist Gnome + GUI-Programme wieder in Deutsch und im Terminal funktionieren auch Umlaute und Sonderzeichen. Da ich jedoch oft und auch gerne in der Console arbeite wo eben dank der fehlenden Keymap eben keine deutschen Umlaute/Sonderzeichen gehen ist das nicht mehr als eine Notlösung. ;-(

EDIT2: Offenbar habe ich ne Lösung gefunden. Normalerweise gehe ich ja wen ich die Locales und die Keymap einstellen will so vor:

Code: Alles auswählen

1. dpkg-reconfigure locales => entsprechende locale auswählen und generieren lassen
2. dpkg-reconfigure console-common => querz => Tastaturtyp und Optionen auswählen
3. dpkg-reconfigure console-tools => beides wird ins System eingepflegt
3. Erneutes Anmelden und die locales + keymap laufen.
Da das nichts gebracht hat habe ich ein wenig rumgesucht und rumprobiert und folgendes hat bei mir die Lösung gebracht:

Code: Alles auswählen

1. dpkg-reconfigure locales (ist bei mir schon eingestellt kann also wegfallen)
2. dpkg-reconfigure console-data
   => OK
      => Wähle Keymap aus Liste
         => querz
            => German
               => Standard
                  => latin1 - no dead keys
                     => OK
3. dpkg-reconfigure console-common (die vorher mit *dpkg-reconfigure console-data* ausgewählte keymap wird automatisch gewählt, man hat keine Möglichkeit etwas auszuwählen) 
4. dpkg-reconfigure console-tools
5. Erneutes Anmelden und die locales + keymap laufen.
Eigentlich sollte zwar der zuerst beschriebene Weg gehen, war zumindest bisher in woody und sarge der Weg der Wahl. Aber offenbar ist da was buggy oder es hat sich geändert.

Grüße
Sturmkind
nobody is perfect! ;-)

pgs
Beiträge: 121
Registriert: 22.07.2004 14:30:40

THX

Beitrag von pgs » 22.07.2004 14:33:06

... funktioniert nach ewigem Rumgemache ganz hervorragend!

mfg, pgs

Sturmkind
Beiträge: 98
Registriert: 02.10.2002 05:43:31
Wohnort: 69436 Haag

Beitrag von Sturmkind » 22.07.2004 17:57:08

Jetzt stellt sich nur noch die Frage ob das jetzt so vorgesehen war oder nen Bug ist.

Grüße
Sturmkind
nobody is perfect! ;-)

/ajk
Beiträge: 86
Registriert: 03.04.2002 14:45:58
Wohnort: Schweiz

Beitrag von /ajk » 23.07.2004 09:41:11

Ich habe das jetzt alles mal nachgemacht und beim letzten: "dpkg-reconfigure console-tools" meldet er mir folgendes:

Code: Alles auswählen

Setting up general console font... findfont: Datei oder Verzeichnis nicht gefunden
Kann Zeichensatzdatei 'sg-latin1' nicht öffnen. failed
Hmm hab jetzt aber keine Ahnung warum das so ist, und was das bedeutet.
Werd schon herausfinden was das mit der Zeichensatzdatei auf sich hat.

Sturmkind
Beiträge: 98
Registriert: 02.10.2002 05:43:31
Wohnort: 69436 Haag

Beitrag von Sturmkind » 23.07.2004 09:49:33

Moin /ajk,

da hast Du doch glatt was gefunden das ich bisher noch nicht hatte. Und ich dachte ich hätte mich schon durch den ganzen Bullshit betreffs Debian und Keymap durchgewühlt.

Ich hoffe das Du bald ne Lösung findest

Grüße
Sturmkind
nobody is perfect! ;-)

/ajk
Beiträge: 86
Registriert: 03.04.2002 14:45:58
Wohnort: Schweiz

Beitrag von /ajk » 26.07.2004 17:00:48

Und auch hier.. Kaum war /dev/null wieder als "charakter Device" vorhanden, verschwand das Problem mit der Schrift... *glglgl*

Ich schlage mich! *hauhau*

/ajk

Sturmkind
Beiträge: 98
Registriert: 02.10.2002 05:43:31
Wohnort: 69436 Haag

Beitrag von Sturmkind » 26.07.2004 17:34:40

Na freut mich das Du es gebacken bekommen hast. Hm soll ich Dir schnell nen Schlagstock rüberreichen? Das ist doch effektiver als wen Du Dich mit Deinen Patschhändchen schlägst! ;-)

Grüße
Sturmkind


PS. Man muß den Leuten manchmal einfach ihren Willen lassen *g*
nobody is perfect! ;-)

/ajk
Beiträge: 86
Registriert: 03.04.2002 14:45:58
Wohnort: Schweiz

Beitrag von /ajk » 27.07.2004 08:39:02

Ne bin ja kein Christ.. sollen die sich mal selber quälen *buhahaha*

Was weis ich warum das nicht ging...

/ajk

Sturmkind
Beiträge: 98
Registriert: 02.10.2002 05:43:31
Wohnort: 69436 Haag

Beitrag von Sturmkind » 27.07.2004 09:10:40

*g* ich weis das Du kein Christ bist. Siehe das Forum des Rabenclan ;-)

Grüße
Sturmkind
nobody is perfect! ;-)

Benutzeravatar
legolaus
Beiträge: 67
Registriert: 07.06.2006 10:14:35
Wohnort: Wetterau / Hessen

Beitrag von legolaus » 14.06.2007 11:15:54

Hi, ich hatte mit debootstrap ein system installiert. Nach dem Start des Systems war alles auf Englisch eingestellt. Keymap, locales usw. Es handelt sich um Debian etch.

Hatte mit loadkeys oder mit obigem vorgehen entsprechend mein keyboard und co laden können:

Code: Alles auswählen

1. dpkg-reconfigure locales (ist bei mir schon eingestellt kann also wegfallen)
2. dpkg-reconfigure console-data
   => OK
      => Wähle Keymap aus Liste
         => querz
            => German
               => Standard
                  => latin1 - no dead keys
                     => OK
3. dpkg-reconfigure console-common (die vorher mit *dpkg-reconfigure console-data* ausgewählte keymap wird automatisch gewählt, man hat keine Möglichkeit etwas auszuwählen)
4. dpkg-reconfigure console-tools
5. Erneutes Anmelden und die locales + keymap laufen.
Hat auch super funktioniert, nur merkt er sich die Einstellungen nicht beim Neustart. Was muss getan werden, damit er beim Neustart die Sachen behält?

Gruss

Antworten