problem: uebers handy ins internet

Debian auf Notebooks und speziellen Geräten wie eingebetteten Systemen, Routern, Set-Top-Boxen, ...
Antworten
cri
Beiträge: 13
Registriert: 08.04.2005 06:57:50

problem: uebers handy ins internet

Beitrag von cri » 08.04.2005 07:10:22

hallo!

ich moechte mit meinem notebook (debian sid, kernel 2.6.8) per bluetooth und handy (nokia 6630) ins internet. die verbindung zum modem klappt, haenge aber an einem problem mit pppd fest. nach der pap-authentfikation bricht pppd mit "LCP terminated by peer" ab.
die verbindung laeuft ueber vodafone.jp.
kann mir da jemand helfen?

vielen dank!

cri

# wvdial
--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATM0
ATM0
OK
--> Sending: AT+CGDCONT=1,"IP","vodafone"
AT+CGDCONT=1,"IP","vodafone"
OK
--> Modem initialized.
--> Sending: ATDT*99#
--> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at Thu Apr 7 21:25:42 2005
--> pid of pppd: 6770
--> Disconnecting at Thu Apr 7 21:25:51 2005
--> The PPP daemon has died: PPP negotiation failed (exit code = 10)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 10)


/etc/wvdial.conf

[Dialer Defaults]
Username = ai@vodafone
Password = vodafone
Phone = *99#
Baud = 460800
PPPD Path = /usr/sbin/pppd
Stupid Mode = 1
Init1 = ATZ
Init2 = ATM0
Init3 = AT+CGDCONT=1,"IP","vodafone"
Auto DNS = 1
SetVolume = 0
Dial Command = ATDT
FlowControl = NOFLOW


/var/log/syslog

pppd[6770]: pppd 2.4.2 started by root, uid 0
pppd[6770]: using channel 25
pppd[6770]: Using interface ppp0
pppd[6770]: Connect: ppp0 <--> /dev/rfcomm0
pppd[6770]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x5779a756> <pcomp> <accomp>]
pppd[6770]: rcvd [LCP ConfRej id=0x1 <magic 0x5779a756> <pcomp> <accomp>]
pppd[6770]: sent [LCP ConfReq id=0x2 <asyncmap 0x0>]
pppd[6770]: rcvd [LCP ConfAck id=0x2 <asyncmap 0x0>]
pppd[6770]: rcvd [LCP ConfReq id=0x0 <auth pap> <mru 1500> <asyncmap 0xa0000>]
pppd[6770]: sent [LCP ConfAck id=0x0 <auth pap> <mru 1500> <asyncmap 0xa0000>]
pppd[6770]: sent [LCP EchoReq id=0x0 magic=0x0]
pppd[6770]: sent [PAP AuthReq id=0x1 user="ai@vodafone" password=<hidden>]Apr 7 21:17:26 localhost pppd[6770]: rcvd [LCP EchoRep id=0x0 magic=0x0]
pppd[6770]: rcvd [PAP AuthAck id=0x1 ""]
pppd[6770]: PAP authentication succeeded
pppd[6770]: sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
pppd[6770]: sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
pppd[6770]: rcvd [IPCP ConfReq id=0x0 <addr 10.6.6.6>]
pppd[6770]: sent [IPCP ConfAck id=0x0 <addr 10.6.6.6>]
pppd[6770]: rcvd [LCP ProtRej id=0x0 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
pppd[6770]: rcvd [LCP TermReq id=0x1]
pppd[6770]: LCP terminated by peer
pppd[6770]: sent [LCP TermAck id=0x1]
pppd[6770]: Connection terminated.
pppd[6770]: Exit.

Benutzeravatar
feltel
Webmaster
Beiträge: 10023
Registriert: 20.12.2001 13:08:23
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Leipzig, Germany
Kontaktdaten:

Beitrag von feltel » 14.04.2005 07:44:35

Ist die D2-Karte auch für GPRS freigeschaltet? Das ist ja ne GPRS-Verbindung die Du da aufbauen willst. Ich hatte so einen ähnlichen Fall auch schonmal wo das (Motorola)-Handy einfach aufgelegt hatte während der Anwahl. Da musst man nen speziellen AT-Befehl vorher absetzen damit das nicht passierte. Ich such das man raus....

cri
Beiträge: 13
Registriert: 08.04.2005 06:57:50

Beitrag von cri » 14.04.2005 10:28:42

ich bin inzwischen mit kppp relativ problemlos im netz. aber es wuerd mich schon interessieren, was ich da fuer wvdial/pppd noch aendern muesste.

atcq
Beiträge: 92
Registriert: 18.05.2007 13:10:33
Wohnort: Biberach
Kontaktdaten:

Beitrag von atcq » 28.05.2007 13:27:47

Hi,

selbes Thema nur einen Schritt weiter ... (funktioniert auch ohne kppp, was vor allem gut ist wenn man kein KDE nutzt und nich noch extra libs für KDE laden/installieren will)

meine /etc/wvdial.conf:

Code: Alles auswählen

[Dialer Defaults]
Phone = *99#
Username = eplus
Password = gprs
New PPPD = yes

[Dialer N6630eplus]
Modem = /dev/rfcomm0
ISDN = off
Modem Type = Analog Modem
Baud = 460800
Init = ATZ
Init2 = AT+CGDCONT=1,,"internet.eplus.de"
Phone = *99#
Dial Prefix = 
Dial Attempts = 1
Dial Command = ATD
Ask Password = off
Password = gprs
Username = eplus
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = off
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = off
 
wvdial bringt dann:

Code: Alles auswählen

atcq@SKYWALKER:~$ wvdial N6630eplus
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CGDCONT=1,,"internet.eplus.de"
AT+CGDCONT=1,,"internet.eplus.de"
OK
--> Modem initialized.
--> Sending: ATD*99#
--> Waiting for carrier.
ATD*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> PPP negotiation detected.
--> Starting pppd at Mon May 28 13:09:12 2007
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 7575
--> Disconnecting at Mon May 28 13:09:13 2007
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)
 
hmm, scheisse ... geht nich ...
aber, als root:

Code: Alles auswählen

atcq@SKYWALKER:~$ sudo wvdial N6630eplus
--> WvDial: Internet dialer version 1.56
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CGDCONT=1,,"internet.eplus.de"
AT+CGDCONT=1,,"internet.eplus.de"
OK
--> Modem initialized.
--> Sending: ATD*99#
--> Waiting for carrier.
ATD*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> Carrier detected.  Waiting for prompt.
~[7f]}#@!}!} } }2}#}$@#}!}$}%\}"}&} }*} } g}%~
--> PPP negotiation detected.
--> Starting pppd at Mon May 28 13:17:21 2007
--> Pid of pppd: 7817
--> Using interface ppp0
--> pppd: 8[03][06][08]
--> pppd: 8[03][06][08]
--> pppd: 8[03][06][08]
--> pppd: 8[03][06][08]
--> local  IP address 10.129.21.80
--> pppd: 8[03][06][08]
--> remote IP address 10.6.6.6
--> pppd: 8[03][06][08]
--> primary   DNS address 212.23.97.2
--> pppd: 8[03][06][08]
--> secondary DNS address 212.23.97.3
--> pppd: 8[03][06][08]
Caught signal 2:  Attempting to exit gracefully... # Trennen der Verbindung durch Ctrl-c
--> Terminating on signal 15
--> pppd: 8[03][06][08]
--> Connect time 0.2 minutes.
--> pppd: 8[03][06][08]
--> pppd: 8[03][06][08]
--> pppd: 8[03][06][08]
--> Disconnecting at Mon May 28 13:17:37 2007
 
funktioniert das ganze auf einmal ...

obwohl user in den Gruppen dialout und dip ist ...!

Jmd. ne Idee was ich da machen könnte?

nepos
Beiträge: 5238
Registriert: 05.01.2005 10:08:12

Beitrag von nepos » 28.05.2007 14:07:08

Wie sehen denn die Berechtigungen der pap-secrets und chap-secrets Dateien aus? Hast du da die nötigen Rechte als User in den Gruppen dialout und dip?

atcq
Beiträge: 92
Registriert: 18.05.2007 13:10:33
Wohnort: Biberach
Kontaktdaten:

Beitrag von atcq » 28.05.2007 15:00:48

Code: Alles auswählen

atcq@SKYWALKER:~$ ls -al /etc/ppp/*secrets
-rw------- 1 root root   93 2007-05-28 13:17 /etc/ppp/chap-secrets
-rw------- 1 root root 1641 2007-05-28 13:17 /etc/ppp/pap-secrets
 
hatte ihnen als besitzer auch mal die Gruppe dialup zugeteilt und die gleichen Rechte gesetzt wie root, brachte leider nur eine kleine Änderung:

Code: Alles auswählen

atcq@SKYWALKER:~$ ls -al /etc/ppp/*secrets
-rw-rw---- 1 root dialout   93 2007-05-28 14:51 /etc/ppp/chap-secrets
-rw-rw---- 1 root dialout 1641 2007-05-28 14:51 /etc/ppp/pap-secrets
 

Code: Alles auswählen

--> PPP negotiation detected.
--> Starting pppd at Mon May 28 14:51:43 2007
--> Pid of pppd: 10181
--> Disconnecting at Mon May 28 14:51:44 2007
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)
 
Ach ja, was noch helfen könnte, (exit code = 2):

Code: Alles auswählen

Aus: man pppd

       2      An error was detected in processing the options given,  such  as
              two mutually exclusive options being used.
 
leider werde ich aus dem exit code jedoch auch nich schlau ... ich kann mir nich vorstellen welche optionen sich da gegenseitig ausschliessen könnten wenn ich user bin und das nicht tun wenn ich root bin ...!?

atcq
Beiträge: 92
Registriert: 18.05.2007 13:10:33
Wohnort: Biberach
Kontaktdaten:

Beitrag von atcq » 01.06.2007 17:12:17

... ok, hab die rechte mal gründlich umgebaut ...

Code: Alles auswählen

cd /etc
chgrp -R dialout ppp wvdial.conf
chmod -R ug+rwX ppp wvdial.conf
cd /usr/sbin
chgrp dialout pppd
chmod g+rx pppd
chmod u+s
 
... dann kann jeder der in dialout ist auch wirklich über wvdial nach Hause telefoniern ...!?
so long and thanks for all the fish!

hym
Beiträge: 5
Registriert: 19.04.2007 17:11:37

Re: problem: uebers handy ins internet

Beitrag von hym » 01.06.2007 19:03:37

Hi!
cri hat geschrieben:die verbindung laeuft ueber vodafone.jp.
kann mir da jemand helfen?
vodafone.jp ...ist das Vodafone Japan?
cri hat geschrieben: --> Sending: AT+CGDCONT=1,"IP","vodafone"
AT+CGDCONT=1,"IP","vodafone"
Für mich sieht der APN falsch aus, in Deutschland sollte es imho "web.vodafone.de" heissen, Username/Passwort sind meist egal. Wenn es allerdings Vodafone Japan ist...kein Plan.

Wenn es nicht funktioniert, könnte man auch mal anstatt "*99#" "*99***1#" verwenden, frag mich bitte nicht, warum. Ist reine Erfahrung...

Gruß,

hym

Antworten