sarge-netinst mit Kernel 2.6.16. Wie?

Du kommst mit der Installation nicht voran oder willst noch was nachfragen? Schau auch in den "Tipps und Tricks"-Bereich.
Antworten
irata
Beiträge: 13
Registriert: 10.02.2005 17:32:58

sarge-netinst mit Kernel 2.6.16. Wie?

Beitrag von irata » 09.05.2006 21:07:40

Hallo,

hab mir ein neues Mainboard geleistet und jetzt festgestellt, dass die meisten Onboard-Geschichten (ICH7R, Marvell 88E8053, etc.) erst vom Kernel >= 2.6.11 unterstützt wird. Ich würd aber gerne die sarge installieren, weil der Rechner ein Web-/Mail-Server geben soll.

Gibt es eine Möglichkeit, ein sarge-netinst-iso zu erzeugen, dass den Kernel 2.6.16 beinhaltet?

Bin für jeden Tipp dankbar!

Gruss Tobias

Benutzeravatar
TCA
Beiträge: 1465
Registriert: 14.05.2004 23:42:30
Wohnort: Göttingen

Beitrag von TCA » 10.05.2006 17:59:39

Du konntest die Etch-Beta von http://www.debian.de/devel/debian-installer/ versuchen.

Die haben den 2.6.15.
Gruss
Marc

Wer glaubt, etwas zu sein,
hat aufgehört, etwas zu werden.

debianforum.de Verhaltensregeln

Benutzeravatar
rotwein
Beiträge: 619
Registriert: 03.06.2003 12:22:51
Wohnort: Altdorf (bei Nürtingen -> bei Stuttgart)

Beitrag von rotwein » 11.05.2006 08:19:48

@irata:

Ab Kernel 2.6.12 (oder so, könnte auch der 2.6.11-er gewesen sein, weiß ich nicht mehr genau) benötigst Du auch ein neues udev und anderes mehr (es gibt also massiv Abhängigkeitsprobleme).

An Deiner Stelle (auch wenns um einen Server geht) würde ich mir gleich ein testing überlegen, die Paketquellen aber alle mit Etch eintragen. Da Etch ja irgend wann (vielleicht Ende des Jahres, da gab's mal so ein paar Verlautbarungen, aber, na ja, wir sind hier bei Debian.... :wink: ) mal stable wird bekommst Du so zu diesem Zeitpunkt automatisch ein stable System.

Ansonsten müsstest Du vermutlich sehr viel von Backports einspielen (eben wegen udev und Abhängigkeiten für den neuen Kernel) und ob das dann besser ist wage ich zu bezweifeln...

Gruß rotwein
...der Dir nur ein paar Anstöße zum Nachdenken geben will...

PS: Für testing gibts mittlerweile ein eigenes security team, wie gut das aber geht weiß ich nicht... http://secure-testing-master.debian.net
If the solution is microsoft I want my problem back

Benutzeravatar
KBDCALLS
Moderator
Beiträge: 22263
Registriert: 24.12.2003 21:26:55
Lizenz eigener Beiträge: MIT Lizenz
Wohnort: Dortmund
Kontaktdaten:

Beitrag von KBDCALLS » 11.05.2006 09:18:26

@rotwein 2.6.12 ist richtig.

@TCA Momentan ist der aktuelle Installer von Etch nicht in der Lage Sarge zu installieren, die Beta 3 soll dann dazu aber wieder in der Lage sein.



http://wiki.debian.org/DebianInstaller/EtchBeta3Prep
Was haben Windows und ein Uboot gemeinsam?
Kaum macht man ein Fenster auf, gehen die Probleme los.

EDV ist die Abkürzung für: Ende der Vernunft

Bevor du einen Beitrag postest:
  • Kennst du unsere Verhaltensregeln
  • Lange Codezeilen/Logs gehören nach NoPaste, in Deinen Beitrag dann der passende Link dazu.

Sarem_Avuton
Beiträge: 546
Registriert: 16.12.2004 09:58:27
Wohnort: Leipzig

Beitrag von Sarem_Avuton » 11.05.2006 09:38:30

Hallo ,

bei mir war es ähnlich, ich habe mich dann für XEN (3.0.2 mit 2.6.16er Kernel) entschieden wo die Dom0 auf testing läuft ohne weitere Dienste. und dann eine DomU mit Sarge gemacht.

Grüße Jörg

Performance ist klasse, kaum ein Unterschied zu nativ install.

irata
Beiträge: 13
Registriert: 10.02.2005 17:32:58

Beitrag von irata » 11.05.2006 13:27:43

Danke für eure ganzen Tipps!!!

Ich habe es jetzt ein bisschen experimentel gemacht, aber bisher klappt es ganz gut.

Hab mit der netinst von etch gebootet und als er dann die Basis-Installation durchführen wollte die sarge-CD eingelegt, keinen Kernel installiert und dann mit der etch "rescue" gebootet und von backports den Kernel und die "udev", etc. eingespielt.

Ich weiss, ist für einen Server vermutlich sehr experimentel, aber ich hoffe, es tut so...

Hab noch ein paar Tage, den Rechner auf Herz und Nieren zu testen, aber bisher hab ich keine Probleme feststellen koennen.


Gruss Tobias

Benutzeravatar
crack
Beiträge: 615
Registriert: 19.08.2003 12:20:26
Lizenz eigener Beiträge: GNU General Public License
Wohnort: München
Kontaktdaten:

Beitrag von crack » 27.05.2006 18:26:32

Hi,

hab grad das selbe Problem aber etwas gefunden:
http://kmuto.jp/b.cgi/debian/d-i-2615.htm#writebacks

directlink:
http://kmuto.jp/debian/d-i/2.6.15/sarge-custom-0206.iso

sagre netinstall-iso mit kernel 2.6.15 aus sid
udev und so wurden, soweit ich weis, rückportiert.

Habe das ganzen schonmal vor einem halben Jahr mit kernel 2.6.13 gemacht, war für nen server dessen RAID-Controller sehr neu war.

Grüße Benny

Antworten